Subject: Re: [Id-event] Secevents IETF 100 discussion (minutes)

From: "Morteza Ansari (moransar)" <[email-masked]>
Date: Fri, 1 Dec 2017 18:57:20 +0000

Personally speaking as someone that doesn’t have the context of the discussions at Singapore, I can’t comment on or able to respond to the consensus calls. Can’t speak for others, but I am guessing most folks that were not in those side discussions are as lost as I am!

Cheers,
Morteza

From: Id-event <[email-masked]> on behalf of Dick Hardt <[email-masked]>
Date: Thursday, November 30, 2017 at 8:42 PM
To: ID Events Mailing List <[email-masked]>, Phil Hunt <[email-masked]>
Subject: Re: [Id-event] Secevents IETF 100 discussion (minutes)

I will be posting a summary of the side meetings real-soon-now.

Per an earlier post, I’ll be posting some questions looking to get consensus on a number of topics.

On Thu, Nov 30, 2017 at 6:32 PM Phil Hunt <[email-masked]<mailto:[email-masked]>> wrote:
Over the week at IETF100 there was initially the official wg meeting plus a number of daily side meetings.

I have not seen the minutes yet, so here are some of my thoughts on the new draft from Annabelle.

The change in direction is substantial (a totally new format and design principle) and I recommend strongly that people read the new draft from Annabelle.

I am aware of some people that could not attend that would like to catch up with minutes before commenting.

A key design difference is the new individual draft acts more as a command message. A SET event is singular and expresses specific intent by the issuer that may be more easily understood. In contrast, the WG draft describes a set of event statements (eg one or more state changes) by the issuer where the receiver decides meaning and action if any within its own context.

I will provide further commentary later. For now I am very concerned with the change in design that suggests SETs be more like structured commands by transmitters to receiving parties.

Best regards,

Phil
_______________________________________________
Id-event mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/id-event
--
Subscribe to the HARDTWARE<http://hardtware.com/> mail list to learn about projects I am working on!

---

From: Dick Hardt <[email-masked]>
Date: Fri, 1 Dec 2017 11:05:19 -0800

Sorry, I have posting out the minutes in my queue, but have not gotten to
it. I will post within the next day.

On Fri, Dec 1, 2017 at 10:57 AM, Morteza Ansari (moransar) <
[email-masked]> wrote:

> Personally speaking as someone that doesn’t have the context of the
> discussions at Singapore, I can’t comment on or able to respond to the
> consensus calls. Can’t speak for others, but I am guessing most folks that
> were not in those side discussions are as lost as I am!
>
>
>
>
>
> Cheers,
>
> Morteza
>
>
>
> *From: *Id-event <[email-masked]> on behalf of Dick Hardt <
> [email-masked]>
> *Date: *Thursday, November 30, 2017 at 8:42 PM
> *To: *ID Events Mailing List <[email-masked]>, Phil Hunt <
> [email-masked]>
> *Subject: *Re: [Id-event] Secevents IETF 100 discussion (minutes)
>
>
>
> On Thu, Nov 30, 2017 at 6:32 PM Phil Hunt <[email-masked]> wrote:
>
> The change in direction is substantial (a totally new format and design
> principle) and I recommend strongly that people read the new draft from
> Annabelle.
>
> A key design difference is the new individual draft acts more as a command
> message. A SET event is singular and expresses specific intent by the
> issuer that may be more easily understood. In contrast, the WG draft
> describes a set of event statements (eg one or more state changes) by the
> issuer where the receiver decides meaning and action if any within its own
> context.
>
> I will provide further commentary later. For now I am very concerned with
> the change in design that suggests SETs be more like structured commands by
> transmitters to receiving parties.
>
> Best regards,
>
> Phil
> [email-masked]
> Subscribe to the HARDTWARE <http://hardtware.com/> mail list to learn
> about projects I am working on!
>

-- 
Subscribe to the HARDTWARE <http://hardtware.com/> mail list to learn about
projects I am working on!

---

From: "Richard Backman, Annabelle" <[email-masked]>
Date: Fri, 1 Dec 2017 19:36:43 +0000

> A key design difference is the new individual draft acts more as a command message.

I’m not sure where you’re getting this from. Could you explain? The new draft makes a stronger statement about the meaning of the content in the SET, i.e. the information being communicated by the transmitter, but it is still completely up to the recipient to decide what they do with that information.

--
Annabelle Richard Backman
Amazon – Identity Services

From: Id-event <[email-masked]> on behalf of Dick Hardt <[email-masked]>
Date: Friday, December 1, 2017 at 11:06 AM
To: "Morteza Ansari (moransar)" <[email-masked]>
Cc: ID Events Mailing List <[email-masked]>, Phil Hunt <[email-masked]>
Subject: Re: [Id-event] Secevents IETF 100 discussion (minutes)

Sorry, I have posting out the minutes in my queue, but have not gotten to it. I will post within the next day.

On Fri, Dec 1, 2017 at 10:57 AM, Morteza Ansari (moransar) <[email-masked]<mailto:[email-masked]>> wrote:
Personally speaking as someone that doesn’t have the context of the discussions at Singapore, I can’t comment on or able to respond to the consensus calls. Can’t speak for others, but I am guessing most folks that were not in those side discussions are as lost as I am!

Cheers,
Morteza

From: Id-event <[email-masked]<mailto:[email-masked]>> on behalf of Dick Hardt <[email-masked]<mailto:[email-masked]>>
Date: Thursday, November 30, 2017 at 8:42 PM
To: ID Events Mailing List <[email-masked]<mailto:[email-masked]>>, Phil Hunt <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Id-event] Secevents IETF 100 discussion (minutes)

Best regards,

Phil

---

From: Justin Richer <[email-masked]>
Date: Mon, 4 Dec 2017 18:59:17 +0000

I disagree with this “key design difference" characterization, from what I can understand of it. I see the new draft not as a command message at all but as a statement describing something that’s happened — which is the whole point of SET. It’s not at all telling the receiving party what to do with that any more than the current draft is. I think this argument is a red herring.

 — Justin

> On Dec 1, 2017, at 7:36 PM, Richard Backman, Annabelle <[email-masked]> wrote:
> 
> On Fri, Dec 1, 2017 at 10:57 AM, Morteza Ansari (moransar) <[email-masked] <mailto:[email-masked]>> wrote:
>> From: Id-event <[email-masked] <mailto:[email-masked]>> on behalf of Dick Hardt <[email-masked] <mailto:[email-masked]>>
>> To: ID Events Mailing List <[email-masked] <mailto:[email-masked]>>, Phil Hunt <[email-masked] <mailto:[email-masked]>>
>> On Thu, Nov 30, 2017 at 6:32 PM Phil Hunt <[email-masked] <mailto:[email-masked]>> wrote:
>>> [email-masked] <mailto:[email-masked]>
>>> https://www.ietf.org/mailman/listinfo/id-event <https://www.ietf.org/mailman/listinfo/id-event>
>> --
>> Subscribe to the HARDTWARE <http://hardtware.com/> mail list to learn about projects I am working on!
> 
> 
> 
>  
> -- 
> Subscribe to the HARDTWARE <http://hardtware.com/> mail list to learn about projects I am working on!

---

From: Andrew Hindle <[email-masked]>
Date: Tue, 5 Dec 2017 09:36:42 +0000

Assuming I'm reading the correct draft (draft-backman-secevent-token-02),
the introduction still contains the following statement: "Security Events
are not commands issued between parties.  A security event is a statement
of fact from the perspective of an issuer about the state of a security
subject".

That seems fairly conclusive.

--&e

On Mon, Dec 4, 2017 at 6:59 PM, Justin Richer <[email-masked]> wrote:

> I disagree with this “key design difference" characterization, from what I
> can understand of it. I see the new draft not as a command message at all
> but as a statement describing something that’s happened — which is the
> whole point of SET. It’s not at all telling the receiving party what to do
> with that any more than the current draft is. I think this argument is a
> red herring.
>
>  — Justin
>
> I’m not sure where you’re getting this from. Could you explain? The new
> draft makes a stronger statement about the meaning of the content in the
> SET, i.e. the information being communicated by the transmitter, but it is
> still completely up to the recipient to decide what they do with that
> information.
>
> --
> *Date: *Friday, December 1, 2017 at 11:06 AM
> *To: *"Morteza Ansari (moransar)" <[email-masked]>
> *Cc: *ID Events Mailing List <[email-masked]>, Phil Hunt <
> [email-masked]>

-- 
Andrew Hindle
Hindle Consulting Limited
+44 7966 136543
Schedule a meeting <https://freebusy.io/[email-masked]/30min>

-- 

------------------------------
Hindle Consulting Limited is a company registered in England and Wales.  Company 
number: 8888564.
Registered office: Claremont House, Deans Court, Bicester, Oxfordshire OX26 
6BW, UK.