Subject: [Id-event] Consenus :: Event Subject Types - resending

From: Yaron Sheffer <[email-masked]>
Date: Sun, 3 Dec 2017 19:39:34 +0200

Do we specify a number of common subjects so that profiles can have a 
standard mechanism?

We could establish an IANA registry of subject types, and define several 
of them in advance, e.g. email, phone number, and a more generic "issuer 
and subject".

We will track results here: 
https://github.com/IETF-SecEvent/Drafts/issues/3 
<https://github.com/IETF-SecEvent/Drafts/issues/3>

Discussion to be on the mail list as usual, not in the issue tracker!

---

From: Mike Jones <[email-masked]>
Date: Tue, 5 Dec 2017 20:55:44 +0000

If the working group decides to work on an optional structured event subject claim definition, I support defining specific subject types, based on implementation and deployment experiences across multiple profiles.  I agree with the use of an IANA registry for event subject types, if this work is done.

To be clear, I oppose trying to add this currently nascent, if potentially valuable, work to the already mature SET spec.

				-- Mike

-----Original Message-----
From: Id-event [mailto:[email-masked]] On Behalf Of Yaron Sheffer
Sent: Sunday, December 3, 2017 9:40 AM
To: SecEvent <[email-masked]>
Subject: [Id-event] Consenus :: Event Subject Types - resending

Do we specify a number of common subjects so that profiles can have a standard mechanism?

We could establish an IANA registry of subject types, and define several of them in advance, e.g. email, phone number, and a more generic "issuer and subject".

_______________________________________________
Id-event mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/id-event

---

From: Phil Hunt <[email-masked]>
Date: Tue, 5 Dec 2017 13:14:34 -0800

Agree with Mike. This should be pursued separately if there is interest.

Phil

Oracle Corporation, Identity Cloud Services Architect
@independentid
www.independentid.com <http://www.independentid.com/>[email-masked] <mailto:[email-masked]>

> On Dec 5, 2017, at 12:55 PM, Mike Jones <[email-masked]> wrote:
> 
> https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_IETF-2DSecEvent_Drafts_issues_3&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=FMPqK9iUUiuYhu_2zV1haqPLgbQLbFbP4rqg9CCL0V8&s=6IbQjpcDCPWldpokWUpGvdcc3F4G8spBR9VNW3BBlBM&e=
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_IETF-2DSecEvent_Drafts_issues_3&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=FMPqK9iUUiuYhu_2zV1haqPLgbQLbFbP4rqg9CCL0V8&s=6IbQjpcDCPWldpokWUpGvdcc3F4G8spBR9VNW3BBlBM&e=>
> 
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_id-2Devent&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=FMPqK9iUUiuYhu_2zV1haqPLgbQLbFbP4rqg9CCL0V8&s=nZD15t0V7WhpHJ6I8CQhu4unXsbwX4cntnsooESSIok&e=
> 
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_id-2Devent&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=FMPqK9iUUiuYhu_2zV1haqPLgbQLbFbP4rqg9CCL0V8&s=nZD15t0V7WhpHJ6I8CQhu4unXsbwX4cntnsooESSIok&e=

---

From: Vladimir Dzhuvinov <[email-masked]>
Date: Wed, 6 Dec 2017 00:08:23 +0200

Hello everyone,

I remember it was January 2017 when the WG decided to adopt
draft-hunt-idevent-token-08 as WG document, which I also supported. By
then the WG had already discussed and addressed the issues around the
SET "events" structure, and the spec had advanced sufficiently to be
useful in practice. Later in 2017 the important issue of mix-up was also
addressed. I was looking forward to the SET getting finally published.

I'm not convinced the new proposed event structure, if taken as the
starting point for a new SET format, will ultimately yield a better
spec. Repeating the discussions on the SET structure will probably lead
to the same arguments and pros / cons that molded the current WG spec
(which I see is already happening). And this will take time, risking the
SET's relevance when it finally emerges from the WG.

Vladimir

---

From: nov matake <[email-masked]>
Date: Wed, 6 Dec 2017 22:17:48 +0900

+1 for Vladimir

Sent from my iPhone

> On Dec 6, 2017, at 7:08, Vladimir Dzhuvinov <[email-masked]> wrote:
> 
> Hello everyone,
>

---

From: nov matake <[email-masked]>
Date: Wed, 6 Dec 2017 22:17:48 +0900

+1 for Vladimir

Sent from my iPhone

---

From: Marius Scurtescu <[email-masked]>
Date: Thu, 7 Dec 2017 11:53:06 -0800

Valdimir and Nov, it is not clear to me what are you referring to. This
thread is about event subject type, you seem to refer to event vs events.
There is a separate thread for that. If so, can we move the discussion that
thread? If not, can you please clarify your position on event subject
types? Thanks.

Marius

On Wed, Dec 6, 2017 at 5:17 AM, nov matake <[email-masked]> wrote:

> >> If the working group decides to work on an optional structured event
> subject claim definition, I support defining specific subject types, based
> on implementation and deployment experiences across multiple profiles.  I
> agree with the use of an IANA registry for event subject types, if this
> work is done.
> >>
> >> To be clear, I oppose trying to add this currently nascent, if
> potentially valuable, work to the already mature SET spec.
> >>
> >>                -- Mike
> >>
> >> We could establish an IANA registry of subject types, and define
> several of them in advance, e.g. email, phone number, and a more generic
> "issuer and subject".
> >>
> >>

---

From: Marius Scurtescu <[email-masked]>
Date: Thu, 7 Dec 2017 11:57:40 -0800

Glad we agree that defining event subject types is useful.

If the SET spec was mature then we wouldn't have this discussion. This is
the first round of feedback from actual early implementors, discarding
these requests and feedback sound very strange to me.

I would think that this is the most important feedback that we as a working
group are looking for.

Marius

On Tue, Dec 5, 2017 at 1:14 PM, Phil Hunt <[email-masked]> wrote:

> www.independentid.com
> [email-masked]
> To be clear, I oppose trying to add this currently nascent, if potentially
> valuable, work to the already mature SET spec.
>
> -- Mike
>
> From: Id-event [mailto:[email-masked]
> <[email-masked]>] On Behalf Of Yaron Sheffer
> https://urldefense.proofpoint.com/v2/url?u=https-3A__github.
> com_IETF-2DSecEvent_Drafts_issues_3&d=DwICAg&c=
> RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=
> na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=FMPqK9iUUiuYhu_
> 2zV1haqPLgbQLbFbP4rqg9CCL0V8&s=6IbQjpcDCPWldpokWUpGvdcc3F4G8s
> pBR9VNW3BBlBM&e=
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_IETF-
> 2DSecEvent_Drafts_issues_3&d=DwICAg&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIr
> MUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=
> FMPqK9iUUiuYhu_2zV1haqPLgbQLbFbP4rqg9CCL0V8&s=
> 6IbQjpcDCPWldpokWUpGvdcc3F4G8spBR9VNW3BBlBM&e=>
>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.
> ietf.org_mailman_listinfo_id-2Devent&d=DwICAg&c=
> RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=
> na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=FMPqK9iUUiuYhu_
> 2zV1haqPLgbQLbFbP4rqg9CCL0V8&s=nZD15t0V7WhpHJ6I8CQhu4unXsbwX4
> cntnsooESSIok&e=
>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.
> ietf.org_mailman_listinfo_id-2Devent&d=DwICAg&c=
> RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=
> na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=FMPqK9iUUiuYhu_
> 2zV1haqPLgbQLbFbP4rqg9CCL0V8&s=nZD15t0V7WhpHJ6I8CQhu4unXsbwX4
> cntnsooESSIok&e=
>
>
>