Subject: [Id-event] WG Last Call for draft-ietf-secevent-token-05

From: Yaron Sheffer <[email-masked]>
Date: Mon, 5 Feb 2018 21:24:01 +0200

First, we would like to thank the authors and the working group members 
who have been working since Singapore to clarify and resolve several 
controversial topics. With this work behind us, we can now move forward 
to publication.

This is to announce working group last call on this draft 
(https://datatracker.ietf.org/doc/draft-ietf-secevent-token/).

Please send your comments to the list. Even if you are perfectly happy 
with the draft, please let us know that you support its publication 
as-is by posting to the list.

Please send your comment within the next two weeks, until Feb. 19.

Thanks,
     Dick and Yaron

---

From: Mike Jones <[email-masked]>
Date: Mon, 5 Feb 2018 19:57:02 +0000

Ready for publication

-----Original Message-----
From: Id-event [mailto:[email-masked]] On Behalf Of Yaron Sheffer
Sent: Monday, February 5, 2018 11:24 AM
To: SecEvent <[email-masked]>
Subject: [Id-event] WG Last Call for draft-ietf-secevent-token-05

First, we would like to thank the authors and the working group members who have been working since Singapore to clarify and resolve several controversial topics. With this work behind us, we can now move forward to publication.

This is to announce working group last call on this draft (https://datatracker.ietf.org/doc/draft-ietf-secevent-token/).

Please send your comments to the list. Even if you are perfectly happy with the draft, please let us know that you support its publication as-is by posting to the list.

Thanks,
     Dick and Yaron

_______________________________________________
Id-event mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/id-event

---

From: Phil Hunt <[email-masked]>
Date: Mon, 5 Feb 2018 12:32:58 -0800

+1. Lets get this published. 

Phil

> On Feb 5, 2018, at 11:57 AM, Mike Jones <[email-masked]> wrote:
> 
> Ready for publication
> 
> This is to announce working group last call on this draft (https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dsecevent-2Dtoken_&d=DwIGaQ&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=nO8CKQKr2kgcB8C8zF-QhajSSLuCHhPdHSjTC59M_YY&s=roIu0H8c1Pidp5yVt_nuHmPN3_dtFUuupi2qEPm4tis&e=).
> 
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_id-2Devent&d=DwIGaQ&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=nO8CKQKr2kgcB8C8zF-QhajSSLuCHhPdHSjTC59M_YY&s=rXHQi8vRzEoMPfaxTtnt0EsG1nZCFDYAmQHc45TnDaY&e=
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_id-2Devent&d=DwIGaQ&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=nO8CKQKr2kgcB8C8zF-QhajSSLuCHhPdHSjTC59M_YY&s=rXHQi8vRzEoMPfaxTtnt0EsG1nZCFDYAmQHc45TnDaY&e=

---

From: "Richard Backman, Annabelle" <[email-masked]>
Date: Mon, 5 Feb 2018 20:38:27 +0000

I'd like to see item 1 below addressed before publishing, as it alters (corrects) the meaning of the text.

One error:
1.  In the "iat" definition in section 2.2: change "...when the event was issued." to "...when the SET was issued."

One clarification:
2.  The 2nd to last paragraph of section 2.4 states "the Event Recipient MUST" ensure integrity, confidentiality, etc. Isn't this properly the issuer's responsibility? Or both?

A handful of nits:
3.  The "aud" definition in section 2.2 is awkwardly written; I suggest rephrasing it to mirror the "iat" definition.
4.  Missing "the" in the "exp" definition in section 2.2: "this claim is time" -> "this claim is the time"
5.  Syntax error in the 3rd list item of section 2: "...is a URI string value is an event identifier..."
6.  Inconsistent use of terms for issuer, recipient, subject. At the very least we should have consistent capitalization:
  a.  Issuer, issuer, Event Issuer, SET Issuer
  b.  Recipient, recipient, Event Recipient
  c.  Subject, subject, Security Subject, security subject, event Subject, event subject

OK, I'm putting away the red pen now. :)

-- 
Annabelle Richard Backman
Amazon – Identity Services
 
On 2/5/18, 12:33 PM, "Id-event on behalf of Phil Hunt" <[email-masked] on behalf of [email-masked]> wrote:

    Phil

---

From: Marius Scurtescu <[email-masked]>
Date: Mon, 5 Feb 2018 12:50:37 -0800

Yes, let's make final fixes and move forward.

A couple of minor nits:
- in the "events" definition, I don't think "Multiple event identifiers
with the same value MUST NOT be used." is needed, since that is not
possible anyhow (assuming I read the statement correctly)
- do we need a formal definition for "event identifier"?

Marius

On Mon, Feb 5, 2018 at 12:38 PM, Richard Backman, Annabelle <
[email-masked]> wrote:

> 1.  In the "iat" definition in section 2.2: change "...when the event was
> issued." to "...when the SET was issued."
>
> One clarification:
> 2.  The 2nd to last paragraph of section 2.4 states "the Event Recipient
> MUST" ensure integrity, confidentiality, etc. Isn't this properly the
> issuer's responsibility? Or both?
>
> A handful of nits:
> 3.  The "aud" definition in section 2.2 is awkwardly written; I suggest
> rephrasing it to mirror the "iat" definition.
> 6.  Inconsistent use of terms for issuer, recipient, subject. At the very
> least we should have consistent capitalization:
> On 2/5/18, 12:33 PM, "Id-event on behalf of Phil Hunt" <
> [email-masked] on behalf of [email-masked]> wrote:
>
>     > First, we would like to thank the authors and the working group
> members who have been working since Singapore to clarify and resolve
> several controversial topics. With this work behind us, we can now move
> forward to publication.
>     >
>     > This is to announce working group last call on this draft (
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_doc_draft-2Dietf-2Dsecevent-2Dtoken_&d=DwIGaQ&c=
> RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=
> na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=nO8CKQKr2kgcB8C8zF-
> QhajSSLuCHhPdHSjTC59M_YY&s=roIu0H8c1Pidp5yVt_nuHmPN3_dtFUuupi2qEPm4tis&e=
> ).
>     >
>     > Please send your comments to the list. Even if you are perfectly
> happy with the draft, please let us know that you support its publication
>     > https://urldefense.proofpoint.com/v2/url?u=https-3A__www.
> ietf.org_mailman_listinfo_id-2Devent&d=DwIGaQ&c=
> RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=
> na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=nO8CKQKr2kgcB8C8zF-
> QhajSSLuCHhPdHSjTC59M_YY&s=rXHQi8vRzEoMPfaxTtnt0EsG1nZCFDYAmQHc45TnDaY&e=
>     > https://urldefense.proofpoint.com/v2/url?u=https-3A__www.
> ietf.org_mailman_listinfo_id-2Devent&d=DwIGaQ&c=
> RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=
> na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=nO8CKQKr2kgcB8C8zF-
> QhajSSLuCHhPdHSjTC59M_YY&s=rXHQi8vRzEoMPfaxTtnt0EsG1nZCFDYAmQHc45TnDaY&e=
>

---

From: William Denniss <[email-masked]>
Date: Mon, 5 Feb 2018 13:28:52 -0800

Good catch Annabelle on the "iat" definition, it's quite ambiguous. I
believe "event" there actually intended to mean "event token" (though it
could be read either way). Changing it to "SET" should clear that up.

I support the publication of this document, once corrected.

On Mon, Feb 5, 2018 at 12:50 PM, Marius Scurtescu <[email-masked]>
wrote:

>> https://urldefense.proofpoint.com/v2/url?u=https-3A__
>> datatracker.ietf.org_doc_draft-2Dietf-2Dsecevent-2Dtoken_&d=
>> DwIGaQ&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FV
>> zBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=nO8CKQKr2kgcB8C8zF-
>>     > https://urldefense.proofpoint.com/v2/url?u=https-3A__www.iet
>> f.org_mailman_listinfo_id-2Devent&d=DwIGaQ&c=RoP1YumCXCgaWHv
>> lZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYq
>> PkAI1aLcLN4KZNA&m=nO8CKQKr2kgcB8C8zF-QhajSSLuCHhPdHSjTC59M_
>> YY&s=rXHQi8vRzEoMPfaxTtnt0EsG1nZCFDYAmQHc45TnDaY&e=
>>     > https://urldefense.proofpoint.com/v2/url?u=https-3A__www.iet
>> f.org_mailman_listinfo_id-2Devent&d=DwIGaQ&c=RoP1YumCXCgaWHv
>> lZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYq
>> PkAI1aLcLN4KZNA&m=nO8CKQKr2kgcB8C8zF-QhajSSLuCHhPdHSjTC59M_
>> YY&s=rXHQi8vRzEoMPfaxTtnt0EsG1nZCFDYAmQHc45TnDaY&e=
>>

---

From: Yaron Sheffer <[email-masked]>
Date: Fri, 16 Feb 2018 00:50:00 +0200

Quick reminder: this last call is open until Feb. 19. If you haven't 
yet, please let us know if you support publication of this document.

Thanks,
	Yaron

---

From: Luke Camery <[email-masked]>
Date: Thu, 15 Feb 2018 23:36:06 +0000

+1, looks great with those minor edits.

On Thu, Feb 15, 2018 at 2:50 PM Yaron Sheffer <[email-masked]> wrote:

> controversial topics. With this work behind us, we can now move forward to
> publication.
> >
> https://datatracker.ietf.org/doc/draft-ietf-secevent-token/).
> >
> with the draft, please let us know that you support its publication as-is
> by posting to the list.
> >

-- 

*  •  **Luke Camery*
*  •  *Associate Product Manager
*  •  *Federated Identity

---

From: Justin Richer <[email-masked]>
Date: Fri, 16 Feb 2018 16:37:26 -0500

I still disagree with the direction, syntax, and scope of the solution in this document, and I stand by all of my objections that were raised in Singapore. I do not believe that my base objections have been addressed by recent changes, merely pushed off to “profiles” which I still believe is going to cause an implementation and interoperability nightmare, rendering this specification all but useless in my view.

I see and acknowledge that the working group is deciding to continue with this model in spite of lengthy discussions, and concede that the work will continue toward publication in spite of my objections.

 — Justin

> On Feb 15, 2018, at 5:50 PM, Yaron Sheffer <[email-masked]> wrote:
> 
> Quick reminder: this last call is open until Feb. 19. If you haven't yet, please let us know if you support publication of this document.
> 
> Thanks,
> 	Yaron
>

---

From: Anthony Nadalin <[email-masked]>
Date: Fri, 16 Feb 2018 21:54:47 +0000

I support publication. 

-----Original Message-----
From: Id-event [mailto:[email-masked]] On Behalf Of Yaron Sheffer
Sent: Monday, February 5, 2018 11:24 AM
To: SecEvent <[email-masked]>
Subject: [Id-event] WG Last Call for draft-ietf-secevent-token-05

This is to announce working group last call on this draft (https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-secevent-token%2F&data=02%7C01%7Ctonynad%40microsoft.com%7C7b94ae58fd4846df983608d56cce09f2%7Cee3303d7fb734b0c8589bcd847f1c277%7C1%7C0%7C636534554543083973&sdata=aepLhPiqIzeQ1H24FQVRucH7zyxRpUy%2FcKrjTIUE9nw%3D&reserved=0).

Thanks,
     Dick and Yaron

_______________________________________________
Id-event mailing list
[email-masked]
https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fid-event&data=02%7C01%7Ctonynad%40microsoft.com%7C7b94ae58fd4846df983608d56cce09f2%7Cee3303d7fb734b0c8589bcd847f1c277%7C1%7C0%7C636534554543083973&sdata=xDescpbITuwTyzzpS25mnUCvASQj1NCmb3ybrXXg894%3D&reserved=0

---

From: Phil Hunt <[email-masked]>
Date: Fri, 16 Feb 2018 23:26:15 -0800

I support. 

Phil

> On Feb 16, 2018, at 1:54 PM, Anthony Nadalin <[email-masked]> wrote:
> 
> I support publication. 
> 
> This is to announce working group last call on this draft (https://urldefense.proofpoint.com/v2/url?u=https-3A__na01.safelinks.protection.outlook.com_-3Furl-3Dhttps-253A-252F-252Fdatatracker.ietf.org-252Fdoc-252Fdraft-2Dietf-2Dsecevent-2Dtoken-252F-26data-3D02-257C01-257Ctonynad-2540microsoft.com-257C7b94ae58fd4846df983608d56cce09f2-257Cee3303d7fb734b0c8589bcd847f1c277-257C1-257C0-257C636534554543083973-26sdata-3DaepLhPiqIzeQ1H24FQVRucH7zyxRpUy-252FcKrjTIUE9nw-253D-26reserved-3D0&d=DwIGaQ&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=wIOXkkpkGDDkuROuiY9SRUw12qzKWvV0xVpxBlE-0pc&s=c0ZK2XslvBobg0Iik951SKbUOLTaCaFosrHhHfXXBOY&e=).
> 
> https://urldefense.proofpoint.com/v2/url?u=https-3A__na01.safelinks.protection.outlook.com_-3Furl-3Dhttps-253A-252F-252Fwww.ietf.org-252Fmailman-252Flistinfo-252Fid-2Devent-26data-3D02-257C01-257Ctonynad-2540microsoft.com-257C7b94ae58fd4846df983608d56cce09f2-257Cee3303d7fb734b0c8589bcd847f1c277-257C1-257C0-257C636534554543083973-26sdata-3DxDescpbITuwTyzzpS25mnUCvASQj1NCmb3ybrXXg894-253D-26reserved-3D0&d=DwIGaQ&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=wIOXkkpkGDDkuROuiY9SRUw12qzKWvV0xVpxBlE-0pc&s=1OYSNt_4H4qNdooSYT5dAPSy5sTBCO6NFo_JQI_shz0&e=
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_id-2Devent&d=DwIGaQ&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=wIOXkkpkGDDkuROuiY9SRUw12qzKWvV0xVpxBlE-0pc&s=0gd7eQzSVtqBPjcnstlJbXKUwtOjdhXI05wf3MC7n7g&e=

---

From: Adam Dawes <[email-masked]>
Date: Sat, 17 Feb 2018 22:05:57 -0800

I support.

-------
sent from my hand phone

On Feb 16, 2018 11:26 PM, "Phil Hunt" <[email-masked]> wrote:

> 3A__na01.safelinks.protection.outlook.com_-3Furl-3Dhttps-
> 253A-252F-252Fdatatracker.ietf.org-252Fdoc-252Fdraft-
> 2Dietf-2Dsecevent-2Dtoken-252F-26data-3D02-257C01-
> 257Ctonynad-2540microsoft.com-257C7b94ae58fd4846df983608d56cce09f2-
> 257Cee3303d7fb734b0c8589bcd847f1c277-257C1-257C0-257C636534554543083973-
> 26sdata-3DaepLhPiqIzeQ1H24FQVRucH7zyxRpUy-252FcKrjTIUE9nw-253D-
> 26reserved-3D0&d=DwIGaQ&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=
> na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=
> wIOXkkpkGDDkuROuiY9SRUw12qzKWvV0xVpxBlE-0pc&s=
> c0ZK2XslvBobg0Iik951SKbUOLTaCaFosrHhHfXXBOY&e=).
> >
> > https://urldefense.proofpoint.com/v2/url?u=https-3A__na01.
> safelinks.protection.outlook.com_-3Furl-3Dhttps-253A-252F-
> 252Fwww.ietf.org-252Fmailman-252Flistinfo-252Fid-2Devent-
> 26data-3D02-257C01-257Ctonynad-2540microsoft.com-
> 257C7b94ae58fd4846df983608d56cce09f2-257Cee3303d7fb734b0c8589bcd847
> f1c277-257C1-257C0-257C636534554543083973-26sdata-
> 3DxDescpbITuwTyzzpS25mnUCvASQj1NCmb3ybrXXg894-253D-
> 26reserved-3D0&d=DwIGaQ&c=RoP1YumCXCgaWHvlZYR8PZh8Bv7qIrMUB65eapI_JnE&r=
> na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=
> wIOXkkpkGDDkuROuiY9SRUw12qzKWvV0xVpxBlE-0pc&s=1OYSNt_
> 4H4qNdooSYT5dAPSy5sTBCO6NFo_JQI_shz0&e=
> na5FVzBTWmanqWNy4DpctyXPpuYqPkAI1aLcLN4KZNA&m=
> wIOXkkpkGDDkuROuiY9SRUw12qzKWvV0xVpxBlE-0pc&s=
> 0gd7eQzSVtqBPjcnstlJbXKUwtOjdhXI05wf3MC7n7g&e=
>

---

From: Vladimir Dzhuvinov <[email-masked]>
Date: Sun, 18 Feb 2018 11:37:55 +0200

I support publication.

Thanks,

Vladimir

On 05/02/18 21:24, Yaron Sheffer wrote:
> several controversial topics. With this work behind us, we can now
> move forward to publication.
>

---

From: "Morteza Ansari (moransar)" <[email-masked]>
Date: Tue, 20 Feb 2018 18:45:25 +0000

Sorry for getting to this late! I support publication as well.

Cheers,
Morteza

On 2/15/18, 2:50 PM, "Id-event on behalf of Yaron Sheffer" <[email-masked] on behalf of [email-masked]> wrote:

    Thanks,
    	Yaron

---

From: Mike Jones <[email-masked]>
Date: Tue, 27 Feb 2018 23:37:56 +0000

Please see https://github.com/independentid/Identity-Events/pull/11 for edits that are intended to address the WGLC comments received.

Marius, I don’t think we need a formal definition of “event identifier” because it’s clearly defined by this usage in Section 2 (The Security Event Token (SET):
Each member of the events JSON object is a name/value pair. The JSON member name is a URI string value, which is the event identifier, and the corresponding value is a JSON object known as the event "payload".

                                                                Thanks all,
                                                                -- Mike

From: Marius Scurtescu <[email-masked]>
Sent: Monday, February 5, 2018 12:51 PM
To: Richard Backman, Annabelle <[email-masked]>
Cc: Phil Hunt <[email-masked]>; Mike Jones <[email-masked]>; Yaron Sheffer <[email-masked]>; SecEvent <[email-masked]>
Subject: Re: [Id-event] WG Last Call for draft-ietf-secevent-token-05

A couple of minor nits:
- in the "events" definition, I don't think "Multiple event identifiers with the same value MUST NOT be used." is needed, since that is not possible anyhow (assuming I read the statement correctly)
- do we need a formal definition for "event identifier"?

Marius

On Mon, Feb 5, 2018 at 12:38 PM, Richard Backman, Annabelle <[email-masked]<mailto:[email-masked]>> wrote:
I'd like to see item 1 below addressed before publishing, as it alters (corrects) the meaning of the text.

One error:

One clarification:

A handful of nits:

On 2/5/18, 12:33 PM, "Id-event on behalf of Phil Hunt" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

    Phil

    > On Feb 5, 2018, at 11:57 AM, Mike Jones <[email-masked]<mailto:[email-masked]>> wrote:
    >
    > Ready for publication
    >
    > From: Id-event [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Yaron Sheffer
    > To: SecEvent <[email-masked]<mailto:[email-masked]>>
    > [email-masked]<mailto:[email-masked]>
    > [email-masked]<mailto:[email-masked]>

    _______________________________________________
    Id-event mailing list
    [email-masked]<mailto:[email-masked]>
    https://www.ietf.org/mailman/listinfo/id-event

_______________________________________________
Id-event mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/id-event

---

From: Marius Scurtescu <[email-masked]>
Date: Tue, 27 Feb 2018 16:18:17 -0800

On Tue, Feb 27, 2018 at 3:37 PM, Mike Jones <[email-masked]>
wrote:

> Please see https://github.com/independentid/Identity-Events/pull/11 for
> edits that are intended to address the WGLC comments received.
>

I just want to bring up the fact that the SET spec uses "Event Issuer" and
"Event Recipient" while the distribution spec and proposed API specs all
use "Event Transmitter" and "Event Receiver".

I just want to make sure we all make a conscious decision here and see if
there are ways to prevent potential confusion.

I understand that "Event Issuer" and "Event Recipient" are in line with
JWT. Also, Transmitter/Receiver might have slightly different meaning (the
entity that issues vs the entity that transmits). But I think they are
close enough to be confusing.

>
>
> Marius, I don’t think we need a formal definition of “event identifier”
> because it’s clearly defined by this usage in Section 2 (The Security Event
> Token (SET):
>
> Each member of the events JSON object is a name/value pair. The JSON
> member name is a URI string value, which is the event identifier, and the
> corresponding value is a JSON object known as the event "payload".
>

A formal definition would be useful IMO. Many profiles will define events
and they will all have to create event identifiers and make reference to
the concept. A clear definition of the term would help.

>
>                                                                 Thanks
> all,
>
>                                                                 -- Mike
>
>
>
> *From:* Marius Scurtescu <[email-masked]>
> *Sent:* Monday, February 5, 2018 12:51 PM
> *To:* Richard Backman, Annabelle <[email-masked]>
> *Cc:* Phil Hunt <[email-masked]>; Mike Jones <
> [email-masked]>; Yaron Sheffer <[email-masked]>;
> SecEvent <[email-masked]>
> *Subject:* Re: [Id-event] WG Last Call for draft-ietf-secevent-token-05
>
>
>

---

From: Mike Jones <[email-masked]>
Date: Wed, 28 Feb 2018 00:22:04 +0000

I could add definitions for “event identifier” and “event payload” if people feel that it would improve the specification.

                                                                -- Mike

From: Marius Scurtescu <[email-masked]>
Sent: Tuesday, February 27, 2018 4:18 PM
To: Mike Jones <[email-masked]>
Cc: Richard Backman, Annabelle <[email-masked]>; Phil Hunt <[email-masked]>; Yaron Sheffer <[email-masked]>; SecEvent <[email-masked]>
Subject: Re: [Id-event] WG Last Call for draft-ietf-secevent-token-05

On Tue, Feb 27, 2018 at 3:37 PM, Mike Jones <[email-masked]<mailto:[email-masked]>> wrote:
Please see https://github.com/independentid/Identity-Events/pull/11 for edits that are intended to address the WGLC comments received.

I just want to bring up the fact that the SET spec uses "Event Issuer" and "Event Recipient" while the distribution spec and proposed API specs all use "Event Transmitter" and "Event Receiver".

I just want to make sure we all make a conscious decision here and see if there are ways to prevent potential confusion.

I understand that "Event Issuer" and "Event Recipient" are in line with JWT. Also, Transmitter/Receiver might have slightly different meaning (the entity that issues vs the entity that transmits). But I think they are close enough to be confusing.

A formal definition would be useful IMO. Many profiles will define events and they will all have to create event identifiers and make reference to the concept. A clear definition of the term would help.

                                                                Thanks all,
                                                                -- Mike

From: Marius Scurtescu <[email-masked]<mailto:[email-masked]>>
Sent: Monday, February 5, 2018 12:51 PM
To: Richard Backman, Annabelle <[email-masked]<mailto:[email-masked]>>
Cc: Phil Hunt <[email-masked]<mailto:[email-masked]>>; Mike Jones <[email-masked]<mailto:[email-masked]>>; Yaron Sheffer <[email-masked]<mailto:[email-masked]>>; SecEvent <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Id-event] WG Last Call for draft-ietf-secevent-token-05

A couple of minor nits:

Marius

One error:

One clarification:

A handful of nits:

    Phil

---

From: Marius Scurtescu <[email-masked]>
Date: Tue, 27 Feb 2018 16:24:15 -0800

+1

Thanks Mike

Marius

On Tue, Feb 27, 2018 at 4:22 PM, Mike Jones <[email-masked]>
wrote:

> I could add definitions for “event identifier” and “event payload” if
> people feel that it would improve the specification.
>
>
>
>                                                                 -- Mike
>
>
>
> *Sent:* Tuesday, February 27, 2018 4:18 PM
> *To:* Mike Jones <[email-masked]>
> *Cc:* Richard Backman, Annabelle <[email-masked]>; Phil Hunt <
> [email-masked]>; Yaron Sheffer <[email-masked]>; SecEvent <
> [email-masked]>
>

---

From: Mike Jones <[email-masked]>
Date: Wed, 28 Feb 2018 23:53:20 +0000

The terms are now defined, as you requested, Marius.  See https://github.com/independentid/Identity-Events/pull/11/commits/7f4927811fea3819c98193bc3fe8bccb82f84d01.

                                                                -- Mike

Sent: Tuesday, February 27, 2018 4:24 PM

+1

Thanks Mike

Marius

On Tue, Feb 27, 2018 at 4:22 PM, Mike Jones <[email-masked]<mailto:[email-masked]>> wrote:
I could add definitions for “event identifier” and “event payload” if people feel that it would improve the specification.

                                                                -- Mike

From: Marius Scurtescu <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, February 27, 2018 4:18 PM
To: Mike Jones <[email-masked]<mailto:[email-masked]>>
Cc: Richard Backman, Annabelle <[email-masked]<mailto:[email-masked]>>; Phil Hunt <[email-masked]<mailto:[email-masked]>>; Yaron Sheffer <[email-masked]<mailto:[email-masked]>>; SecEvent <[email-masked]<mailto:[email-masked]>>

                                                                Thanks all,
                                                                -- Mike

A couple of minor nits:

Marius

One error:

One clarification:

A handful of nits:

    Phil