Subject: [Id-event] separate push and poll delivery drafts

From: Marius Scurtescu <[email-masked]>
Date: Mon, 5 Mar 2018 08:41:56 -0800

The current delivery draft defines both a push and a poll delivery methods:
https://tools.ietf.org/html/draft-ietf-secevent-delivery-02

Two issues have been raised with the current draft:

1. Many implementors raised the concern that they want to implement either
push or poll, but not both. With both delivery methods in one spec
optionality is tricky, the suggestion was to make them MTI, but not
mandatory to deploy which is very confusing.

2. For the draft to move to Last Call status we need implementors for all
parts of the draft. Currently there are push implementations, but not poll
implementations. By separating them we can allow the more mature method to
move forward while allowing the less mature method to be refined and gain
implementation feedback.

Also, by having separate specs per delivery method we set the stage for
other delivery methods to be added easily.

Can we add this to the agenda to be discussed in London?

The discussion should answer:
A. Do we have consensus for splitting the delivery spec into two?
B. If yes for A, can the two new specs replace the existing spec and stay
as working group drafts (this would be ideal)? As opposed to the two new
specs starting from scratch as I-Ds.

If it helps, I am happy to send to the list two separate specs as TXT/PDF
so we have something concrete to look at. Let me know.

I will not be in London, but will try to attend remotely.

Thanks,
Marius

---

From: "Richard Backman, Annabelle" <[email-masked]>
Date: Tue, 6 Mar 2018 00:14:44 +0000

+1 for splitting them into two separate drafts. It will make each one clearer, and remove ambiguity as to what transmitters and receivers need to implement.

We should get this on the agenda for London. I can present it.

--
Annabelle Richard Backman
Amazon – Identity Services

From: Id-event <[email-masked]> on behalf of Marius Scurtescu <[email-masked]>
Date: Monday, March 5, 2018 at 8:42 AM
To: ID Events Mailing List <[email-masked]>, Yaron Sheffer <[email-masked]>, "Hardt, Dick" <[email-masked]>, Phillip Hunt <[email-masked]>
Cc: Adam Dawes <[email-masked]>
Subject: [Id-event] separate push and poll delivery drafts

1. Many implementors raised the concern that they want to implement either push or poll, but not both. With both delivery methods in one spec optionality is tricky, the suggestion was to make them MTI, but not mandatory to deploy which is very confusing.

2. For the draft to move to Last Call status we need implementors for all parts of the draft. Currently there are push implementations, but not poll implementations. By separating them we can allow the more mature method to move forward while allowing the less mature method to be refined and gain implementation feedback.

Also, by having separate specs per delivery method we set the stage for other delivery methods to be added easily.

The discussion should answer:
A. Do we have consensus for splitting the delivery spec into two?
B. If yes for A, can the two new specs replace the existing spec and stay as working group drafts (this would be ideal)? As opposed to the two new specs starting from scratch as I-Ds.

If it helps, I am happy to send to the list two separate specs as TXT/PDF so we have something concrete to look at. Let me know.

Thanks,
Marius

---

From: Marius Scurtescu <[email-masked]>
Date: Tue, 6 Mar 2018 09:51:23 -0800

On Mon, Mar 5, 2018 at 4:14 PM, Richard Backman, Annabelle <
[email-masked]> wrote:

> +1 for splitting them into two separate drafts. It will make each one
> clearer, and remove ambiguity as to what transmitters and receivers need to
> implement.
>
>
>

Thanks for offering to present.

Yaron, please let us know if this is on the agenda.

> *From: *Id-event <[email-masked]> on behalf of Marius
> Scurtescu <[email-masked]>
> *Date: *Monday, March 5, 2018 at 8:42 AM
> *To: *ID Events Mailing List <[email-masked]>, Yaron Sheffer <
> [email-masked]>, "Hardt, Dick" <[email-masked]>, Phillip Hunt <
> [email-masked]>
> *Cc: *Adam Dawes <[email-masked]>
> *Subject: *[Id-event] separate push and poll delivery drafts
>
>
>

---

From: Yaron Sheffer <[email-masked]>
Date: Tue, 6 Mar 2018 23:29:26 -0800

It is on the agenda now.

Thanks,
	Yaron

On 06/03/18 09:51, Marius Scurtescu wrote:
> On Mon, Mar 5, 2018 at 4:14 PM, Richard Backman, Annabelle 
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     +1 for splitting them into two separate drafts. It will make each
>     one clearer, and remove ambiguity as to what transmitters and
>     receivers need to implement.____
> 
>     __ __
> 
>     ____
>     __ __
>     -- ____
>     Annabelle Richard Backman____
> 
>     Amazon – Identity Services____
> 
>     __ __
> 
>     *From: *Id-event <[email-masked]
>     <mailto:[email-masked]>> on behalf of Marius Scurtescu
>     <[email-masked] <mailto:[email-masked]>>
>     *To: *ID Events Mailing List <[email-masked]
>     <mailto:[email-masked]>>, Yaron Sheffer <[email-masked]
>     <mailto:[email-masked]>>, "Hardt, Dick" <[email-masked]
>     <mailto:[email-masked]>>, Phillip Hunt <[email-masked]
>     <mailto:[email-masked]>>
>     *Cc: *Adam Dawes <[email-masked] <mailto:[email-masked]>>
>     *Subject: *[Id-event] separate push and poll delivery drafts____
> 
>     __ __
> 
>     The current delivery draft defines both a push and a poll delivery
>     methods: ____
> 
>     https://tools.ietf.org/html/draft-ietf-secevent-delivery-02<https://tools.ietf.org/html/draft-ietf-secevent-delivery-02>____
> 
>     __ __
> 
>     Two issues have been raised with the current draft:____
> 
>     __ __
> 
>     1. Many implementors raised the concern that they want to implement
>     either push or poll, but not both. With both delivery methods in one
>     spec optionality is tricky, the suggestion was to make them MTI, but
>     not mandatory to deploy which is very confusing.____
> 
>     __ __
> 
>     2. For the draft to move to Last Call status we need implementors
>     for all parts of the draft. Currently there are push
>     implementations, but not poll implementations. By separating them we
>     can allow the more mature method to move forward while allowing the
>     less mature method to be refined and gain implementation feedback.____
> 
>     __ __
> 
>     Also, by having separate specs per delivery method we set the stage
>     for other delivery methods to be added easily.____
> 
>     __ __
> 
>     Can we add this to the agenda to be discussed in London?____
> 
>     __ __
> 
>     The discussion should answer:____
> 
>     A. Do we have consensus for splitting the delivery spec into two?____
> 
>     B. If yes for A, can the two new specs replace the existing spec and
>     stay as working group drafts (this would be ideal)? As opposed to
>     the two new specs starting from scratch as I-Ds.____
> 
>     __ __
> 
>     If it helps, I am happy to send to the list two separate specs as
>     TXT/PDF so we have something concrete to look at. Let me know.____
> 
>     __ __
> 
>     I will not be in London, but will try to attend remotely.____
> 
>     __ __
> 
>     Thanks,____
> 
>     Marius____
> 
>