Subject: Re: [Id-event] Push draft: conclusion of WGLC

From: Benjamin Kaduk <[email-masked]>
Date: Wed, 6 Mar 2019 09:35:13 -0600

Hi everyone,

I think that Dick and Yaron are correct to determine that this document
doesn't have WG consensus (rough or otherwise) to advance at this time.
That, of course, can change given additional inputs.

I'll note that the WGLC period is not a formal requirement of the process,
but rather more of a conventional tool that WG chairs use to determine
WG consensus.  In the KITTEN WG (that I chaired for a few years), which
is a very low-energy group, we've largely distanced ourselves from WGLC in
favor of a more rolling period where input comes in.  Regardless of how
they get it, the chairs still need reason to believe that there is a critical
mass of support in the WG for the work, and that all known technical issues
have been addressed in some way (whether technical changes in the document or
through subsequent discussion to determine it is not an issue/out of
scope/not the direction the WG wants to go/etc.)  Historical interest and
engagement of the kind that Annabelle points out can factor into this decision,
but it's also the case that in order to advance, the current document needs
WG consensus, and consensus that some previous version was "pointed in the
right direction" isn't quite the same.

I agree with Mike that I hope this inability to make a determination of
consensus can be a wake-up call that we need greater participation in
order to proceed.

I think at this point there's a few possible paths including but not
limited to:

1) get another couple positive reviews from people who are informed in the
space (whether by following the work along the way or otherwise), and finish
addressing the comments Phil raised during WGLC.  I know that they are rooted
in a longstanding philosophical disagreement, but Phil is correct to raise them
one last time during WGLC, and the conclusion of WGLC^W^W^Wdetermination of WG
rough consensus involves the chairs being confident on the technical resolution
to those issues. [0]  It's much easier for the chairs to do that when there's
a contervailing writeup presented right next to the issues that were raised.

2) Not get more reviews, and have some discussion that concludes that the
previous energy for push has evaporated, which would require the shared content
with pull to be pulled [sic] back into the pull document before that could
advance.  (Yes, that would be unpleasant and duplicate work that's already been
done.  Nobody said this was a great option.)

3) Have some discussion that concludes that the WG just doesn't have enough energy
to work on any of its remaining chartered items (i.e., event delivery), in which
case it would be appropriate to close the WG.

>From this list, there seems a clear "best outcome", but we'll need some help from
the WG participants to make it happen.  It might be worth getting some "survey
results" about who is still interested in working on what, to help the chairs
gauge the best path forward.

-Ben

[0] BTW, Phil would also be justified in raising the questions again during
IETF LC, but it's generally considered best to only do that in the case when
the broader IETF community would be unaware of the previous discussions and is
believed to not be considering the topic without additional intervention.  IMO,
having the controversy properly discussed in the shepherd writeup would probably
fill that need, but Phil and everyone else should use their own judgement.

On Wed, Feb 27, 2019 at 02:58:01PM -0800, Dick Hardt wrote:
> Hi Marius
> 
> Per my other response, implementations are important, but do not represent
> rough consensus.
> 
> Yaron and I have reached out the the AD to get guidance on how to proceed.
> 
> There is low energy in the WG, the implication is that the WG may be ready
> to terminate.
> 
> 
> 
> On Wed, Feb 27, 2019 at 2:42 PM Marius Scurtescu <marius.scurtescu=
> [email-masked]> wrote:
> 
> > Any chance for an answer from the chairs to the 3 questions below?
> >
> > On Sun, Feb 24, 2019 at 4:52 PM Marius Scurtescu <
> > [email-masked]> wrote:
> >
> >> Regrettable indeed :-(
> >>
> >> Were the recent official launches by Adobe and Google taken into
> >> consideration?
> >>
> >> Is it possible to consult the AD for options?
> >>
> >> Did we consider the implications for the whole working group?
> >>
> >> While the group is indeed at a low point of activity, a lot of work went
> >> into this draft and it is central for real life implementations.
> >>
> >>
> >>
> >>
> >> On Sun, Feb 17, 2019 at 6:43 AM Yaron Sheffer <[email-masked]>
> >> wrote:
> >>
> >>> Dear working group,
> >>>
> >>> We issued a 2-week second last call for draft-ietf-secevent-http-push-04
> >>> on Jan. 24, and extended it by a further week, which expired on Friday. We
> >>> had to issue a second last call because of lack of response to the first
> >>> last call which took place in November/December.
> >>>
> >>> The results were better in the second try (2 non-authors in support, and
> >>> 1 not clearly supporting publication) but not enough in our mind to push
> >>> the document forward.
> >>>
> >>> This means that we will not be publishing the Push protocol as a working
> >>> group document. The authors are welcome to publish it through other
> >>> channels, as an AD-sposored RFC or through the ISE.
> >>>
> >>> We regret that we have reached this impasse, but clearly there is too
> >>> little energy within the working group. We thank the authors for the
> >>> significant effort that they put into this document, and thank the working
> >>> group members who reviewed it.
> >>>
> >>> Regards,
> >>>
> >>>     Dick and Yaron
> >>> _______________________________________________
> >>> Id-event mailing list
> >>> [email-masked]
> >>> https://www.ietf.org/mailman/listinfo/id-event
> >>>
> >> _______________________________________________
> > Id-event mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/id-event
> >

> _______________________________________________
> Id-event mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/id-event

---

From: Mike Jones <[email-masked]>
Date: Sat, 9 Mar 2019 17:47:42 +0000

I just send my (belated) review of the push draft.  Sorry for the delay on my part.  I plan to solicit more reviews from additional working group members in the time leading up to and during Prague.

				-- Mike

-----Original Message-----
From: Id-event <[email-masked]> On Behalf Of Benjamin Kaduk
Sent: Wednesday, March 6, 2019 7:35 AM
To: SecEvent <[email-masked]>
Cc: Yaron Sheffer <[email-masked]>; Marius Scurtescu <marius.scurtescu=[email-masked]>; Dick Hardt <[email-masked]>
Subject: Re: [Id-event] Push draft: conclusion of WGLC

Hi everyone,

I think that Dick and Yaron are correct to determine that this document doesn't have WG consensus (rough or otherwise) to advance at this time.
That, of course, can change given additional inputs.

I'll note that the WGLC period is not a formal requirement of the process, but rather more of a conventional tool that WG chairs use to determine WG consensus.  In the KITTEN WG (that I chaired for a few years), which is a very low-energy group, we've largely distanced ourselves from WGLC in favor of a more rolling period where input comes in.  Regardless of how they get it, the chairs still need reason to believe that there is a critical mass of support in the WG for the work, and that all known technical issues have been addressed in some way (whether technical changes in the document or through subsequent discussion to determine it is not an issue/out of scope/not the direction the WG wants to go/etc.)  Historical interest and engagement of the kind that Annabelle points out can factor into this decision, but it's also the case that in order to advance, the current document needs WG consensus, and consensus that some previous version was "pointed in the right direction" isn't quite the same.

I agree with Mike that I hope this inability to make a determination of consensus can be a wake-up call that we need greater participation in order to proceed.

I think at this point there's a few possible paths including but not limited to:

1) get another couple positive reviews from people who are informed in the space (whether by following the work along the way or otherwise), and finish addressing the comments Phil raised during WGLC.  I know that they are rooted in a longstanding philosophical disagreement, but Phil is correct to raise them one last time during WGLC, and the conclusion of WGLC^W^W^Wdetermination of WG rough consensus involves the chairs being confident on the technical resolution to those issues. [0]  It's much easier for the chairs to do that when there's a contervailing writeup presented right next to the issues that were raised.

2) Not get more reviews, and have some discussion that concludes that the previous energy for push has evaporated, which would require the shared content with pull to be pulled [sic] back into the pull document before that could advance.  (Yes, that would be unpleasant and duplicate work that's already been done.  Nobody said this was a great option.)

3) Have some discussion that concludes that the WG just doesn't have enough energy to work on any of its remaining chartered items (i.e., event delivery), in which case it would be appropriate to close the WG.

>From this list, there seems a clear "best outcome", but we'll need some 
the WG participants to make it happen.  It might be worth getting some "survey results" about who is still interested in working on what, to help the chairs gauge the best path forward.

-Ben

[0] BTW, Phil would also be justified in raising the questions again during IETF LC, but it's generally considered best to only do that in the case when the broader IETF community would be unaware of the previous discussions and is believed to not be considering the topic without additional intervention.  IMO, having the controversy properly discussed in the shepherd writeup would probably fill that need, but Phil and everyone else should use their own judgement.

On Wed, Feb 27, 2019 at 02:58:01PM -0800, Dick Hardt wrote:
> Hi Marius
> 
> Per my other response, implementations are important, but do not 
> represent rough consensus.
> 
> There is low energy in the WG, the implication is that the WG may be 
> ready to terminate.
> 
> 
> 
> >> While the group is indeed at a low point of activity, a lot of work 
> >> went into this draft and it is central for real life implementations.
> >>
> >>
> >>
> >>
> >>> We issued a 2-week second last call for 
> >>> draft-ietf-secevent-http-push-04 on Jan. 24, and extended it by a 
> >>> further week, which expired on Friday. We had to issue a second 
> >>> last call because of lack of response to the first last call which took place in November/December.
> >>>
> >>> 1 not clearly supporting publication) but not enough in our mind 
> >>> to push the document forward.
> >>>
> >>> This means that we will not be publishing the Push protocol as a 
> >>> working group document. The authors are welcome to publish it 
> >>> through other channels, as an AD-sposored RFC or through the ISE.
> >>>
> >>> We regret that we have reached this impasse, but clearly there is 
> >>> too little energy within the working group. We thank the authors 
> >>> for the significant effort that they put into this document, and 
> >>> thank the working group members who reviewed it.
> >>>
> >>> Regards,
> >>>
> >>>     Dick and Yaron