Subject: [Id-event] Duplicate SET Recipient definition

From: Mike Jones <[email-masked]>
Date: Mon, 8 Jul 2019 21:30:36 +0000

Hi Annabelle,

Please delete the "Set Recipient" definition from the Push spec, as this term is already defined in the Security Event Token (SET)  specification [RFC 8417].

                                                                Thanks,
                                                                -- Mike

---

From: "Richard Backman, Annabelle" <[email-masked]>
Date: Mon, 8 Jul 2019 22:50:51 +0000

The current language was a compromise between it being confusing to have SET Transmitter defined here but not SET Recipient, and the fact that SET Recipient is already defined. See brief discussion here: https://mailarchive.ietf.org/arch/msg/id-event/iUDvQEZHrJ5o1aehCbZIkwqwmWs

I’m open to suggestions. We could separately list the specific terms used in this doc that are defined in 8417?

--
Annabelle Richard Backman
AWS Identity

From: Mike Jones <[email-masked]>
Date: Monday, July 8, 2019 at 2:31 PM
To: "Richard Backman, Annabelle" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Duplicate SET Recipient definition

Hi Annabelle,

Please delete the “Set Recipient” definition from the Push spec, as this term is already defined in the Security Event Token (SET)  specification [RFC 8417].

                                                                Thanks,
                                                                -- Mike

---

From: Mike Jones <[email-masked]>
Date: Mon, 8 Jul 2019 22:53:55 +0000

I’d be fine with that treatment.  For instance, https://tools.ietf.org/html/rfc7519#section-2 contains just such a list (actually, three such lists).

From: Richard Backman, Annabelle <[email-masked]>
Sent: Monday, July 8, 2019 3:51 PM
To: Mike Jones <[email-masked]>
Cc: [email-masked]
Subject: Re: Duplicate SET Recipient definition

The current language was a compromise between it being confusing to have SET Transmitter defined here but not SET Recipient, and the fact that SET Recipient is already defined. See brief discussion here: https://mailarchive.ietf.org/arch/msg/id-event/iUDvQEZHrJ5o1aehCbZIkwqwmWs<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmailarchive.ietf.org%2Farch%2Fmsg%2Fid-event%2FiUDvQEZHrJ5o1aehCbZIkwqwmWs&data=02%7C01%7CMichael.Jones%40microsoft.com%7C72fe76eac7af4797c28b08d703f6bd59%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636982230583422930&sdata=EGAfk%2BlhBSWDjixTA5MDKQvg6afcvEpLhKE9wvpncK4%3D&reserved=0>

From: Mike Jones <[email-masked]<mailto:[email-masked]>>
Date: Monday, July 8, 2019 at 2:31 PM
To: "Richard Backman, Annabelle" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Duplicate SET Recipient definition

Hi Annabelle,

                                                                Thanks,
                                                                -- Mike