Subject: Re: [Id-event] Roman Danyliw's No Objection on draft-ietf-secevent-http-poll-11: (with COMMENT)

From: Mike Jones <[email-masked]>
Date: Thu, 25 Jun 2020 05:44:20 +0000

Thanks for your review, Roman.  https://tools.ietf.org/html/draft-ietf-secevent-http-poll-12 is intended to address your comments.  Detailed replies are inline, prefixed by "Mike>".

-----Original Message-----
From: Roman Danyliw via Datatracker <[email-masked]> 
Sent: Tuesday, June 23, 2020 8:09 AM
To: The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; Yaron Sheffer <[email-masked]>; [email-masked]
Subject: Roman Danyliw's No Objection on draft-ietf-secevent-http-poll-11: (with COMMENT)

Roman Danyliw has entered the following ballot position for
draft-ietf-secevent-http-poll-11: No Objection

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-secevent-http-poll/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

** Section 2.2.  Per the ack array, is it fair to assume that an empty array is ignored?

Mike> It unambiguously is now. ;-)

** Section 2.4.  Per “After a period of time configured between the SET Transmitter and Recipient, …”, is that configuration out of band/scope for this specification?

Mike> Yes, it's now explicitly described as being out of band.

** Section 2.4.1.  Figure 1.  All of the other figures seem to explicitly state that this is a non-normative example.  s/The following is an example request/The following is a non-normative example of a request/.

Mike> I made this one consistent with the others.

** Section 4.3.  This section is identical to Section 5.3 of draft-ietf-secevent-http-push.  Please review the recommended clarifications mentioned there -- https://mailarchive.ietf.org/arch/msg/id-event/9h4_z8S-JyMMCbrdW6V7b_YmGbI/

Mike> Also applied here.

				Thanks again,
				-- Mike

---

From: Roman Danyliw <[email-masked]>
Date: Thu, 25 Jun 2020 12:25:03 +0000

Hi Mike!

Thanks for the clarifications below and the updated text now in -12.  It addresses all of my comments.

Regards,
Roman

> From: Mike Jones <[email-masked]>
> Sent: Thursday, June 25, 2020 1:44 AM
> To: Roman Danyliw <[email-masked]>; The IESG <[email-masked]>
> Cc: [email-masked]; [email-masked]; id-
> [email-masked]; Yaron Sheffer <[email-masked]>
> Subject: RE: Roman Danyliw's No Objection on draft-ietf-secevent-http-poll-11:
> (with COMMENT)
> 
> Thanks for your review, Roman.  https://tools.ietf.org/html/draft-ietf-secevent-
> http-poll-12 is intended to address your comments.  Detailed replies are inline,
> prefixed by "Mike>".
> 
> Cc: [email-masked]; [email-masked]; id-
> [email-masked]; Yaron Sheffer <[email-masked]>;
> [email-masked]
> When responding, please keep the subject line intact and reply to all email
> addresses included in the To and CC lines. (Feel free to cut this introductory
> paragraph, however.)
> 
> 
> ** Section 2.4.  Per “After a period of time configured between the SET
> Transmitter and Recipient, …”, is that configuration out of band/scope for this
> specification?
> 
> ** Section 2.4.1.  Figure 1.  All of the other figures seem to explicitly state that
> this is a non-normative example.  s/The following is an example request/The
> following is a non-normative example of a request/.
> 
> ** Section 4.3.  This section is identical to Section 5.3 of draft-ietf-secevent-
> http-push.  Please review the recommended clarifications mentioned there --
> https://mailarchive.ietf.org/arch/msg/id-event/9h4_z8S-
> JyMMCbrdW6V7b_YmGbI/
> 
> Mike> Also applied here.
> 
> 				Thanks again,
> 				-- Mike

---

From: Benjamin Kaduk <[email-masked]>
Date: Thu, 25 Jun 2020 15:32:09 -0700

> Subject: Roman Danyliw's No Objection on draft-ietf-secevent-http-poll-11: (with COMMENT)

It's good to be explicit about this.
(FWIW, my assumption in the previous undocumented state is that an empty
array was an error and would be rejected, though I don't think we
particularly benefit from such strict parsing semantics in this case.)

-Ben