Subject: [Id-event] Erik Kline's No Objection on draft-ietf-secevent-http-push-12: (with COMMENT)

From: Erik Kline via Datatracker <[email-masked]>
Date: Sat, 20 Jun 2020 23:09:20 -0700

Erik Kline has entered the following ballot position for
draft-ietf-secevent-http-push-12: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-secevent-http-push/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

[[ questions ]]

[ section 2.4 ]

* If the SET Issuer is not recognized as an issuer the recipient likes, what
  err string is best?  Most of the listed codes seem plausible in some small
  way, which lead me to think that either I'm confused or just a small bit of
  text might be added to one of the entry's description.

[ section 5.4 ]

* Is rate-limiting problematic transmitters also a reasonable approach?

[ section 5.5 ]

* Would it not also suffice to record in storage the relevant information from
  from the transmission context?

---

From: Mike Jones <[email-masked]>
Date: Thu, 25 Jun 2020 04:50:21 +0000

Thanks for your review, Erik.  https://tools.ietf.org/html/draft-ietf-secevent-http-push-13 is intended to address your comments.  Detailed replies are inline, prefixed by "Mike>".

-----Original Message-----
From: Erik Kline via Datatracker <[email-masked]> 
Sent: Saturday, June 20, 2020 11:09 PM
To: The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; Yaron Sheffer <[email-masked]>; [email-masked]
Subject: Erik Kline's No Objection on draft-ietf-secevent-http-push-12: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

[[ questions ]]

[ section 2.4 ]

Mike> Thanks for pointing out this ambiguity.  I added two new error codes, invalid_issuer and invalid_audience, to address specific error cases.

[ section 5.4 ]

Mike> I added a description of this approach.

[ section 5.5 ]

Mike> I added a description of this approach.

				Thanks again,
				-- Mike