Subject: [Id-event] Erik Kline's No Objection on draft-ietf-secevent-http-poll-11: (with COMMENT)

From: Erik Kline via Datatracker <[email-masked]>
Date: Tue, 23 Jun 2020 00:32:47 -0700

Erik Kline has entered the following ballot position for
draft-ietf-secevent-http-poll-11: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-secevent-http-poll/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

[[ questions ]]

[ section 2.4.2 ]

* What should happen with an ACK-only request that has maxEvents: 0 and
  returnImmediately: false?

  Should the default value of returnImmediately be !maxEvents?

---

From: Mike Jones <[email-masked]>
Date: Thu, 25 Jun 2020 04:56:52 +0000

Thanks for your review, Erik.  https://tools.ietf.org/html/draft-ietf-secevent-http-poll-12 is intended to address your comments.  Detailed replies are inline, prefixed by "Mike>".

-----Original Message-----
From: Erik Kline via Datatracker <[email-masked]> 
Sent: Tuesday, June 23, 2020 12:33 AM
To: The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; Yaron Sheffer <[email-masked]>; [email-masked]
Subject: Erik Kline's No Objection on draft-ietf-secevent-http-poll-11: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

[[ questions ]]

[ section 2.4.2 ]

Mike> Great question!  I defined the answer in the new second paragraph of https://tools.ietf.org/html/draft-ietf-secevent-http-poll-12#section-2.4.2.  The governing principle is that returnImmediately is independent of the other parameters.

Mike> See my previous answer.

				Thanks again,
				-- Mike