Subject: [Id-event] Robert Wilton's No Objection on draft-ietf-secevent-http-poll-11: (with COMMENT)

From: Robert Wilton via Datatracker <[email-masked]>
Date: Mon, 22 Jun 2020 09:51:01 -0700

Robert Wilton has entered the following ballot position for
draft-ietf-secevent-http-poll-11: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-secevent-http-poll/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Hi,

I found that document easy to read/understand (despite not really knowing what
"SET"s are).  However, I did have a query about the algorithm:

It seems to me that if a client fails to acknowledge a SET (e.g. due to a bug,
or perhaps a message is lost) then it has to wait until the server times out
waiting for the SET acknowledgement before the server hopefully resends it.

However, I would normally expect that a client should automatically acknowledge
all SETs in the order that it receives them because it doesn't seem to have a
good reason not to do so.  Hence, I was wondering whether it would be useful to
have an option to allow clients to request that the next "maxEvents" SETs also
include any unacknowledged SETs?  This would allow clients to potentially
recover lost SETs more quickly and more robustly?  I.e. for the case where a
client expects to acknowledge all existing received SETs before/when requesting
more.

Regards,
Rob

---

From: Mike Jones <[email-masked]>
Date: Thu, 25 Jun 2020 05:09:36 +0000

Thanks for your review, Rob.  https://tools.ietf.org/html/draft-ietf-secevent-http-poll-12 is intended to address your comments.  Detailed replies are inline, prefixed by "Mike>".

-----Original Message-----
From: Robert Wilton via Datatracker <[email-masked]> 
Sent: Monday, June 22, 2020 9:51 AM
To: The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; Yaron Sheffer <[email-masked]>; [email-masked]
Subject: [EXTERNAL] Robert Wilton's No Objection on draft-ietf-secevent-http-poll-11: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Hi,

I found that document easy to read/understand (despite not really knowing what "SET"s are).  However, I did have a query about the algorithm:

It seems to me that if a client fails to acknowledge a SET (e.g. due to a bug, or perhaps a message is lost) then it has to wait until the server times out waiting for the SET acknowledgement before the server hopefully resends it.

However, I would normally expect that a client should automatically acknowledge all SETs in the order that it receives them because it doesn't seem to have a good reason not to do so.  Hence, I was wondering whether it would be useful to have an option to allow clients to request that the next "maxEvents" SETs also include any unacknowledged SETs?  This would allow clients to potentially recover lost SETs more quickly and more robustly?  I.e. for the case where a client expects to acknowledge all existing received SETs before/when requesting more.

Mike> I added text saying that both retried and first-time SETs are part of the "sets" member.  Once the transmitter has seen what's been acknowledged by the recipient, there's no reason to have to wait to retransmit.  In response to other IESG review comments strict ordering is not guaranteed.  For instance, priority ordering might be appropriate for some use cases.

Regards,
Rob

				Thanks again,
				-- Mike