Subject: Re: [Id-event] New revision: draft-ietf-secevent-subject-identifiers-07

From: Justin Richer <[email-masked]>
Date: Wed, 7 Apr 2021 09:10:49 -0400

Annabelle and chairs, any updates on these items?

Thanks,
 — Justin

> On Mar 10, 2021, at 1:42 PM, Tim Cappalli <[email-masked]> wrote:
> 
> +1 Justin
> From: Id-event <[email-masked]> on behalf of Justin Richer <[email-masked]>
> Sent: Wednesday, March 10, 2021 13:39
> To: Richard Backman, Annabelle <richanna=[email-masked]>
> Cc: [email-masked] <[email-masked]>
> Subject: Re: [Id-event] New revision: draft-ietf-secevent-subject-identifiers-07
>  
> One more thought:
> 
> Distributed Identifiers (DIDs) are being finalized in the W3C and their use is becoming more widespread.
> 
> https://www.w3.org/TR/did-core/ <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.w3.org%2FTR%2Fdid-core%2F&data=04%7C01%7Ctim.cappalli%40microsoft.com%7C7dd8131cacb54f0137f408d8e3f3db55%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637509983795201447%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=LXfaNWKpO0SEcXPYZsf8SRgO48S9BQIKgLmVlBiZUL0%3D&reserved=0>
> 
> I would like to see “did” as a defined format in this spec. If we don’t define it now, it would be an early entry to the extension registry, so it probably makes sense to define it here. What do you and the chairs think?
> 
>  — Justin
> 
>> On Mar 9, 2021, at 4:16 PM, Justin Richer <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Annabelle,
>> 
>> I just read through this draft, and this is great work! It always amazes me how such a small changing in framing can drastically improve a technical work. It’s much clearer as to what it’s for and how it’s used. I’m curious if this syntax change affects the existing use of this work in RISC, though? I’m not directly familiar with that group’s status.
>> 
>> Also, the “opaque” identifier format is precisely what we need for another project, so I’m really glad to see that included in the core.
>> 
>> Personally, I think this draft is ready for WGLC and on to publication.
>> 
>>  — Justin
>> 
>>> On Mar 8, 2021, at 8:46 PM, Richard Backman, Annabelle <richanna=[email-masked] <mailto:richanna=[email-masked]>> wrote:
>>> 
>>> Hello Security Events Working Group,
>>> 
>>> I have just published an update to the Subject Identifiers draft, making the following notable changes:
>>> 
>>> The term "Subject Identifier Type" has been replaced with "Identifier Format", and the `subject_type` member has been changed to `format`. This is part of an attempt to further emphasize the difference the fact that Subject Identifiers and Identifier Formats relate to identifiers themselves, not the subjects they identify.
>>> 
>>> Note that this change applies to the IANA registry as well.
>>> 
>>> Added a section for considerations for specifications that define Identifier Formats, prohibiting them from defining rules that make assertions or declarations about the subject, rather than about the identifier.
>>> 
>>> A new format, `opaque` has been added. This is intended for scenarios where an opaque string is used as the identifier, and no additional semantics are asserted about it. (e.g., it is not to be parsed or interpreted as anything other than an identifier)
>>> 
>>> Clarified that "subject" is used in a generic sense, i.e., not specifically referring to subjects of JWTs. Also defined the term "JWT Subject" for the specific case, and updated the draft to use that when referring specifically to a subject of a JWT.
>>> 
>>> URL:            https://www.ietf.org/archive/id/draft-ietf-secevent-subject-identifiers-07.txt <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-ietf-secevent-subject-identifiers-07.txt&data=04%7C01%7Ctim.cappalli%40microsoft.com%7C7dd8131cacb54f0137f408d8e3f3db55%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637509983795201447%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=xaxH694j1XVyDYkr3EAEDE9bLitSOBf5VjcbK%2BQhYuw%3D&reserved=0>
>>> Status:         https://datatracker.ietf.org/doc/draft-ietf-secevent-subject-identifiers/ <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-secevent-subject-identifiers%2F&data=04%7C01%7Ctim.cappalli%40microsoft.com%7C7dd8131cacb54f0137f408d8e3f3db55%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637509983795211444%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=Y%2Fr1LNE0Vu0jaDzy%2F9YGVUUdjeOkjMp2ZytQg8JXVPg%3D&reserved=0>
>>> Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-secevent-subject-identifiers <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-secevent-subject-identifiers&data=04%7C01%7Ctim.cappalli%40microsoft.com%7C7dd8131cacb54f0137f408d8e3f3db55%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637509983795211444%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=QffCgYCX6QJcZVHccIcQrUnij0dhHGHy6e14s6EGjXY%3D&reserved=0>
>>> Htmlized:       https://tools.ietf.org/html/draft-ietf-secevent-subject-identifiers-07 <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-secevent-subject-identifiers-07&data=04%7C01%7Ctim.cappalli%40microsoft.com%7C7dd8131cacb54f0137f408d8e3f3db55%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637509983795221435%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=gnfOJBPGysU5o63lXkFnDOq%2B2378Dl7bXJXlefcix8s%3D&reserved=0>
>>> Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-secevent-subject-identifiers-07 <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-ietf-secevent-subject-identifiers-07&data=04%7C01%7Ctim.cappalli%40microsoft.com%7C7dd8131cacb54f0137f408d8e3f3db55%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637509983795221435%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=NrhBT%2FhVsgcz7hTAsvKxlgflFKMbpheiBS3oqmZzzWw%3D&reserved=0>
>>> 
>>> Abstract:
>>>   Security events communicated within Security Event Tokens may support
>>>   a variety of identifiers to identify subjects related to the event.
>>>   This specification formalizes the notion of subject identifiers as
>>>   structured information that describe a subject, and named formats
>>>   that define the syntax and semantics for encoding subject identifiers
>>>   as JSON objects.  It also defines a registry for defining and
>>>   allocating names for such formats, as well as the "sub_id" JSON Web
>>>   Token (JWT) claim.
>>> 
>>> –
>>> Annabelle Backman (she/her)
>>> [email-masked] <mailto:[email-masked]>_______________________________________________
>>> Id-event mailing list
>>> [email-masked] <mailto:[email-masked]>
>>> https://www.ietf.org/mailman/listinfo/id-event <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fid-event&data=04%7C01%7Ctim.cappalli%40microsoft.com%7C7dd8131cacb54f0137f408d8e3f3db55%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637509983795231432%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=h6tuMBhHECWGfWtXY7298EfEyfOxvOXHtaCE0%2BZaQdI%3D&reserved=0>
>> 
>> _______________________________________________
>> Id-event mailing list
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/id-event

---

From: Justin Richer <[email-masked]>
Date: Tue, 13 Apr 2021 11:22:16 -0400

After speaking with the DID working group in the W3C, I’ve submitted a PR to add the DID method:

https://github.com/richanna/secevent/pull/2 <https://github.com/richanna/secevent/pull/2>

 — Justin

> On Apr 7, 2021, at 9:10 AM, Justin Richer <[email-masked]> wrote:
> 
>> On Mar 10, 2021, at 1:42 PM, Tim Cappalli <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> +1 Justin
>> From: Id-event <[email-masked] <mailto:[email-masked]>> on behalf of Justin Richer <[email-masked] <mailto:[email-masked]>>
>> To: Richard Backman, Annabelle <richanna=[email-masked] <mailto:richanna=[email-masked]>>
>> Cc: [email-masked] <mailto:[email-masked]> <[email-masked] <mailto:[email-masked]>>
>>> https://www.ietf.org/mailman/listinfo/id-event <https://www.ietf.org/mailman/listinfo/id-event>
> [email-masked]

---

From: Yaron Sheffer <[email-masked]>
Date: Tue, 13 Apr 2021 19:39:56 +0300

(Hats off)

I support this addition.

Thanks,

                Yaron

From: Id-event <[email-masked]> on behalf of Justin Richer <[email-masked]>
Date: Tuesday, April 13, 2021 at 18:22
To: Tim Cappalli <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "richanna=[email-masked]" <richanna=[email-masked]>
Subject: Re: [Id-event] New revision: draft-ietf-secevent-subject-identifiers-07

https://github.com/richanna/secevent/pull/2

 — Justin

Thanks,

 — Justin

+1 Justin

One more thought:

https://www.w3.org/TR/did-core/

 — Justin

On Mar 9, 2021, at 4:16 PM, Justin Richer <[email-masked]> wrote:

Annabelle,

 — Justin

On Mar 8, 2021, at 8:46 PM, Richard Backman, Annabelle <richanna=[email-masked]> wrote:

URL:            https://www.ietf.org/archive/id/draft-ietf-secevent-subject-identifiers-07.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-secevent-subject-identifiers/
Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-secevent-subject-identifiers
Htmlized:       https://tools.ietf.org/html/draft-ietf-secevent-subject-identifiers-07
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-secevent-subject-identifiers-07

Abstract:

–

[email-masked]

_______________________________________________ Id-event mailing list [email-masked] https://www.ietf.org/mailman/listinfo/id-event