Subject: TTL values for DVMRP control messages

From: Sundeep Singatwaria <[email-masked]>
Date: Sun, 24 Oct 1999 19:30:47 -0700

The DVMRP draft specifies that IP TTL value of probe messages MUST be set
to 1.
What about the other control messages like DVMRP report, prune, graft and
graft ACK. Is it possible for any of these control messages to have a value
greater than 1 for some scenario ?

Thanks in advance.
sundeep

---

From: Tom Pusateri <[email-masked]>
Date: Sun, 24 Oct 1999 21:16:05 -0700

In message <[email-masked]> y
>greater than 1 for some scenario ?

Ideally, no. In practice, yes.

If these messages are sent to a tunnel endpoint, there are two ways
of sending them. The first is to encapsulate them inside the tunnel
in which case, using a TTL of 1 would work fine. However, some
implementations had difficulty doing this because of the operating
system they run on. Therefore, they sent these messages along side
the tunnel which requires TTLs > 1.

In this sense, the probe message is really no different than these
other control messages.

Tom