Subject: Re: IGMPv2 and IGMPv1 Routers on the same segment.

From: "John M. Zwiebel" <[email-masked]>
Date: Tue, 14 Dec 1999 11:30:53 -0800

Yes you can do this, but there's no way to move back to IGMPv2 when the
IGMPv1 system goes away.  Its better to follow the RFC and manually 
configure it.

 ^ >Hi,
 ^ >
 ^ >Is there any way of dynamically determining whether IGMPv1 and IGMPv2
 ^ >routers are present on the same network segment.
 ^ 
 ^ One way of doing this is by noting that IGMPv2 queries should contain a non
 ^ zero value for the Maximum Response Time field. IGMPv1 queriers set it to 0
 ^ as it is not defined. Another way of dynamically determining the queriers
 ^ present, though not very robust, is to use the IP Router Alert option. All
 ^ the IGMPv2 query packets use this option.
 ^ 
 ^ >I have a situation where I have both IGMPv1 and IGMPv2 Router are present o
    n
 ^ >the same segment.
 ^ >
 ^ >Both Routers becomes Queriers on that network segment. 
 ^ >
 ^ >If required more details, I can provide the configuration/information.
 ^ >
 ^ >Thanks in advance, 
 ^ >
 ^ >Amarnath
 ^ >Pluris, Inc.
 ^ 
 ^ ---
 ^ 	Soma.
 ^ 

------------------------------------------------------------------------------
	John Zwiebel                       Phone: 408-526-5303
	Cisco Systems Inc.                 
	IP Multicast Group

---

From: "Soma S. Muppidi" <[email-masked]>
Date: Tue, 14 Dec 1999 10:49:59 -0800

>Hi,
>
>Is there any way of dynamically determining whether IGMPv1 and IGMPv2
>routers are present on the same network segment.

One way of doing this is by noting that IGMPv2 queries should contain a non
zero value for the Maximum Response Time field. IGMPv1 queriers set it to 0
as it is not defined. Another way of dynamically determining the queriers
present, though not very robust, is to use the IP Router Alert option. All
the IGMPv2 query packets use this option.

>I have a situation where I have both IGMPv1 and IGMPv2 Router are present on
>the same segment.
>
>Both Routers becomes Queriers on that network segment. 
>
>If required more details, I can provide the configuration/information.
>
>Thanks in advance, 
>
>Amarnath
>Pluris, Inc.

---
	Soma.