Subject: DVMRP

From: Ali Boudani <[email-masked]>
Date: Wed, 21 Feb 2001 12:07:07 +0100

Hello,
I have two questions:
1- Is DVMRP is till used in a large networks or PIM is replacing it??
2- With DVMRP when using the RPM algorithm , why should we periodically
send messages and after that prune the tree??
It is more simple to send the first message, prune all banches where
there is no members and wait for a graft message if there any new
members.
Why should we send the datagram to all the internetwork again and have
the prune mechanism again?? (bandwidth can we wasted)
thanx

---

From: Vijayanand Chandrasekar <[email-masked]>
Date: Wed, 21 Feb 2001 17:24:55 +0530

> the prune mechanism again?? (bandwidth can we wasted)

This a question of minimising state information in the routers. Using the
current mechanism, the prune state that is maintained on a downstream(which
is needed for grafting) will be timed out after the prune life time. So , we
don't have to maintain state of all possible (S,G) prunes, as this involves
storage of lot of state info.

Otherwise , if implemented as you suggest all (S,G) prunes sent to upstream
should be maintained for ever !.

THe current prune life time is large enough to prevent too much BW wastage.

Regards,
Vijay

---

From: Beau Williamson <[email-masked]>
Date: Wed, 21 Feb 2001 09:28:17 -0800

>1- Is DVMRP is till used in a large networks or PIM is replacing it??

While DVMRP *may* still be in use in some networks, the trend is clearly towards PIM.  

In general, network engineers should be designing all new multicast networks around PIM since this is pretty much the key multicast protocol on which extensions and augmentations are being built in the IETF.  There is little or no serious work being done on any other protocol.  

Beau Williamson