Subject: Re: Multicast

From: Bill Fenner <[email-masked]>
Date: Wed, 7 Mar 2001 18:11:12 -0800

[I removed [email-masked], as well as most of the other entries, from
the cc: line.]

Signed applets work if you grant the rights (at least in Netscape).
I tried Marshall's applet and I got:

JavaScript or a Java applet from 'Multicast Technologies, Inc ' is
requesting additional privileges.

Granting the following is HIGH RISK:
Broadcasting information to multiple computers over a network.

I granted that one, and got another one, saying

Granting the following is HIGH RISK:
Accepting connections from other computers on a network

Then a third, saying:

Granting the following is HIGH RISK:
Contacting and connecting with other computers over a network

And finally, my system joined the group:

18:06:55.843130 mango.attlabs.att.com > 233.64.133.12: igmp v2 report 233.64.133.12 [ttl 1]

but netscape's warnings are plenty threatening (and prolific) to make
some/many/most consumers not click all those buttons.  (Netscape will
remember these decisions, and I *think* the decision is based on the
signer, so if you get someone to click all these buttons once they will
trust all of the applets signed by the same key, but still...)

  Bill

---

From: Marshall Eubanks <[email-masked]>
Date: Wed, 07 Mar 2001 22:52:45 -0500

Hi Bill;

> [I removed [email-masked], as well as most of the other entries, from

Thanks - I should have done that. I don't think the whole IETF is interested...

> I tried Marshall's applet and I got:

Marty Schoch wrote it.
> trust all of the applets signed by the same key, but still...)

Hey, at least we didn't make you sign a waiver.

Our button web page warns you about these messages (Microsoft IE requires just one such
grant, BTW).  We couldn't figure out how to shut them off.
If anyone knows a way to get the applet to work without this, please let me know.

What we were trying to do here was to get something that the uninitiated could use without
downloading anything, so this seemed acceptable. It is problematic for most applet applications, of
course.

It seems to me that joining a mulitcast group from a applet running inside a virtual machine is
fairly safe. Maybe the browser makers could make an exception for a join with transmission disabled.

                                   Regards
                                   Marshall Eubanks

   Multicast Technologies, Inc.
   10301 Democracy Lane, Suite 410
   Fairfax, Virginia 22030
   Phone : 703-293-9624          Fax     : 703-293-9609     
   e-mail : [email-masked]     http://www.on-the-i.com