Subject: RE: IGMP snooping draft: Solicitation for Comments

From: Beau Williamson <[email-masked]>
Date: Mon, 26 Mar 2001 18:24:57 -0600

Sundeep,

Please be careful about stating what your competition does and does not support to this mailing list which is read by many of our collective customers. Your comment below is misleading and implies that Cisco does not support IGMP Snooping.  Cisco *does* support IGMP Snooping as well as having support for CGMP which is another protocol that *is* Cisco proprietary.

Having said that, I too think that an attempt to standardize IGMP Snooping is outside of the scope of the IETF.

Beau Williamson

At 12:15 PM 3/26/2001, Sundeep Singatwaria wrote:
> 
>We have been supporting IGMP snopping on our Accelar switches for many years now. Cisco, has it own propiteary way of doing snopping. Are we standardizing it now. How come there is a renewed interest for this in IETF when it was considered outside its charter a couple of years back.
> 
>Sundeep.  
>-----Original Message----- 
>From: Morten Jagd Christensen [mailto:[email-masked]] 
>Sent: Monday, March 26, 2001 5:39 AM 
>To: idmr 
>Subject: IGMP snooping draft: Solicitation for Comments
>
>Hi, 
>
>Some of you may have seen that we have posted a draft on this list  
>on aspects of IGMP snooping switches. 
>
>The draft is available as: draft-ietf-idmr-igmp-snoop-00.txt 
>
>A presentation of this draft was made at the IETF meeting last  
>week. Generally I would say that the draft was well received with only  
>positive comments or encouragements although it will probably move  
>out of the idmr WG soon. 
>
>Since the IETF idmr WG meeting had a limited number of attendees  
>compared to the number of subscribers of this list (I suppose)  I would  
>like to solicit for comments on the draft.  
>So, please send us comments if: 
>
>1) You have read the draft and have any comments whatsoever. No comment  
>is to simple. 
>
>2) You are working for a company producing IGMP snooping switches and  
>have experiences that you want to share. For example regarding interoperability  
>issues or solutions that you have found to be practical. 
>
>3) You know some people who might be interested in this work. Either send me  
>their email addresses or forward this mail to them. 
>
>4) You're IGMP agnostic but still want to share your view on this. 
>
>You can either post your reply to the discussion list or you can email me  
>directly (CC to Frank Solensky) is you don't want your name out in the  
>public. 
>
>Your contribution will be appreciated. 
>
>Cheers 
>
>/Morten 
>
>--------------------------------------------------  
>Morten Jagd Christensen        | Exbit Technology  
>M.Sc., Ph.D.                   | www.exbit.com  
>Network- and System Architect  | [email-masked]

---

From: Cheng Hong <[email-masked]>
Date: Tue, 27 Mar 2001 12:08:30 +0800

Hi,

I got some questions about the IGMPv3 draft.

[1]
In section 6.4.1, page 32, the router action table column 2 suggests that
upon the reception of IS_EX(B) report on a router of state INCLUDE(A), the
router would switch state to EXCLUDE(A*B, B-A), and the actions to take
including Delete(A-B).

[2]
In section 6.5 and appendix A.3, it is suggested that when the group timer
expires, the router should switch back to INCLUDE mode, following the rules
of EXCLUDE(X,Y) ---> INCLUDE(X).

Is that means the router mentioned in [1] would switch back to INCLUDE(A*B)
instead of INCLUDE(A) when no host with Exclude mode exists in the subnet?
Would this block the traffic from (A-B) while some hosts MAY request?

PS: Does the draft suggest that the router would modify it is states every
time it receives a current-state report? And as mentioned earlier in the
draft that IGMPv3 host would not perform report suppressing. Would this make
the router busy at updating it states?

Regards

Cheng

---

From: Isidor Kouvelas <[email-masked]>
Date: Tue, 27 Mar 2001 11:12:56 -0800

It is a missconfiguration to have a router configured to operate IGMPv1
and a router configured to operate IGMPv3 on the same link. The only
action taken by v3 is to log the error. The administrator must then fix
the problem. The protocol behaviour under this condition is not defined.

thanks
I

Mladen Sablic writes:
>Hi,
>
>I have a question about how a router should behave when it hears a V1 Query.
>
>(section 7.3.1 of draft-ietf-idmr-igmp-v3-07.txt)
>Apart from logging a warning should it become a Non-Querier irrespective of
>its IP address and just sit and listen to reports OR is this behaviour
>deliberately left undefined as there are not that many IGMPv1 routers
>out there and all V2 implementations should come up by default as V2?
>
>Thanks,
>
>Mladen
>

---

From: Mladen Sablic <[email-masked]>
Date: Tue, 27 Mar 2001 19:09:03 +0100

Hi,

Thanks,

Mladen

---

From: Bill Fenner <[email-masked]>
Date: Tue, 27 Mar 2001 16:11:05 -0800

Since IGMPv1 did not specify a querier election, many implementations
elect the IGMP querier based upon routing protocol neighbors, e.g.
the highest IP address PIM neighbor.  So, if the highest IP address
PIM neighbor is an IGMPv3 router who just shuts up when it hears a
v1 Query, then there will be no Querier.

Since there's no easy way to deal with it, we left it specified that
it's simply an administrative problem to ensure that these are
consistent.

  Bill