Subject: [idn] FYI: CNNIC services GBK, Big5, and UTF8 encodings

From: Eric Brunner-Williams in Portland Maine <[email-masked]>
Date: Sat, 10 Feb 2001 11:49:58 -0500

[Please trim the cc if replying!]

Announced Monday, February 5th, at the following URL:

http://english.peopledaily.com.cn/200102/05/eng20010205_61600.html

My understanding is that CNNIC does or will provide a resolver which has
	support for these three encodings within the .cn ccTLD,
	defaults (like AOL keywords) any FQDN to FQDN.cn,
	supports these three encodings within the the DNS root, at least
		for some set of iso3166 labels, e.g., cn, and possibly tw
	and probably does more than the peopledaily writer describes.

These aren't ASCII Compatible Extension (ACE) encoding mechanisms, and differ
from the iDNS/NSI mechanism deployment of last November, which is ACE-based.

For those familiar with either GBK or Big5, feel free to ignore the next
two paras.

For those unfamiliar with the GB series, GBK is the MS Windows PRC version
(K == kuozhan "extension"), see also GB 1390.1-93 and GB 2312-80, and for
the EUC-centric (me, other Unix i18n weenies), overlaps EUC-CN, and encodes
the Chinese subset of ISO 10646-1:1993.

For those unfamiliar with Big5, it is the de facto standard in Taiwan (Mac
and Windows) and is equivalent to the first two planes of CNS 11643-1992,
and for the EUC-centric, differs from EUC-TW code sets 0 and 1 mainly in
having an additional encoding block.

The CNNIC's approach appears to be at odds with a recent IDN WG I-D [1],
which observed:

> Note also that because modern OS are Unicode based and have network-
> downloadable IMEs, "interoperability" is becoming less equivalent to
> "use BIG5 characters only" or "use GB2312 character only" or "use
> Shift-JIS characters only".

What appears to be the case is CNNIC is offering network-downloadable
code-set-specific resolvers, independent of (native) Unicode deployment
in OS products and input method extension delivery mechanisms.

Incidently, the January edition of the CNNIC semiannual data is available.
Semiannual Survey Report on the Development of China's Internet (Jan. 2001)
http://www.cnnic.cn/develst/e-cnnic200101.shtml

Corrections and additional comments welcome, Maine is a ways from Beijing.

Eric

[1] "Han Ideograph (CJK) for Internationalized Domain Names", Seng et al.,
    http://search.ietf.org/internet-drafts/draft-ietf-idn-cjk-00.txt

---

From: wenhui zhang <[email-masked]>
Date: Tue, 13 Feb 2001 22:55:13 -0800 (PST)

Hello
    The resolver of Chinese Domain Name System(CDNS),
as a part of CDNS
which CNNIC provides, is just like the resolver of
Netscape browser that
does not change the encoding of user's local requires
and send the original requirement to a code-switcher. 
The code switcher can transfer local
encoding to UTF-8 and vice versa. Any local encoding
query before it enter to name server is changed to
UTF8-based encoding query. The name server can handle
UTF8-based encoding query.The ACE-based domain name
will not be changed and its processes is just as
former.
    Using this mechanism, no matter what kind of
native encoding set,
the multilingual domain name system will work
correctly.

Yours regards

deng xiang
2001.2
--- Eric Brunner-Williams in Portland Maine

__________________________________________________
Do You Yahoo!?
Get personalized email addresses from Yahoo! Mail - only $35 
a year!  http://personal.mail.yahoo.com/