Subject: Re: [idn] An open letter to the IDN WG (long)

From: "A. Vine" <[email-masked]>
Date: Thu, 22 Mar 2001 10:57:19 -0800

Er, I appreciate the discussion, but not the singling out of mothers and
grandmothers.  I may one day be one of the above, and I'd like to think
that
I know as much about entering character data in any charset in any
fashion
than one person can know when it isn't something they do exclusively.
Thank you for remembering that non-technical people are not necessarily
women with children, particularly older ones.

Andrea Vine
P.S.  I knit too.
----- Original Message -----
From: "Dave Crocker" <[email-masked]>
To: "John C Klensin" <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, March 19, 2001 1:59 PM
Subject: Re: [idn] An open letter to the IDN WG (long)

> At 01:15 PM 3/19/2001, John C Klensin wrote:
> >--On Monday, 19 March, 2001 12:49 -0800 Dave Crocker
> ><[email-masked]> wrote:
> > > When computer engineers make wishful assertions about our...
> >
> >And that, to reprise part of our conversation in Melbourne, is
> >why I believe a "grandmother test" needs to be applied to this
> >work.  And Nameprep --and, more generally, the attempt to get
> >words in free text to act as identifiers-- fails it.
>
> you have perfectly telescoped the topic I was most concerned about in
your
> own open letter:
>
>          your note introduces feature creep
>
> "The attempt to get words in free text to act as identifiers" is not a
goal
> or requirement of the DNS.
>
> It is therefore not a goal or requirement of internationalizing the
DNS.
>
> I fully appreciate the appeal and benefit with that goal, but it is
not
> within scope.
>
> Domain names sometimes seduce people into thinking that they represent
> words if free text, but that is not what they are.
>
>          ***  And we have no need to expand domain names to be words
in
> free text  ***
>
> It is one thing to deal with a "coding" limitation and fix it, that
is, to
> move from ASCII as the end-user string to an international range of
> characters.  It is an entirely different thing to try to change the
> philosophy and semantics of the domain name "type".
>
> Even grandmothers can learn cryptic syntax, though it is not
reasonable to
> force them to learn different character sets.
>
> There is always a balance to seek and, yes, we need to be very careful
> about the burden we place on grandmothers.  However they learn postal
codes
> and telephone numbers.  And all the evidence is that they learn URLs
> reasonably well.  Domain name restrictions fall well within that scope
of
> restrictions.
>
> d/
>
> ----------
> Dave Crocker   <mailto:[email-masked]>
> Brandenburg InternetWorking   <http://www.brandenburg.com>
> tel: +1.408.246.8253;   fax: +1.408.273.6464
>
>
>

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>
Sent: Friday, March 23, 2001 2:43 AM
Subject: BOUNCE [email-masked]: Non-member submission from ["A. Vine"
<[email-masked]>]

> >From [email-masked] Thu Mar 22 10:43:42 2001
> Received: from r2d2.netscape.com ([205.217.237.47] helo=netscape.com)
> by psg.com with esmtp (Exim 3.16 #1)
> id 14gA3i-0006vH-00
> for [email-masked]; Thu, 22 Mar 2001 10:43:42 -0800
> Received: from u-gotmail.red.iplanet.com (u-gotmail.red.iplanet.com
[192.18.73.45])
> by netscape.com (8.10.0/8.10.0) with ESMTP id f2MIhU924230;
> Thu, 22 Mar 2001 10:43:30 -0800 (PST)
> Received: from copper (gbl-dhcp-192-234.France.Sun.COM
[129.157.192.234])
>  by we-gotmail.red.iplanet.com
>  (iPlanet Messaging Server 5.1 (built Mar 11 2001))
>  with SMTP id <[email-masked]>; Thu,
>  22 Mar 2001 10:50:15 -0800 (PST)
> Date: Thu, 22 Mar 2001 10:39:12 -0800
> From: "A. Vine" <[email-masked]>
> Subject: Re: [idn] An open letter to the IDN WG (long)
> To: Dave Crocker <[email-masked]>, John C Klensin <[email-masked]>
> Cc: [email-masked]
> Message-id: <01c301c0b2ff$64c6ab00$eac09d81@copper>
> MIME-version: 1.0
> X-MIMEOLE: Produced By Microsoft MimeOLE V5.00.2919.6700
> X-Mailer: Microsoft Outlook Express 5.00.2919.6700
> Content-type: text/plain; charset=iso-8859-1
> Content-transfer-encoding: 7BIT
> X-Priority: 3
> X-MSMail-priority: Normal
> References: <[email-masked]>
>  <[email-masked]>
>
> Er, I appreciate the discussion, but not the singling out of mothers
and
> grandmothers.  I may one day be one of the above, and I'd like to
think that
> I know as much about entering character data in any charset in any
fashion
> than one person can know when it isn't something they do exclusively.
> Thank you for remembering that non-technical people are not
necessarily
> women with children, particularly older ones.
>
> Andrea Vine
> P.S.  I knit too.
> ----- Original Message -----
> From: "Dave Crocker" <[email-masked]>
> To: "John C Klensin" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Monday, March 19, 2001 1:59 PM
> Subject: Re: [idn] An open letter to the IDN WG (long)
>
>
> > At 01:15 PM 3/19/2001, John C Klensin wrote:
> > >--On Monday, 19 March, 2001 12:49 -0800 Dave Crocker
> > ><[email-masked]> wrote:
> > > > When computer engineers make wishful assertions about our...
> > >
> > >And that, to reprise part of our conversation in Melbourne, is
> > >why I believe a "grandmother test" needs to be applied to this
> > >work.  And Nameprep --and, more generally, the attempt to get
> > >words in free text to act as identifiers-- fails it.
> >
> > you have perfectly telescoped the topic I was most concerned about
in your
> > own open letter:
> >
> >          your note introduces feature creep
> >
> > "The attempt to get words in free text to act as identifiers" is not
a
> goal
> > or requirement of the DNS.
> >
> > It is therefore not a goal or requirement of internationalizing the
DNS.
> >
> > I fully appreciate the appeal and benefit with that goal, but it is
not
> > within scope.
> >
> > Domain names sometimes seduce people into thinking that they
represent
> > words if free text, but that is not what they are.
> >
> >          ***  And we have no need to expand domain names to be words
in
> > free text  ***
> >
> > It is one thing to deal with a "coding" limitation and fix it, that
is, to
> > move from ASCII as the end-user string to an international range of
> > characters.  It is an entirely different thing to try to change the
> > philosophy and semantics of the domain name "type".
> >
> > Even grandmothers can learn cryptic syntax, though it is not
reasonable to
> > force them to learn different character sets.
> >
> > There is always a balance to seek and, yes, we need to be very
careful
> > about the burden we place on grandmothers.  However they learn
postal
> codes
> > and telephone numbers.  And all the evidence is that they learn URLs
> > reasonably well.  Domain name restrictions fall well within that
scope of
> > restrictions.
> >
> > d/
> >
> > ----------
> > Dave Crocker   <mailto:[email-masked]>
> > Brandenburg InternetWorking   <http://www.brandenburg.com>
> > tel: +1.408.246.8253;   fax: +1.408.273.6464
> >
> >
> >
>
>

---

From: Dave Crocker <[email-masked]>
Date: Thu, 22 Mar 2001 16:51:12 -0600

>women with children, particularly older ones.

"Politically correct" has become a slur.  As it should be.

It began with a serious and valid concern about public expression of biases 
and slurs.  Then it became its own tyranny.

If we are all required to author text that is only so sanitized that it 
cannot possibly cross the path of anyone's sensitivities, then we are 
required to author text that has no soul and will usually fail to call up 
adequate descriptive and referential force.  However readers have some 
responsibility, too.  They are are required to take comments in context.

Please note that the core of John's comment was about his own mother.  As 
was mine, albeit in a followup note.

Are we prohibited from citing people within our direct experience, 
including family members?

Are we prohibited from citing the population sample that they might 
represent, in order to give personality to an issue?

The purpose of the reference was to give flexh to a generalization about 
the population of non-technical users.  Within technical discussions, it is 
easy to lose track of the nature and texture of the non-technical user 
population.  The term "non-technical user" is not sufficient.

Let's try to cut each other a bit of slack.

The point of my original comment was, I think, pretty clear.  The nature of 
the burden placed on users is an extremely important issue.  We most 
certainly must distinguish between those of us qualifying as geeks, with 
all of the attendant willingness to make infinite adjustments to 
technology, versus those of us who are non-technical, who are "other", who 
are everyday real people.  Like kindly and unkindly, intelligent and 
average, knitting and non-knitting grandmothers.

The burden of change that may reasonably be placed on this latter group, 
for using technology, is not the same as for geeks.  But -- and this was my 
primary point -- the burden is not zero, either.

It's ok to require SOME change, and we have plenty of evidence that the 
current domain name semantic model is entirely within the grasp of the vast 
majority of the world's literate population.  We need to expand the 
character set.  We do not need to change the semantic.

d/

----------

---

From: Dave Crocker <[email-masked]>
Date: Fri, 23 Mar 2001 08:44:07 -0800

At 12:36 AM 3/23/2001, A. Vine wrote:
>This is intended to be a gentle reminder that the
>perpetual use of women with children as the litmus test for idiot-proof is
>in itself not only reflecting a bias, but perpetuating it.

A dilemma.

First please note that the context had to do with non-technical users.  No 
criticism or negative connotations were present.  So your use of the term 
idiot-proof demonstrates putting a negative spin on the material than was 
present objectively.

Frankly the intent was to specify an exemplar for the target audience of 
the work.  As such, "grandmothers" was an ideal.  (Given that I often refer 
to the non-technical population as "real" people, one could argue that 
choosing grandmothers was a compliment, but that's a stretch.)

The dilemma comes from the fact that my grandmother-aged mother (oh, hell, 
*I* am old enough to be a grandparent, darn) is doing well with webTV while 
my father is doing only mediocre and my step-father refuses to touch the stuff.

d/

----------