Subject: [idn] Thoughts on nameprep

From: "Bruce Thomson" <[email-masked]>
Date: Fri, 9 Mar 2001 12:39:58 +0900

Hi, pardon my late appearance on the list.

I have read all about nameprep, and cannot understand
why we need it at all.
I have lived in Japan for 23 years, and wrote what I
believe was the first Japanese-language word processor
for a laptop computer in 1986. I presently receive about
80 e-mails in Japanese per day, and send perhaps 10.

In the case of Japanese, there are legacy character
encodings that date back from before we had graphics
on personal computers, that is, each character code
was written into a byte in VRAM, and was translated by
the hardware into the corresponding graphic. With the
introduction of Japanese support, naturally we had
two-byte characters and single-byte characters mixed,
and the two-byte ones were twice the width on the
screen as well.

Naturally, we now have full graphics, and there is no
particular relationship between a character's width
in memory and on the screen, as we have proportional
fonts, and settable font sizes, etc. Nonetheless, the
Japanese computer user is saddled with ancient
useless encodings that make input error-prone.
Nameprep would of course make domain-name input
more user friendly, especially for raw beginners.

My point is, though, that this problem is not unique
to domain names, and solving it only for domain names
does not seem to be useful. If a novice user doesn't
immediately learn that certain characters such as
full-width numbers and half-width kana have been
deprecated, he will be completely unable to use most
popular applications.

He won't be able to enter his address or credit card
number; he won't be able to enter user names or
passwords. So my question is, why is the idn WG
involved in this issue? This should be the purview
of the keyboard people.

The justification I have heard is that people not
proficient in the particular language will not be able
to pick up a (Japanese) business card and reliably type
in the domain name, because many characters look alike
to him. Well, I feel that such people should not be using
Japanese domain names. The whole reason for idns
is for non-English-speaking people to not be forced
to use English. There is no need to force English speakers
to use idns. The domain should just have another
Romanized domain name.

When I send an e-mail to a Japanese, I might append a
signature file with my return address, snail mail address,
name, etc., and these will all be in Japanese. When I
send overseas, I will of course use a different signature
file. And I can just define an extra account under Outlook
that will let me choose which signature file to use, and
have a different return address as well. I would never
send anything overseas with an idn return address,
just as I would not write the text in Japanese.

It's enough that Japanese domains should work well in Japan,
and that will happen without nameprep. I am not as familiar
with the situation in other languages, but I think the same
logic would apply. Our problem here seems to be that
the interested parties (i.e., the non-English speakers) are
not well represented on this list. So I urge people in other
countries with experience similar to mine to please
speak up on this.

Nameprep can and probably will be implemented at the
application level. Microsoft already prepends www. and
appends .com if I leave them off. They can handle this
kind of thing. But what is the pressure to put it in the spec?

Bruce

---

From: Patrik Fältström <[email-masked]>
Date: Fri, 9 Mar 2001 07:27:40 +0100

At 12.39 +0900 01-03-09, Bruce Thomson wrote:
>application level.

Please see the IDNA proposal.

   paf

---

From: Harald Alvestrand <[email-masked]>
Date: Fri, 09 Mar 2001 15:41:51 +0100

>kind of thing. But what is the pressure to put it in the spec?

as you say, all implementations can, and probably will, handle "this kind 
of thing".
But if two implementations do it differently, they will look up different 
domain names.
That's the whole reason.

--
Harald Tveit Alvestrand, [email-masked]
+47 41 44 29 94
Personal email: [email-masked]