Subject: [idn] stringprep comment 3

From: "Soobok Lee" <[email-masked]>
Date: Wed, 30 Jan 2002 03:18:29 +0900

In stringprep
'abstract'

"Abstract

This document describes a framework for preparing text
strings in order
to increase the likelihood that string input and string
comparison work
in ways that make sense for typical users throughout the
world. The
stringprep protocol is useful for protocol identifier values,
company
and personal names, internationalized domain names, and other
text
strings."

Do you see  "increase the likelihood ..."
, not "ensure"  ?

How humble and modest
assertion!

But, how can such framework serve for
protocol *identifier* values ?

Can any stable and trustworthy identifier
system rely on

rules that are just *likely to work for
typical users* ?

"In this case, "correct" means that if two different people enter
what
they think is the same string into two different input mechanisms,
the
strings should match on a character-by-character basis."

This requirement  is not met  in
"turkish < I dot-above> and <I><dot-above>"
.

Current version of stringprep fails to unifiy
them and therefore

fails to satisfy   *typical* azeri
and lithuanian users.

Soobok
Lee

---

From: Paul Hoffman / IMC <[email-masked]>
Date: Tue, 29 Jan 2002 12:39:25 -0800

At 3:18 AM +0900 1/30/02, Soobok Lee wrote:
>
>  In stringprep 'abstract'
>
>
>"Abstract
>
>This document describes a framework for preparing text strings in order
>to increase the likelihood that string input and string comparison work
>in ways that make sense for typical users throughout the world. The
>stringprep protocol is useful for protocol identifier values, company
>and personal names, internationalized domain names, and other text
>strings."
>
>Do you see  "increase the likelihood ..." , not "ensure"  ?

Yes, exactly. We know *for sure* that there will be confusion; there 
have been many examples shown on this mailing list already.

>How humble and modest assertion!

Thank you.

>But, how can such framework serve for protocol *identifier* values ?

In exactly the same way that the current one does: there are lots of 
problems with string input and comparison today for LDH strings.

>Can any stable and trustworthy identifier system rely on
>  rules that are just *likely to work for typical users* ?

Of course. It works acceptably today for DNS names, for email 
addresses, and so on. Do you have a proposal for assuring the entry 
of today's DNS names and email addresses are correct? If so, many 
people would greatly want to see it!

>"In this case, "correct" means that if two different people enter what
>they think is the same string into two different input mechanisms, the
>This requirement  is not met  in "turkish < I dot-above> and <I><dot-above>" .
>Current version of stringprep fails to unifiy them and therefore
>fails to satisfy   *typical* azeri and lithuanian users.

Of course. This is no different than if one person enters 
"chongwon.co.kr" and another enters "chong-won.co.kr" and they get 
different results.

Everything you have said in this message is strong support for the 
IRNSS work. I hope you will contribute to it.

--Paul Hoffman, Director
--Internet Mail Consortium