Subject: Re: [idn] Prohibit CDN code points

From: "ben" <[email-masked]>
Date: Mon, 21 Jan 2002 11:21:59 -0500

Hi Tseng,

Actually... now that I read your suggestion more carefully, are you
suggesting to change Verisign's current ASCII(.com) to ML(.com)?
Hmmmm... what a strange suggestion.

Thanks,
Ben

----- Original Message -----
From: "cc-www.com (Ben)" <[email-masked]>
To: "[email-masked]" <[email-masked]>; "Kenny Huang"
<[email-masked]>; "IETF-IDN" <[email-masked]>; "Paul Hoffman
/ IMC" <[email-masked]>
Sent: Monday, January 21, 2002 11:10 AM
Subject: Re: [idn] Prohibit CDN code points

> Hi Tseng / Paul,
>
> I like Tseng's idea for a new type of ML-gTLD very very very very
very
> much!  :-)
>
> Unfortunately, I don't think it answers the problem Paul and I
brought
> up- which is what to do about the *current situation* with the gTLD
> that has registered domains in Chinese, Japanese, Korean (even a
> mixture of them) if infact we want to prohibit CDNs and let the
other
> IDNs move forward.
>
> Thanks,
> Ben
>
>
>
> ----- Original Message -----
> From: "[email-masked]" <[email-masked]>
> To: "ben" <[email-masked]>; "Kenny Huang" <[email-masked]>;
> "IETF-IDN" <[email-masked]>; "Paul Hoffman / IMC"
<[email-masked]>
> Sent: Monday, January 21, 2002 9:58 AM
> Subject: Re: [idn] Prohibit CDN code points
>
>
> > It is possible if  we assume the ccTLD implied the language used .
> So, they
> > can be treated with different way based on the ccTLD name implied
> language.
> > Now,  only gTLD has this problems.  If  only ASCII ".com" is used,
> it can
> > not identify which language is used in hostname part. But if
> ML-gTLD is
> > available , the ML(com) can be classfied by the implied language
> characters
> > in ML(com). Especially , ML(gTLD) is very small  and can be
> predefined .
> >
> > L.M.Tseng
> > ----- Original Message -----
> > From: "Paul Hoffman / IMC" <[email-masked]>
> > To: "ben" <[email-masked]>; "Kenny Huang"
<[email-masked]>;
> > "IETF-IDN" <[email-masked]>
> > Sent: Monday, January 21, 2002 2:00 AM
> > Subject: Re: [idn] Prohibit CDN code points
> >
> >
> > > At 12:30 PM -0500 1/20/02, ben wrote:
> > > >Is it possible to let the
> > > >Japanese and Korean domains names go forward and prohibit
Chinese
> > > >domain names?
> > >
> > > No, and that one of the main problems that the CDN community
> faces.
> > > In the ISO/IEC 10646 repertoire (which is the same as the
Unicode
> > > repertoire), it is impossible to differentiate between Chinese
> > > characters and Korean characters and Japanese characters. Thus,
> any
> > > proposal to remove the characters for one language removes them
> for
> > > all.
> > >
> > > --Paul Hoffman, Director
> > > --Internet Mail Consortium
> > >
> >
> >
>

---

From: [email-masked] <[email-masked]>
Date: Tue, 22 Jan 2002 00:38:26 +0800

I  just  describe the possible  methods even it is very strange.  For  CJK
code point switch off  temporary , another approach may be that we can let
code point of Hangel and Kana
go forward but let ideograph part (Han character) delayed , so Korean and
Japan can use their own pure national language to reduce the troubles come
from delay.

L.M.Tseng
----- Original Message -----
From: "ben" <[email-masked]>
To: "cc-www.com (Ben)" <[email-masked]>; "[email-masked]"
<[email-masked]>; "Kenny Huang" <[email-masked]>; "IETF-IDN"
<[email-masked]>; "Paul Hoffman / IMC" <[email-masked]>
Sent: Tuesday, January 22, 2002 12:21 AM
Subject: Re: [idn] Prohibit CDN code points

---

From: Yoshiro YONEYA <[email-masked]>
Date: Wed, 23 Jan 2002 00:15:42 +0900 (JST)

Prof Tseng,

From: <[email-masked]>
Subject: Re: [idn] Prohibit CDN code points
Date: Tue, 22 Jan 2002 00:38:26 +0800

> Japan can use their own pure national language to reduce the troubles come

As you know, CJK stands for Chinese, Japanese and Korean.  So even
though your suggestion makes sense for Chinese, it is non-sense for
Japanese.

-- 
Yoshiro YONEYA <[email-masked]>

---

From: hoho <[email-masked]>
Date: Wed, 23 Jan 2002 00:08:35 +0800

On the other hand, IDN WG is pushing for a standard which introduces a large
amount
of ambiguity into domain names. It does not make sense to users in CJK. This is
especially true for users in China and Taiwan.

-- Janming

---

From: Dave Crocker <[email-masked]>
Date: Tue, 22 Jan 2002 08:24:13 -0800

At 12:08 AM 1/23/2002 +0800, hoho wrote:
>amount of ambiguity into domain names. It does not make sense to users in 
>CJK. This is

Sorry, no.  It introduces no ambiguity at all.

Please feel free to provide a technical analysis that demonstrates such 
ambiguity.

d/

----------
Dave Crocker  <mailto:[email-masked]>
Brandenburg InternetWorking  <http://www.brandenburg.com>
tel +1.408.246.8253;  fax +1.408.273.6464

---

From: [email-masked] <[email-masked]>
Date: Wed, 23 Jan 2002 01:05:36 +0800

Dear  Yoneya :
          If  it is non-sense to you , it can be neglected from you .  I do
not like hurt to each others. I just hope to reduce the troubles.

L.M.Tseng

---

From: Yoshiro YONEYA <[email-masked]>
Date: Wed, 23 Jan 2002 12:27:20 +0900 (JST)

Prof Tseng,

From: <[email-masked]>
Subject: Re: [idn] Prohibit CDN code points
Date: Wed, 23 Jan 2002 01:05:36 +0800

> not like hurt to each others. I just hope to reduce the troubles.

Do you mean your suggestion can be neglected from who think it is
non-sense?  Consensus of the IDN WG is, considering language aspect is
out of scope.

-- 
Yoshiro YONEYA <[email-masked]>

---

From: "Kenny Huang" <[email-masked]>
Date: Wed, 23 Jan 2002 14:08:44 +0800

> non-sense?  Consensus of the IDN WG is, considering language aspect is

Language and terminology issue shall be discussed at other layers 
(e.g., IRNSS wg). The issue (prohibit code points) I raised because it is
impartible with future development in other wg. Therefore I suggest
prohibiting these controversial code points until things are in progress.

We don't have to change the whole infrastructure all at once. Especially
not many of us realize what side effect (business, operation, ..,etc) the CJK 
community will encounter.  

People working here have many impressive engineering experience.
Do we pay enough attention to realize user requirements ?  If we don't have
clear user requirements, what sort of system will eventually be delivered ?
Please correct me if any of you do have clear and complete user requirements 
from user community.

Best Regards

Kenny Huang