Subject: Re: [idn] Prohibit CDN code points

From: Kenneth Whistler <[email-masked]>
Date: Wed, 23 Jan 2002 19:11:03 -0800 (PST)

> Yes, You point out the key point. The problem is caused by  Unicode 
> ambiguity.

This is utter nonsense.

The characters are the same because they come from the same source --
China -- and got borrowed historically by neighboring cultures in
Japan, Korea, and Vietnam, to write different languages. This is
no different (except in scale) from Latin characters getting borrowed
around for the alphabets of different languages, including Chinese(!).

If I write in Chinese, zhong1guo2ke1xue2yuan4 "Chinese Academy of
Sciences", a Japanese can read it right off, *in Japanese* as
chuugokukagakuin. Why? Because it is the *same* 5 characters, used
for two different languages. Unicode has nothing to do with it.
This was true before Unicode existed, and is true now.

> 
> Because of Unicode ambiguity, many critical problems will comes out:
> the registration dispute of 2^n, the delegation/resolution inconsistent, 
> the naming
> uncertainty.

The simplified versus traditional Chinese character issue is
something brought to the world by Chinese politics, and by
independent standardization and character encoding work that
gave us GB 2312 and Big 5 (and CNS, etc.).

Once again, Unicode really has nothing to do with this, other
than to make the nature of the problem clearer, perhaps.

But dream on, if you think you can resolve the problems of
Chinese naming by pursuing an avenue of distinct
national character sets and character encodings for each
political jurisdiction.

Furthermore, the national standardization groups in East Asia
are busy adopting each others characters into their national
standards -- *then* what do you do? GB 18030 is already a
mandated Chinese national standard, and it contains all the
Han characters from 10646, including all the Japanese-only
and Korean-only ones. Everybody has to support GB 18030
in China now, and it has all the traditional forms and all
the simplified forms in it, as well. That is the political
and technical reality.

> 
> CDN requirements are extremely required in CDN users daily live.
> All of the problems caused by Unicode ambiguity shell hurt CDN.

Sorry, this just won't cut it. It isn't Unicode ambiguity
that is at issue. It is the complex problems of having to
deal with two competing Chinese orthographies in a globalizing
world that includes Japanese and Koreans using the same
characters that is causing the pain. Trying to scapegoat
the Unicode Standard for the difficulties of IT globalization
in East Asia is just silly.
 
--Ken

> Erin Chen
> 
> Paul Hoffman / IMC wrote:
> 
> > At 12:30 PM -0500 1/20/02, ben wrote:
> >
> >> Is it possible to let the
> >> Japanese and Korean domains names go forward and prohibit Chinese
> >> domain names?
> >
> >
> > No, and that one of the main problems that the CDN community faces. In 
> > the ISO/IEC 10646 repertoire (which is the same as the Unicode 
> > repertoire), it is impossible to differentiate between Chinese 
> > characters and Korean characters and Japanese characters. Thus, any 
> > proposal to remove the characters for one language removes them for all.
> >
> > --Paul Hoffman, Director
> > --Internet Mail Consortium

---

From: YangWoo Ko <[email-masked]>
Date: Thu, 24 Jan 2002 12:43:02 +0900

> gave us GB 2312 and Big 5 (and CNS, etc.).

As I am not fairly well aware of standardization history of Chinese 
character code in China, please correct me if I am wrong.

Simplification of chinese character was done for cultural and educational 
purpose. And GB and Big5 is just a refelction of national policy (or
standard) into informational technology world. There is no political issue 
at all here.

Standardization process in a specific country is usually done by that 
country independently. That is quite natural. I have never heard that 
while defining ASCII, US people consulted with other countries.

-- 
/*------------------------------------------------
YangWoo Ko : [email-masked]
We Invent Enterprise Software Solutions
and Make You Secure & Powerful.
------------------------------------------------*/