Subject: Re: [idn] utf8/legacy versioning

From: "Soobok Lee" <[email-masked]>
Date: Mon, 3 Jun 2002 11:14:53 +0900

Moreover,

 if "utf-8" is to be a charset, it should have defined the specific set of characters and contains 
versioning tags.

 I suggest:  "utf-8" is an encoding form for UCS. "utf8-8-3.1" and "utf-8-3.2" are charsets names which are
snapshots of UCS with specified encoding form utf-8. This taxonomy would make this situation clear.
Do not forget the set of characters of vague "utf-8" is not fixed from its definition.

 Soobok Lee

----- Original Message ----- 
From: "Soobok Lee" <[email-masked]>
To: <[email-masked]>; "Paul Hoffman / IMC" <[email-masked]>
Sent: Monday, June 03, 2002 11:03 AM
Subject: Re: [idn] utf8/legacy versioning

> 
> Thanks for your correction. UTF-8 (not utf8) is in that list.
> 
> But, UTF-8 is a character encoding form of UCS and does not specify the specific set of supported characters 
> in the numerous versions of UCS.   That is the point where utf-8 and iso8859-1/ksc_5601_1987 differ.
> I.e., UTF-8 defines encoding schemes over UCS which has been an open set and will remains as an open set.
> 
> UTF-8 , from its definition, cannot have versioing suffices, like "utf-8-3.2" or "utf-8-3.1".
> That's why "utf-8" should not be regardsed as a "genuine" charset, IMO.
> 
> Correct me if i am wrong at some points. Thanks.
> 
> Soobok Lee
> 
> ----- Original Message ----- 
> From: "Paul Hoffman / IMC" <[email-masked]>
> To: "Soobok Lee" <[email-masked]>; <[email-masked]>
> Sent: Monday, June 03, 2002 10:36 AM
> Subject: Re: [idn] utf8/legacy versioning
> 
> 
> > At 10:11 AM +0900 6/3/02, Soobok Lee wrote:
> > >Moreover, It does not have "utf8" charset entry, because "utf8" is 
> > >just one of the encodings of the Universal
> > >Character Set, not an independent charset plus encoding like "ks_c_5601-1987".
> > 
> > Both your statement and your reasoning are wrong. UTF-8 has been a 
> > registered charset since RFC 2279 was issued.
> > 
> > --Paul Hoffman, Director
> > --Internet Mail Consortium
>

---

From: Kenneth Whistler <[email-masked]>
Date: Mon, 3 Jun 2002 16:51:48 -0700 (PDT)

I'm not stepping into the issue of how to define the
charsets, but to answer Soobok Lee's specific inquiry:

> Everyone knows UCS(ISo10646) and Unicode (UTC) changes and expands over time.
> Does  UCS (ISO10646) versioning  strictly follow  Unicode Versioning (UTC) ?

The answer to that question is no. Unicode versioning is specified exactly
on the Unicode website, by references to specific sets of contributory
data files.

ISO/IEC 10646 expansion is by the publication of amendments, once they
have gone through international ballotting.

The two encoding committees, UTC and SC2/WG2, work hard to have significant
synchronization points, where the two standards can be matched up with
identical repertoires, but in between major versions it can get a little
tricky to match "versions" of the two standards.

The recent major synchronization point was Unicode 3.0. Here is the
information about that and subsequent synchronizations:

Unicode Version                   10646 Publication

Unicode 3.0                       ISO/IEC 10646-1:2000 (Second Edition)

=======================================================================

Unicode 3.1                       ISO/IEC 10646-1:2000 (Second Edition)
                                  + 2 characters from Amendment 1 to Part 1
                                  ISO/IEC 10646-2:2001

=======================================================================

Unicode 3.2                       ISO/IEC 10646-1:2000 (Second Edition)
                                  Amendment 1 to 10646-1:2000 (published 2002)
                                  ISO/IEC 10646-2:2001

=======================================================================

And prospectively, we anticipate the following synchronization in
repertoires sometime late next year:

Unicode 4.0                       ISO/IEC 10646-1:2000 (Second Edition)
                                  Amendment 1 to 10646-1:2000 (published 2002)
                                  Amendment 2 to 10646-1:2000 (to appear 2003?)
                                  ISO/IEC 10646-2:2001
                                  Amendment 1 to 10646-1:2001 (to appear 2003?)

But this situation is somewhat muddied by the fact that SC2/WG2 is also
starting on a project to merge Part 1 and Part 2 of 10646 into a single
standard, in which case it is conceivable that in 2003 or 2004 the coalesced
10646 will be reissued, presumably as ISO/IEC 10646:2003 (or 2004) (Third Edition),
rolling in the amendments. If so, we would return to a relatively simpler
publication situation, as for Unicode 3.0.

--Ken

> Then, Why can't we see "utf8-3.1" or "utf8-3.2" for Unicode 3.1 and 3.2 recpectively?
>