Subject: [idn] Cut&paste discussion

From: Erik Nordmark <[email-masked]>
Date: Sat, 7 Sep 2002 10:31:17 +0200 (CEST)

The mailing list has had a cut&paste discussion many times.
There is some utility for the WG to understand the issues involved, but
as folks have pointed out the actual implementation issues are just that -
implementation issues relating to an operating system and not a protocol.

Thought: would it make sense to start a separate mailing list
for folks that are implementing IDNA support where different strategies
for dealing with cut&paste issues, API stuff, and whatever else implementors
might care about, can be discussed?

  Erik

---

From: "James Seng" <[email-masked]>
Date: Sat, 7 Sep 2002 17:20:15 +0800

Not sure if it fit what you want but there is already
[email-masked] to discuss IDNA issues.

-James Seng

---

From: "Soobok Lee" <[email-masked]>
Date: Sat, 7 Sep 2002 21:50:33 +0900

----- Original Message ----- 
From: "Erik Nordmark" <[email-masked]>
To: <[email-masked]>
Sent: Saturday, September 07, 2002 5:31 PM
Subject: [idn] Cut&paste discussion

> implementation issues relating to an operating system and not a protocol.

"Is copy&paste implementable consistantly & properly under IDNA?" and "How to implement IDNA's
copy&paste in specific OS platforms?" are different questions.  Do you agree?

The former one was discussed, not the latter.

---

From: Erik Nordmark <[email-masked]>
Date: Mon, 9 Sep 2002 10:15:04 +0200 (CEST)

> "Is copy&paste implementable consistantly & properly under IDNA?" and "How
> to implement IDNA's copy&paste in specific OS platforms?" are different
> questions.  Do you agree?

Sure look like different questions to me.

> The former one was discussed, not the latter.

Patrik's and others discussions about cut&paste on MAC vs. the X window system
sure seemed like it was touching on the latter question of yours.

But my question was really whether folks would find benefit in having a
separate mailing list for discussing implementation issues with IDNA
in general.

  Erik

---

From: "Soobok Lee" <[email-masked]>
Date: Mon, 9 Sep 2002 20:31:35 +0900

----- Original Message ----- 
From: "Erik Nordmark" <[email-masked]>
To: "Soobok Lee" <[email-masked]>
Cc: "Erik Nordmark" <[email-masked]>; <[email-masked]>
Sent: Monday, September 09, 2002 5:15 PM
Subject: Re: [idn] Cut&paste discussion

> sure seemed like it was touching on the latter question of yours.

It may have seemed that way if you assume the problem resides only in X-windows system.

However,even in MAC OSX and MS Windows, you can lauch "telnet(ssh) yourhost.com" and
launch TTY-based MUA like mutt or pine in it, as in X-windows. Therefore, I think
IDN strings' copy&paste implementability issues is not GUI issue, but rather
embedded/layered/tunneled (i don't know better term) application architecture
issue present in ALL operating systems and GUIs. 

that is, tty-based applications are presented to end user through 
purely textual applicaton like telnet,ssh,xterm, and there copy&paste operation
on specific pattern of 18n strings in the text screen should be special than those
for any other patterns of strings. That problem exists in all Operating system environments
,so   that is not a implementation specific issue, but a implementability issue
common in all OS and GUIs.

> separate mailing list for discussing implementation issues with IDNA

I agree that the latter one should be discussed in other place, while
the former one is still our issue.

---

From: "Soobok Lee" <[email-masked]>
Date: Tue, 10 Sep 2002 15:15:28 +0900

In addition to telnet/ssh/xterm + IDN-ware mutt/pine cases,
 the case of webbrowser + remote IDN-aware webmail services like hotmail.com  comes to my mind.

IN any cases above, copy&paste should be consistent throughout the GUI or operating systems in
the format in which the being-copied application exports the IDN strings to outer worlds.

In summary, as far as i remember in this discussion, the only feasible alternative was 
"export as it is, without ACE conversion". That means ACE forms of IDN can't be the default 
in copy&paste , while the ACE form is the MUST in  most wire protocols.

But, "Export as it is" exposes IDN strings  to various kinds of exceptions, when they
are copied into non-IDN-aware applications or transcoded to/from Unicode at the
edges between OS/GUI paste buffer and applications. Of course, when all applications become 
IDN-aware and begin to use only Unicode without any legacy charset supports, those problem
will disappear. Until then, those problems will annoy implementors and that was why someone
tried to suggest ACE form should be the norm in copy&paste of IDN strings.