Subject: [idn] homographs in TrueType fonts

From: Erik van der Poel <[email-masked]>
Date: Thu, 05 May 2005 14:34:41 -0700

I have written a small program that parses a number of TrueType font 
tables to determine which pairs of Unicode codepoints end up using the 
same glyphs. The ASCII part of the table is included below. Each line 
has a codepoint, its glyph, the other codepoint of the pair, and the 
number of fonts in which that pair is identical.

U+2044 and U+2215 use the same glyph as the slash (U+002F) in a few East 
Asian fonts. Note also that the capital letters I and O have homographs, 
although some apps present domain names in lower case, so those 
homographs would stand out in those apps. For the complete table, see:

http://nameprep.org/tt-hg.html

Erik

0021(!);01C3;2
0022(");02BA;4
0022(");05F4;12
0027(');0060;1
0027(');02B9;4
0027(');05F3;12
0027(');2032;6
0028(();FD3E;3
0029());FD3F;3
002C(,);201A;9
002D(-);2010;12
002D(-);2012;1
002D(-);2013;2
002F(/);2044;3
002F(/);2215;4
003A(:);05C3;1
003C(<);2039;1
003E(>);203A;1
0049(I);04C0;4
004F(O);2D54;1
005C(\);00A5;2
005C(\);20A9;8
0060(`);0300;1
0061(a);03B1;4
0061(a);0430;52
0063(c);0441;51
0064(d);0501;1
0065(e);0435;55
0066(f);0192;1
0067(g);0261;2
0068(h);04BB;10
0069(i);0456;60
006A(j);03F3;3
006A(j);0458;57
006D(m);0442;15
006E(n);043F;13
006F(o);03BF;48
006F(o);043E;52
006F(o);0585;1
006F(o);1D0F;1
0070(p);0440;53
0073(s);0455;57
0075(u);0438;14
0076(v);03BD;27
0076(v);03C5;1
0076(v);0475;2
0078(x);03C7;2
0078(x);0445;46
0079(y);0443;48
007C(|);01C0;1

---

From: "Mark Davis" <[email-masked]>
Date: Fri, 6 May 2005 17:01:13 -0700

Eric, I updated the file on
http://unicode.org/reports/tr36/draft/confusables.txt incorporating your
list (and others).

There is also the file
http://unicode.org/reports/tr36/draft/confusables-raw.txt, which contains
raw data; it is not reconciled, and not closed. The items with a number or
'skip' in the third field are usually from your data. I do remove some of
the data where you have identicals because they are basically font bugs.

Anyway, comments welcome.

‎Mark