Subject: [Idna-update] [Technical Errata Reported] RFC5890 (6929)

From: RFC Errata System <[email-masked]>
Date: Sat, 9 Apr 2022 13:17:40 -0700 (PDT)

The following errata report has been submitted for RFC5890,
"Internationalized Domain Names for Applications (IDNA): Definitions and Document Framework".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6929

--------------------------------------
Type: Technical
Reported by: Jesus Alvarado <[email-masked]>

Section: 5890

Original Text
-------------
Because A-labels (the form actually used in the
DNS) are potentially much more compressed than UTF-8 (and UTF-8 is,
in general, more compressed that UTF-16 or UTF-32), U-labels that
obey all of the relevant symmetry (and other) constraints of these
documents  may be quite a bit longer, potentially up to 252 characters
(Unicode code points).

Corrected Text
--------------
Because A-labels (the form actually used in the
DNS) are potentially much more compressed than UTF-8 (and UTF-8 is,
in general, more compressed that UTF-16 or UTF-32), U-labels that
obey all of the relevant symmetry (and other) constraints of these
documents  may be quite a bit longer, potentially up to 252 characters
(Unicode code points).
But in the encode (Unicode) they both need the process that some don’t understand in a wrap and curl. To different but same meaning in the most different way.

Notes
-----
I had a ion encoding working bigger in a math calculation.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5890 (draft-ietf-idnabis-defs-13)
--------------------------------------
Title               : Internationalized Domain Names for Applications (IDNA): Definitions and Document Framework
Publication Date    : August 2010
Author(s)           : J. Klensin
Category            : PROPOSED STANDARD
Source              : Internationalized Domain Names in Applications (Revised)
Area                : Applications
Stream              : IETF
Verifying Party     : IESG

---

From: Paul Hoffman <[email-masked]>
Date: Sat, 09 Apr 2022 17:26:28 -0700

Please reject. This is an editorial comment, not an erratum.

--Paul Hoffman

On 9 Apr 2022, at 13:17, RFC Errata System wrote:

> But in the encode (Unicode) they both need the process that some 
> don’t understand in a wrap and curl. To different but same meaning 
> in the most different way.
>
> Notes
> -----
> Title               : Internationalized Domain Names for Applications 
> (IDNA): Definitions and Document Framework

---

From: Patrik Fältström <[email-masked]>
Date: Sun, 10 Apr 2022 07:03:25 +0200

> Please reject. This is an editorial comment, not an erratum.

+1

> _______________________________________________
> IDNA-UPDATE mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idna-update

---

From: Chris Smiley <[email-masked]>
Date: Mon, 11 Apr 2022 14:18:34 -0700

Greetings,

FYI - this report has been deleted as junk.

Thank you.

RFC Editor/cs

> On Apr 9, 2022, at 1:17 PM, RFC Errata System <[email-masked]> wrote:
>