Subject: RE: Proxy: comments on section 9.1.3

From: "Abarbanel, Benjamin" <[email-masked]>
Date: Fri, 6 Sep 2002 10:43:25 -0400

Mathew:

> -----Original Message-----
> From: 'Mathew Richardson' [mailto:[email-masked]]
> Sent: Friday, September 06, 2002 10:34 AM
> To: Abarbanel, Benjamin
> Cc: [email-masked]
> Subject: Re: Proxy: comments on section 9.1.3
> 
> 
> > Abarbanel, Benjamin <[email-masked]> [Fri, 
> Sep 06, 2002 at 10:26:59AM -0400]:
> >Mathew:
> >
> > 
> >> >
> >> >I'm looking for clarification to wording in section 9.1.3 
> >> Phase 3: Route
> >> >Dessemination of draft-ietf-idr-bgp4-17.txt.
> >> >
> >> >My understanding is that a BGP route should not be 
> >> advertised to a peer if
> >> >that route is not also in the Routing Table (e.g. FIB).  I 
> >> was looking for
> >> >wording to support this, but am now starting to second 
> guess myself.
> >> >
> >
> >What about the case where the best BGP route for a given 
> destination is
> >rejected/
> >preempted from the routing table by a higher preferenced 
> IGP, Static, etc.,
> >route which is really used for forwarding?
> 
> This route would have to be in the Loc-RIB, and would replace 
> all other
> routes in the Loc-RIB.  Whether this actually happens or not 
> is a matter
> of local-policy.
> 
Agree, the Loc-RIB routes are only BGP ones, therefore this 
route will pass all policy filters and be added. But, ---->

> >Somewhere in section 9.1.x, Do we want to mention the fact 
> that the best 
> >Loc-RIB BGP route for a given destination is still 
> advertised to outgoing 
> >peers via the Adj-RIB-out after it passes the outbound 
> policy filtering,
> >even though it is not really used for forwarding?
> 
> <snip>
> 
> You're talking about the case where a BGP route to some destination D
> has been installed in the Loc-RIB, but no route to 
> destination D has been
> added to the forwarding table?  I'm not sure we want to 
> elaborate on that
> case, except, perhaps, to disallow it.

Wrong, there is an IGP or static route to destination D in the routing
table as the best forwarding route, the BGP route to destination D that is
installed in the Loc-RIB with a different Next Hop router is not used for
forwarding. That is the inconsistency I am talking about.

Ben

> mrr

---

From: "'Mathew Richardson'" <[email-masked]>
Date: Fri, 6 Sep 2002 11:16:06 -0400

> Abarbanel, Benjamin <[email-masked]> [Fri, Sep 06, 2002 at 10:43:25AM -0400]:
>Mathew:
>

<snip something that Mr. Abarbanel and I seem to agree on>

<snip>

I think that case must either be disallowed, or placed outside the
scope of the base document.  How about adding to section 9.1.3,
at the end:

  Any local-policy which results in reachability being added to an
  Adj-RIB-Out without also being added to the local BGP speaker's
  forwarding table, are beyond the scope of this document.

mrr

---

From: "'Mathew Richardson'" <[email-masked]>
Date: Fri, 6 Sep 2002 11:23:30 -0400

> 'Mathew Richardson' <[email-masked]> [Fri, Sep 06, 2002 at 11:16:06AM -0400]:

<snip>

<snip>

The last line should read:

  forwarding table is beyond the scope of this document.

,rr

---

From: Yakov Rekhter <[email-masked]>
Date: Fri, 20 Sep 2002 09:07:43 -0700

Matt,

>   forwarding table is beyond the scope of this document.

Accepted with a minor rewording (as follows):

 Any local-policy which results in routes being added to an
 Adj-RIB-Out without also being added to the local BGP speaker's
 forwarding table, is outside the scope of this document.

Yakov.

---

From: "'Mathew Richardson'" <[email-masked]>
Date: Fri, 20 Sep 2002 14:33:28 -0400

> Yakov Rekhter <[email-masked]> [Fri, Sep 20, 2002 at 09:07:43AM -0700]:

<snip>

> forwarding table, is outside the scope of this document.

Sounds good.

mrr