Subject: RE: Generial Editorial Comment

From: "Abarbanel, Benjamin" <[email-masked]>
Date: Tue, 24 Sep 2002 10:27:48 -0400

That is one reason why its not a good idea to export BGP routes to other
protocols.

While we are on the subject of BGP interworking with other protocols. If its
a bad idea to redistribute the massive BGP tables into IGP protocols such as
OSPF/ISIS, should we not have a rule in some spec forbidding it from being
done
to avoid an IGP meltdown?

Ben

> -----Original Message-----
> From: Curtis Villamizar [mailto:[email-masked]]
> Sent: Monday, September 23, 2002 9:33 PM
> To: Abarbanel, Benjamin
> Cc: 'Yakov Rekhter'; 'Manav Bhatia'; [email-masked]
> Subject: Re: Generial Editorial Comment 
> 
> 
> 
> In message 
> <[email-masked]>, 
> "Abarbanel, Benjamin" writes:
> > 
> > Overall paragraph sounds good to me.
> > 
> > Except one sentence does'nt sound right.
> > 
> > "Alternately the IGP can pass BGP information among routers 
> within an AS,
> >  taking care not to lose BGP attributes". 
> > 
> >  Is it possible for IGP protocols (OSPF/ISIS) to carry such 
> BGP attributes
> > as  
> >  "AS PATH", in their link state packets?
> 
> This kind of thing could be done by defining a new OSPF opaque LSA.
> Back in 1993 or 1994 Dennis Fergusson proposed an OSPF LSA type 8 for
> this purpose to offset the inadequacy of the rfc1745 use of OSPF tags
> but the internet-draft expired.  Dennis later decided that it wasn't
> such a good idea anyway as the number of BGP routes had grown
> considerably since he made the proposal.
> 
> So the answer with existing IGPs excluding yet to be defined
> extensions is "no".
> 
> > Ben
> 
> Curtis
>

---

From: Jeffrey Haas <[email-masked]>
Date: Tue, 24 Sep 2002 11:08:40 -0400

> to avoid an IGP meltdown?

While some may disagree, it is not our place to take the loaded
shotgun out of the hands of foolish network operators.  Not even
if they point it at themselves, repeatedly press the trigger
and wonder why people are telling them it is a bad idea.

Otherwise known as:
Rope. Gallows. Have fun.

-- 
Jeff Haas 
NextHop Technologies

---

From: Curtis Villamizar <[email-masked]>
Date: Wed, 25 Sep 2002 12:43:53 -0400

In message <[email-masked]>, 
> to avoid an IGP meltdown?

Its always been considered a usage issue, not an implementation issue.
The protocol spec doesn't give configuration advise.

I suppose we could change anything, but there is a place for this sort
of thing and it is in the replacement for rfc1772.

Curtis