Subject: RE: issue 11

From: "Sivananda Ramnath - CTD, Chennai." <[email-masked]>
Date: Fri, 27 Sep 2002 18:06:22 +0530

Hello,

    There is support in some router vendors to allow more than one BGP route
to be installed, for the purpose for load balancing. Given that this is a
current practice, and seems to be a useful feature as well, should we insist
that only one route be installed in the Loc-RIB ? 

    I would like to suggest that all sections which use MUST in the context
of only one route in Loc-RIB be relaxed a little to a SHOULD, and a section
added that states that it is possible for a n implementation to add more
than one route to the Loc-RIB for the purposes of load balancing.

    While it will be useful to describe how this situation is the handler,
it is perhaps sufficient to even state that handling of this situation is
outside the scope of this RFC.

   I am including some proposed text for this purpose:

For the part:

>     The Loc-RIB must contain only one route per destination; 

consider instead,

% The Loc-RIB SHOULD contain only one route per destination.
% An implementation may choose to install multiple routes to
% a destination (for the purposes of load balancing). The
% handling of such a configuration, however, is outside the
% scope of this RFC.

Perhaps, this can be in section 3.2 instead.

Sivanand
([email-masked])

> -----Original Message-----
> From: Yakov Rekhter [mailto:[email-masked]]
> Sent: Wednesday, September 25, 2002 9:01 PM
> To: [email-masked]
> Subject: issue 11
> 
> 
>   11) Rules for routes from Loc-RIB to Adj-RIB-Out - Section 9.1
>   
> --------------------------------------------------------------
> --------------
>   Status: No Consensus
>   Change: Potentially
>   Summary: Variety of texts proposed to help clear up the 
> rules for moving
>    routes from Loc-RIB into Adj-RIB-Out.
>   
>   Discussion:
>   
>   The "Proxy: comments on section 9.1.3" thread brought up 
> some lack of
>   clarity in the section discussing the rules for which 
> routes get propegated
>   from the Loc-RIB into the Adj-RIB-Out.	These 
> discussions resulted in
>   a number of suggestions for new text.
>   
>   The first new text was proposed to clarify the issue that the thread
>   first brought up:
>   
>   I agree that this could use some clarification. How about adding
>   to b) in section 9.1:
>   
>     The Loc-RIB must contain only one route per destination; 
> further, it
>     must include all routes that the BGP speaker is using.
>   
>   changing c) in section 9.1.2 to:
>   
>     c) is selected as a result of the Phase 2 tie breaking 
> rules specified
>     in 9.1.2.2, or
>   
>   and adding
>   
>     d) when routing protocols other than BGP are in use, is 
> determined by
>     some other local means to be the route that will actually 
> be used to
>     reach a particular destination.
>   
>   This text was never discussed or a consensus formed on 
> putting it in the
>   document.
>   
>   This modification to 9.1.2 was also proposed to address the 
> same concern:
>   
>   How about changing the paragraph after c) in 9.1.2 to:
>   
>     The local speaker SHALL then install that route in the Loc-RIB,
>     replacing any route to the same destination that is 
> currently being
>     held in the Loc-RIB.	This route SHALL then also be 
> installed in
>     the BGP speakers forwarding table.
>   
>   There was one response in the negative to this change, 
> arguing that is
>   is not necessary.
>   
> Wrt "adding to b) in section 9.1", the second part (after ";") is
> redundant as this point is already stated in 3.2. Wrt the first
> point about Loc-RIB containing just one route per destination, I
> would suggest to add it to section 3.2, where Loc-RIB is first
> introduced, rather than adding it to 9.1.
> 
> Wrt "changing c)... and adding...", I have no objections to add/modify
> the text, as suggested above.
> 
> I am not sure though that changing the paragraph after c) in 9.1.2
> is really necessary though, so I would prefer to keep it as is. 
> 
> Yakov.
>

---

From: Jeffrey Haas <[email-masked]>
Date: Fri, 27 Sep 2002 09:50:09 -0400

> that only one route be installed in the Loc-RIB ? 

When more than one instance is installed in the LocRib, how
many instances are distributed to the Adj-Ribs-Out?  Is it deterministic?
Does more than one vendor support this mechanism in an interoperable
fashion?

> than one route to the Loc-RIB for the purposes of load balancing.

Is it truly adding more than one route to the LocRib or just the FIB?

-- 
Jeff Haas 
NextHop Technologies

---

From: Yakov Rekhter <[email-masked]>
Date: Fri, 27 Sep 2002 06:56:31 -0700

Jeff,

> Does more than one vendor support this mechanism in an interoperable

As Sivanand mentioned in his e-mail:

 The handling of such a configuration, however, is outside the
 scope of this RFC.

Yakov.

---

From: Jeffrey Haas <[email-masked]>
Date: Fri, 27 Sep 2002 10:08:04 -0400

>  The handling of such a configuration, however, is outside the

As far as I know, vendors who support this do some sanity checking
to make sure that the routes they install will not cause loops.

If we mention the possibility we shouldn't abrogate the responsibility
of telling people how to do this without doing Bad Things.

-- 
Jeff Haas 
NextHop Technologies

---

From: Yakov Rekhter <[email-masked]>
Date: Fri, 27 Sep 2002 07:24:58 -0700

Jeff,

> of telling people how to do this without doing Bad Things.

That doesn't mean that we need to tell this in the base spec. A separate
Internet Draft on BGP multipath may be a good place to document this.

Yakov.