Subject: RE: issue 55

From: "Natale, Jonathan" <[email-masked]>
Date: Wed, 25 Sep 2002 11:19:13 -0400

How about:
"Path segment length is a 1-octet long field containing
the number of ASs (which is half the number of octets
since each AS is 2 octets) in the path segment value
field (also note that the path may contain more than 1
segment).

-----Original Message-----
From: Yakov Rekhter [mailto:[email-masked]] 
Sent: Wednesday, September 25, 2002 11:05 AM
To: [email-masked]
Subject: issue 55

  55) Section 4.3 - Description of AS_PATH length
 
----------------------------------------------------------------------------
  Status: No Consensus
  Change: Potentially
  Summary: Should we clarify, such as adding an ASCII diagram, the
description
   of AS_PATH length?  No diagram or text has been proposed.
  
  Discussion:
  
  This question was raised:
  
  Length fields elsewhere in the draft specify the number of bytes that a
  variable length field uses.  For AS_PATH, length is used as the number
  of 2 byte AS numbers.  In the interest of not having to check other
  sources to be sure, should the descripton of path segment value:
  
  "The path segment value field contains one or more AS numbers, each
  encoded as a 2-octets long field."
  
  explicitly mention the number of bytes used by the variable length field?
  
  Or, make the description of length explicitly mention that it is not the
  length of the variable length field as is the case with other length
fields?
  
  One respone to this agreed that some more clarification would be good,
  specifically an ASCII art diagram.  No diagram was proposed.

How about replacing 

   Path segment length is a 1-octet long field containing
   the number of ASs in the path segment value field.

with the following

   Path segment length is a 1-octet long field containing
   the number of ASs (but not the number of octets) in the path 
   segment value field.

Yakov.

---

From: Jeffrey Haas <[email-masked]>
Date: Wed, 25 Sep 2002 11:58:11 -0400

>    the number of ASs (but not the number of octets) in the path 

with the clarification of deleting the word "but".

-- 
Jeff Haas 
NextHop Technologies

---

From: Yakov Rekhter <[email-masked]>
Date: Wed, 25 Sep 2002 09:17:13 -0700

Jeff,

> with the clarification of deleting the word "but".

That would be fine.

Yakov.

---

From: [email-masked]
Date: Fri, 27 Sep 2002 10:50:11 -0700

I also prefer the "but-less" version of Yakov's text. If there are
no objections/more input, I'll move this issue into the consensus
category.

Andrew

On Wed, Sep 25, 2002 at 09:17:13AM -0700, Yakov Rekhter wrote:
> Delivered-To: [email-masked]
> Delivered-To: [email-masked]
> Delivered-To: [email-masked]
> To: Jeffrey Haas <[email-masked]>
> Cc: [email-masked]
> Subject: Re: issue 55 
> In-Reply-To: Your message of "Wed, 25 Sep 2002 11:58:11 EDT."
>              <[email-masked]> 
> Date: Wed, 25 Sep 2002 09:17:13 -0700
> From: Yakov Rekhter <[email-masked]>
> Precedence: bulk
> X-OriginalArrivalTime: 25 Sep 2002 16:20:24.0826 (UTC) FILETIME=[7403DDA0:01C264AF]
> 
> Jeff,
>