Subject: RE: issue 10

From: "Natale, Jonathan" <[email-masked]>
Date: Mon, 30 Sep 2002 08:57:43 -0400

Ok.  So we have consensus on:
"If due to the limits on the maximum size of an UPDATE message
(see Section 4) a single route doesn't fit into the message,
the BGP speaker may choose not to advertise the route to its
peers and may choose to log an error locally."  

-----Original Message-----
From: Yakov Rekhter [mailto:[email-masked]] 
Sent: Monday, September 30, 2002 8:24 AM
To: Natale, Jonathan
Cc: [email-masked]
Subject: Re: issue 10 

Jonathan,

> I think we should change:
> "   If due to the limits on the maximum size of an UPDATE message
>    (see Section 4) a single route doesn't fit into the message,
>    the BGP speaker may choose not to advertise the route to its
>    peers.  Other alternatives of handling this situation are outside
>    the scope of this document."
> To:
>    If due to the limits on the maximum size of an UPDATE message
>    (see Section 4) a single route doesn't fit into the message,
>    the BGP speaker may choose not to advertise the route to its
>    peers and may choose to log an error locally.  Other alternatives of
>    handling this situation are outside the scope of this document."

That would be fine with me, although I am not sure we need the
last sentence ("Other alternatives....").

Yakov.

> 1) Does this happen in real life?
> 2) Candidate for INFORM?
> 3) Maybe add ~= "rate limit these error logs"?
> 
> -----Original Message-----
> From: Yakov Rekhter [mailto:[email-masked]] 
> Sent: Wednesday, September 25, 2002 2:47 PM
> To: [email-masked]
> Subject: issue 10
> 
>   10) Extending AS_PATH Attribute
>  
>
----------------------------------------------------------------------------
>   Status: No Consensus
>   Change: Potentially
>   Summary: Specific text required to delimit behavior when AS_PATH length
>    is exceeded.
>   
>   Discussion:
>   
>   The "Extending AS_PATH attribute length en route" thread brought up
>   the issue of what action should we specify when we receive a route
>   with an AS_PATH that exceeds the defined maximum length.  There was
>   some discussion, and it was suggested that, after logging the error,
>   the route not be propegated.  No text was proposed.  This issue needs
>   consensus:  Do we specify the behavior?  If so what with what text?
> 
> The real issue here is how to handle the case when a route
> (a single address prefix + path attributes) doesn't fit into
> 4K bytes (as the max BGP message size is 4 K). To address
> this issue I would suggest to add the following to 9.2:
> 
>    If due to the limits on the maximum size of an UPDATE message
>    (see Section 4) a single route doesn't fit into the message,
>    the BGP speaker may choose not to advertise the route to its
>    peers.  Other alternatives of handling this situation are outside
>    the scope of this document.
> 
> Yakov.

---

From: Jeffrey Haas <[email-masked]>
Date: Mon, 30 Sep 2002 10:53:38 -0400

> peers and may choose to log an error locally."  

If it *may* choosen not to advertise, that doesn't mean *must*.

If its going to advertise things, how is it going to behave?

-- 
Jeff Haas 
NextHop Technologies

---

From: Yakov Rekhter <[email-masked]>
Date: Mon, 30 Sep 2002 10:15:26 -0700

Jeff,

> If its going to advertise things, how is it going to behave?

Perhaps we should replace "may choose not to advertise..." with 
"SHOULD NOT advertise...".

Yakov.

---

From: Jeffrey Haas <[email-masked]>
Date: Mon, 30 Sep 2002 13:20:31 -0400

Yakov,

> "SHOULD NOT advertise...".

If it going to choose to advertise, and we're in an overflow
situation, how do we do it?

I suggest that the words really should be "must not advertise" and
"may choose to log an error".

-- 
Jeff Haas 
NextHop Technologies

---

From: Yakov Rekhter <[email-masked]>
Date: Mon, 30 Sep 2002 10:23:19 -0700

Jeff,

> "may choose to log an error".

That would be fine too.

Yakov.

---

From: [email-masked]
Date: Mon, 30 Sep 2002 14:47:42 -0700

Ok, so to incorporate the proposed changes in one paragraph, the text
we have on the table right now is:

    If due to the limits on the maximum size of an UPDATE message
    (see Section 4) a single route doesn't fit into the message,
    the BGP speaker MUST not advertise the route to its peers and
    may choose to log an error locally.

Are we in agreement that this is acceptable?

Andrew

On Mon, Sep 30, 2002 at 10:23:19AM -0700, Yakov Rekhter wrote:
> Delivered-To: [email-masked]
> Delivered-To: [email-masked]
> Delivered-To: [email-masked]
> To: Jeffrey Haas <[email-masked]>
> Cc: [email-masked]
> Subject: Re: issue 10 
> In-Reply-To: Your message of "Mon, 30 Sep 2002 13:20:31 EDT."
>              <[email-masked]> 
> Date: Mon, 30 Sep 2002 10:23:19 -0700
> From: Yakov Rekhter <[email-masked]>
> Precedence: bulk
> X-OriginalArrivalTime: 30 Sep 2002 17:25:42.0467 (UTC) FILETIME=[672D3130:01C268A6]
> 
> Jeff,
>