Subject: RE: FSM more words

From: "Abarbanel, Benjamin" <[email-masked]>
Date: Wed, 11 Sep 2002 17:38:21 -0400

Curtis:
  If I were a lawyer I would disagree with you. Cause one small word could
mean the difference between victory or defeat of a case. Just some thoughts.

Ben

> -----Original Message-----
> From: Curtis Villamizar [mailto:[email-masked]]
> Sent: Wednesday, September 11, 2002 5:33 PM
> To: Tom Petch
> Cc: idr; Susan Hares; yakov Rekhter; [email-masked];
> [email-masked]; randy Bush
> Subject: Re: FSM more words 
> 
> 
> 
> In message <013601c259b9$f5fcc340$0301a8c0@tom3>, "Tom Petch" writes:
> > In the 26Aug text, I find the timer terminology still confusing.
> > Timers can, I find, 
> > stop
> > start
> > restart
> > clear
> > set
> > reset
> > expire
> > 
> > Rich the English language is but I see this as overuse.
> > For me, timers
> > start, stop, expire
> 
> I didn't find the word "reset" in draft-ietf-idr-bgp4-17.tx.
> 
> Restarting a time is getting rid of any running timer and starting the
> timer from its configured initial value (ie: stop, then start).  That
> seems to be entirely consistent with uses of the word restart in other
> contexts.
> 
> Clear and stop a timer are synonomous.  I can't see how that could not
> be obvious.
> 
> The word set is used in phrases like "set Hold timer to a large value"
> which is not adequately covered by the words start and stop.
> 
> > The only further refinement is that they may start with an initial
> > value or with the value they had when they were stopped (eg NFL game
> > clocks); I do not believe, but cannot be sure, that the last is ever
> > used in the FSM.  Which means all we need is
> > start with initial value (spell it out just to be sure)
> > stop
> > expire
> > and anything else just confuses - me and I suspect others.
> > 
> > Tom Petch
> > [email-masked]
> 
> Just as we can't include a complete TCP tutorial, we can't include
> english dictionary entries for every small word used in the document.
> 
> I don't see any reason for change.
> 
> Curtis
>

---

From: Curtis Villamizar <[email-masked]>
Date: Wed, 11 Sep 2002 19:03:08 -0400

In message <[email-masked]>, 
> mean the difference between victory or defeat of a case. Just some thoughts.

You are obviously in the wrong profession.  Please consider a change.  :-)

Curtis