Subject: FW: I-D ACTION:draft-ietf-idr-bgp-identifier-01.txt

From: "David Waters" <[email-masked]>
Date: Tue, 17 Sep 2002 18:54:45 +0530

Hello,
I have always been slightly disturbed with this terminology used in BGP i.e
BGP ID. Why cant we like all the other protocols use the term Router ID?
Can it be mentioned explicitly in this document that the BGP ID is nothing
but a Router ID. I gather that it is painfully obvious to the people really
conversant with BGP but it is not so with the newbies !

I had struggled during my initial days with the protocol and i find that
more and more people get confused with this BGP ID. Is there any thought in
the IDR WG to look into this issue.

David.

----- Original Message -----
From: <[email-masked]>
To: <IETF-Announce:>
Cc: <[email-masked]>
Sent: Monday, September 16, 2002 5:16 PM
Subject: I-D ACTION:draft-ietf-idr-bgp-identifier-01.txt

| A New Internet-Draft is available from the on-line Internet-Drafts
directories.
| This draft is a work item of the Inter-Domain Routing Working Group of
the IETF.
|
| Title : AS-wide Unique BGP Identifier for BGP-4
| Author(s) : E. Chen, J. Yuan
| Filename : draft-ietf-idr-bgp-identifier-01.txt
| Pages : 4
| Date : 2002-9-13
|
| To accommodate situations where the current requirements for the BGP
| Identifier are not met, this document relaxes the definition of the
| BGP Identifier to be a 4-octet unsigned, non-zero integer, and
| relaxes the 'uniqueness' requirement so that only AS-wide uniqueness
| of the BGP Identifiers is required. These revisions to the base BGP
| specification do not introduce any backward compatibility issue.
|
| A URL for this Internet-Draft is:
| http://www.ietf.org/internet-drafts/draft-ietf-idr-bgp-identifier-01.txt
|
| To remove yourself from the IETF Announcement list, send a message to
| ietf-announce-request with the word unsubscribe in the body of the
message.
|
| Internet-Drafts are also available by anonymous FTP. Login with the
username
| "anonymous" and a password of your e-mail address. After logging in,
| type "cd internet-drafts" and then
| "get draft-ietf-idr-bgp-identifier-01.txt".
|
| A list of Internet-Drafts directories can be found in
| http://www.ietf.org/shadow.html
| or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
|
|
| Internet-Drafts can also be obtained by e-mail.
|
| Send a message to:
| [email-masked].
| In the body type:
| "FILE /internet-drafts/draft-ietf-idr-bgp-identifier-01.txt".
|
| NOTE: The mail server at ietf.org can return the document in
| MIME-encoded form by using the "mpack" utility.  To use this
| feature, insert the command "ENCODING mime" before the "FILE"
| command.  To decode the response(s), you will need "munpack" or
| a MIME-compliant mail reader.  Different MIME-compliant mail readers
| exhibit different behavior, especially when dealing with
| "multipart" MIME messages (i.e. documents which have been split

---

From: Yakov Rekhter <[email-masked]>
Date: Tue, 17 Sep 2002 14:34:12 -0700

David,

> the IDR WG to look into this issue.

First of all the term Router ID is used by neither RIP nor ISIS. This
term is used just by OSPF. So, saying that "all the other protocols
use the term Router ID" may be a bit too strong.

Second, there is no requirement to have BGP ID the same as the OSPF
Router ID (see recent e-mail exchange on this list).

Third, the semantics of OSPF Router ID is different from the semantics
of BGP ID (the latter has to be an IP address, while the former need
not to).

With all of the above in mind, I think we should stick with the term
BGP ID.

Yakov.

---

From: "David Waters" <[email-masked]>
Date: Wed, 18 Sep 2002 10:10:32 +0530

anybody has any idea as to why the BGP-OSPF RFC is now historical and why
it isnt being deployed anywhere?

- David

----- Original Message -----
From: "Yakov Rekhter" <[email-masked]>
To: "David Waters" <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, September 18, 2002 3:04 AM
Subject: Re: FW: I-D ACTION:draft-ietf-idr-bgp-identifier-01.txt

| David,
|
| > Hello,
| > I have always been slightly disturbed with this terminology used in BGP
i.e
| > BGP ID. Why cant we like all the other protocols use the term Router
ID?
| > Can it be mentioned explicitly in this document that the BGP ID is
nothing
| > but a Router ID. I gather that it is painfully obvious to the people
really
| > conversant with BGP but it is not so with the newbies !
| >
| > I had struggled during my initial days with the protocol and i find
that
| > more and more people get confused with this BGP ID. Is there any
thought in
| > the IDR WG to look into this issue.
|
| First of all the term Router ID is used by neither RIP nor ISIS. This
| term is used just by OSPF. So, saying that "all the other protocols
| use the term Router ID" may be a bit too strong.
|
| Second, there is no requirement to have BGP ID the same as the OSPF
| Router ID (see recent e-mail exchange on this list).
|
| Third, the semantics of OSPF Router ID is different from the semantics
| of BGP ID (the latter has to be an IP address, while the former need
| not to).
|
| With all of the above in mind, I think we should stick with the term
| BGP ID.
|
| Yakov.
|
| >
| > David.
| >
| > ----- Original Message -----
| > From: <[email-masked]>
| > To: <IETF-Announce:>
| > Cc: <[email-masked]>
| > Sent: Monday, September 16, 2002 5:16 PM
| > Subject: I-D ACTION:draft-ietf-idr-bgp-identifier-01.txt
| >
| >
| > | A New Internet-Draft is available from the on-line Internet-Drafts
| > directories.
| > | This draft is a work item of the Inter-Domain Routing Working Group
of
| > the IETF.
| > |
| > | Title : AS-wide Unique BGP Identifier for BGP-4
| > | Author(s) : E. Chen, J. Yuan
| > | Filename : draft-ietf-idr-bgp-identifier-01.txt
| > | Pages : 4
| > | Date : 2002-9-13
| > |
| > | To accommodate situations where the current requirements for the BGP
| > | Identifier are not met, this document relaxes the definition of the
| > | BGP Identifier to be a 4-octet unsigned, non-zero integer, and
| > | relaxes the 'uniqueness' requirement so that only AS-wide uniqueness
| > | of the BGP Identifiers is required. These revisions to the base BGP
| > | specification do not introduce any backward compatibility issue.
| > |
| > | A URL for this Internet-Draft is:
| > |
http://www.ietf.org/internet-drafts/draft-ietf-idr-bgp-identifier-01.txt
| > |
| > | To remove yourself from the IETF Announcement list, send a message to
| > | ietf-announce-request with the word unsubscribe in the body of the
| > message.
| > |
| > | Internet-Drafts are also available by anonymous FTP. Login with the
| > username
| > | "anonymous" and a password of your e-mail address. After logging in,
| > | type "cd internet-drafts" and then
| > | "get draft-ietf-idr-bgp-identifier-01.txt".
| > |
| > | A list of Internet-Drafts directories can be found in
| > | http://www.ietf.org/shadow.html
| > | or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
| > |
| > |
| > | Internet-Drafts can also be obtained by e-mail.
| > |
| > | Send a message to:
| > | [email-masked].
| > | In the body type:
| > | "FILE /internet-drafts/draft-ietf-idr-bgp-identifier-01.txt".
| > |
| > | NOTE: The mail server at ietf.org can return the document in
| > | MIME-encoded form by using the "mpack" utility.  To use this
| > | feature, insert the command "ENCODING mime" before the "FILE"
| | command.  To decode the response(s), you will need "munpack" or
| > | a MIME-compliant mail reader.  Different MIME-compliant mail readers
| > | exhibit different behavior, especially when dealing with
| > | "multipart" MIME messages (i.e. documents which have been split
| >
| >
|

---

From: "David Waters" <[email-masked]>
Date: Wed, 18 Sep 2002 14:04:15 +0530

Yakov,
I did go through all the archives and i found no logical conclusion to the
great debate (everybody just kind of "backed off" in despair!) and nowhere
did i find the reason why they shouldn't match. What i indeed found were
some mails which clearly indicated (e.g. TE extensions to OSPF) that they
should be the same.

Anyway its a good practice to do so. Is there any network operator in the
wild *not* doing this?

I'll be surprised to find any raised hands.

Additionally you also said that only OSPF uses this term. Well i have some
more protocols using it and they all imply the same meaning.

- EIGRP
- PIM
- MPLS - TE

This list is in no way exhaustive and we can definitely come up with more.
It'll be really nice if somebody can come up with some kind of document on
RID issue.

David.

----- Original Message -----
From: "Yakov Rekhter" <[email-masked]>
To: "David Waters" <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, September 18, 2002 3:04 AM
Subject: Re: FW: I-D ACTION:draft-ietf-idr-bgp-identifier-01.txt

| David,
|
| > Hello,

---

From: Russ White <[email-masked]>
Date: Wed, 18 Sep 2002 08:44:37 -0400 (EDT)

> Anyway its a good practice to do so. Is there any network
> operator in the wild *not* doing this?

Virtually every network I've encountered has synchronization
turned off--so, while their protocol IDs may match, they are not
being checked.

Russ

__________________________________
[email-masked] CCIE <>< Grace Alone

---

From: "David Waters" <[email-masked]>
Date: Wed, 18 Sep 2002 19:25:44 +0530

and what when you do TE?

----- Original Message ----- 
From: "Russ White" <[email-masked]>
To: "David Waters" <[email-masked]>
Cc: "Yakov Rekhter" <[email-masked]>; <[email-masked]>
Sent: Wednesday, September 18, 2002 6:14 PM
Subject: Re: FW: I-D ACTION:draft-ietf-idr-bgp-identifier-01.txt 

| 
| > Anyway its a good practice to do so. Is there any network
| > operator in the wild *not* doing this?
| 
| Virtually every network I've encountered has synchronization
| turned off--so, while their protocol IDs may match, they are not
| being checked.
| 
| Russ
| 
| 
| __________________________________
| [email-masked] CCIE <>< Grace Alone
| 
| 
|

---

From: Russ White <[email-masked]>
Date: Wed, 18 Sep 2002 10:01:40 -0400 (EDT)

I didn't say they didn't match--just that as far as I know, it's
not being checked on the BGP side. If it's a TE requirement, it
seems like it should be in any given TE or MPLS extenstion draft,
rather than in the BGP base spec.

:-)

Russ

---

From: "David Waters" <[email-masked]>
Date: Wed, 18 Sep 2002 19:35:22 +0530

snip from one of the earlier posts in the WG -
"draft-ietf-isis-traffic-04.txt states that if some router advertises the
router ID TLV (containing the 4-octet router ID of the router originating
the LSP) in its LSP, and if it also advertises BGP routes with the BGP next
hop set to the BGP router ID (which is what is usually done), then in such
cases, the TE router ID should match the BGP router ID."

I guess other documents are saying this :-)

David

----- Original Message -----
From: "Russ White" <[email-masked]>
To: "David Waters" <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, September 18, 2002 7:31 PM
Subject: Re: FW: I-D ACTION:draft-ietf-idr-bgp-identifier-01.txt

|
| I didn't say they didn't match--just that as far as I know, it's
| not being checked on the BGP side. If it's a TE requirement, it
| seems like it should be in any given TE or MPLS extenstion draft,
| rather than in the BGP base spec.
|
| :-)
|
| Russ
|
| On Wed, 18 Sep 2002, David Waters wrote:
|
| > and what when you do TE?
| >
| > ----- Original Message -----
| > From: "Russ White" <[email-masked]>
| > To: "David Waters" <[email-masked]>
| > Cc: "Yakov Rekhter" <[email-masked]>; <[email-masked]>
| > Sent: Wednesday, September 18, 2002 6:14 PM
| > Subject: Re: FW: I-D ACTION:draft-ietf-idr-bgp-identifier-01.txt
| >
| >
| > |
| > | > Anyway its a good practice to do so. Is there any network
| > | > operator in the wild *not* doing this?
| > |
| > | Virtually every network I've encountered has synchronization
| > | turned off--so, while their protocol IDs may match, they are not
| > | being checked.
| > |
| > | Russ
| > |
| > |
| > | __________________________________
| > | [email-masked] CCIE <>< Grace Alone
| > |
| > |
| > |
| >
|
| __________________________________
| [email-masked] CCIE <>< Grace Alone
|
|

---

From: "David Waters" <[email-masked]>
Date: Wed, 18 Sep 2002 19:44:50 +0530

moreover i am not asking this to be added in the base spec :-)

-- David

---

From: Curtis Villamizar <[email-masked]>
Date: Wed, 18 Sep 2002 17:58:49 -0400

In message <[email-masked]>, "David Waters" writ
> the IDR WG to look into this issue.

We coincidentally just went through a long discussion (in the context
of reviewing dir-bgp4-17) about when the BGP ID is not equal to the
Router ID used by the IGP.  The fact that BGP ID can be (but usually
isn't) different from Router ID is why the term BGP ID is used.

Curtis

---

From: Curtis Villamizar <[email-masked]>
Date: Wed, 18 Sep 2002 18:37:38 -0400

In message <[email-masked]>, "David Waters" writ
> it isnt being deployed anywhere?

RFC1745 is historic because:

  The AS path frequently didn't fit into the tags and truncating AS
  path is harmfull (can cause route loops).

  Networks tended to blow up in a spectacular manner when injecting
  10s or thousands of BGP routes into the IGP back when people
  actually tried doing this.  There have also been spectacular network
  failures due to accidentally injecting BGP into the IGP.

Or more briefly -- its use is considered dangerous.

Curtis