Subject: RE: Review: Section 2, TCP Port 179

From: "Abarbanel, Benjamin" <[email-masked]>
Date: Mon, 9 Sep 2002 15:08:56 -0400

Michael:

  This issue with the recieve on port 179 and transmit from port X for BGP 
goes back to the Client-Server model in TCP. If you look at Stevens book, a
Server should not transmit from a well known port it is trying to establish
many sessions on with its clients.  Therefore, the assumption in the BGP
spec is that it must be a unique number for each BGP peer the current peer
has a session with.

Ben

> -----Original Message-----
> From: Michael C. Cambria [mailto:[email-masked]]
> Sent: Monday, September 09, 2002 2:39 PM
> To: [email-masked]
> Subject: Re: Review: Section 2, TCP Port 179
> 
> 
> 
> 
> [email-masked] wrote:
> > Ok, so we have two options:
> > 
> > "BGP listens on TCP port 179."
> > 
> > Which leaves the transmit port undefined. Or:
> > 
> > "BGP listens on TCP port 179 and transmits from an 
> implemetation-dependent
> > port."
> > 
> > Thinking of a new operational network engineer reading the 
> spec, the latter
> > seems more clear.  What do you think as an implementor?
> 
> As an implementor, I'd just want to know what was legal.
> 
> Thus, with the suggested changes, if I picked 179 to transmit on, and 
> the peer had a stack that didn't implement the TCP simultaneous open 
> properly, it will be unambigous as to which was not complient.
> 
> MikeC
>

---

From: Mathew Richardson <[email-masked]>
Date: Mon, 9 Sep 2002 16:15:08 -0400

> Abarbanel, Benjamin <[email-masked]> [Mon, Sep 09, 2002 at 03:08:56PM -0400]:
>Michael:
>

<snip>

I don't believe that this assumption is present in the spec, and I
don't think we want to add it.  It should be sufficient to note that
BGP listens for TCP connections on port 179, and the set of ports
from which BGP initiates TCP connections is a local matter.

mrr