Subject: RE: Review: Section 2, TCP Port 179

From: "Natale, Jonathan" <[email-masked]>
Date: Tue, 10 Sep 2002 08:31:37 -0400

I agree.  Let's not make this a TCP tutorial.  Maybe add reference to 1 or
more TCP RFCs???

Also,  If not already done, I think whether or not to accept incoming
connects on 179 while in Idle should be clarified--some/most implementations
do, others do not.

-----Original Message-----
From: John G. Scudder [mailto:[email-masked]] 
Sent: Monday, September 09, 2002 5:10 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: Review: Section 2, TCP Port 179

At 11:41 AM -0700 9/9/02, [email-masked] wrote:
>Ok, so we have two options:
>
>"BGP listens on TCP port 179."
>
>Which leaves the transmit port undefined. Or:
>
>"BGP listens on TCP port 179 and transmits from an implemetation-dependent
>port."
>
>Thinking of a new operational network engineer reading the spec, the latter
>seems more clear.  What do you think as an implementor?

Brevity is the soul of wit.  I prefer the former option.  Anyone who 
is a little bit familiar with TCP should understand that only the 
listen port needs to be 179.  As Yakov points out, it's a _BGP_ spec 
and IMO doesn't need to be a TCP tutorial.

(Furthermore, the second statement is technically incorrect because 
one of the two BGP speakers in any connection will be sourcing its 
traffic from port 179.)

Regards,

--John

---

From: [email-masked]
Date: Tue, 10 Sep 2002 10:12:53 -0700

Ok, so we can tweak the spec to say "BGP listens on TCP port 179." Instead
of "BGP uses TCP port 179 for establishing its connections."  

As for the FSM Idle state accept or no, do you have some proposed text, 
Jonathan?

Andrew

On Tue, Sep 10, 2002 at 08:31:37AM -0400, Natale, Jonathan wrote:
> Delivered-To: [email-masked]
> Delivered-To: [email-masked]
> Delivered-To: [email-masked]
> From: "Natale, Jonathan" <[email-masked]>
> To: "'John G. Scudder'" <[email-masked]>, [email-masked]
> Cc: [email-masked]
> Subject: RE: Review: Section 2, TCP Port 179
> Date: Tue, 10 Sep 2002 08:31:37 -0400
> X-Mailer: Internet Mail Service (5.5.2653.19)
> Precedence: bulk
> X-OriginalArrivalTime: 10 Sep 2002 12:33:54.0309 (UTC) FILETIME=[533D4B50:01C258C6]
>

---

From: Susan Hares <[email-masked]>
Date: Tue, 10 Sep 2002 13:45:22 -0400

Could you clarify the question, accept or no by referring to
the exact test in the FSM words?

Thanks,

Sue

---

From: Yakov Rekhter <[email-masked]>
Date: Tue, 10 Sep 2002 10:57:03 -0700

Jonathan,

> I agree.  Let's not make this a TCP tutorial.  Maybe add reference to 1 or

It is already in the spec (see the Reference section):

   [4] Postel, J., "Transmission Control Protocol - DARPA Internet
   Program Protocol Specification", RFC793, September 1981.

Yakov.