Subject: RE: admin dist/gp spec proposal

From: "Natale, Jonathan" <[email-masked]>
Date: Fri, 6 Sep 2002 14:21:21 -0400

-----Original Message-----
From: Abarbanel, Benjamin [mailto:[email-masked]] 
Sent: Friday, September 06, 2002 1:49 PM
To: 'Natale, Jonathan'
Subject: RE: admin dist/gp spec proposal

Jonathan:
Forward this message to the IDR list. I think we dropped off.

Ben

> -----Original Message-----
> From: Natale, Jonathan [mailto:[email-masked]]
> Sent: Friday, September 06, 2002 1:46 PM
> To: 'Abarbanel, Benjamin'
> Subject: RE: admin dist/gp spec proposal
> 
> 
> I agree.  The default values of the various protocols as they 
> are currently
> implemented make sense:
> Connected
> Static
> Ebgp
> Igp's
> Ibgp
> 
> ...they should be documented in 1812 ideally, but putting it 
> in 1771 would
> not hurt.  Added a phrase to indicate that they may be user 
> configurable is
> good too.
> 
> -----Original Message-----
> From: Abarbanel, Benjamin [mailto:[email-masked]] 
> Sent: Friday, September 06, 2002 11:39 AM
> To: 'Mathew Richardson'; Natale, Jonathan
> Cc: [email-masked]
> Subject: RE: admin dist/gp spec proposal
> 
> 
> 
>  
> > 
> > > Natale, Jonathan <[email-masked]> [Fri, Sep 06, 
> > 2002 at 10:53:40AM -0400]:
> > >Add sect. in bgp draft stating that ebgp routes should be 
> > preferred over any
> > >igp routes and any igp routes should be preferred over ibgp 
> > routes.  The
> > >exception to this is igp summary routes may be preferred 
> > over ebgp routes.
> > 
> > The EBGP vs. IBGP is already covered in section 9.1.2.2.  As to how
> > BGP and non-BGP routes interact, I suspect that that really 
> > should remain
> > largely a local policy matter.  A BCP is probably in order (does one
> > on this topic already exist?)
> >
> Clearly the BGP and non-BGP route competition for dominance 
> in the routing
> table is firstly, defaulted and secondly policy over-written 
> by a local
> router administrator.  Just some mention of operational 
> impact by turning 
> some policy knobs and changing certain route selection 
> decisions and their 
> control plane impacts will be nice. Maybe this belongs in a 
> different spec.
> 
> I find spreading the knowledge across many specs a bit inconvenient.
> 
> IMHO,
> Ben
>

---

From: Yakov Rekhter <[email-masked]>
Date: Fri, 06 Sep 2002 11:31:08 -0700

Natale,

> > not hurt.  Added a phrase to indicate that they may be user 

Perhaps it is time to update 1812. But let's not use BGP
spec as a replacement for updating 1812 - it is not.

Yakov.