Subject: RE: Review: Section 2, TCP Port 179

From: "Abarbanel, Benjamin" <[email-masked]>
Date: Mon, 9 Sep 2002 16:18:35 -0400

> >
> >  This issue with the recieve on port 179 and transmit from 
> port X for BGP 
> >goes back to the Client-Server model in TCP. If you look at 
> Stevens book, a
> >Server should not transmit from a well known port it is 
> trying to establish
> >many sessions on with its clients.  Therefore, the 
> assumption in the BGP
> >spec is that it must be a unique number for each BGP peer 
> the current peer
> >has a session with.
> 
> <snip>
> 
> I don't believe that this assumption is present in the spec, and I
> don't think we want to add it.  It should be sufficient to note that
> BGP listens for TCP connections on port 179, and the set of ports
> from which BGP initiates TCP connections is a local matter.
> 

That is fine by me. I only mentioned it, because all implementations
must know this fact or BGP wont work.

Its amazing what a couple of words can accomplish in a document.

Ben

---

From: "Michael C. Cambria" <[email-masked]>
Date: Tue, 10 Sep 2002 08:33:29 -0400

Curtis Villamizar wrote:

>  though some minor editorial changes could be made.

Which is all the original message (and most I've sent) asked for.

MikeC