Subject: Re: issue 8

From: Yakov Rekhter <[email-masked]>
Date: Thu, 26 Sep 2002 05:52:10 -0700

forwarding...
------- Forwarded Message

Date:    Thu, 26 Sep 2002 16:58:19 +0530
From:    "Sivananda Ramnath - CTD, Chennai." <[email-masked]>
To:      Yakov Rekhter <[email-masked]>
Subject: FW: issue 8

Hello,

    My mail does not seem to have made it to the list. Could you please
forward it ?

Thanks,
Siva
([email-masked])

- -----Original Message-----
From: Sivananda Ramnath - CTD, Chennai. 
Sent: Thursday, September 26, 2002 3:21 PM
To: [email-masked]
Subject: RE: issue 8

Hello,

    The ConnectRetry timer is should have a value that is 'sufficiently
large to allow TCP initialization. Application of jitter can reduce the this
value (by up to 25%). A configuration which the ConnectRetry timer has been
pegged at a value close to TCP connection time may cause a connection to be
terminated as a result of this jitter. Is this a cause for concern ? 

    The default value suggested for ConnectRetry (120 seconds) is
sufficiently large that event with a jitter of 0.75, it will be greater than
TCP'c connection establishment timer.

    Is adding a jitter to the ConnectRetry timer a standard practice ? What
benefit does this provide ?

Sivanand
([email-masked])

> -----Original Message-----
> From: Yakov Rekhter [mailto:[email-masked]]
> Sent: Wednesday, September 25, 2002 7:08 AM
> To: [email-masked]
> Subject: issue 8
> 
> 
>    8) Jitter Text
>    
> --------------------------------------------------------------
> --------------
>    Status: No Consensus
>    Change: Potentially 
>    Summary:
>     Change:
>      "jitter should be applied to the
>       timers associated with MinASOriginationInterval, Keepalive, and
>       MinRouteAdvertisementInterval"
>     To:
>      "jitter should be applied to the timers associated with 
> ConnectRetry timer"
>    
>    Discussion:
>    
>    In the tread entitled "bgp draft review":
>    The thread also proposed:
>    
>    "jitter should be applied to the
>       timers associated with MinASOriginationInterval, Keepalive, and
>       MinRouteAdvertisementInterval"
>    
>    Be changed to:
>    
>    "jitter should be applied to the
>       timers associated with ConnectRetry timer"
>    
>    - There was limited discussion on this issue.  Implementions will
>    add jitter to all of these.  There is no consensus on changing this
>    text.
> 
> I would suggest that we'll change the text to make sure that jitter
> is applied to all the timers. To make this change I would suggest
> to get rid of section 9.2.1.3 ("Jitter"), move the text of this
> section into Appendix "BGP Timers", and expand the text to indicate
> that jitter applies to ConnectRetry timer as well.
> 
> Yakov.
> 

------- End of Forwarded Message

---

From: Curtis Villamizar <[email-masked]>
Date: Thu, 26 Sep 2002 12:33:39 -0400

In message <[email-masked]>, Yakov Rekhter writes
> benefit does this provide ?

The TCP connection establishment timer is 75 seconds (sysctl yield
"net.inet.tcp.keepinit: 75000" in BSD-oids).

The ConnectRetry determines when to make a second attempt after a
prior attempt to connect has failed.  It is to avoid a rapid
succession of retries on immediate failures (for example "Connection
refused" if the peer was in the middle of a reboot, Network
Unreachable if you can't get there from here, etc) but also covers the
case where the TCP SYN goes off and is never heard from again.

Curtis