Subject: RE: BGP - IGP Redistribution Issue

From: "Abarbanel, Benjamin" <[email-masked]>
Date: Tue, 24 Sep 2002 12:23:14 -0400

Agreed, are there other "good practice" issues that can be added to this
spec?

Ben

> -----Original Message-----
> From: Alexei Roudnev [mailto:[email-masked]]
> Sent: Tuesday, September 24, 2002 12:11 PM
> To: Abarbanel, Benjamin; 'Jeffrey Haas'
> Cc: [email-masked]
> Subject: Re: BGP - IGP Redistribution Issue
> 
> 
> > > As much as I would really like to incorporate some of the 
> best current
> > > practices that network operators have in operating BGP networks in
> > > a 1772 replacement, we shouldn't try to reproduce works such as
> > > Halabi's book in a RFC.
> > >
> >
> > I thought Halabi's book was derived from IETF Specs and Cisco field
> > experience.
> It was re-written 2 years ago, without sugnificant changes.
> 
> Anyway, it is a good idea to have some statement preventing 
> people from bad
> practices (such as injecting bgp routes into IGP, even in 
> small network).
> 
>

---

From: Manav Bhatia <[email-masked]>
Date: Wed, 25 Sep 2002 10:08:50 +0530

some more things which could be pondered upon.

- Bringing down all the EBGP connections immediately when the interface
over which they run goes down (without waiting for the HoldTimer to
expire!).

- router id [hope am not opening a can of worms :-)]

- A discussion on multiple views/instances/processes of BGP (many ISPs are
using it) and their possible interaction amongst themselves/IGPs.

- Using communities

- Limited interaction with IGPs

- Hierarchical peering using Route Reflectors

Manav
----- Original Message -----
From: "Abarbanel, Benjamin" <[email-masked]>
To: "'Alexei Roudnev'" <[email-masked]>; "Abarbanel, Benjamin"
<[email-masked]>; "'Jeffrey Haas'" <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, September 24, 2002 9:53 PM
Subject: RE: BGP - IGP Redistribution Issue

| Agreed, are there other "good practice" issues that can be added to this
| spec?
|
| Ben
|
| > -----Original Message-----
| > From: Alexei Roudnev [mailto:[email-masked]]
| > Sent: Tuesday, September 24, 2002 12:11 PM
| > To: Abarbanel, Benjamin; 'Jeffrey Haas'
| > Cc: [email-masked]
| > Subject: Re: BGP - IGP Redistribution Issue
| >
| >
| > > > As much as I would really like to incorporate some of the
| > best current
| > > > practices that network operators have in operating BGP networks in
| > > > a 1772 replacement, we shouldn't try to reproduce works such as
| > > > Halabi's book in a RFC.
| > > >
| > >
| > > I thought Halabi's book was derived from IETF Specs and Cisco field
| > > experience.
| > It was re-written 2 years ago, without sugnificant changes.
| >
| > Anyway, it is a good idea to have some statement preventing
| > people from bad
| > practices (such as injecting bgp routes into IGP, even in
| > small network).
| >
| >

---

From: Yakov Rekhter <[email-masked]>
Date: Wed, 25 Sep 2002 05:40:09 -0700

Manav,

> - router id [hope am not opening a can of worms :-)]

We've been through this discussion before... 

> using it) and their possible interaction amongst themselves/IGPs.

outside the scope of the base spec. 

> - Using communities

Ditto.

> - Limited interaction with IGPs

Ditto.

> - Hierarchical peering using Route Reflectors

Ditto (although may be well within the scope of the Route Reflectors spec).

Yakov.

P.S. Folks, the WG chairs would reallly appreciate if (at least for now)
we stay focused on discussing just the *base* spec, and defering
issues that do not belong to the base spec till some later point...

---

From: Manav Bhatia <[email-masked]>
Date: Wed, 25 Sep 2002 18:33:06 +0530

Yakov,
This was in response to what other possible things can be discussed a BCP
document and wasn't with reference to the base spec! Anyway we shall all
wait for the base spec to first get fixed before we look into these issues.

Thanks,
Manav

----- Original Message -----
From: "Yakov Rekhter" <[email-masked]>
To: "Manav Bhatia" <[email-masked]>
Cc: "Abarbanel, Benjamin" <[email-masked]>; "'Alexei
Roudnev'" <[email-masked]>; "'Jeffrey Haas'" <[email-masked]>;
<[email-masked]>
Sent: Wednesday, September 25, 2002 6:10 PM
Subject: Re: BGP - IGP Redistribution Issue

| Manav,
|
| > some more things which could be pondered upon.
| >
| > - Bringing down all the EBGP connections immediately when the interface
| > over which they run goes down (without waiting for the HoldTimer to
| > expire!).
| >
| > - router id [hope am not opening a can of worms :-)]
|
| We've been through this discussion before...
|
| > - A discussion on multiple views/instances/processes of BGP (many ISPs
are
| > using it) and their possible interaction amongst themselves/IGPs.
|
| outside the scope of the base spec.
|
| > - Using communities
|
| Ditto.
|
| > - Limited interaction with IGPs
|
| Ditto.
|
| > - Hierarchical peering using Route Reflectors
|
| Ditto (although may be well within the scope of the Route Reflectors
spec).
|
| Yakov.
|
| P.S. Folks, the WG chairs would reallly appreciate if (at least for now)
| we stay focused on discussing just the *base* spec, and defering
| issues that do not belong to the base spec till some later point...
|
| >
| > Manav
| > ----- Original Message -----
| > From: "Abarbanel, Benjamin" <[email-masked]>
| > To: "'Alexei Roudnev'" <[email-masked]>; "Abarbanel, Benjamin"
| > <[email-masked]>; "'Jeffrey Haas'" <[email-masked]>
| > Cc: <[email-masked]>
| > Sent: Tuesday, September 24, 2002 9:53 PM
| > Subject: RE: BGP - IGP Redistribution Issue
| >
| >
| > | Agreed, are there other "good practice" issues that can be added to
this
| > | spec?
| > |
| > | Ben
| > |
| > | > -----Original Message-----
| > | > From: Alexei Roudnev [mailto:[email-masked]]
| > | > Sent: Tuesday, September 24, 2002 12:11 PM
| > | > To: Abarbanel, Benjamin; 'Jeffrey Haas'
| > | > Cc: [email-masked]
| > | > Subject: Re: BGP - IGP Redistribution Issue
| > | >
| > | >
| > | > > > As much as I would really like to incorporate some of the
| > | > best current
| > | > > > practices that network operators have in operating BGP networks
in
| > | > > > a 1772 replacement, we shouldn't try to reproduce works such as
| > | > > > Halabi's book in a RFC.
| > | > > >
| > | > >
| > | > > I thought Halabi's book was derived from IETF Specs and Cisco
field
| > | > > experience.
| > | > It was re-written 2 years ago, without sugnificant changes.
| > | >
| > | > Anyway, it is a good idea to have some statement preventing
| > | > people from bad
| > | > practices (such as injecting bgp routes into IGP, even in
| > | > small network).
| > | >
| > | >
| >

---

From: Yakov Rekhter <[email-masked]>
Date: Wed, 25 Sep 2002 06:06:44 -0700

Manav,

> wait for the base spec to first get fixed before we look into these issues.

Thanks !!!

Yakov.

---

From: Jeffrey Haas <[email-masked]>
Date: Wed, 25 Sep 2002 10:23:09 -0400

> over which they run goes down (without waiting for the HoldTimer to

If your interface hiccups once due to a framing error on your
circuit that causes a flap, do you really want to bring it down?

This can be addressed out of scope from the BGP document by
having the local TCP stack be aware of sessions over a given
interface and decreasing the session timeouts when the interface
goes down.  This means you shouldn't have to wait for the full
length of time for the session to go down.

-- 
Jeff Haas 
NextHop Technologies

---

From: Curtis Villamizar <[email-masked]>
Date: Wed, 25 Sep 2002 14:04:21 -0400

In message <[email-masked]>, Manav Bhatia writes
> | > practices (such as injecting bgp routes into IGP, even in

People responding should keep in mind that configuration advice is
still out of scope for the base BGP protocol spec which is what we are
disussing.

Curtis