Subject: RE: admin dist/gp spec proposal

From: "Abarbanel, Benjamin" <[email-masked]>
Date: Fri, 6 Sep 2002 15:45:39 -0400

Is there something that replaces them to go to for technical correctness?

> -----Original Message-----
> From: Yakov Rekhter [mailto:[email-masked]]
> Sent: Friday, September 06, 2002 3:43 PM
> To: Natale, Jonathan
> Cc: 'Abarbanel, Benjamin'; [email-masked]
> Subject: Re: admin dist/gp spec proposal 
> 
> 
> Natale,
> 
> > 1745 and 1403 are historic
> 
> correct. And with this in mind I would suggest we stop 
> reference/pointing
> to them.
> 
> Yakov.
> 
> > -----Original Message-----
> > From: Abarbanel, Benjamin [mailto:[email-masked]] 
> > Sent: Friday, September 06, 2002 3:38 PM
> > To: 'Natale, Jonathan'; Abarbanel, Benjamin; 'Yakov Rekhter'
> > Cc: [email-masked]
> > Subject: RE: admin dist/gp spec proposal 
> > 
> > 
> >  
> > > 
> > > Not that I am aware of.  There certainly is a case where they 
> > > must be the
> > > same (cisco bgp w/ ospf, don't know all the details of 
> > > how/why).  
> > 
> > RFC1745, and RFC1403 tell you why they must be the same.
> > 
> > > Maybe the local admin method of numbering is more 
> versatile by allowing 
> > > them to be different.  I think they should MUST be the 
> same and in some 
> > > implementation they are (gated, bay).
> > > 
> > > -----Original Message-----
> > > From: Abarbanel, Benjamin [mailto:[email-masked]] 
> > > Sent: Friday, September 06, 2002 3:29 PM
> > > To: 'Yakov Rekhter'; Abarbanel, Benjamin
> > > Cc: Natale, Jonathan; [email-masked]
> > > Subject: RE: admin dist/gp spec proposal 
> > > 
> > > 
> > > > 
> > > > > I would like to rephrase my statement on one sentence.
> > > > > 
> > > > > " BTW. BGP Identifier is a vague way of naming what 
> we know as the
> > > > >   Router-ID in all other IP related protocols."
> > > > 
> > > > This is *technically* incorrect. 
> > > >
> > > Is there a case where the BGP Identifier, should or must be 
> > > different than
> > > the Router-ID for the routing system to work correctly?
> > > 
> > > Ben
> > > 
> > >  
> > > > 
> > > > > 
> > > > > 
> > > > > > -----Original Message-----
> > > > > > From: Abarbanel, Benjamin 
> > > [mailto:[email-masked]]
> > > > > > Sent: Friday, September 06, 2002 3:01 PM
> > > > > > To: 'Yakov Rekhter'; Natale, Jonathan
> > > > > > Cc: [email-masked]
> > > > > > Subject: RE: admin dist/gp spec proposal 
> > > > > > 
> > > > > > 
> > > > > > Yakov:
> > > > > >   There is no reference to RFC1812 in the reference section 
> > > > > > nor references 
> > > > > > to this spec where appropriate in the BGP relevant 
> > > > > > discussions. As was 
> > > > > > earlier mentioned. At least we need to tie the thread 
> > > > between the two
> > > > > > specs so people know what the assumptions are.  
> > > > > > 
> > > > > > BTW. BGP Identifier is a very misleading way of naming what 
> > > > > > we know as the
> > > > > > Router ID in all other protocols. I would like to 
> suggest we 
> > > > > > enhance its 
> > > > > > description as follows:
> > > > > > 
> > > > > > Current statement:
> > > > > > ==================
> > > > > > "BGP Identifier:
> > > > > > 
> > > > >          This 4-octet unsigned integer indicates the BGP 
> > > > Identifier of
> > > > > >          the sender. A given BGP speaker sets the value 
> > > of its BGP
> > > > > >          Identifier to an IP address assigned to that BGP 
> > > > > > speaker.  The
> > > > > >          value of the BGP Identifier is determined 
> on startup 
> > > > > > and is the
> > > > > >          same for every local interface and every 
> BGP peer. "
> > > > > > 
> > > > > > New Statement:
> > > > > > ==============
> > > > > > "BGP Identifier:
> > > > > > 
> > > > > >          This 4-octet unsigned integer indicates the BGP 
> > > > Identifier of
> > > > > >          the sender. A given BGP speaker sets the value 
> > > of its BGP
> > > > > >          Identifier also known as the Router-ID, to an IP 
> > > > > > address assigned 
> > > > > >          to that BGP speaker. The value of the BGP 
> > > Identifier is 
> > > > > >          determined on startup and is the same for every 
> > > > > > local interface 
> > > > > >          and every BGP peer and other IP related protocols. 
> > > > > > See [x],[y] for 
> > > > > >          more details on Router-ID useage between BGP and 
> > > > > > other protocols."
> > > > > > 
> > > > > > Where x = RFC1403,
> > > > > >       y = RFC1745
> > > > > > 
> > > > > > Ben
> > > > > > > -----Original Message-----
> > > > > > > From: Yakov Rekhter [mailto:[email-masked]]
> > > > > > > Sent: Friday, September 06, 2002 2:31 PM
> > > > > > > To: Natale, Jonathan
> > > > > > > Cc: [email-masked]
> > > > > > > Subject: Re: admin dist/gp spec proposal 
> > > > > > > 
> > > > > > > 
> > > > > > > Natale,
> > > > > > > 
> > > > > > > > 
> > > > > > > > 
> > > > > > > > -----Original Message-----
> > > > > > > > From: Abarbanel, Benjamin 
> > > > [mailto:[email-masked]] 
> > > > > > > > Sent: Friday, September 06, 2002 1:49 PM
> > > > > > > > To: 'Natale, Jonathan'
> > > > > > > > Subject: RE: admin dist/gp spec proposal
> > > > > > > > 
> > > > > > > > Jonathan:
> > > > > > > > Forward this message to the IDR list. I think we 
> > > dropped off.
> > > > > > > > 
> > > > > > > > Ben
> > > > > > > > 
> > > > > > > > > -----Original Message-----
> > > > > > > > > From: Natale, Jonathan 
> [mailto:[email-masked]]
> > > > > > > > > Sent: Friday, September 06, 2002 1:46 PM
> > > > > > > > > To: 'Abarbanel, Benjamin'
> > > > > > > > > Subject: RE: admin dist/gp spec proposal
> > > > > > > > > 
> > > > > > > > > 
> > > > > > > > > I agree.  The default values of the various 
> > > > protocols as they 
> > > > > > > > > are currently
> > > > > > > > > implemented make sense:
> > > > > > > > > Connected
> > > > > > > > > Static
> > > > > > > > > Ebgp
> > > > > > > > > Igp's
> > > > > > > > > Ibgp
> > > > > > > > > 
> > > > > > > > > ...they should be documented in 1812 ideally, but 
> > > > putting it 
> > > > > > > > > in 1771 would
> > > > > > > > > not hurt.  Added a phrase to indicate that they 
> > > may be user 
> > > > > > > > > configurable is
> > > > > > > > > good too.
> > > > > > > 
> > > > > > > Perhaps it is time to update 1812. But let's not use BGP
> > > > > > > spec as a replacement for updating 1812 - it is not.
> > > > > > > 
> > > > > > > Yakov.
> > > > > > > 
> > > > > > > > > 
> > > > > > > > > -----Original Message-----
> > > > > > > > > From: Abarbanel, Benjamin 
> > > > > [mailto:[email-masked]] 
> > > > > > > > Sent: Friday, September 06, 2002 11:39 AM
> > > > > > > > To: 'Mathew Richardson'; Natale, Jonathan
> > > > > > > > Cc: [email-masked]
> > > > > > > > Subject: RE: admin dist/gp spec proposal
> > > > > > > > 
> > > > > > > > 
> > > > > > > > 
> > > > > > > >  
> > > > > > > > > 
> > > > > > > > > > Natale, Jonathan <[email-masked]> 
> > > > [Fri, Sep 06, 
> > > > > > > > > 2002 at 10:53:40AM -0400]:
> > > > > > > > > >Add sect. in bgp draft stating that ebgp routes 
> > > should be 
> > > > > > > > > preferred over any
> > > > > > > > > >igp routes and any igp routes should be preferred 
> > > > over ibgp 
> > > > > > > > > routes.  The
> > > > > > > > > >exception to this is igp summary routes may 
> be preferred 
> > > > > > > > > over ebgp routes.
> > > > > > > > > 
> > > > > > > > > The EBGP vs. IBGP is already covered in section 
> > > > > > 9.1.2.2.  As to how
> > > > > > > > > BGP and non-BGP routes interact, I suspect that 
> > > that really 
> > > > > > > > > should remain
> > > > > > > > > largely a local policy matter.  A BCP is probably in 
> > > > > > order (does one
> > > > > > > > > on this topic already exist?)
> > > > > > > > >
> > > > > > > > Clearly the BGP and non-BGP route competition 
> for dominance 
> > > > > > > > in the routing
> > > > > > > > table is firstly, defaulted and secondly policy 
> > > over-written 
> > > > > > > > by a local
> > > > > > > > router administrator.  Just some mention of operational 
> > > > > > > > impact by turning 
> > > > > > > > some policy knobs and changing certain route selection 
> > > > > > > > decisions and their 
> > > > > > > > control plane impacts will be nice. Maybe this 
> belongs in a 
> > > > > > > different spec.
> > > > > > > > 
> > > > > > > > I find spreading the knowledge across many specs a bit 
> > > > > > inconvenient.
> > > > > > > > 
> > > > > > > > IMHO,
> > > > > > > > Ben
> > > > > > > > 
> > > > > > 
> > > > 
> > > 
>

---

From: Yakov Rekhter <[email-masked]>
Date: Fri, 06 Sep 2002 12:47:49 -0700

> Is there something that replaces them to go to for technical correctness?

not to my knowledge.

Yakov.