Subject: Re: BGP - IGP Redistribution Issue

From: "Misha Dovek" <[email-masked]>
Date: Wed, 25 Sep 2002 14:09:52 +0530

Manav,

| - Bringing down all the EBGP connections immediately when the interface
| over which they run goes down (without waiting for the HoldTimer to
| expire!).

I agree that this does not exist in any IETF document.

|
| - router id [hope am not opening a can of worms :-)]
|
| - A discussion on multiple views/instances/processes of BGP (many ISPs are
| using it) and their possible interaction amongst themselves/IGPs.

That *might* prove interesting.

|
| - Limited interaction with IGPs

Why limited? I gathered that redistributing BGP info into IGP is a strict No
No!

|
| - Hierarchical peering using Route Reflectors

Yes, i am aware of certain ISPs doing that.

Misha

---

From: Mareline Sheldon <[email-masked]>
Date: Wed, 25 Sep 2002 05:03:12 -0700 (PDT)

Misha,

> That *might* prove interesting.

my votes on this too.

> Why limited? I gathered that redistributing BGP info into IGP is a strict No

interaction with IGP does not necessarily mean redistributing routes to and fro the IGPs.
There are other ways also by which BGP could interact with the IGPs e.g. Traffic Engineering

mareline s.

> Yes, i am aware of certain ISPs doing that.

__________________________________________________
Do you Yahoo!?
New DSL Internet Access from SBC & Yahoo!
http://sbc.yahoo.com

---

From: Yakov Rekhter <[email-masked]>
Date: Wed, 25 Sep 2002 05:37:23 -0700

Mareline,

> > That *might* prove interesting.

This seems to be clearly outside the scope of the *base* spec. And what we 
are discussing right now is the base spec.

> interaction with IGP does not necessarily mean redistributing routes
> to and f ro the IGPs.  There are other ways also by which BGP could
> interact with the IGPs e.g. Traffic Engineering

The interaction with IGP (including interaction with TE) is outside
the scope of the base spec. 

Yakov.

---

From: Mareline Sheldon <[email-masked]>
Date: Wed, 25 Sep 2002 06:06:24 -0700 (PDT)

Yakov,
> are discussing right now is the base spec.

It was meant for the Best Current Practises document (something like a 1772) and not the
*base* spec!

mareline s.