Subject: RE: your mail

From: "Natale, Jonathan" <[email-masked]>
Date: Tue, 24 Sep 2002 17:58:55 -0400

Thanks for the prompt reply.  A major vendor sets it to 0x0E for v2,3,4.
Another vendor sets it to 0x10 for v1.  These are 2 other ways to interpret
this (both incorrect).  Interesting.

-----Original Message-----
From: Jeffrey Haas [mailto:[email-masked]] 
Sent: Tuesday, September 24, 2002 5:46 PM
To: Natale, Jonathan
Cc: [email-masked]
Subject: Re: your mail

On Tue, Sep 24, 2002 at 05:38:52PM -0400, Natale, Jonathan wrote:
> The way I read the bgpVersion SNMP object description, it should be set to
> 0x7000 if you support versions 2, 3, and 4; 0x1000 if you support version
4.
> Is this correct?

According to the MIB, yes.

> Thank you.

-- 
Jeff Haas 
NextHop Technologies

---

From: Jeffrey Haas <[email-masked]>
Date: Wed, 25 Sep 2002 10:27:33 -0400

> this (both incorrect).  Interesting.

Upon reading this further, 0x0e is correct for 2,3,4.  I made
the mistake of thinking binary rather than hex as shown below.

My apologies.

-- 
Jeff Haas 
NextHop Technologies

---

From: Jeffrey Haas <[email-masked]>
Date: Wed, 25 Sep 2002 11:42:53 -0400

> the mistake of thinking binary rather than hex as shown below.

And I'm batting zero this morning.
(No more bgp mail until after lunch... :-)

The comment in the MIB is quite plain about bit zero being the MSB of
the octet.

-- 
Jeff Haas 
NextHop Technologies