Subject: RE: issue 37

From: "Abarbanel, Benjamin" <[email-masked]>
Date: Mon, 30 Sep 2002 11:27:56 -0400

Curtis,

see below

> -----Original Message-----
> From: Curtis Villamizar [mailto:[email-masked]]
> Sent: Monday, September 30, 2002 11:01 AM
> To: Abarbanel, Benjamin
> Cc: [email-masked]'; Kunihiro Ishiguro; 
> Yakov Rekhter;
> [email-masked]
> Subject: Re: issue 37 
> 
> 
> 
> In message 
> <[email-masked]>, 
> "Abarbanel, Benjamin" writes:
> > My opinion to this question, if such terms as "withdrawn routes" and
> > "unfeasable routes" are used multiple times as either 
> verbs, adjectives, and
> > nouns interchangeably, then it would be wise to define them 
> in the "commonly
> > used terms" section. If they are used only in one mode in a 
> few places, then
> > as Yakov stated its OK to let the local useage define the meaning.
> > 
> > Ben
> > 
> > > -----Original Message-----
> > > From: [email-masked]
> > > [mailto:[email-masked]]
> > > Sent: Friday, September 27, 2002 3:28 PM
> > > To: Kunihiro Ishiguro
> > > Cc: Yakov Rekhter; [email-masked]
> > > Subject: Re: issue 37
> > > 
> > > 
> > > To address the concern in the original post:  Do we want to add a 
> > > definition of "Unfeasable Routes" to the glossary/list of 
> frequently
> > > used terms?
> > > 
> > > Andrew
> > > 
> > > On Thu, Sep 26, 2002 at 10:05:53AM -0700, Kunihiro Ishiguro wrote:
> > > > Delivered-To: [email-masked]
> > > > Delivered-To: [email-masked]
> > > > Delivered-To: [email-masked]
> > > > Date: Thu, 26 Sep 2002 10:05:53 -0700
> > > > From: Kunihiro Ishiguro <[email-masked]>
> > > > To: Yakov Rekhter <[email-masked]>
> > > > Cc: [email-masked]
> > > > Subject: Re: issue 37 
> > > > In-Reply-To: <[email-masked]>
> > > > User-Agent: Wanderlust/2.8.1 (Something) SEMI/1.14.3 
> > > (Ushinoya) FLIM/1.14.2 (Yagi-Nishiguchi) APEL/10.3 
> > > Emacs/21.2.50 (powerpc-unknown-linux-gnu) MULE/5.0 (SAKAKI)
> > > > Precedence: bulk
> > > > X-OriginalArrivalTime: 26 Sep 2002 17:06:04.0179 (UTC) 
> > > FILETIME=[FF35B630:01C2657E]
> > > > 
> > > > Thanks for clear explanation.  I'm convinced.
> > > > 
> > > > >> 
> > > >-------------------------------------------------------------
> > > ---------------
> > > > >> >37) Combine "Unfeasable Routes" and "Withdrawn Routes"
> > > > >> 
> > > >-------------------------------------------------------------
> > > ---------------
> > > > >> >Status: No Consensus
> > > > >> >Change: Potentially
> > > > >> >Summary: No definition extant for "Unfeasable Routes". 
> > > > >> >
> > > > >> >Discussion:
> > > > >> >
> > > > >> >3. P. 45, Phase I, There is no definition of what are 
> > > unfeasible routes? Are
> > > > >> >they the same as withdrawn routes? If so, the two 
> > > should be combined to one
> > > > >> >name.
> > > > >> 
> > > > >> >From implementation stand point there is no 
> difference between
> > > > >> "Unfeasible Routes" and "Withdrawn Routes".  When 
> the route is
> > > > >> unfeasible, BGP withdraw the route.  I think combining 
> > > two name to one
> > > > >> name make sense.
> > > > >
> > > > >The routes are withdrawn from service because they are 
> unfeasible,
> > > > >not because they are "withdrawn". So, we need to keep the term
> > > > >"unfeasible" to indicate the *reason* why a route could be 
> > > withdrawn.
> > > > >On the other hand, "withdrawn" is used as a verb, and 
> to the best
> > > > >of my knowledge "unfeasible" can't be used as a verb.  
> With this
> > > > >in mind, I don't think that we can combine the two 
> into a single
> > > > >term.
> > > 
> > 
> 
> 
> 
> Suggested definitions for discussion:
> 
>    Unfeasible route: A route which has been withdrawn can no longer be
>      used for forwarding is referred to as an infeasible route.
> 
     Then why not call it withdrawn route? 

     BTW did you really mean "infeasible"?

     Also when one says a route is unfeasible, what does it mean. 
       a. The route is no longer reachable? 
       b. The route has some attributes that are not usefull?
       c. The route is temporarily put out of service with the anticipation
it
          will be put back in service, later? 
       d. Also, why have it hanging around taking up space, if its not 
          feasible?
       e. The route is to be removed from the active routes list?

     Personnally I would use the adjective "withdrawn route" in place of
     "unfeasible route". Keeps content simple and precise and based on the
     (verb) action that was performed.

>    Withdrawn route: A route which was advertised but has more recently
>      appeared in the unreachable section of an UPDATE message is
>      referred to as a withdrawn route.
     
     This definition does not tell me anything.

>    Withdrawing a route: Putting a prefix into the unreachable section
>      is referred to as "withdrawing" a route.
> 
     This definition does not tell me anything.
 
Ben

---

From: Curtis Villamizar <[email-masked]>
Date: Mon, 30 Sep 2002 12:31:23 -0400

In message <[email-masked]>, 
>      BTW did you really mean "infeasible"?

Duh... yeah, that's what I meant.  :-}

>      (verb) action that was performed.

   1.  Storage allocation is entirely out of scope.

   2.  It may take up space if route flap damping is used to
       "remember" that the thing went up and down a lot, but that is
       out of scope.

   3.  The router might use a garbage collecting memory allocator and
       so take up space, but that is out of scope.

   4.  The definition need not enumerate all implication of the
       concept of infeasible routes.

   5.  This conversation is now bordering on the ridiculous.

>      This definition does not tell me anything.

I'd like to ask for consensus on whether these or any definitions of
infeasible and withdrawn are needed at all.  I proposed short
definitions for discussion with the statement that I thought they were
sufficiently obvious that we don't need them.  If someone does think
we need them and that definitions I proposed are deficient, please
offer a set of definitions and we can see if there is consensus to add
them.  The consensus so far seems to be that we don't need them so
objectors please step forward with proposed definitions.

Curtis