Subject: RE: Router ID

From: "Abarbanel, Benjamin" <[email-masked]>
Date: Tue, 10 Sep 2002 12:41:36 -0400

Hopefully in closing this thread. 

I retract what I said about a must for BGP Identifier being routable.
I should have said "should" be made routable. My thinking is based on
using the loopback address for the router-ID/BGP ID, making it interface
independent and thus provide greater reachability. Also, from NMS point of
view make the router-ID more reachable via a loopback address. So on and so
on ...

Thank you for this informative discussion on BGP-Identifiers and router-ID.

Ben

> -----Original Message-----
> From: John G. Scudder [mailto:[email-masked]]
> Sent: Tuesday, September 10, 2002 12:10 PM
> To: Abarbanel, Benjamin
> Cc: [email-masked]
> Subject: RE: Router ID
> 
> 
> At 11:58 AM -0400 9/10/02, Abarbanel, Benjamin wrote:
> >This is taken out of RFC1771 and current BGP draft 17.
> >
> >"BGP Identifier:
> >
> >          This 4-octet unsigned integer indicates the BGP 
> Identifier of
> >          the sender. A given BGP speaker sets the value of its BGP
> >          Identifier to an IP address assigned to that BGP 
> speaker.  "
> >
> >Most IP addresses I am familiar with are routable.
> 
> Well, sure.  That is quite different from your assertion that the 
> "BGP Identifier must be routable for the protocol to work," however. 
> The fact is, that statement is incorrect in practice and even in 
> theory (nowhere does the spec enforce or even strictly speaking 
> mandate the routability of the identifier).
> 
> >If not, the description
> >should not read "IP address", but only "4-octet unsigned integer".
> 
> Just so.  In fact Enke pointed this out several days ago:
> 
> At 11:49 PM -0700 9/6/02, Enke Chen wrote:
> >Indeed, and please take note of the IDR WG draft on the BGP 
> Identifier:
> >
> >      draft-ietf-idr-bgp-identifier-00.txt
> 
>  From the abstract:
> 
>     this document relaxes the definition of the
>     BGP Identifier to be a 4-octet unsigned, non-zero integer
> 
> At 11:59 AM -0400 9/10/02, Abarbanel, Benjamin wrote:
> >   Can we end this thread, it does not look like we are getting
> >any closure on this topic.
> 
> An excellent suggestion.
> 
> --John
>

---

From: Naiming Shen <[email-masked]>
Date: Tue, 10 Sep 2002 10:27:54 -0700

I hope this will be the LAST. I think you got a point that all the
process identifier "usually" should be the same(except for isis, which
has a 6 byte id, but it has a way to make a 4 byte bogus one), and
there is no reason not to make them the same. but there are cases
where the IDs should not be the same. If you have multiple OSPF processes
running on the router, it's an advantage to make them diff ids. when
you want to setup lsp tunnels, you know exactly which OSPF instance
the rsvp is interacted with. so from protocol point of view, there
should be no requirement on this issue.

 ] Hopefully in closing this thread. 
 ] 
 ] I retract what I said about a must for BGP Identifier being routable.
 ] I should have said "should" be made routable. My thinking is based on
 ] using the loopback address for the router-ID/BGP ID, making it interface
 ] independent and thus provide greater reachability. Also, from NMS point of
 ] view make the router-ID more reachable via a loopback address. So on and so
 ] on ...
 ] 
 ] Thank you for this informative discussion on BGP-Identifiers and router-ID.
 ] 
 ] Ben
 ] 
 ] > -----Original Message-----
 ] > From: John G. Scudder [mailto:[email-masked]]
 ] > Sent: Tuesday, September 10, 2002 12:10 PM
 ] > To: Abarbanel, Benjamin
 ] > Cc: [email-masked]
 ] > Subject: RE: Router ID
 ] > 
 ] > 
 ] > At 11:58 AM -0400 9/10/02, Abarbanel, Benjamin wrote:
 ] > >This is taken out of RFC1771 and current BGP draft 17.
 ] > >
 ] > >"BGP Identifier:
 ] > >
 ] > >          This 4-octet unsigned integer indicates the BGP 
 ] > Identifier of
 ] > >          the sender. A given BGP speaker sets the value of its BGP
 ] > >          Identifier to an IP address assigned to that BGP 
 ] > speaker.  "
 ] > >
 ] > >Most IP addresses I am familiar with are routable.
 ] > 
 ] > Well, sure.  That is quite different from your assertion that the 
 ] > "BGP Identifier must be routable for the protocol to work," however. 
 ] > The fact is, that statement is incorrect in practice and even in 
 ] > theory (nowhere does the spec enforce or even strictly speaking 
 ] > mandate the routability of the identifier).
 ] > 
 ] > >If not, the description
 ] > >should not read "IP address", but only "4-octet unsigned integer".
 ] > 
 ] > Just so.  In fact Enke pointed this out several days ago:
 ] > 
 ] > At 11:49 PM -0700 9/6/02, Enke Chen wrote:
 ] > >Indeed, and please take note of the IDR WG draft on the BGP 
 ] > Identifier:
 ] > >
 ] > >      draft-ietf-idr-bgp-identifier-00.txt
 ] > 
 ] >  From the abstract:
 ] > 
 ] >     this document relaxes the definition of the
 ] >     BGP Identifier to be a 4-octet unsigned, non-zero integer
 ] > 
 ] > At 11:59 AM -0400 9/10/02, Abarbanel, Benjamin wrote:
 ] > >   Can we end this thread, it does not look like we are getting
 > >any closure on this topic.
 ] > 
 ] > An excellent suggestion.
 ] > 
 ] > --John
 ] > 

- Naiming