Subject: RE: admin dist/gp spec proposal

From: "Abarbanel, Benjamin" <[email-masked]>
Date: Fri, 6 Sep 2002 15:56:48 -0400

This is turning into a joke, do we want to tie loose ends or not?

:-)

> -----Original Message-----
> From: Natale, Jonathan [mailto:[email-masked]]
> Sent: Friday, September 06, 2002 3:50 PM
> To: 'Jeffrey Haas'
> Cc: [email-masked]
> Subject: RE: admin dist/gp spec proposal
> 
> 
> Possibly in 1812 (next life???)
> 
> :-)
> 
> -----Original Message-----
> From: Jeffrey Haas [mailto:[email-masked]] 
> Sent: Friday, September 06, 2002 3:48 PM
> To: Natale, Jonathan
> Subject: Re: admin dist/gp spec proposal
> 
> On Fri, Sep 06, 2002 at 01:54:23PM -0400, Natale, Jonathan wrote:
> > Right.  The bgp route will be the active route in the routing table
> > precisely because it (the ebgp learn route) has a lower 
> admin dist than
> the
> > igp learned route (which it would have got from the other 
> bgp router (both
> > bgp routers redistribute the route to igp so both also 
> receive it via
> igp)).
> 
> Oh.  Thats what I thought.
> 
> I never had much cause to inject my bgp routes into my igp so some
> of the consequences of that didn't make sense.
> 
> In discussing this with Matt, we seem to agree that talking about
> this in some document makes sense, but not in the base document.
> Do you agree?
> 
> -- 
> Jeff Haas 
> NextHop Technologies
>

---

From: Jeffrey Haas <[email-masked]>
Date: Tue, 10 Sep 2002 10:19:55 -0400

Not specifically picking on you Curtis, but having had essentially
the same conversation three times yesterday:

On Mon, Sep 09, 2002 at 06:27:34PM -0400, Curtis Villamizar wrote:
> Some of us
> have been looking at BGP4 for over 8 years and do try to remain
> patient with newbies.  When the newbies are clueless, return to
> discussions that occurred and were resolved years ago, and vigorously
> make incorrect assertions it makes it harder to maintain patience.

When something makes it into a document, hopefully its painfully
obvious why its in there.  When its not painfully obvious, the wisdom
that was behind why it ended up in the document must sometimes
be rediscovered if its not spelled out plainly.

The attempts to rediscover that are very educational for newbies, but
frustrating for our "elders".  No FAQ, lots of silly questions. :-)

> Curtis

-- 
Jeff Haas 
NextHop Technologies

---

From: Yakov Rekhter <[email-masked]>
Date: Tue, 10 Sep 2002 10:47:46 -0700

Jeff,

> be rediscovered if its not spelled out plainly.

Let's remember that a protocol spec needn't always say "why" for 
everything. 

Yakov.

---

From: Randy Bush <[email-masked]>
Date: Tue, 10 Sep 2002 11:31:31 -0700

> Let's remember that a protocol spec needn't always say "why" for 

glad you two agree.  indeed, when it's really obvious to a new reader,
it need not.

randy

---

From: Jeffrey Haas <[email-masked]>
Date: Tue, 10 Sep 2002 14:32:44 -0400

Yakov,

> Let's remember that a protocol spec needn't always say "why" for 

Please note I didn't say where this wisdom should be documented.
For example, 1772-1774 have some of this wisdom for 1771.

-- 
Jeff Haas 
NextHop Technologies