Subject: RE: Proxy: comments on section 9.1.3

From: "Abarbanel, Benjamin" <[email-masked]>
Date: Fri, 20 Sep 2002 12:27:38 -0400

My only point is if a BGP route is added to the FIB (Routing Table), it does
not
gaurantee it is used for forwarding. There may be other protocol routes
in the FIB for the same destination that get preference and thus cause the
BGP route not to be used for forwarding. 

I thought we were trying to say that any time this happens the impacts to
BGP propagating this route to outgoing peers is outside the scope of this
documents.

Ben
> -----Original Message-----
> From: Natale, Jonathan [mailto:[email-masked]]
> Sent: Friday, September 20, 2002 12:18 PM
> To: 'Abarbanel, Benjamin'; 'Yakov Rekhter'; 'Mathew Richardson'
> Cc: [email-masked]
> Subject: RE: Proxy: comments on section 9.1.3 
> 
> 
> Ben,
> 
> I like Yakov's better.  Nothing personal.
> 
> :-)
> 
> -----Original Message-----
> From: Abarbanel, Benjamin [mailto:[email-masked]] 
> Sent: Friday, September 20, 2002 12:16 PM
> To: 'Yakov Rekhter'; 'Mathew Richardson'
> Cc: [email-masked]
> Subject: RE: Proxy: comments on section 9.1.3 
> 
> Yakov:
>   I hate to sound picky, but could this improve the intended meaning?
> 
>   "Any local-policy which results in routes being added to an
>    Adj-RIB-Out without also being used for forwarding, is outside the 
>    scope of this document."
> 
> Ben
> 
> > -----Original Message-----
> > From: Yakov Rekhter [mailto:[email-masked]]
> > Sent: Friday, September 20, 2002 12:08 PM
> > To: 'Mathew Richardson'
> > Cc: [email-masked]
> > Subject: Re: Proxy: comments on section 9.1.3 
> > 
> > 
> > Matt,
> > 
> > > > 'Mathew Richardson' <[email-masked]> [Fri, Sep 06, 2002 
> > at 11:16:06AM -040
> > 0]:
> > > 
> > > <snip>
> > > 
> > > Replying to myself to correct some poor grammar:
> > > 
> > > >I think that case must either be disallowed, or placed 
> outside the
> > > >scope of the base document.  How about adding to section 9.1.3,
> > > >at the end:
> > > >
> > > >  Any local-policy which results in reachability being 
> added to an
> > > >  Adj-RIB-Out without also being added to the local BGP speaker's
> > > >  forwarding table, are beyond the scope of this document.
> > > 
> > > <snip>
> > > 
> > > The last line should read:
> > > 
> > >   forwarding table is beyond the scope of this document.
> > 
> > Accepted with a minor rewording (as follows):
> > 
> >  Any local-policy which results in routes being added to an
> >  Adj-RIB-Out without also being added to the local BGP speaker's
> >  forwarding table, is outside the scope of this document.
> > 
> > Yakov.
> > 
>

---

From: Jeffrey Haas <[email-masked]>
Date: Fri, 20 Sep 2002 13:40:37 -0400

Ben,

To be picky:

> My only point is if a BGP route is added to the FIB (Routing Table), it does

The FIB is distinct from the Routing Table.  The Routing Table is
used to populate one or more FIBs.

(And, if you have implementations with multiple routing instances,
VRFs, etc, then you may have multiple Routing Tables that
control or share access to one or more FIBs. :-)

-- 
Jeff Haas 
NextHop Technologies

---

From: Curtis Villamizar <[email-masked]>
Date: Fri, 20 Sep 2002 15:42:39 -0400

In message <[email-masked]>, 

Ben,

The FIB is the forwarding table (forwarding information base).  There
is one entry per destination in the FIB though in multipath the one
entry may specify split traffic over more than one next hop.

The FIB is by definition what is used for forwarding.

Curtis