Subject: RE: Review of draft-ietf-idr-bgp4-17.txt

From: "Abarbanel, Benjamin" <[email-masked]>
Date: Wed, 11 Sep 2002 11:40:01 -0400

Actually, I would venture to say that all BGP implementations that use the
basic UNIX TCP/IP paradigm have to do this. If I am wrong, anyone please
correct me.

Ben

> -----Original Message-----
> From: Yakov Rekhter [mailto:[email-masked]]
> Sent: Wednesday, September 11, 2002 11:37 AM
> To: Abarbanel, Benjamin
> Cc: [email-masked]'
> Subject: Re: Review of draft-ietf-idr-bgp4-17.txt 
> 
> 
> Ben,
> 
> > Yakov:
> >   That may be true, but I have seen in a couple of BGP 
> implementations
> > handling the socket level that the BGP code had to 
> reassemble the logical
> > packet. TCP did not do it. 
> > 
> > What I mean the application code had to read from the 
> socket several times
> > to get the entire packet and reassemble it, before passing 
> it to the BGP
> > state machine.
> 
> This is purely an *implementation* issue, and as such is not
> subject to standardization.
> 
> Yakov.
> 
> > 
> > Ben
> > 
> > > -----Original Message-----
> > > From: Yakov Rekhter [mailto:[email-masked]]
> > > Sent: Wednesday, September 11, 2002 11:26 AM
> > > To: Abarbanel, Benjamin
> > > Cc: [email-masked]'
> > > Subject: Re: Review of draft-ietf-idr-bgp4-17.txt 
> > > 
> > > 
> > > Ben,
> > > 
> > > > Part I.
> > > > 
> > > > Technical Comments:
> > > > ===================
> > > > 1. P.6  section 4. Message Formats, its possible for the 
> > > source BGP peer IP
> > > > layer to fragment a message such that the receiving BGP 
> > > peer socket layer
> > > > would have to reassemble it. Need to mention this, since 
> > > BGP implementations
> > > > are required to do this.  
> > > 
> > > *BGP* implementations are *not* required to perform any 
> > > message reassembly.
> > > (remember this is BGP spec, not TCP and/or IP spec).
> > > 
> > > Yakov.
> > > 
>

---

From: Yakov Rekhter <[email-masked]>
Date: Wed, 11 Sep 2002 08:49:17 -0700

Ben,

> basic UNIX TCP/IP paradigm have to do this. If I am wrong, anyone please

Using UNIX TCP/IP paradigm is *not* a requirement for a BGP implementation.

Yakov.