Subject: RE: Proxy: comments on section 9.1.3

From: "Abarbanel, Benjamin" <[email-masked]>
Date: Fri, 6 Sep 2002 11:26:15 -0400

A route is not a route, unless you have a Next Hop address. How can 
you get from point A to point B without a (Next Hop) delivary router?

IMHO, 
Ben

> -----Original Message-----
> From: Natale, Jonathan [mailto:[email-masked]]
> Sent: Friday, September 06, 2002 11:14 AM
> To: 'Abarbanel, Benjamin'; 'Jeffrey Haas'; 'Mathew Richardson'
> Cc: [email-masked]
> Subject: RE: Proxy: comments on section 9.1.3
> 
> 
> The confusion here is "routes".  Is it:
> Prefix + prefix length (this is what it is in my mind)
> OR
> Prefix + prefix length + protocol
> OR
> Prefix + prefix length + next hop
> OR
> Prefix + prefix length + next hop + protocol
> OR
> ???
> 
> -----Original Message-----
> From: Abarbanel, Benjamin [mailto:[email-masked]] 
> Sent: Friday, September 06, 2002 10:55 AM
> To: 'Jeffrey Haas'; 'Mathew Richardson'
> Cc: Abarbanel, Benjamin; [email-masked]
> Subject: RE: Proxy: comments on section 9.1.3
> 
> Jeff:
>   I did not imply we forbid these non-FIB routes from being 
> added to the
> Loc-RIB,
> just that we cover this case by saying we still knowingly 
> advertise these
> non-FIB
> routes to our outbound BGP peers. Anyone with any doubt will 
> know exactly
> what we
> mean. Perhaps a statement as to the impact on the topological 
> graph in this 
> scenario will be helpfull.
> 
> Ben
> 
> > -----Original Message-----
> > From: Jeffrey Haas [mailto:[email-masked]]
> > Sent: Friday, September 06, 2002 10:50 AM
> > To: 'Mathew Richardson'
> > Cc: Abarbanel, Benjamin; [email-masked]
> > Subject: Re: Proxy: comments on section 9.1.3
> > 
> > 
> > On Fri, Sep 06, 2002 at 10:41:38AM -0400, 'Mathew Richardson' wrote:
> > > And what do either of these have to do with the base BGP spec?
> > 
> > Adding language that specifically forbidding adding routes 
> to Loc-Rib
> > when they wouldn't be added to the FIB would preclude some forms
> > of route concentrators.  I don't think we really want to do that.
> > 
> > > mrr
> > 
> > -- 
> > Jeff Haas 
> > NextHop Technologies
> > 
>

---

From: Jeffrey Haas <[email-masked]>
Date: Fri, 6 Sep 2002 11:34:03 -0400

IMHO:
A prefix implies a prefix and its associated prefix length.
A destination implies an associated nexthop.
A route is a destination for a particular protocol.  A route
may have additional properties that are protocol specific.

The base bgp document (sec 3.1) has always had the unfortunate wording
implying that a route is a path attribute set and multiple NLRI.

-- 
Jeff Haas 
NextHop Technologies

---

From: Jeffrey Haas <[email-masked]>
Date: Tue, 10 Sep 2002 10:35:20 -0400

Curtis,

On Mon, Sep 09, 2002 at 04:23:07PM -0400, Curtis Villamizar wrote:
> I think I covered this accurately and completely enough.  Maybe we
> should put something in the document.  I don't care much if we use
> NRLI or prefix as the key when defining what a route is.  NRLI leaves
> open use of BGP for non-IP purposes.

the point of confusion is over "route".  We define "route"
as being multiple NLRI with a given set of path attributes.
Since this is mentioned in the singular it is not unreasonable,
English-wise, to assume that its an atomic entity and you should
operate on the whole thing.

If you then try to carry this definition throughout the whole document -
multiple NLRI and a set of path attributes - then you run into trouble.

Thats all I'm saying.

If it still sounds like I'm speaking nonsense, I'll gather all of the
references together as an example.

> Curtis

-- 
Jeff Haas 
NextHop Technologies

---

From: Jeffrey Haas <[email-masked]>
Date: Tue, 10 Sep 2002 14:30:10 -0400

On Tue, Sep 10, 2002 at 02:17:11PM -0400, Curtis Villamizar wrote:
> That is not how route is defined.  It is a single NRLI and path
> attributes.  A route is defined as reaching multiple destinations,
> where destinations means hosts.

[...]

> You are referring to 3.1 which maybe isn't clear enough.
> 
>  3.1 Routes: Advertisement and Storage
> 
>    For the purpose of this protocol, a route is defined as a unit of
>    information that pairs a set of destinations with the attributes of a

Note *set*.

Thus, I expect that a "route" consists of one or more destinations
in the NLRI with path attributes.

-- 
Jeff Haas 
NextHop Technologies

---

From: Jeffrey Haas <[email-masked]>
Date: Fri, 20 Sep 2002 14:31:54 -0400

BTW, just to be public about this:

On Tue, Sep 10, 2002 at 05:28:15PM -0400, Curtis Villamizar wrote:
> destination == host address
> 
> One route is one NRLI plus the attributes.
> 
> One UPDATE may have zero or more NRLI.

Thanks for your explanation.  With the note that "destination== host address",
things made much more sense.  But I've had every one of our new people
at NextHop reading the spec ask about this, so I like the new text
much better. :-)

-- 
Jeff Haas 
NextHop Technologies