Subject: RE: Proxy: comments on section 9.1.3

From: "Natale, Jonathan" <[email-masked]>
Date: Fri, 6 Sep 2002 11:14:24 -0400

The confusion here is "routes".  Is it:
Prefix + prefix length (this is what it is in my mind)
OR
Prefix + prefix length + protocol
OR
Prefix + prefix length + next hop
OR
Prefix + prefix length + next hop + protocol
OR
???

-----Original Message-----
From: Abarbanel, Benjamin [mailto:[email-masked]] 
Sent: Friday, September 06, 2002 10:55 AM
To: 'Jeffrey Haas'; 'Mathew Richardson'
Cc: Abarbanel, Benjamin; [email-masked]
Subject: RE: Proxy: comments on section 9.1.3

Jeff:
  I did not imply we forbid these non-FIB routes from being added to the
Loc-RIB,
just that we cover this case by saying we still knowingly advertise these
non-FIB
routes to our outbound BGP peers. Anyone with any doubt will know exactly
what we
mean. Perhaps a statement as to the impact on the topological graph in this 
scenario will be helpfull.

Ben

> -----Original Message-----
> From: Jeffrey Haas [mailto:[email-masked]]
> Sent: Friday, September 06, 2002 10:50 AM
> To: 'Mathew Richardson'
> Cc: Abarbanel, Benjamin; [email-masked]
> Subject: Re: Proxy: comments on section 9.1.3
> 
> 
> On Fri, Sep 06, 2002 at 10:41:38AM -0400, 'Mathew Richardson' wrote:
> > And what do either of these have to do with the base BGP spec?
> 
> Adding language that specifically forbidding adding routes to Loc-Rib
> when they wouldn't be added to the FIB would preclude some forms
> of route concentrators.  I don't think we really want to do that.
> 
> > mrr
> 
> -- 
> Jeff Haas 
> NextHop Technologies
>

---

From: Yakov Rekhter <[email-masked]>
Date: Fri, 06 Sep 2002 08:29:28 -0700

Natale,

> Prefix + prefix length + next hop + protocol

From section 3.1:

  For the purpose of this protocol, a route is defined as a unit of
  information that pairs a set of destinations with the attributes
  of a path to those destinations.  The set of destinations are the   
  systems whose IP addresses are reported in the Network Layer
  Reachability Information (NLRI) field and the path is the information
  reported in the path attributes field of the same UPDATE message.

Yakov.