Subject: RE: issue 32.1

From: "Natale, Jonathan" <[email-masked]>
Date: Wed, 25 Sep 2002 15:19:21 -0400

1) this is a required attribute, "shall" is too weak if anything.  I must
have missed something here.

2) Also, I think "by the autonomous system that originates"
should be changed to "by the speaker that originates"

-----Original Message-----
From: Yakov Rekhter [mailto:[email-masked]] 
Sent: Wednesday, September 25, 2002 2:52 PM
To: Jeffrey Haas
Cc: Natale, Jonathan; [email-masked]
Subject: Re: issue 32.1 

Jeff,

> On Wed, Sep 25, 2002 at 02:35:03PM -0400, Natale, Jonathan wrote:
> >      ORIGIN is a well-known mandatory attribute. The ORIGIN attribute
> >      shall be generated by the autonomous system that originates the
> >      associated routing information. Its value shall not be
> >      changed by any other speaker unless the other speaker is
> >      administratively configured to do so to affect policy
> >      decisions."
> 
> "shall" may be a bit strong.

Agreed. So, how about if we'll use the text suggested by Jonathan,
but replace "shall" with "should".

Yakov.

---

From: Mathew Richardson <[email-masked]>
Date: Wed, 25 Sep 2002 15:23:45 -0400

> Natale, Jonathan <[email-masked]> [Wed, Sep 25, 2002 at 03:19:21PM -0400]:

<snip>

>> >      changed by any other speaker unless the other speaker is

<snip>

mrr

---

From: Jeffrey Haas <[email-masked]>
Date: Wed, 25 Sep 2002 15:24:33 -0400

> have missed something here.

As to changing the value of the attribute:
If there was some historic reason that having it set to EGP aside
from biasing route selection (and I don't know the answer to that),
then it may have been important for BGP<->EGP interaction.

In any case, EGP is historic.  Thus, the value is only used to
bias route selection and changing it should be No Big Deal, so
long as its done with the idea in mind that you're using rope
and here's the gallows.

At worst, this allows you to say that a route learned via an IGP
is better than a route learned by static configuration.  This will
generally give you the results you expect.

> should be changed to "by the speaker that originates"

I agree.

-- 
Jeff Haas 
NextHop Technologies

---

From: Yakov Rekhter <[email-masked]>
Date: Wed, 25 Sep 2002 12:25:01 -0700

Jonathan,

> have missed something here.

There are two "shall" in the text. Jeff suggested to replace the second
"shall" with "should".

> should be changed to "by the speaker that originates"

Agreed.

Yakov.