Subject: RE: Router ID

From: "Abarbanel, Benjamin" <[email-masked]>
Date: Tue, 10 Sep 2002 11:58:59 -0400

This is taken out of RFC1771 and current BGP draft 17.

"BGP Identifier:

         This 4-octet unsigned integer indicates the BGP Identifier of
         the sender. A given BGP speaker sets the value of its BGP
         Identifier to an IP address assigned to that BGP speaker.  "

Most IP addresses I am familiar with are routable. If not, the description
should not read "IP address", but only "4-octet unsigned integer".

Ben

> -----Original Message-----
> From: John G. Scudder [mailto:[email-masked]]
> Sent: Tuesday, September 10, 2002 11:41 AM
> To: Abarbanel, Benjamin
> Cc: [email-masked]'
> Subject: Re: Router ID
> 
> 
> At 10:28 AM -0400 9/10/02, Abarbanel, Benjamin wrote:
> >  Clearly, BGP Identifier must be routable for the protocol to
> >  work and the session to be Established.
> 
> This is incorrect for several implementations with which I am 
> familiar.
> 
> --John
>

---

From: "John G. Scudder" <[email-masked]>
Date: Tue, 10 Sep 2002 12:09:41 -0400

At 11:58 AM -0400 9/10/02, Abarbanel, Benjamin wrote:
>Most IP addresses I am familiar with are routable.

Well, sure.  That is quite different from your assertion that the 
"BGP Identifier must be routable for the protocol to work," however. 
The fact is, that statement is incorrect in practice and even in 
theory (nowhere does the spec enforce or even strictly speaking 
mandate the routability of the identifier).

>If not, the description

Just so.  In fact Enke pointed this out several days ago:

At 11:49 PM -0700 9/6/02, Enke Chen wrote:
>Indeed, and please take note of the IDR WG draft on the BGP Identifier:
>
>      draft-ietf-idr-bgp-identifier-00.txt

 From the abstract:

    this document relaxes the definition of the
    BGP Identifier to be a 4-octet unsigned, non-zero integer

At 11:59 AM -0400 9/10/02, Abarbanel, Benjamin wrote:
>   Can we end this thread, it does not look like we are getting
>any closure on this topic.

An excellent suggestion.

--John