Subject: RE: Review of draft-ietf-idr-bgp4-17.txt

From: "Abarbanel, Benjamin" <[email-masked]>
Date: Wed, 11 Sep 2002 17:07:14 -0400

Yakov,
  Dont we need the WG ADS approval to remove sections from the document?

  (e.g. FSM Section to be deleted)

Ben

> -----Original Message-----
> From: Yakov Rekhter [mailto:[email-masked]]
> Sent: Wednesday, September 11, 2002 5:04 PM
> To: Justin Fletcher
> Cc: [email-masked]; Alex Zinin; Abarbanel, Benjamin
> Subject: Re: Review of draft-ietf-idr-bgp4-17.txt 
> 
> 
> Justin,
> 
> > > >  I thought section 6.2 "Processing Messages on a Stream 
> Protocol"
> > > >  actually talked about these things...
> > > > 
> > > > -- 
> > > > Alex
> > > 
> > > 
> > > A you suggesting we turn the terse reminder in the appendix into a
> > > full TCP programming tutorial?
> > > 
> > > Maybe we should just change that section to.
> > > 
> > >   6.2  Processing Messages on a Stream Protocol
> > > 
> > >      BGP uses TCP as a transport mechanism.  If you are 
> unsure as to
> > >      how to handle asynchronous reads and writes on TCP 
> sockets please
> > >      refer to Unix Network Programming [RWStevens] or other
> > >      introductory text for programming techniques for the 
> operating
> > >      system and TCP implementation that you are using.
> > > 
> > > That would save having to rewrite major parts of Stevens 
> work into the
> > > BGP spec.
> > > 
> > > Curtis
> > 
> > Perhaps the entire section should be deleted as beyond scope.
> 
> That would be fine too.
> 
> Yakov.
>

---

From: Yakov Rekhter <[email-masked]>
Date: Wed, 11 Sep 2002 14:11:39 -0700

Ben,

>   (e.g. FSM Section to be deleted)

I don't recall seeing this requirement in the RFCs that document
the IETF process.

Yakov.

---

From: Alex Zinin <[email-masked]>
Date: Mon, 16 Sep 2002 13:56:26 -0700

> I don't recall seeing this requirement in the RFCs that document

Correct. This is a WG detail. Feedback from the ADs maybe considered
as hints about what the ADs will be looking for during the document
review. In the FSM case, the ADs would be really surprised if no FSM
description was in the spec. In the case of section 6.2, I personally
do not see a reason to remove it from the spec (it is in the appendix
anyways), but I won't raise a flag if the WG decides to do so.

Alex