Subject: RE: issue 37

From: "Abarbanel, Benjamin" <[email-masked]>
Date: Mon, 30 Sep 2002 12:45:42 -0400

> -----Original Message-----
> From: Curtis Villamizar [mailto:[email-masked]]
> Sent: Monday, September 30, 2002 12:31 PM
> To: Abarbanel, Benjamin
> Cc: [email-masked]'; 
> [email-masked]'; Kunihiro
> Ishiguro; Yakov Rekhter; [email-masked]
> Subject: Re: issue 37 
> 
> 
> 
> In message 
> <[email-masked]>, 
> "Abarbanel, Benjamin" writes:
> > > 
> > > Suggested definitions for discussion:
> > > 
> > >    Unfeasible route: A route which has been withdrawn can 
> no longer be
> > >      used for forwarding is referred to as an infeasible route.
> > > 
> >      Then why not call it withdrawn route? 
> > 
> >      BTW did you really mean "infeasible"?
> 
> Duh... yeah, that's what I meant.  :-}
>

The word "infeasible" is mentioned 0 times in this spec,
The word "unfeasible" is mentioned 6 times in this spec.

So now we have Unfeasible routes, Infeasible routes, Withdrawn routes.
Sounds like we need some definitions pretty badly. :)
 
> >      Also when one says a route is unfeasible, what does it mean. 
> >        a. The route is no longer reachable? 
> >        b. The route has some attributes that are not usefull?
> >        c. The route is temporarily put out of service with 
> the anticipation
> > it
> >           will be put back in service, later? 
> >        d. Also, why have it hanging around taking up space, 
> if its not 
> >           feasible?
> >        e. The route is to be removed from the active routes list?
> > 
> >      Personnally I would use the adjective "withdrawn 
> route" in place of
> >      "unfeasible route". Keeps content simple and precise 
> and based on the
> >      (verb) action that was performed.
> 
>    1.  Storage allocation is entirely out of scope.
> 
>    2.  It may take up space if route flap damping is used to
>        "remember" that the thing went up and down a lot, but that is
>        out of scope.
> 
>    3.  The router might use a garbage collecting memory allocator and
>        so take up space, but that is out of scope.
> 
>    4.  The definition need not enumerate all implication of the
>        concept of infeasible routes.
> 
>    5.  This conversation is now bordering on the ridiculous.
> 

  I agree, it started as a minor issue and grew to this. So if no one
is interested in defining this I will agree to drop this issue.

Matter Closed, court adjurned on issue 37.

Ben

---

From: Jeffrey Haas <[email-masked]>
Date: Mon, 30 Sep 2002 12:49:25 -0400

> Sounds like we need some definitions pretty badly. :)

Much like the comments on Sue's FSM document, we don't need definitions
quite so much as we need consitancy.

-- 
Jeff Haas 
NextHop Technologies