Subject: RE: admin dist/gp spec proposal

From: "Abarbanel, Benjamin" <[email-masked]>
Date: Mon, 9 Sep 2002 18:25:56 -0400

Curtis:
  The problem is, most major vendors allow you to redistribute routes from
BGP to OSPF via a configuration policy. Even if that is a bad idea, it is
allowed and can be done by anyone. Good or bad, it is provided to the
operator.
Therefore, the IETF specs should be written that say what can be done and
suggest what should be done in building a stable network. 

I agree with you its a bad ideas to redistribute BGP into OSPF if there are
alot of BGP routes involved. Aggregation policies might help reduce the
number
of routes redistributed. 

Ben

> -----Original Message-----
> From: Curtis Villamizar [mailto:[email-masked]]
> Sent: Monday, September 09, 2002 6:17 PM
> To: Abarbanel, Benjamin
> Cc: 'Yakov Rekhter'; Natale, Jonathan; [email-masked]
> Subject: Re: admin dist/gp spec proposal 
> 
> 
> 
> In message 
> <[email-masked]>, 
> "Abarbanel, Benjamin" writes:
> > Is there something that replaces them to go to for 
> technical correctness?
> 
> They are considered hazardous waste generated by the IDR WG.  RFC1745
> was an attempt to avoid the need for IBGP and use OSPF flooding.  Some
> ideas work out, some don't.  With Opaque LSAs and some modification to
> the periodic expiration of LSA (BGP into OSPF generates a huge number
> of LSAs, making it toxic) it might be made to work.  There is no
> replacement.  Most people, once they understand both OSPF and BGP
> don't see a need for a replacement to describe current usage.
> 
> Curtis
>

---

From: Russ White <[email-masked]>
Date: Mon, 9 Sep 2002 19:19:46 -0400 (EDT)

> Therefore, the IETF specs should be written that say what can
> be done and suggest what should be done in building a stable
> network.

But this wouldn't be a part of the base BGP spec.

Note: You cannot know, for certain, that you can have the same
router id in all routing protocol processes. For instance, most
implementations allow multiple processes of any given
protocol. What if you have two bgp processes, and one ospf
process--how would you share the router id's in this case? Or
(more common) two ospf processes, and one bgp process? Which
router id goes on which process?

Basically, the router id for BGP should be left as a standalone
entity, and we shouldn't worry about it's interaction with other
protocols, if at all possible.

:-)

Russ

__________________________________
[email-masked] CCIE <>< Grace Alone