Subject: RE: Review of draft-ietf-idr-bgp4-17.txt

From: "Abarbanel, Benjamin" <[email-masked]>
Date: Wed, 11 Sep 2002 11:14:39 -0400

No it means if they are placed in different messages and sent in the order 
that the source router wants the destination router to execute them. 

It just makes the messages simpler, requiring less rules of processing.

Ben

> -----Original Message-----
> From: Kaarthik Sivakumar [mailto:[email-masked]]
> Sent: Wednesday, September 11, 2002 11:12 AM
> To: Abarbanel, Benjamin
> Cc: [email-masked]'
> Subject: Re: Review of draft-ietf-idr-bgp4-17.txt
> 
> 
> >>> "BA" == Benjamin Abarbanel <Abarbanel> writes:
> 
> [...]
> 
> BA> 4. P.16, last paragraph in section 4.3 as stated,
> BA>  "An UPDATE message should not include the same address 
> prefix in the
> BA>   WITHDRAWN ROUTES and Network Layer Reachability 
> Information fields,
> BA>   however a BGP speaker MUST be able to process UPDATE 
> messages in this
> BA>   form. A BGP speaker should treat an UPDATE message of 
> this form as if
> BA>   the WITHDRAWN ROUTES doesn't contain the address prefix."
>               
> BA> This complexity could have been avoided if withdrawn 
> routes and NRLI
> BA> prefixes with their attributes were mutually exclusive of 
> each other and
> BA> appeared in different update messages. If that was the 
> case, the priority of
> BA> which field to process first would have been as simple as 
> using "first come,
> BA> first served" message processing approach.
> 
> What you suggest isnt the same as what is there now. The draft says
> that NLRI has higher preference to a WITHDRAWN prefix and this makes
> the behavior predictable. In what you suggest the behavior isnt
> predictable. Or is it? Hmm .. Maybe I am mistaken here, but it doesnt
> seem like the same thing.
> 
> Kaarthik
>

---

From: Yakov Rekhter <[email-masked]>
Date: Wed, 11 Sep 2002 08:34:29 -0700

Ben,

> It just makes the messages simpler, requiring less rules of processing.

it also makes the case where they are in the same message unspecified.