Subject: RE: issue 24

From: "Abarbanel, Benjamin" <[email-masked]>
Date: Wed, 25 Sep 2002 17:08:50 -0400

Yakov,

> -----Original Message-----
> From: Yakov Rekhter [mailto:[email-masked]]
> Sent: Wednesday, September 25, 2002 5:02 PM
> To: Abarbanel, Benjamin
> Cc: [email-masked]
> Subject: Re: issue 24 
> 
> 
> Ben,
> 
> > Jeff:
> > 
> >   I was just responding to Yakove comment:
> > 
> > "By *definition* a route is a <path attribute, NLRI> pair. From that
> > definition it follows that changing one or more path attributes of
> > a route means changing a route, which means withdrawing the old
> > route (route with the old attributes) from service and advertising
> > a new route (route with the new attributes)."
> > 
> > I think we are playing with words here, 3.1a and 3.1b do not address
> > the point as I have argued. Therefore, I am still not satisfied 
> > we nailed it down in the spec. 
> > 
> > As you can see I dont care for assumptions very much.
> > 
> > I would like to see this statement added somewhere in section 3.1:
> > 
> > "A route's attributes can be added, modified, or deleted by 
> sending another
> >  UPDATE message with the same route and the new attributes, or by
> > withdrawing
> >  the route (route with the old attributes) from service and 
> advertising
> >  a new route (same route with the new attributes)."
> 
> If it is "the same route", then *by definition* of a route it 
> has to be
> the same attributes. And if the attributes changed, then it 
> is no longer
> "the same route". With this in mind how about adding the 
> following to 3.1:
> 
>   Changing attribute of a route means that the route is withdrawn
>   from service, and a replacement route is advertised. The replacement
>   route carries new (changed) attributes and has the same NLRI as the 
>   route that was withdrawn.
> 
> Yakov.
> 

  Can we change the current route's attribute without taking it out of
service
  (implying no possible network outage)? 

  If the answer is yes, than you will need an extra sentence. 

  If the answer is no, then I am happy with your statement.

Ben

> > 
> > 
> > Ben
> > 
> > > -----Original Message-----
> > > From: Jeffrey Haas [mailto:[email-masked]]
> > > Sent: Wednesday, September 25, 2002 4:35 PM
> > > To: Abarbanel, Benjamin
> > > Cc: 'Yakov Rekhter'; [email-masked]
> > > Subject: Re: issue 24
> > > 
> > > 
> > > Ben,
> > > 
> > > On Wed, Sep 25, 2002 at 04:28:07PM -0400, Abarbanel, 
> Benjamin wrote:
> > > > Why withdraw and add the same route if one of the optional 
> > > attributes
> > > > changes from value A to value B.
> > > 
> > > If you're just changing an attribute, the withdrawal is implicit
> > > rather than explicit.  You wouldn't want to explicitly withdraw
> > > a route if you just want to change the attributes because that
> > > has consequences for route damping and also for the MRAI and 
> > > MAOI timers.
> > > 
> > > 3.1a covers the explicit withdrawal
> > > 3.1b covers an implicit withdrawal
> > > 
> > > -- 
> > > Jeff Haas 
> > > NextHop Technologies
> > > 
>

---

From: Yakov Rekhter <[email-masked]>
Date: Wed, 25 Sep 2002 14:19:28 -0700

Ben,
 
> service (implying no possible network outage)? 
> 

How about the following replacement for the text I proposed above:

   Changing attribute of a route is accomplished by advertising a
   replacement route. The replacement route carries new (changed)
   attributes and has the same NLRI as the original route.

Yakov.

---

From: Jeffrey Haas <[email-masked]>
Date: Thu, 26 Sep 2002 11:18:13 -0400

Yakov, Ben,

>    attributes and has the same NLRI as the original route.

My issue with this is that we're defining a route as a path attributes set
keyed on an NLRI.  In the case of MP-BGP, its also keyed on the AFI/SAFI.

So, to say that we're "changing attributes" is really saying that we're
changing the route.

So, to say that we are withdrawing the previous route (by our
definition of a route) from service is indeed correct.  Its just the
fact that we can do so by sending a new path attributes set with
an existing NLRI key to atomically update it that makes it a "change".

However, the notion of it being a "change" is probably an implementation
detail, although one that has strong ties with the MRAI and MAOI times
and WRD.

-- 
Jeff Haas 
NextHop Technologies

---

From: Curtis Villamizar <[email-masked]>
Date: Thu, 26 Sep 2002 12:20:59 -0400

In message <[email-masked]>, 

Ben,

It is an atomic operation.  Text stays the same.  No outage.

Curtis

---

From: [email-masked]
Date: Thu, 26 Sep 2002 16:53:19 -0700

Jeff,

Actually, I think that the proposed text is ok.  If we replace "route"
with "path attribute, NLRI pair" (which is how it is defined) we have
this:

Changing the attributes of a path attribute, NLRI pair is accomplished
by advertising a replacement path attribute, NLRI pair.  The replacement
path attribute, NLRI pair carries new (changed) attributes and has the
same NLRI as the original path attribute, NLRI pair.

Now, I am NOT suggesting we replace "route" in the the text that goes
in the draft, it is too cumbersome.  But, if we look at the substitution
it helps unpack the terms.

Andrew

On Thu, Sep 26, 2002 at 11:18:13AM -0400, Jeffrey Haas wrote:
> Delivered-To: [email-masked]
> Delivered-To: [email-masked]
> Delivered-To: [email-masked]
> Date: Thu, 26 Sep 2002 11:18:13 -0400
> From: Jeffrey Haas <[email-masked]>
> To: Yakov Rekhter <[email-masked]>
> Cc: "Abarbanel, Benjamin" <[email-masked]>, [email-masked]
> Subject: Re: issue 24
> User-Agent: Mutt/1.2.5i
> In-Reply-To: <[email-masked]>; from [email-masked] on Wed, Sep 25, 2002 at 02:19:28PM -0700
> X-Virus-Scanned: by AMaViS perl-11
> Precedence: bulk
> X-OriginalArrivalTime: 26 Sep 2002 15:20:42.0468 (UTC) FILETIME=[472D2A40:01C26570]
> 
> Yakov, Ben,
>