Subject: Router ID

From: "Abarbanel, Benjamin" <[email-masked]>
Date: Tue, 10 Sep 2002 10:28:49 -0400

Clearly, the OSPF Router ID does not have to be routable by 
 design on its own. Its TE/MPLS Router ID must be routable. 
 If the OSPF administrator chose an IP Routable number for the 
 non-TE OSPF router ID, it would NOT break non-TE OSPF. 
 
 Clearly, BGP Identifier must be routable for the protocol to 
 work and the session to be Established.
 
 Clearly, ISIS SYSTEM-ID is not routable in the IP world, but 
 its IP TE/MPLS Router-ID must be routable. 
 
 Requiring people to chose routable IP address in protocols 
 like OSPF makes a lot of sense. The only issue is existing OSPF 
 deployments will have to renumber their OSPF routers. I can understand 
 the reluctance to do so.
 
 But as a standards body and one that hopefully recommends the 
 proper way to build networks in the most idealistic environments, I 
 would suggest that the Router ID definition be brought closer to
convergence 
 than is currently done.
 
 Getting of the soap box,
 Ben
 
 P.S. I think Yakov's idea of writing a draft regarding this 
 topic is a good one. You guys want to co-author it?
 
> > -----Original Message-----
> > From: Natale, Jonathan [mailto:[email-masked]]
> > Sent: Tuesday, September 10, 2002 10:12 AM
> > To: [email-masked]
> > Subject: RE: admin dist/gp spec proposal 
> > 
> > 
> > "If the matching route is learned from an OSPF neighbor, its 
> > OSPF router ID
> > must match the BGP router ID of the iBGP neighbor."
> > -- http://www.cisco.com/warp/public/459/25.shtml
> > 
> > 
> > -----Original Message-----
> > From: Curtis Villamizar [mailto:[email-masked]] 
> > Sent: Monday, September 09, 2002 6:11 PM
> > To: Abarbanel, Benjamin
> > Cc: 'Natale, Jonathan'; 'Yakov Rekhter'; [email-masked]
> > Subject: Re: admin dist/gp spec proposal 
> > 
> > 
> > In message
> > <[email-masked]>, 
> > "Abarbanel, Benjamin" writes:
> > > 
> > >  
> > > > 
> > > > Not that I am aware of.  There certainly is a case where they 
> > > > must be the
> > > > same (cisco bgp w/ ospf, don't know all the details of 
> > > > how/why).  
> > > 
> > > RFC1745, and RFC1403 tell you why they must be the same.
> > 
> > These documents are both historic.  In a prior message I 
> mentioned but
> > did not give the details as to why this practice (injecting BGP into
> > OSPF ala RFC1745) could be extremely harmfull.
> > 
> > Curtis
> > 
>

---

From: "John G. Scudder" <[email-masked]>
Date: Tue, 10 Sep 2002 11:41:22 -0400

>  work and the session to be Established.

This is incorrect for several implementations with which I am familiar.

--John