Subject: RE: Review of draft-ietf-idr-bgp4-17.txt

From: "Abarbanel, Benjamin" <[email-masked]>
Date: Wed, 11 Sep 2002 17:25:52 -0400

Yakov,

I dont want this thread to turn into being absurd. So lets drop the topic
I dont think we are getting anywhere here.

I just made an innocent comment about fixing the meaning of some text. I
apologize to all those who are offended by my review of the spec.

Thank You,
Ben

> -----Original Message-----
> From: Yakov Rekhter [mailto:[email-masked]]
> Sent: Wednesday, September 11, 2002 5:22 PM
> To: Abarbanel, Benjamin
> Cc: 'Yakov Rekhter'; 'Justin Fletcher'; [email-masked]; Alex Zinin
> Subject: Re: Review of draft-ietf-idr-bgp4-17.txt 
> 
> 
> > Just common sense, knowing how BGP, TCP and sockets work. I 
> guess I made
> > too a general statement, 
> 
> I think you are correct on this.
> 
> >                             maybe I should have said all 
> implementations
> > I looked at do it this way. 
> 
> That would certainly be more accurate. It would be even better if you
> would say how many implementations you looked at.
> 
> Yakov.
>   
> > > -----Original Message-----
> > > From: Yakov Rekhter [mailto:[email-masked]]
> > > Sent: Wednesday, September 11, 2002 5:09 PM
> > > To: Abarbanel, Benjamin
> > > Cc: 'Justin Fletcher'; [email-masked]; Alex Zinin
> > > Subject: Re: Review of draft-ietf-idr-bgp4-17.txt 
> > > 
> > > 
> > > Ben,
> > > 
> > > > At some point the wisdom of the day was to put this in. 
> Now its too
> > > > implementation specific, and people want to remove it. 
> When in fact 
> > > > everyone who builds BGP code does it this way.
> > > 
> > > Are you 100% sure that "everyone who builds BGP code does it 
> > > this way" ?
> > > (Did you actually check this with *everyone* who builds BGP ?)
> > > 
> > > Yakov.
> > > 
> > > > I see no reason why section Appendix 6.2 should be deleted. 
> > > > 
> > > > Thank You,
> > > > Ben
> > > > 
> > > > > -----Original Message-----
> > > > > From: Justin Fletcher [mailto:[email-masked]]
> > > > > Sent: Wednesday, September 11, 2002 5:01 PM
> > > > > To: [email-masked]
> > > > > Cc: Alex Zinin; Yakov Rekhter; Abarbanel, Benjamin
> > > > > Subject: Re: Review of draft-ietf-idr-bgp4-17.txt
> > > > > 
> > > > > 
> > > > > On Wed, 2002-09-11 at 13:30, Curtis Villamizar wrote:
> > > > > > 
> > > > > > In message <[email-masked]>, Alex 
> > > Zinin writes:
> > > > > > > Yakov, Ben-
> > > > > > > 
> > > > > > >  I thought section 6.2 "Processing Messages on a 
> > > Stream Protocol"
> > > > > > >  actually talked about these things...
> > > > > > > 
> > > > > > > -- 
> > > > > > > Alex
> > > > > > 
> > > > > > 
> > > > > > A you suggesting we turn the terse reminder in the 
> > > appendix into a
> > > > > > full TCP programming tutorial?
> > > > > > 
> > > > > > Maybe we should just change that section to.
> > > > > > 
> > > > > >   6.2  Processing Messages on a Stream Protocol
> > > > > > 
> > > > > >      BGP uses TCP as a transport mechanism.  If you are 
> > > unsure as to
> > > > > >      how to handle asynchronous reads and writes on TCP 
> > > > > sockets please
> > > > > >      refer to Unix Network Programming [RWStevens] or other
> > > > > >      introductory text for programming techniques for 
> > > the operating
> > > > > >      system and TCP implementation that you are using.
> > > > > > 
> > > > > > That would save having to rewrite major parts of Stevens 
> > > > > work into the
> > > > > > BGP spec.
> > > > > > 
> > > > > > Curtis
> > > > > 
> > > > > Perhaps the entire section should be deleted as beyond scope.
> > > > > 
> > > > > Justin Fletcher
> > > > > 
> > > > > 
> > > 
>

---

From: Alex Zinin <[email-masked]>
Date: Mon, 16 Sep 2002 14:24:11 -0700

A couple of requests here:

1) Don't *make* it personal, and don't *take* it personal, please.

2) WG chairs, please foster a healthy, open, and cooperative
   environment in the WG.

Thanks.

-- 
Alex