Subject: RE: BGP Connections

From: "Abarbanel, Benjamin" <[email-masked]>
Date: Thu, 19 Sep 2002 12:17:42 -0400

Nicolas:

You comments raise interesting observations.

below

> -----Original Message-----
> From: Nicolas REBIERRE [mailto:[email-masked]]
> Sent: Thursday, September 19, 2002 11:56 AM
> To: [email-masked]
> Subject: BGP Connections
> 
> 
> Hi all,
> 
> MP-BGP allows to advertise both IPv4 and IPv6 routes upon a TCP over
> IPv4 connection. But shouldn't it better to have 2 distinct FSM with 2
> TCP connections: BGP/TCP/IPv6 for IPv6 routes, BGP/TCP/IPv4 for IPv4
> routes ? This allows to handle IPv4 and IPv6 separately. Moreover, if

Since the core/backbone network is only a IPv4 network, you will not be 
able to setup a TCP session over IPv6 infrastructure. Most likely you will 
use tunneling IPv6 over IPv4 or IPv6 over MPLS/IPv4 to propagate the IPv6
routing information.  I think the goal now is to pass exterior IPv6 (island)
clouds information through a core IPv4 backbone. When the core is a true 
IPv6 topology your point makes sense.

> there is only one BGP/TCP/IPv4 connection for both kind of routes, a
> problem on IPv6 connectivity will not be detected.
> 
True, that is the drawback of the current (temporary) solution. 

> So If one wants to receive both IPv4 and IPv6 routes from a dual stack
> peer, could we impose to configure two connections to that peer,
> one for IPv4 and onother one for IPv6.
Not possible with current specs that I have seen.

> Could this restriction cause interoperability problems with some
> implementations ?
Maybe, can you be more specific what you are thinking of?

Ben

---

From: Mareline Sheldon <[email-masked]>
Date: Thu, 19 Sep 2002 20:38:41 -0700 (PDT)

are there any thoughts for writing a BGP spec for IPv6 which uses the IPv6 features like
anycast, link local IP addresses, site local etc.. as of now we just use IPv4 to carry IPv6
information. Are there any thoughts for actually running BGP over v6?

just a thought .. 

mareline s.

> Maybe, can you be more specific what you are thinking of?

__________________________________________________
Do you Yahoo!?
New DSL Internet Access from SBC & Yahoo!
http://sbc.yahoo.com

---

From: Jeffrey Haas <[email-masked]>
Date: Fri, 20 Sep 2002 09:56:07 -0400

> information. Are there any thoughts for actually running BGP over v6?

GateD and Cisco definitely interoperate using IPv6 as its networking layer.

What "features" of IPv6 were you specifically thinking of?
Anycast would be generally broken since we use a transport protocol
like TCP.
There was a link-layer peering extension proposed a while ago:
draft-kato-bgp-ipv6-link-local-01

-- 
Jeff Haas 
NextHop Technologies