Subject: RE: Review of draft-ietf-idr-bgp4-17.txt

From: "Abarbanel, Benjamin" <[email-masked]>
Date: Wed, 11 Sep 2002 14:43:38 -0400

The point is the application has to reassemble the packet, not TCP.

It is well covered in section 6.2 Appendix 6.

Ben

BTW. The smoke and dust has already settled on this point. I agree to
say I have no issue, other than to ask that a pointer to Appendix 6.2
be placed in the place where I saw it was missing.

> -----Original Message-----
> From: Natale, Jonathan [mailto:[email-masked]]
> Sent: Wednesday, September 11, 2002 2:38 PM
> To: 'Abarbanel, Benjamin'; 'Yakov Rekhter'
> Cc: [email-masked]'
> Subject: RE: Review of draft-ietf-idr-bgp4-17.txt 
> 
> 
> Huh?  Seems like a violation of basic TCP concepts!  Do you 
> mean the entire
> MESSAGE?  That would make sense and I think the draft already 
> mentions that
> you should not do anything until the whole msg is read.  It should be
> understood (from TCP concepts) that the msg can get chopped up and/or
> concatenated.  Maybe I missed the point.
> 
> -----Original Message-----
> From: Abarbanel, Benjamin [mailto:[email-masked]] 
> Sent: Wednesday, September 11, 2002 11:30 AM
> To: 'Yakov Rekhter'; Abarbanel, Benjamin
> Cc: [email-masked]'
> Subject: RE: Review of draft-ietf-idr-bgp4-17.txt 
> 
> Yakov:
>   That may be true, but I have seen in a couple of BGP implementations
> handling the socket level that the BGP code had to reassemble 
> the logical
> packet. TCP did not do it. 
> 
> What I mean the application code had to read from the socket 
> several times
> to get the entire packet and reassemble it, before passing it 
> to the BGP
> state 
> machine.
> 
> Ben
> 
> > -----Original Message-----
> > From: Yakov Rekhter [mailto:[email-masked]]
> > Sent: Wednesday, September 11, 2002 11:26 AM
> > To: Abarbanel, Benjamin
> > Cc: [email-masked]'
> > Subject: Re: Review of draft-ietf-idr-bgp4-17.txt 
> > 
> > 
> > Ben,
> > 
> > > Part I.
> > > 
> > > Technical Comments:
> > > ===================
> > > 1. P.6  section 4. Message Formats, its possible for the 
> > source BGP peer IP
> > > layer to fragment a message such that the receiving BGP 
> > peer socket layer
> > > would have to reassemble it. Need to mention this, since 
> > BGP implementations
> > > are required to do this.  
> > 
> > *BGP* implementations are *not* required to perform any 
> > message reassembly.
> > (remember this is BGP spec, not TCP and/or IP spec).
> > 
> > Yakov.
> > 
>

---

From: "John G. Scudder" <[email-masked]>
Date: Wed, 11 Sep 2002 14:51:21 -0400

>The point is the application has to reassemble the packet, not TCP.

I think the crux of the confusion is in the use of the word "packet". 
BGP doesn't know from packets, which have a specific network-layer 
meaning.  It uses messages, or what some folks like to call protocol 
data units (PDUs).

So actually, there is something to be fixed here.  In section 4.3, 
second line of first paragraph, s/UPDATE packet/UPDATE message/. 
That's the only misuse of "packet" I found in a quick grep of the 
document.

--John

---

From: Yakov Rekhter <[email-masked]>
Date: Wed, 18 Sep 2002 11:04:44 -0700

> That's the only misuse of "packet" I found in a quick grep of the 

Done.

yakov.