Subject: RE: your mail

From: "Abarbanel, Benjamin" <[email-masked]>
Date: Wed, 11 Sep 2002 13:43:18 -0400

My point is that no one "reads from a peer", that is physically impossible.
If there are many other ways to skin the cat, then mention like this,
"reads from a peer socket/stream/session/etc." just to be technically
correct.

Ben

> -----Original Message-----
> From: Jeffrey Haas [mailto:[email-masked]]
> Sent: Wednesday, September 11, 2002 1:40 PM
> To: Abarbanel, Benjamin
> Cc: [email-masked]'
> Subject: Re: your mail
> 
> 
> If I read this correctly to being a diff on just "socket", I'd
> recommend against the change.
> 
> Could be streams.
> Could be foo.
> 
> The fact that we mention blocking transport stream connections at
> all seems a bit silly - its an implementation detail.  But
> at least that section makes a pretense at "these are things that
> we've learned..."
> 
> On Wed, Sep 11, 2002 at 12:09:22PM -0400, Abarbanel, Benjamin wrote:
> > On p. 61, section 6.2
> > I will like to rephrase for clarity this:
> > 
> > "An implementation that would "hang" the routing 
> information process while
> > trying to read from a peer could set up a message buffer 
> (4096 bytes) per
> > peer and fill it with data as available until a complete 
> message has been
> > received. "
> > 
> > To This:
> > 
> > "An implementation that would "hang" the routing 
> information process while
> > trying to read from a peer socket could set up a message 
> buffer (4096 bytes)
> > per peer and fill it with data as available until a 
> complete message has
> > been
> > received. "
> > 
> > Thanks,
> > Ben
> > 
> 
> -- 
> Jeff Haas 
> NextHop Technologies
>

---

From: Jeffrey Haas <[email-masked]>
Date: Wed, 11 Sep 2002 13:45:01 -0400

> "reads from a peer socket/stream/session/etc." just to be technically

reads data from the transport connection with the peer.

-- 
Jeff Haas 
NextHop Technologies

---

From: Curtis Villamizar <[email-masked]>
Date: Wed, 11 Sep 2002 18:12:23 -0400

In message <[email-masked]>, 
> "reads from a peer socket/stream/session/etc." just to be technically

It if physically impossible to "read from a peer" which also makes it
painfully obvious that what is meant is "read from the socket for the
TCP connection that is associated with the BGP session for a specific
peer".

The latter is unambiguous even to the complete idiot but overly wordy
for anyone with an understanding of what a protocol based on TCP
entails.  The former is short and it is unambiguous for the intended
audience of the BGP protocol spec.

Curtis

ps - Please stop wasting our time.  Please be sure that your comments
are regarding something that is incorrect, incomplete, ambiguous, or
unclear when read from the standpoint of a person well versed in IP
routing, TCP, and TCP programming.