Subject: RE: [Idr] Re: weights in BGP

From: "john smith" <[email-masked]>
Date: Thu, 16 Sep 2004 07:34:24 +0000

Hi,

Let us look further down

>Hi John,
>
>]AS1-----AS2
>]\         /       |
>]\       /         |
>]   AS3       |
>]     |            |
>]    AS4-----
>]
>
>[clipped]
>
>]
>]As far as I understand, weights are not propogated,(which you
>]have confirmed is correct), but I do know that only those
>]routes from BGP which enter the forwarding plane can be sent
>]to peers. Is that not correct to?
>
>Yes.
>
>This kind of topology will eventually converge. Assume AS4 advertises a
>prefix X to AS3.

Perhaps you miunderstood the topology

AS4 is connected to AS3 and AS2.

so AS4 advertises this to AS3 && to AS2. Why would it advertise it to one 
and wait for it to converge and then choose the other?
so we have (best paths):

(1)
AS2---AS_PATH: AS4
AS3---AS_PATH: AS4
AS1--no path

>
>AS3 has with it one route to X, with AS_PATH AS4.

yes
and AS2 has AS_PATH AS4 too. is that correct?

>It advertises this to AS1 and AS2
>
>AS2 will receive two UPDATEs, one from AS3 and the other from AS1 and will
>thus have the following AS_PATHs.
>
>AS_PATH1: AS3 AS4
>AS_PATH2: AS1 AS3 AS4

==>
you missed:
AS_PATH3: AS4  here.

eitherways
AS2 would have received that prior to the update from AS3 directly from 
AS4??

AS2 would also have advertised this to AS1 in the time that AS3 converges. 
Is that correct/incorrect??
I believe there is nothing which says this is incorrect?

>
>Because of the weight configured on AS2, it will select the route from AS3.
>The best selected route is thus AS_PATH1 and it advertises this to AS1

So now AS1 would have (only best paths)
(2)
AS1:--AS_PATH: AS2 AS4.
AS2:--AS_PATH: AS3 AS4
AS3:--AS_PATH: AS4

>
>AS1 now has two routes, one which it received from AS2 and the other from
>AS3.
>AS_PATH1: AS2 AS3 AS4
>AS_PATH2: AS3 AS4
>
>Because of the weight, it will select the one from AS2.

see (2) above.

After this the progression as I see it should be:
(3)
AS1--AS_PATH: AS2 AS3 AS4
AS2--AS_PATH: AS3 AS4
AS3--AS_PATH: AS1 AS2 AS4

>
>It will send an implicit withdraw to AS2, replacing "AS1 AS3 AS4" with "AS1
>AS2 AS3 AS4". AS2 upon receiving this UPDATE will find its own AS, and will
>ignore this.
>
yes and no.

>AS1 also advertises it best route to AS3.
>
>Thus AS3 now has the following routes.
>
>AS_PATH1: AS1 AS2 AS3 AS4
>AS_PATH2: AS4

the next state as I see it should be:

(4)
AS1--AS_PATH: AS2 AS3 AS4
AS2--AS_PATH: AS4
AS3--AS_PATH: AS4
This will take me back to (1)

>
>It will ignore the first UPDATE because it will find its own AS number in
>the AS_PATH and will select the path it learnt from AS4. Note that it
>overrides your weight configuration. But then, weight only works when you
>have two feasible candidate routes, and in this case there is only one
>feasible route. The other is not considered because of the AS loop.
>
>The network will thus converge!

I do not quite grasp how it will... perhaps you could point out where I am 
wrong in the above?
>
>]I fail to understand which router detects the loop in what
>]case, as mentioned by you below.
>
>Hope this helps!
>

hope i clarified my question?

>Regards,
>Manav

_________________________________________________________________
The new MSN 8: advanced junk mail protection and 2 months FREE* 
http://join.msn.com/?page=features/junkmail

_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

---

From: "Manav Bhatia" <[email-masked]>
Date: Thu, 16 Sep 2004 15:41:18 +0530

John,

]
](1)
]AS2---AS_PATH: AS4

No. If you have configured a weight on AS2 which prefers routes from AS3,
then it will choose the path from AS3 as the best against the one it
receives directly from AS4. 

Thus the best path in AS2 is still "AS3 AS4".

Regards,
Manav

]AS3---AS_PATH: AS4
]AS1--no path
]
]>
]>AS3 has with it one route to X, with AS_PATH AS4.
]
]yes
]and AS2 has AS_PATH AS4 too. is that correct?
]
]>It advertises this to AS1 and AS2
]>
]>AS2 will receive two UPDATEs, one from AS3 and the other from AS1 and 
]>will thus have the following AS_PATHs.
]>
]>AS_PATH1: AS3 AS4
]>AS_PATH2: AS1 AS3 AS4
]
]
]==>
]you missed:
]AS_PATH3: AS4  here.
]
]eitherways
]AS2 would have received that prior to the update from AS3 
]directly from AS4??
]
]AS2 would also have advertised this to AS1 in the time that 
]AS3 converges. 
]Is that correct/incorrect??
]I believe there is nothing which says this is incorrect?
]
]>
]>Because of the weight configured on AS2, it will select the 
]route from AS3.
]>The best selected route is thus AS_PATH1 and it advertises this to AS1
]
]So now AS1 would have (only best paths)
](2)
]AS1:--AS_PATH: AS2 AS4.
]AS2:--AS_PATH: AS3 AS4
]AS3:--AS_PATH: AS4
]
]>
]>AS1 now has two routes, one which it received from AS2 and the other 
]>from AS3.
]>AS_PATH1: AS2 AS3 AS4
]>AS_PATH2: AS3 AS4
]>
]>Because of the weight, it will select the one from AS2.
]
]see (2) above.
]
]After this the progression as I see it should be:
](3)
]AS1--AS_PATH: AS2 AS3 AS4
]AS2--AS_PATH: AS3 AS4
]AS3--AS_PATH: AS1 AS2 AS4
]
]>
]>It will send an implicit withdraw to AS2, replacing "AS1 AS3 
]AS4" with 
]>"AS1
]>AS2 AS3 AS4". AS2 upon receiving this UPDATE will find its 
]own AS, and 
]>will ignore this.
]>
]yes and no.
]
]>AS1 also advertises it best route to AS3.
]>
]>Thus AS3 now has the following routes.
]>
]>AS_PATH1: AS1 AS2 AS3 AS4
]>AS_PATH2: AS4
]
]the next state as I see it should be:
]
](4)
]AS1--AS_PATH: AS2 AS3 AS4
]AS2--AS_PATH: AS4
]AS3--AS_PATH: AS4
]This will take me back to (1)
]
]>
]>It will ignore the first UPDATE because it will find its own 
]AS number 
]>in the AS_PATH and will select the path it learnt from AS4. Note that 
]>it overrides your weight configuration. But then, weight only works 
]>when you have two feasible candidate routes, and in this case 
]there is 
]>only one feasible route. The other is not considered because 
]of the AS loop.
]>
]>The network will thus converge!
]
]I do not quite grasp how it will... perhaps you could point 
]out where I am wrong in the above?
]>
]>]I fail to understand which router detects the loop in what ]case, as 
]>mentioned by you below.
]>
]>Hope this helps!
]>
]
]hope i clarified my question?
]
]>Regards,
]>Manav
]>
]
]_________________________________________________________________
]The new MSN 8: advanced junk mail protection and 2 months 
]FREE* http://join.msn.com/?page=features/junkmail
]