Subject: [Idr] weights in BGP

From: "john smith" <[email-masked]>
Date: Wed, 15 Sep 2004 12:35:17 +0000

Hi folks,

I do not see weights in the BGP base spec.
However, I have seen it on a number of routers

I would liek to know how people use the metric across different ASes.

Consider the following case:

AS1----AS2...
\      /
\   /       |
  AS3
   |         |
  AS4.........

AS1 makes a route map to prefer via weights  (* AS2)
AS3 makes a route map to prefer via weights  (* AS1)
AS2 weights  (* AS3)

AS4 comes up now/flaps up after a reboot.

Will this converge?
-JS

_________________________________________________________________
STOP MORE SPAM with the new MSN 8 and get 2 months FREE* 
http://join.msn.com/?page=features/junkmail

_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

---

From: "john smith" <[email-masked]>
Date: Wed, 15 Sep 2004 13:59:31 +0000

Hi,

Am sorry if I am wasting the time of the WG with this,
just one final post on the topic.

I am not saying weights are advertised.
All I am saying is that weights are used to select the best route on a given 
node to insert into the local_rib.
And the impelementation should advertise only what is inserted into the 
local_rib? isnt that correct?
So
a. if i do not know what my neighbours are doing
b. I use weights to choose routes.
c. I advertise routes based on what goes into the local_rib, and such a 
scenario does occur, as individual ASes do not know what each one is doing,
can we not end up in a unstable topology.

Many thanks for your replies!

>From: Michael Dell <[email-masked]>
>To: 'john smith' <[email-masked]>, [email-masked]
>Subject: RE: [Idr] weights in cisco
>Date: Wed, 15 Sep 2004 14:09:27 +0100
>
>John
>
>Weights are a Cisco feature.  See
>http://www.cisco.com/en/US/tech/tk365/tk80/technologies_tech_note09186a00800
>c95bb.shtml#weight for some discussion on weights.
>
>The important point to note is that the weight of a route is purely local 
>to
>a router - it is assigned via a route map, but is not advertised to peers 
>in
>any way.
>
>Regards
>
>Mike Dell
>
>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]]On Behalf Of
>john smith
>Sent: 15 September 2004 13:35
>To: [email-masked]
>Subject: [Idr] weights in cisco
>
>
>Hi folks,
>
>The new MSN 8: advanced junk mail protection and 2 months FREE*

_________________________________________________________________
The new MSN 8: advanced junk mail protection and 2 months FREE* 
http://join.msn.com/?page=features/junkmail

---

From: "john smith" <[email-masked]>
Date: Fri, 17 Sep 2004 06:59:31 +0000

What about the time when there is no prefix for AS4 coming from AS3?
Will it ignore all prefixes coming directly from AS4 in that case?

>From: "Manav Bhatia" <[email-masked]>
>Reply-To: <[email-masked]>
>To: "'john smith'" <[email-masked]>, <[email-masked]>
>Subject: RE: [Idr] Re: weights in BGP
>Date: Thu, 16 Sep 2004 15:41:18 +0530
>
>John,
>
>]
>](1)
>]AS2---AS_PATH: AS4
>
>No. If you have configured a weight on AS2 which prefers routes from AS3,
>then it will choose the path from AS3 as the best against the one it
>receives directly from AS4.
>
>Thus the best path in AS2 is still "AS3 AS4".
>
>Regards,
>Manav
>
>]AS3---AS_PATH: AS4
>]AS1--no path
>]
>]>
>]>AS3 has with it one route to X, with AS_PATH AS4.
>]
>]yes
>]and AS2 has AS_PATH AS4 too. is that correct?
>]
>]>It advertises this to AS1 and AS2
>]>
>]>AS2 will receive two UPDATEs, one from AS3 and the other from AS1 and
>]>will thus have the following AS_PATHs.
>]>
>]>AS_PATH1: AS3 AS4
>]>AS_PATH2: AS1 AS3 AS4
>]
>]
>]==>
>]you missed:
>]AS_PATH3: AS4  here.
>]
>]eitherways
>]AS2 would have received that prior to the update from AS3
>]directly from AS4??
>]
>]AS2 would also have advertised this to AS1 in the time that
>]AS3 converges.
>]Is that correct/incorrect??
>]I believe there is nothing which says this is incorrect?
>]
>]>
>]>Because of the weight configured on AS2, it will select the
>]route from AS3.
>]>The best selected route is thus AS_PATH1 and it advertises this to AS1
>]
>]So now AS1 would have (only best paths)
>](2)
>]AS1:--AS_PATH: AS2 AS4.
>]AS2:--AS_PATH: AS3 AS4
>]AS3:--AS_PATH: AS4
>]
>]>
>]>AS1 now has two routes, one which it received from AS2 and the other
>]>from AS3.
>]>AS_PATH1: AS2 AS3 AS4
>]>AS_PATH2: AS3 AS4
>]>
>]>Because of the weight, it will select the one from AS2.
>]
>]see (2) above.
>]
>]After this the progression as I see it should be:
>](3)
>]AS1--AS_PATH: AS2 AS3 AS4
>]AS2--AS_PATH: AS3 AS4
>]AS3--AS_PATH: AS1 AS2 AS4
>]
>]>
>]>It will send an implicit withdraw to AS2, replacing "AS1 AS3
>]AS4" with
>]>"AS1
>]>AS2 AS3 AS4". AS2 upon receiving this UPDATE will find its
>]own AS, and
>]>will ignore this.
>]>
>]yes and no.
>]
>]>AS1 also advertises it best route to AS3.
>]>
>]>Thus AS3 now has the following routes.
>]>
>]>AS_PATH1: AS1 AS2 AS3 AS4
>]>AS_PATH2: AS4
>]
>]the next state as I see it should be:
>]
>](4)
>]AS1--AS_PATH: AS2 AS3 AS4
>]AS2--AS_PATH: AS4
>]AS3--AS_PATH: AS4
>]This will take me back to (1)
>]
>]>
>]>It will ignore the first UPDATE because it will find its own
>]AS number
>]>in the AS_PATH and will select the path it learnt from AS4. Note that
>]>it overrides your weight configuration. But then, weight only works
>]>when you have two feasible candidate routes, and in this case
>]there is
>]>only one feasible route. The other is not considered because
>]of the AS loop.
>]>
>]>The network will thus converge!
>]
>]I do not quite grasp how it will... perhaps you could point
>]out where I am wrong in the above?
>]>
>]>]I fail to understand which router detects the loop in what ]case, as
>]>mentioned by you below.
>]>
>]>Hope this helps!
>]>
>]
>]hope i clarified my question?
>]
>]>Regards,
>]>Manav
>]>
>]
>]_________________________________________________________________
>]The new MSN 8: advanced junk mail protection and 2 months
>]FREE* http://join.msn.com/?page=features/junkmail
>]
>

---

From: "john smith" <[email-masked]>
Date: Mon, 20 Sep 2004 15:41:42 +0000

Hi Manav,

awaiting a reply,

Do you also suggest I should use local_pref on incoming eBGP peering? That 
would have the same effect, would it not?

>>receives directly from AS4.

What about the time when there is no prefix for AS4 coming from AS3 to AS2?
Will it ignore all prefixes coming directly from AS4 in that case?

>>Thus the best path in AS2 is still "AS3 AS4".

-best rgds