Subject: Re: [Idr] FW: I-D ACTION:draft-bhatia-ecmp-routes-in-bgp-01.txt

From: Tulip Rasputin <[email-masked]>
Date: Thu, 23 Sep 2004 13:05:37 -0400 (EDT)

> WD_NLRI: NULL
> Path Attributes:
>   + Origin - IGP
>   + AS_PATH - 65535
>   + NEXT_HOP - 192.168.1.1
>   + MP_REACH_NLRI
>     o AFI - 1 (ipv4)
>     o SAFI - 1 (unicast)
>     o MP_NEXTHOP - 192.168.1.2
>     o MP_NLRI - 10.0.1/24
> NLRI: 10.0.0/24

I am wondering. Why would an implementation put an IPv4/Unicast route inside MP_REACH_NLRI path
attribute? 

Tulip

______________________________________________________________________ 
Post your free ad now! http://personals.yahoo.ca

_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

---

From: Jeffrey Haas <[email-masked]>
Date: Tue, 28 Sep 2004 11:14:18 -0400

Tulip,

> I am wondering. Why would an implementation put an IPv4/Unicast route inside MP_REACH_NLRI path

It's an implementation choice.  Nothing precludes it.

The fact that you can represent the same information two different
ways within a given BGP packet is the source for potential problems.

Thankfully, all of the implementations I've seen choose to put it
in one spot consistently.

-- 
Jeff Haas 
NextHop Technologies