Subject: Re: [Idr] FW: I-D ACTION:draft-bhatia-ecmp-routes-in-bgp-01.txt

From: Glen Kent <[email-masked]>
Date: Thu, 9 Sep 2004 10:43:12 +0530

Hmm .. 

Why dont you advertise the equal cost routes that you have learnt from
other BGP speakers to your EBGP peers? Why go in for those complex
AS_PATH manipulations when advertising routes to an EBGP peer?

Glen

Could be an obvious thing, but its late in the night and my coffee mug is empty!

----- Original Message ----- 
From: "Manav Bhatia" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, September 08, 2004 10:17 AM
Subject: [Idr] FW: I-D ACTION:draft-bhatia-ecmp-routes-in-bgp-01.txt

> Hi,
> 
> This is the revised draft that was presented in 57th IETF. We would like
> this draft to be discussed in the IDR WG to see if it's a sensible work item
> for this working group.
> 
> Thanks,
> Manav
> 
> ----- Original Message ----- 
> From: <[email-masked]>
> To: <[email-masked]>
> Sent: Wednesday, September 08, 2004 1:26 AM
> Subject: I-D ACTION:draft-bhatia-ecmp-routes-in-bgp-01.txt
> 
> 
>>A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
>> 
>> 
>> Title : Advertising Equal Cost MultiPath routes in BGP
>> Author(s) : M. Bhatia,  J. Halpern
>> Filename : draft-bhatia-ecmp-routes-in-bgp-01.txt
>> Pages : 18
>> Date : 2004-9-7
>> 
>> This document describes an extensible mechanism that will allow a BGP 
>>   [BGP4] speaker to advertise equal cost multiple BGP routes for a 
>>   destination to its peers. A new BGP capability [BGP-CAP], termed   
>>   "Equal Cost Multipath Capability", is defined, which would allow a 
>>   local BGP speaker to express its ability to support advertisement of    
>>   such multiple paths to its peers.
>> 
>> A URL for this Internet-Draft is:
>> http://www.ietf.org/internet-drafts/draft-bhatia-ecmp-routes-in-bgp-01.txt

_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

---

From: "Manav Bhatia" <[email-masked]>
Date: Thu, 9 Sep 2004 14:59:17 +0530

Glen,

We don't need to advertise the individual ECMP BGP routes to the EBGP peer,
as the EBGP peer always resets the NEXT_HOP to itself. All you need to tell
your downstream peers is the ASes that their traffic will be going through
if it comes to you.

You need to construct the synthetic AS_PATH if you are installing multiple
BGP routes in your FIB (for load balancing, etc) because you *have* to
advertise whatever you use for your forwarding. Failing to do that can break
your routing in interesting ways!

Regards,
Manav

]-----Original Message-----
]From: Glen Kent [mailto:[email-masked]] 
]Sent: Thursday, September 09, 2004 10:43 AM
]To: [email-masked]; [email-masked]
]Subject: Re: [Idr] FW: I-D 
]ACTION:draft-bhatia-ecmp-routes-in-bgp-01.txt
]
]Hmm .. 
]
]Why dont you advertise the equal cost routes that you have 
]learnt from other BGP speakers to your EBGP peers? Why go in 
]for those complex AS_PATH manipulations when advertising 
]routes to an EBGP peer?
]
]Glen
]
]Could be an obvious thing, but its late in the night and my 
]coffee mug is empty!
]
]----- Original Message -----
]From: "Manav Bhatia" <[email-masked]>
]To: <[email-masked]>
]Sent: Wednesday, September 08, 2004 10:17 AM
]Subject: [Idr] FW: I-D ACTION:draft-bhatia-ecmp-routes-in-bgp-01.txt
]
]
]> Hi,
]> 
]> This is the revised draft that was presented in 57th IETF. 
]We would like
]> this draft to be discussed in the IDR WG to see if it's a 
]sensible work item
]> for this working group.
]> 
]> Thanks,
]> Manav
]> 
]> ----- Original Message ----- 
]> From: <[email-masked]>
]> To: <[email-masked]>
]> Sent: Wednesday, September 08, 2004 1:26 AM
]> Subject: I-D ACTION:draft-bhatia-ecmp-routes-in-bgp-01.txt
]> 
]> 
]>>A New Internet-Draft is available from the on-line Internet-Drafts
]> directories.
]>> 
]>> 
]>> Title : Advertising Equal Cost MultiPath routes in BGP
]>> Author(s) : M. Bhatia,  J. Halpern
]>> Filename : draft-bhatia-ecmp-routes-in-bgp-01.txt
]>> Pages : 18
]>> Date : 2004-9-7
]>> 
]>> This document describes an extensible mechanism that will 
]allow a BGP 
]>>   [BGP4] speaker to advertise equal cost multiple BGP routes for a 
]>>   destination to its peers. A new BGP capability [BGP-CAP], 
]termed   
]>>   "Equal Cost Multipath Capability", is defined, which 
]would allow a 
]>>   local BGP speaker to express its ability to support 
]advertisement of    
]>>   such multiple paths to its peers.
]>> 
]>> A URL for this Internet-Draft is:
]>> 
]http://www.ietf.org/internet-drafts/draft-bhatia-ecmp-routes-in
]-bgp-01.txt
]

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 09 Sep 2004 07:47:32 -0400

Allow me to paraphrase slightly:

When speaking to an ECMP speaking EBGP peer, we could send the multiple paths.
There is slightly more information available to the peer if we do 
that.  But not much.

We still need to define the AS path manipulation so that an entity which is 
using multiple paths (and possibly hearing multiple paths from other 
speakers) will be able to construct usable paths that preserve loop prevention.
Thus, we concluded that we need the ugly bits anyway.
So we used them to avoid adding protocol complexity to EBGP interaction.
If folks want the multiple paths across the EBGP exchanges, it can probably 
be done.

Yours,
Joel

---

From: Glen Kent <[email-masked]>
Date: Fri, 10 Sep 2004 08:13:30 +0530

Joel,

> speakers) will be able to construct usable paths that preserve loop prevention.

Aha .. 

> If folks want the multiple paths across the EBGP exchanges, it can probably

Yes you can certainly do that, but then how do you deal with routers
that cant parse this new path attribute? I think the current solution
is more backward compatible and easier to roll out.

Looks Good.

Glen.