Subject: [Idr] Prefix-list ORF sequence number question

From: "Vivian Lu" <[email-masked]>
Date: Wed, 9 Feb 2005 09:12:02 -0500

Hi, 

I have a question regarding prefix-list ORF draft,
draft-ietf-idr-bgp-prefix-orf-00.txt. 

The "sequence" field as specified in the draft is the following, 
	"The 'Sequence' field is a number that specifies the relative
ordering of the entry." 

What is the scope to which the statement is referring that makes the
ordering significant? 

Is the scope 
*	per bgp peer session? 
		-- That is, sequence number is continuously incremented for
each orf entry through out the peer session. 
		-- Sequence number gets reset when the peer session is
reset. 
*	per ORF message? 
		-- That is, sequence number is continuously incremented for
each orf entry within an ORF message. 
		-- Sequence number gets reset when a new ORF message is
created. 
*	per ORF type block in the orf message ?
		-- That is, sequence number is continuously incremented for
each orf entry within an ORF type block inside an ORF message.
		-- Sequence number gets reset when a new ORF type block is
written. 

We are wondering which one is what you intended and the industry may agree
with. 

Thanks. 
Vivian. 

_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

---

From: "Enke Chen \(enkechen\)" <[email-masked]>
Date: Wed, 9 Feb 2005 10:38:06 -0800

Hi, Vivian:

Please see my comments inlined.

> -----Original Message-----
> From: Vivian Lu [mailto:[email-masked]] 
> Sent: Wednesday, February 09, 2005 6:12 AM
> To: Vivian Lu; [email-masked]'; [email-masked]'
> Cc: [email-masked]'
> Subject: Prefix-list ORF sequence number question
> 
> Hi, 
> 
>         "The 'Sequence' field is a number that specifies the 
> relative ordering of the entry." 
> 
> What is the scope to which the statement is referring that 
> makes the ordering significant? 

The "Sequence" field is used in Sect 6. Address Prefix ORF Matching
when multiple ORF entries match a particular NLRI.

We can add some text to the definition in the next revision.

> 
> Is the scope 
> 
> 	*	per bgp peer session? 
> 
> 		-- That is, sequence number is continuously 
> incremented for each orf entry through out the peer session. 
> 		-- Sequence number gets reset when the peer 
> session is reset. 
> 	*	per ORF message? 
> 
> 		-- That is, sequence number is continuously 
> incremented for each orf entry within an ORF message. 
> 		-- Sequence number gets reset when a new ORF 
> message is created. 
> 		-- That is, sequence number is continuously 
> incremented for each orf entry within an ORF type block 
> inside an ORF message.
> 
> 		-- Sequence number gets reset when a new ORF 
> type block is written. 
> 
> We are wondering which one is what you intended and the 
> industry may agree with. 

Per the base ORF spec., ORFs are exchanged on a per peer
basis, and the life time of an ORF is the duration of the
session.

The scope of the sequence number is within the prefix-ORF
type exchanged over the session.  It is a local matter
(on the sender) how the sequenece number is assigned for
the intended semantics "relative ordering").

-- Enke