Subject: [Idr] BGP as an IGP

From: "Alok" <[email-masked]>
Date: Mon, 28 Feb 2005 18:59:58 +0530

Hi,

Are there any good references to using BGP as an IGP in the following
scenarios:

a. using RRs. (topology being a ring)
b. using Full mesh. (topology being full mesh)
c. using confederations (topology being triangles joined together)

In terms of scalability, what is the most recommended?

-thanks
Alok

_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

---

From: Rich Fulton <[email-masked]>
Date: Mon, 28 Feb 2005 09:09:07 -0500 (EST)

> c. using confederations (topology being triangles joined together)

http://www.amazon.com/exec/obidos/ASIN/1562056522/002-8674552-3904820

> In terms of scalability, what is the most recommended?

that is a loaded question.  typically RRs will 
win the scalability debate.  but it really 
depends on your topology.

   /rf

---

From: Robert Raszuk <[email-masked]>
Date: Mon, 28 Feb 2005 08:34:30 -0800

Alok,

Using BGP as an IGP works well when the number of routers involved is 
less or equal then two. When you have real network you are much better 
using real IGP to resolve bgp next hops as opposed to multi level BGP 
recursion or whole bunch of static routes.

Once we get on the same page there then we can move to selecting bgp 
route distribution scheme :). Either one listed below has pros & cons.

Cheers,
R.

PS. Btw that sounds more like a question to isp-bgp list then to idr.

 > Alok wrote:

---

From: "Alok" <[email-masked]>
Date: Tue, 1 Mar 2005 00:11:22 +0530

Thank you all for your responses and the references.

I am not talking about recursive resolution.

However, I am still at loss to comprehend what is wrong with static to
"adjacent" loopbacks (topology being physical full mesh or not)

Perhaps I should clarify this offlist.

-thanks
Alok