Subject: [Idr] Implementation Report on draft-ooms-v6ops-bgp-tunnel-04.txt

From: "Francois Le Faucheur \(flefauch\)" <[email-masked]>
Date: Mon, 7 Feb 2005 17:10:42 +0100

Hello,

A Last Call has been issued on Jan 31 in IDR for
draft-ooms-v6ops-bgp-tunnel-04.txt.

In line with the requirements for progressing a Routing document
(RFC1264), an implementation report needs to be submitted to the IESG on
draft-ooms-v6ops-bgp-tunnel-04.txt.

As an input to this report, we would like to gather information on
existing implementations of draft-ooms-v6ops-bgp-tunnel-04.txt. Hence,
could those who have implemented these extensions provide:
	-1- identification of the implementation
	-2- statement of compliance (provide all the Yes/No answers in
statement below which is based on all the MUST/SHOULD/MAY of
draft-ooms-v6ops-bgp-tunnel-04.txt)
	-3- statement as to whether you allow that information to be
made public or want it to be kept confidential.

You can either respond onto the list (assuming you are happy to have the
info public) or respond in private to myself or to the WG chairs.

Thank you 

Francois

STATEMENT OF COMPLIANCE TO draft-ooms-v6ops-bgp-tunnel-04.txt
=============================================================

2. Protocol Overview

"
The 6PE router MUST be dual stack IPv4 and IPv6.
"
==> Does your implementation comply?: Y/N

"
The 6PE router MUST be configurable with at least one IPv4 address on
the IPv4 side and at least one IPv6 address on the IPv6 side.
"
==> Does your implementation comply?: Y/N

"
The 6PE routers MUST exchange the IPv6 prefixes over MP-BGP sessions as
per [MP-BGP-v6] running over IPv4.
"
==> Does your implementation comply?: Y/N

"
The MP-BGP AFI used MUST be IPv6 (value 2). 
"
==> Does your implementation comply?: Y/N

"
Therefore, the IPv4 address of the egress 6PE router MUST be encoded as
an IPv4-mapped IPv6 address in the BGP Next Hop field.
"
==> Does your implementation comply?: Y/N

"
In addition, the 6PE MUST bind a label to the IPv6 prefix as per
[LABEL]. 
"
==> Does your implementation comply?: Y/N

"
The SAFI used in MP-BGP MUST be the "label" SAFI (value 4) as defined in
[LABEL]. 
"
==> Does your implementation comply?: Y/N

"
The Ingress 6PE router MUST forward IPv6 data over the IPv4-signaled LSP
towards the Egress 6PE router identified by the IPv4 address advertised
in the IPv4-mapped IPv6 address of the BGP Next Hop for the
corresponding IPv6 prefix.
"
==> Does your implementation comply?: Y/N

3. Transport over IPv4-signaled LSPs and IPv6 label binding

"
When tunneling IPv6 packets over the IPv4 MPLS backbone, rather than
successively prepend an IPv4 header and then perform label imposition
based on the IPv4 header, the ingress 6PE Router MUST directly perform
label imposition of the IPv6 header without prepending any IPv4 header. 
"
==> Does your implementation comply?: Y/N

"
The (outer) label imposed MUST correspond to the IPv4-signaled LSP
starting on the ingress 6PE Router and ending on the egress 6PE Router.
"
==> Does your implementation comply?: Y/N

"
This label advertised by the Egress 6PE Router with MP-BGP MAY be an
arbitrary label value which identifies an IPv6 routing context or
outgoing interface to send the packet to, or MAY be the IPv6 Explicit
Null Label. 
"
==> Does your implementation comply and advertise an "arbitrary label
value"?: Y/N
==> Does your implementation comply and advertise "IPv6 Explicit Null
Label"?: Y/N

"
An Ingress 6PE Router MUST be able to accept any such advertised label.
"
==> Does your implementation comply and accept an "arbitrary label
value"?: Y/N
==> Does your implementation comply and accept "IPv6 Explicit Null
Label"?: Y/N

4. Crossing Multiple IPv4 Autonomous Systems

"
(a) EBGP redistribution of IPv6 routes from AS to neighboring AS
The exchange of IPv6 routes MUST be carried out as per [MP-BGP-v6].
"
==> Does your implementation support (a)?: Y/N
==> If yes, does it comply?: Y/N

"
(b) EBGP redistribution of labeled IPv6 routes from AS to neighboring AS
When peering over IPv6, the exchange of labeled IPv6 routes MUST be
carried out as per [MP-BGP-v6] and [LABEL]. 
"
==> Does your implementation support (b)?: Y/N
==> If yes, does it comply?: Y/N

"
When peering over IPv4, the exchange of labeled IPv6 routes MUST be
carried out as per [MP-BGP-v6] and [LABEL] with encoding of the IPv4
address of the ASBR as an IPv4-mapped IPv6 address in the BGP Next Hop
field.
"
==> Does your implementation comply?: Y/N

5. Security Considerations

"
To this end an ASBR 6PE SHOULD only accept labeled packets from its peer
ASBR 6PE if the topmost label is a label that it has explicitly signaled
to that peer ASBR 6PE.
"
==> Does your implementation comply?: Y/N

_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

---

From: "Francois Le Faucheur \(flefauch\)" <[email-masked]>
Date: Wed, 9 Feb 2005 21:30:10 +0100

Hello,

For information, below is the statement of compliance for Cisco IOS implementation of draft-ooms-v6ops-bgp-tunnel-04.txt.

Francois

2. Protocol Overview

"
The 6PE router MUST be dual stack IPv4 and IPv6.
"
==> Does your implementation comply?: Y

"
The 6PE router MUST be configurable with at least one IPv4 address on
the IPv4 side and at least one IPv6 address on the IPv6 side.
"
==> Does your implementation comply?: Y

"
The 6PE routers MUST exchange the IPv6 prefixes over MP-BGP sessions as
per [MP-BGP-v6] running over IPv4.
"
==> Does your implementation comply?: Y

"
The MP-BGP AFI used MUST be IPv6 (value 2). 
"
==> Does your implementation comply?: Y

"
Therefore, the IPv4 address of the egress 6PE router MUST be encoded as
an IPv4-mapped IPv6 address in the BGP Next Hop field.
"
==> Does your implementation comply?: Y

"
In addition, the 6PE MUST bind a label to the IPv6 prefix as per
[LABEL]. 
"
==> Does your implementation comply?: Y

"
The SAFI used in MP-BGP MUST be the "label" SAFI (value 4) as defined in
[LABEL]. 
"
==> Does your implementation comply?: Y

"
==> Does your implementation comply?: Y

"
==> Does your implementation comply?: Y

"
The (outer) label imposed MUST correspond to the IPv4-signaled LSP
starting on the ingress 6PE Router and ending on the egress 6PE Router.
"
==> Does your implementation comply?: Y

"
value"?: Y
Label"?: N

"
value"?: Y
Label"?: Y

"
(a) EBGP redistribution of IPv6 routes from AS to neighboring AS
The exchange of IPv6 routes MUST be carried out as per [MP-BGP-v6].
"
==> Does your implementation support (a)?: Y
==> If yes, does it comply?: Y

"
(b) EBGP redistribution of labeled IPv6 routes from AS to neighboring AS
When peering over IPv6, the exchange of labeled IPv6 routes MUST be
carried out as per [MP-BGP-v6] and [LABEL]. 
"
==> Does your implementation support (b)?: Y
==> If yes, does it comply?: Y

"
When peering over IPv4, the exchange of labeled IPv6 routes MUST be
carried out as per [MP-BGP-v6] and [LABEL] with encoding of the IPv4
address of the ASBR as an IPv4-mapped IPv6 address in the BGP Next Hop
field.
"
==> Does your implementation comply?: Y

"
To this end an ASBR 6PE SHOULD only accept labeled packets from its peer
ASBR 6PE if the topmost label is a label that it has explicitly signaled
to that peer ASBR 6PE.
"
==> Does your implementation comply?: N (under development)

>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On 
>> Behalf Of Francois Le Faucheur (flefauch)
>> Sent: lundi 7 février 2005 17:11
>> To: [email-masked]
>> Cc: Bill Fenner; [email-masked]; [email-masked]; 
>> [email-masked]; Susan Hares
>> Subject: [Idr] Implementation Report on 
>> draft-ooms-v6ops-bgp-tunnel-04.txt 
>> 
>> Hello,
>> 
>> existing implementations of 
>> draft-ooms-v6ops-bgp-tunnel-04.txt. Hence,