Subject: RE: [Idr] IDR WG Minutes

From: John Smith <[email-masked]>
Date: Mon, 8 Aug 2005 19:00:48 +0100 (BST)

> Paul ??: If in ECMP case, what AS sequence? How to pass multiple 
> paths to a legacy speaker?
> 
> Retana:  Cap advert defines who can learn add_path. Other 
> applications like EBGP ECMP and propagating multiple paths will have 
> to be addressed.
> 
> Retana: Constrained scope.

I dont think we should be considering proposals that preclude advertising and using BGP
ECMP routes. More so when the WG is considering taking this up as an item. 

> Rekhter: We can have as many ad hoc solutions as we want or a more 
> general solution. We as a group should decide on a more general 
> solution. We should look at potential new functionality once we have 
> more than one path being advertised.
> Suggestion is that the authors of three proposals should find common 

Which third proposal?

> solution to all problems that WG would like to address. A mailing 
> list will be set up to discuss this problem and solution. On the IDR
> mailing list please identify problems.

A good step IMO.

> 
> Rekhter: Do we need requirements document?
> 
> Ward: No, absolutely not.

John 

___________________________________________________________ 
To help you stay safe and secure online, we've developed the all new Yahoo! Security Centre. http://uk.security.yahoo.com

_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

---

From: Yakov Rekhter <[email-masked]>
Date: Mon, 08 Aug 2005 11:14:30 -0700

John,

> I dont think we should be considering proposals that preclude advertising and
> using BGP ECMP routes. More so when the WG is considering taking this up 
> as an item. 

Please repost this point once we'll start a discussion on the mailing
list about this work (I am going to post an e-mail on this topic shortly).

> > Suggestion is that the authors of three proposals should find common 

Here are the three proposals (in no particular order):

draft-bhatia-ecmp-routes-in-bgp-01.txt 
draft-zhang-idr-bgp-entire-routes-reflect-00.txt
draft-walton-bgp-add-paths-03.txt

> > Ward: No, absolutely not.

Yakov.

---

From: "john smith" <[email-masked]>
Date: Fri, 12 Aug 2005 12:26:05 +0000

John,

>ECMP routes. More so when the WG is considering taking this up as an item.
Given the assumption that
a. CPUs will grow faster that ASICs.
b. memory on control plane will be cheaper than those in the forwarding 
plane components,

i see a benefit in signalling paths to solve a problem that BGP may not 
solve in its current form.

the only advantage this gives is help solve negative arcs.
Closer to Local_pref on eBGP/MED oscillations scenarios.

the only reason I brought up this topic was that i was not dead sure how 
weights are used on eBGP peers.
Could be my lack of knowledge of coupled be too much obfuscation around the 
correct solution :-).

It does make sense to have the feature though.

_________________________________________________________________
FREE pop-up blocking with the new MSN Toolbar - get it now! 
http://toolbar.msn.click-url.com/go/onm00200415ave/direct/01/