Subject: [Idr] Multiple Paths in BGP

From: "Manav Bhatia" <[email-masked]>
Date: Wed, 15 Feb 2006 10:48:05 +0530

Hi,

Recently there have been proposals in the IDR to extend BGP to advertise
multiple paths for a given NLRI. There are various applications that could
use this - Passive Route Servers, Interdomain TE, ECMP, MED oscillations,
Suboptimal routing with RRs, etc. 

We have written a draft that proposes a new path attribute MULTIPLE_HOP that
can be used to advertise multiple paths in BGP. This draft has been built
upon the feedback/suggestions that we received for the earlier versions of
our ecmp draft.

http://www.ietf.org/internet-drafts/draft-bhatia-bgp-multiple-next-hops-00.t
xt

We also propose a way for BGP speakers to legitimately do ECMP using the new
path attribute defined in the above draft. 

http://www.ietf.org/internet-drafts/draft-bhatia-ecmp-routes-in-bgp-02.txt

Would appreciate comments on the above drafts.

Thanks,
Manav

_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

---

From: Cristel Pelsser <[email-masked]>
Date: Mon, 20 Feb 2006 15:18:07 +0100

Hi Manav,

Your explanation is correct.

Hi Tom and all,

We have shown in a paper 
(http://www.info.ucl.ac.be/~cpe/Pelsser_IPOM.pdf 
<http://www.info.ucl.ac.be/%7Ecpe/Pelsser_IPOM.pdf>) and in an IETF 
draft (http://www.info.ucl.ac.be/~cpe/draft-pelsser-bgp-pce-00.txt 
<http://www.info.ucl.ac.be/%7Ecpe/draft-pelsser-bgp-pce-00.txt>) that 
the BGP routes learned at a single BGP router are often not sufficient 
to be able to compute constrained interdomain paths. If a PCE receives 
all the BGP routes learned inside the AS it has more chances to find an 
interdomain path that respects given constraints than a simple BGP 
router. Thus, it is useful for a BGP router to distribute more than one 
route for each destination to the PCEs inside its AS.

Best regards,

Cristel

Manav Bhatia wrote:

>I hope this is correct! :)
>
>BTW, Would love to know your comments on this draft. Are there things that
>you would want to added/modified/deleted in this draft and does this help
>you in your purpose?
>
>Thanks,
>Manav
>----- Original Message ----- 
>From: "Manav Bhatia" <[email-masked]>
>To: "Tom Sanders" <[email-masked]>; <[email-masked]>
>Sent: Friday, February 17, 2006 2:51 PM
>Subject: Re: [Idr] Multiple Paths in BGP
>
>
>  
>
>>Hi Toms,
>>
>>If you consider using a PCE to aid in the establishment of interdomain
>>    
>>
>LSPs,
>  
>
>>the PCE would need to collect all interdomain/intradomain routes.
>>
>>Because of the fact that BGP advertises only one best path (which is btw
>>selected based on criterions not based on the QoS/TE parameters), there
>>    
>>
>can
>  
>
>>be scenarios when a PCE would never get to learn about some of the paths
>>that are available. Those paths would thus never be used by a PCE for
>>computing the primary and the backup interdomain LSPs.
>>
>>With this draft, BGP speakers can advertise multiple paths using the
>>MULTIPLE_HOP path attribute and a PCE can potentially use *all* the paths
>>that are available.
>>
>>Olivier and Cristel should be able to give you more information on this.
>>
>>Thanks,
>>Manav
>>
>>----- Original Message ----- 
>>From: "Tom Sanders" <[email-masked]>
>>To: <[email-masked]>
>>Sent: Thursday, February 16, 2006 7:58 AM
>>Subject: RE: [Idr] Multiple Paths in BGP
>>
>>
>>    
>>
>>>multiple paths for a given NLRI. There are various applications that
>>>      
>>>
>could
>  
>
>>>use this - Passive Route Servers, Interdomain TE, ECMP, MED
>>>      
>>>
>oscillations,
>  
>
>>I read the drafts but could find nothing pertaining to Interdomain TE. How
>>can the ideas presented in the draft help in doing Interdomain TE?
>>
>>Toms.
>>
>>    
>>
>>>We have written a draft that proposes a new path attribute MULTIPLE_HOP
>>>      
>>>
>>that
>>    
>>
>>>can be used to advertise multiple paths in BGP. This draft has been
>>>      
>>>
>built
>  
>
>>>upon the feedback/suggestions that we received for the earlier versions
>>>      
>>>
>of
>  
>
>>>our ecmp draft.
>>>
>>>
>>>      
>>>
>>>We also propose a way for BGP speakers to legitimately do ECMP using the
>>>      
>>>
>>new
>>    
>>
>>--
>>Toms.
>>--------------------------------------------------------------------------
>>    
>>
>--
>  
>
>>----
>>
>>
>>    
>>

-- 
                       '''
                      (0 0)
        +-------oOO----(_)---------------+
        |        Cristel Pelsser         |
        | http://www.info.ucl.ac.be/~cpe |
        +--------------------oOO---------+
                     |__|__|
                      || ||
                     ooO Ooo