Subject: [Idr] 4-Byte ASN - subtype for extended community

From: "Kavitha G - TLS ,Chennai" <[email-masked]>
Date: Mon, 9 Oct 2006 17:39:04 +0530

For BGP 4-octet AS, what is the sub-type value to be used in extended
communities?

In the draft 4-octet AS specific Extended community, the subtype are given
for Route Target and Route Origin. 

When there is no support for BGP-MPLS-VPN, how this 4-octet AS specific can
be sent in the extended community attribute. [i.e., For general 4-octet AS
number in extended comm, which is used similar to community attribute] 

Is there a subtype mentioned for this kind of extended community usage or is
it planned for future drafts 

Thanks,

Kavitha

DISCLAIMER 
The contents of this e-mail and any attachment(s) are confidential and intended for the 

named recipient(s) only. It shall not attach any liability on the originator or HCL or its 

affiliates. Any views or opinions presented in this email are solely those of the author and 

may not necessarily reflect the opinions of HCL or its affiliates. Any form of reproduction, 

dissemination, copying, disclosure, modification, distribution and / or publication of this 

message without the prior written consent of the author of this e-mail is strictly 

prohibited. If you have received this email in error please delete it and notify the sender 

immediately. Before opening any mail and attachments please check them for viruses and 

defect.
_______________________________________________
Idr mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/idr

---

From: Yakov Rekhter <[email-masked]>
Date: Mon, 09 Oct 2006 06:48:30 -0700

Kavitha,

> In the draft 4-octet AS specific Extended community, the subtype are
> given for Route Target and Route Origin.
> 
> When there is no support for BGP-MPLS-VPN, how this 4-octet AS specific 
> can be sent in the extended community attribute. [i.e., For general 
> 4-octet AS number in extended comm, which is used similar to community 
> attribute]

The IANA would need to create a registry (as specified in the
IANA Consideration section of draft-rekhter-as4octet-ext-community),
and then one would need to request an assignment from that registry.
  
Yakov.