Subject: [Idr] draft-huston-as-representation-00.txt as IDR WG document

From: Yakov Rekhter <[email-masked]>
Date: Wed, 20 Aug 2008 18:39:21 -0700

Folks,

Please send your comments on the attached. The deadline for comments
is Sep 3, 2008.

Yakov.
------- Forwarded Message

Date:    Wed, 20 Aug 2008 16:46:30 +1000
From:    Geoff Huston <[email-masked]>
To:      [email-masked]
cc:      George Michaelson <[email-masked]>
Subject: [Idr] Draft on the textual representation of AS Numbers

The issue of the appropriate format for the textual representation of  
32-bit AS numbers appears to a matter of continuing comment, and there  
have been some calls for the IETF to adopt a standard representation  
for 32-bit AS numbers in the same way that RFC4291 defines a standard  
textual representation of IPv6 addresses. The appropriate WG for this  
work appears to be the IDR working group, and I would like to request  
that the WG considers draft-huston-as-representation-00.txt for  
adoption as a Working Group draft.

regards,

    Geoff Huston
_______________________________________________
Idr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/idr

------- End of Forwarded Message

_______________________________________________
Idr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/idr

---

From: Gaurab Raj Upadhaya <[email-masked]>
Date: Thu, 21 Aug 2008 05:25:18 +0100

Geoff,

> adoption as a Working Group draft.

I support the use of ASPLAIN and adoption of this Draft.

thanks
 -gaurab

---

From: "John G. Scudder" <[email-masked]>
Date: Sun, 24 Aug 2008 19:20:06 -0400

I'm in favor of adoption (of the notation and the draft).

--John

---

From: Enke Chen <[email-masked]>
Date: Sun, 24 Aug 2008 16:40:48 -0700

Hi, folks:

I would like to suggest using "::" (double colons) instead of "." (dot) 
as the delimiter because

       o "." means any character  in a regular expression.
       o ":" is already used in the representation of communities.

Other than that, I think the document is fine.

Thanks.   -- Enke

---

From: David Woodgate <[email-masked]>
Date: Wed, 27 Aug 2008 13:28:39 +1000

Enke,

Just to clarify, are you saying that you would prefer a formatted 
4-byte AS number instead of ASPLAIN (i.e. unformatted)?

(I believe draft-huston proposes ASPLAIN and draft-michaelson proposes ASDOT.)

Regards,

                                 David Woodgate

---

From: David Woodgate <[email-masked]>
Date: Wed, 27 Aug 2008 13:33:49 +1000

John,

Given the presence of the two drafts, would you mind confirming for 
me that you mean you support the ASPLAIN (unformatted) format 
proposed in draft-huston?

With many thanks,

                                         David Woodgate

---

From: "John G. Scudder" <[email-masked]>
Date: Tue, 26 Aug 2008 20:44:28 -0700

Yes, that's what I meant.

Regards,

--John

---

From: Enke Chen <[email-masked]>
Date: Tue, 26 Aug 2008 20:58:51 -0700

Hi, David:

I prefer the formatted one ("2::100") as that is easier to remember and 
to communicate.

(sorry that I mixed up the two drafts).

Regards,    -- Enke

---

From: James Spenceley <[email-masked]>
Date: Thu, 28 Aug 2008 09:55:43 +1000

For the information of the list,

At APNIC26 today there was almost entirely unanimous support for using  
ASPLAIN by the AP operator community.

prop-065 "Format for delegation and recording of 4-byte AS numbers"  
proposing APNIC adopts the use of ASPLAIN reached consensus.

On that basis I support the adoption of draft-huston-as- 
representation-00.txt

Cheers,

--
James

On 27/08/2008, at 1:58 PM, Enke Chen wrote:

>> (I believe draft-huston proposes ASPLAIN and draft-michaelson  
>> proposes
>> ASDOT.)
>>
>> Regards,
>>
>>                                David Woodgate
>>

CEO
Vocus Group Limited
Level 2, Vocus House
189 Miller Street
North Sydney, NSW 2060
(m) +61 407 496 866
(w) +61 2 9959 3913

---

From: "tom.petch" <[email-masked]>
Date: Thu, 28 Aug 2008 13:49:50 +0200

----- Original Message -----
From: "Enke Chen" <[email-masked]>
To: "David Woodgate" <[email-masked]>
Cc: "Yakov Rekhter" <[email-masked]>; <[email-masked]>
Sent: Wednesday, August 27, 2008 5:58 AM
Subject: Re: [Idr] draft-huston-as-representation-00.txt as IDR WG document

> I prefer the formatted one ("2::100") as that is easier to remember and

+1

> (sorry that I mixed up the two drafts).
(me too - when first I read them, I thought that they were the same draft and
that the two co-authors had inadvertently both submitted the same I-D:-(.

Tom Petch

> David Woodgate wrote:
<snip>

---

From: Alan Barrett <[email-masked]>
Date: Sun, 31 Aug 2008 21:27:44 +0200

> I prefer the formatted one ("2::100") as that is easier to remember and 

That sounds like a proposal for yet another format, neither the "131172"
of the ASPLAIN format, nor the "2.100" of the ASDOT format?

I support the format that has been labeled "ASPLAIN", in which AS
numbers are represented as decimal integers without any internal
boundaries or delimiters.

--apb (Alan Barrett)