Subject: Re: [Idr] BGP MIBv2 updates

From: Yakov Rekhter <[email-masked]>
Date: Mon, 23 Feb 2009 07:34:28 -0800

Folks,

Please comment on the attached request. The deadline for comments
is March 9, 2009.

Yakov.
------- Forwarded Message

Date:    Mon, 23 Feb 2009 10:24:09 -0500
From:    Jeffrey Haas <[email-masked]>
To:      [email-masked]
Subject: Re: [Idr] BGP MIBv2 updates

I was requested to be a little more clear here.

On Sat, Feb 21, 2009 at 11:50:42PM -0500, Jeffrey Haas wrote:
> In order to encourage implementation of these drafts, I'd like to request an
> early allocation from the mib-2 space for these MIBs.

I'd like to request an early allocation from mib-2 for the following
SNMP MODULE-IDENTITYs.

bgp4V2, published in draft-ietf-idr-bgp4-mibv2-09.
bgp4V2TC, published in draft-ietf-idr-bgp4-mibv2-tc-mib-00.

_______________________________________________
Idr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/idr

------- End of Forwarded Message

---

From: "tom.petch" <[email-masked]>
Date: Tue, 24 Feb 2009 12:24:18 +0100

----- Original Message -----
From: "Yakov Rekhter" <[email-masked]>
To: <[email-masked]>
Sent: Monday, February 23, 2009 4:34 PM
Subject: Re: [Idr] BGP MIBv2 updates

> Please comment on the attached request. The deadline for comments

I think that this is a sensible idea (and yes I understood it the first time:-).

I take it that Yakov's e-mail is in pursuance to RFC4020 3.1 3).

A question; RFC4181 discourages this approach, preferring experimental (which I
think inappropriate here).  Has the IESG approved early allocation for MIB
Modules as per RFC4020 2 a)?  This topic came up on another list recently and
there was no mention of early allocation.  I see no mention of approval on the
IANA website.

Tom Petch

---

From: Jeffrey Haas <[email-masked]>
Date: Tue, 24 Feb 2009 10:57:47 -0500

On Tue, Feb 24, 2009 at 12:24:18PM +0100, tom.petch wrote:
> think inappropriate here).

The exact same RFC contains a clause which is one of the motives for not
doing experimental.  

:  Experience has shown that it is impractical to move objects from one
:  subtree to another once those objects have seen large-scale use in an
:  operational environment.  Hence any object that is targeted for
:  deployment in an operational environment MUST NOT be registered under
:  the experimental subtree, irrespective of the standardization status
:  of that object.

Unless I misunderstood our MIB doctor, I was encouraged to not request
experimental allocation.

-- Jeff

---

From: "tom.petch" <[email-masked]>
Date: Tue, 24 Feb 2009 19:16:51 +0100

----- Original Message -----
From: "Jeffrey Haas" <[email-masked]>
To: "tom.petch" <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, February 24, 2009 4:57 PM
Subject: Re: [Idr] BGP MIBv2 updates

> Unless I misunderstood our MIB doctor, I was encouraged to not request

Yes, I agree which then leaves
- waiting until the RFC is approved
- or getting IESG permission for early allocation.

I presume this thread is part of the latter strategy but I am unclear how
successful this is, like I see no mention on the IANA website of this being an
IESG approved category (but that could just be me struggling to find anything on
the IANA website:-(

Tom Petch