Subject: [Idr] draft-rosen-idr-aigp-00.txt as IDR WG document

From: Yakov Rekhter <[email-masked]>
Date: Wed, 25 Mar 2009 06:51:28 -0700

Folks,

We received a request to accept draft-rosen-idr-aigp-00.txt as an
IDR WG document. The deadline for comments on this request is April
8, 2009.

If anyone is aware of the IPR related to the draft, please follow
the procedurs of rfc3979.

Yakov.
------- Forwarded Message

Date:    Tue, 24 Mar 2009 22:09:29 -0700
From:    "Pradosh Mohapatra (pmohapat)" <[email-masked]>
To:      "idr" <[email-masked]>
Subject: [Idr] draft-rosen-idr-aigp-00.txt as IDR WG document

The authors would like to request that draft-rosen-idr-aigp-00.txt
be adopted as an IDR WG document. We presented it yesterday @ IDR.
_______________________________________________
Idr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/idr

------- End of Forwarded Message

---

From: "Zafar Ali (zali)" <[email-masked]>
Date: Wed, 25 Mar 2009 10:27:05 -0400

In Favor. 

Thanks

Regards... Zafar  

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Yakov Rekhter
> Sent: Wednesday, March 25, 2009 9:51 AM
> To: [email-masked]
> We received a request to accept draft-rosen-idr-aigp-00.txt 
> as an IDR WG document. The deadline for comments on this 
> request is April 8, 2009.
> 
> If anyone is aware of the IPR related to the draft, please 
> follow the procedurs of rfc3979.
> 
> Yakov.
> The authors would like to request that 
> draft-rosen-idr-aigp-00.txt be adopted as an IDR WG document. 
> We presented it yesterday @ IDR.

---

From: Gargi Nalawade <[email-masked]>
Date: Wed, 25 Mar 2009 14:27:43 -0700

The draft should be updated to specify procedures for upgrading with this extension, before being considered for a WG doc, IMHO.

In its current form, it requires a flash upgrade of the network to ensure that there are no routing loops, as Enke also pointed out.

-Gargi

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Yakov Rekhter [[email-masked]]
Sent: Wednesday, March 25, 2009 6:51 AM
To: [email-masked]
Subject: [Idr]  draft-rosen-idr-aigp-00.txt as IDR WG document

Folks,

Yakov.

---

From: john heasley <[email-masked]>
Date: Wed, 25 Mar 2009 22:59:23 +0000

Why is AIGP considered before local-preference in best path selection?
LP is our trump card.  In Cisco's algorithm, it is also before locally
originated/redistributed routes.  Was the intention that it be before
ASPATH?

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 25 Mar 2009 16:09:32 -0700

Hi John,

> originated/redistributed routes.  Was the intention that it be before

Yes that was exactly the intention when we discussed this at the design 
phase.

But I am yet to get convinced that MED + Cost Community with POI before 
AS_PATH length is not a better alternative to the problem at hand.

Cheers,
R.

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 25 Mar 2009 16:15:41 -0700

Hi Gargi,

> The draft should be updated to specify procedures for upgrading with
> this extension, before being considered for a WG doc, IMHO.
> 
> In its current form, it requires a flash upgrade of the network to
> ensure that there are no routing loops, as Enke also pointed out.

I don't think it requires flash upgrade as defined today. Note that this 
is to be contained by design to a single service provider which may 
consist of more then one AS.

The feature is off by default and enabled when all _essential_ network 
elements are upgraded with the new functionality.

Just to note - If you are running some form of encapsulation (for 
example MPLS) within your ASes such number of nodes to upgrade to make 
this useful is significantly reduced.

Cheers,
R.

---

From: "Pradosh Mohapatra (pmohapat)" <[email-masked]>
Date: Wed, 25 Mar 2009 18:02:20 -0700

Hi Gargi,

| The draft should be updated to specify procedures for 
| upgrading with this extension, before being considered for a 
| WG doc, IMHO.
| 
| In its current form, it requires a flash upgrade of the 
| network to ensure that there are no routing loops, as Enke 
| also pointed out.

No, it doesn't. Section 3.1 of the document talks about the
applicability:

   This document only considers the use of the AIGP attribute in
   networks where each router uses tunneling of some sort to deliver a
   packet to its BGP next hop.  Use of the AIGP attribute in networks
   that do not use tunneling is outside the scope of this document.

There is no flash upgrade required with this in mind. If a
router is not upgraded, the bestpath selection will not
be what is desired (so could be sub-optimal)... and that's 
about it.

- Pradosh

---

From: Gargi Nalawade <[email-masked]>
Date: Thu, 26 Mar 2009 10:28:28 -0700

Hi Pradosh,

As per the quoted text, the draft is requiring of all routers in the network to 
understand the AIGP attribute, right? Which means upgrading the whole 
network to understand this. 

If all routers in the network are not upgraded, then some routers would 
recognize AIGP and do bestpath taking it into account, while others which 
do not, will run bestpath without it and each could point to different bestpaths.
Translating - potential routing loops (not just sub-optimal routing). i.e. Without 
upgrading the whole network.

Thanks,
Gargi

________________________________________
From: Pradosh Mohapatra (pmohapat) [[email-masked]]
Sent: Wednesday, March 25, 2009 6:02 PM
To: Gargi Nalawade; Yakov Rekhter; [email-masked]
Subject: RE: [Idr] draft-rosen-idr-aigp-00.txt as IDR WG document

Hi Gargi,

- Pradosh

---

From: "Pradosh Mohapatra (pmohapat)" <[email-masked]>
Date: Thu, 26 Mar 2009 13:56:19 -0700

| As per the quoted text, the draft is requiring of all routers 
| in the network to understand the AIGP attribute, right? Which 
| means upgrading the whole network to understand this. 
| 
| If all routers in the network are not upgraded, then some 
| routers would recognize AIGP and do bestpath taking it into 
| account, while others which do not, will run bestpath without 
| it and each could point to different bestpaths.
| Translating - potential routing loops (not just sub-optimal 
| routing). i.e. Without upgrading the whole network.

If the network deploys tunneling (e.g. label forwarding), we
will not get into loops (with partly upgraded routers).

- Pradosh

| 
| Thanks,
| Gargi
| 
| ________________________________________
| From: Pradosh Mohapatra (pmohapat) [[email-masked]]
| Sent: Wednesday, March 25, 2009 6:02 PM
| To: Gargi Nalawade; Yakov Rekhter; [email-masked]
| Subject: RE: [Idr] draft-rosen-idr-aigp-00.txt as IDR WG document
| 
| Hi Gargi,
| 
| | The draft should be updated to specify procedures for 
| upgrading with 
| | this extension, before being considered for a WG doc, IMHO.
| |
| | In its current form, it requires a flash upgrade of the network to 
| | ensure that there are no routing loops, as Enke also pointed out.
| 
| No, it doesn't. Section 3.1 of the document talks about the
| applicability:
| 
|    This document only considers the use of the AIGP attribute in
|    networks where each router uses tunneling of some sort to deliver a
|    packet to its BGP next hop.  Use of the AIGP attribute in networks
|    that do not use tunneling is outside the scope of this document.
| 
| There is no flash upgrade required with this in mind. If a 
| router is not upgraded, the bestpath selection will not be 
| what is desired (so could be sub-optimal)... and that's about it.
| 
| - Pradosh
|

---

From: "UTTARO, JAMES, ATTLABS" <[email-masked]>
Date: Fri, 27 Mar 2009 22:44:38 -0400

The notion is that we are trying to perform a best path selection that
is consistent across Multiple AS/IGP domains.. If two or more AS domains
and some subset of speakers "agree" to use the AIGP metric then there is
an implicit agreement that they will all honor each others IGP Cost
methodology and accumulate a metric that is consistent. If we placed
AIGP below LP or AS-PATH etc... it would imply tha an AS can a local
decision regardless of the information from upstream AS domains ( AIGP
metric ). I just want to be clear that AIGP is for a set of AS domains
that are all under a common ISP or administrative authority.. AIGP is
not appropriate between AS domains under different administrative
control..

Jim Uttaro

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
john heasley
Sent: Wednesday, March 25, 2009 6:59 PM
To: Yakov Rekhter; [email-masked]
Subject: Re: [Idr] draft-rosen-idr-aigp-00.txt as IDR WG document