Subject: [Idr] draft-chen-bgp-ext-opt-param as an IDR WG document

From: "John G. Scudder" <[email-masked]>
Date: Tue, 29 Sep 2009 09:39:39 -0400

Folks,

We have received a request to adopt draft-chen-bgp-ext-opt-param as an  
IDR working group document.  Please send comments to the list.  The  
deadline for comments is October 14, 2009.

--John

Begin forwarded message:

> From: Enke Chen <[email-masked]>
> Date: August 14, 2009 12:51:50 PM EDT
> To: Sue Hares <[email-masked]>, John Scudder <[email-masked]>
> Cc: "Enke Chen (enkechen)" <[email-masked]>, Inter-Domain  
> Routing List <[email-masked]>
> Subject: draft-chen-bgp-ext-opt-param-01.txt
>
> Hi, Sue and John:
>
> I would like to request that draft-chen-bgp-ext-opt-param-01.txt be
> adopted as an IDR WG document.
>
> The draft was presented at the last IETF.
>
> Thanks.   -- Enke
>
> -------- Original Message --------
> Subject: 	I-D Action:draft-chen-bgp-ext-opt-param-01.txt
> Date: 	Thu, 25 Jun 2009 09:15:04 -0700 (PDT)
> From: 	[email-masked]
> Reply-To: 	[email-masked]
> To: 	[email-masked]
>
>
>
> A New Internet-Draft is available from the on-line Internet-Drafts  
> directories.
>
> 	Title           : Extended Optional Parameters Length for BGP OPEN  
> Message
> 	Author(s)       : E. Chen, J. Scudder
> 	Filename        : draft-chen-bgp-ext-opt-param-01.txt
> 	Pages           : 5
> 	Date            : 2009-06-25
>
> The Optional Parameters in the BGP OPEN message as defined in the
> base BGP specification are limited to 255 octets due to a one-octet
> length field.  BGP Capabilities are carried in this field and may
> foreseeably exceed 255 octets in the future, leading to concern about
> this limitation.
>
> In this document we extend the BGP OPEN length field in a backward-
> compatible manner.  The Parameter Length field of individual Optional
> Parameters is similarly extended.
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-chen-bgp-ext-opt- 
> param-01.txt
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
>
>
>

---

From: Enke Chen <[email-masked]>
Date: Tue, 29 Sep 2009 14:53:56 -0700

BTW, the draft was presented at the last IETF, and the presentation is 
available online:

     http://www.ietf.org/proceedings/75/slides/idr-2.pdf

-- Enke

John G. Scudder wrote:
>> Cc: "Enke Chen (enkechen)" <[email-masked]>, Inter-Domain Routing 
>> List <[email-masked]>
>>     Title           : Extended Optional Parameters Length for BGP 
>> OPEN Message
>> http://www.ietf.org/internet-drafts/draft-chen-bgp-ext-opt-param-01.txt
>>
> ------------------------------------------------------------------------
>
>
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr