Subject: [Idr] SNMP bgpPeerTable IPV6

From: Stefano Gargiulo <[email-masked]>
Date: Wed, 28 Jul 2010 20:39:21 +0200

Hi, i'm sorry if this is not the right place to ask this, but i'm tring:

Is there some proposal pending for implementing a *standard* bgp4 MIB 
with full support for Ipv6?

Time is coming: in 2011/12 ipv4 will end all allocable space as you know.

But my question is more pratical:
How to monitoring ipv6 bgp peers? anyone does that now? how?

I need to start from now, so i hope that a standard will come up soon... 
but for now i ask are there enterprise MIBs to do that on Juniper and 
Cisco routers? anyone knows the root OIDs?

Thank you in advance,
Best regards,
Stefano.

---

From: Kalpesh Zinjuwadia <[email-masked]>
Date: Wed, 28 Jul 2010 12:27:18 -0700

There is an ID for BGP4 MIBv2 which supports IPv6 AF (IPv6 peers, NLRIs, etc). Not a public MIB yet. Check the vendor's MIB specs to find out if it's supported and the enterprise-specific root OID.

http://tools.ietf.org/html/draft-ietf-idr-bgp4-mibv2-10

Force10 supports it under FORCE10-BGP4-V2-MIB

Thanks,
Kalpesh

From: [email-masked] [mailto:[email-masked]] On Behalf Of Stefano Gargiulo
Sent: Wednesday, July 28, 2010 11:39 AM
To: [email-masked]; [email-masked]
Subject: [Idr] SNMP bgpPeerTable IPV6

Is there some proposal pending for implementing a standard bgp4 MIB with full support for Ipv6?

I need to start from now, so i hope that a standard will come up soon... but for now i ask are there enterprise MIBs to do that on Juniper and Cisco routers? anyone knows the root OIDs?

Thank you in advance,
Best regards,
Stefano.

---

From: Stefano Gargiulo <[email-masked]>
Date: Thu, 29 Jul 2010 16:24:40 +0200

Thank you so much Kalpesh.

Best regards,
Stefano.

Il 28/07/2010 21:27, Kalpesh Zinjuwadia ha scritto:
>
> There is an ID for BGP4 MIBv2 which supports IPv6 AF (IPv6 peers, 
> NLRIs, etc). Not a public MIB yet. Check the vendor's MIB specs to 
> find out if it's supported and the enterprise-specific root OID.
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf 
> Of *Stefano Gargiulo
> *Sent:* Wednesday, July 28, 2010 11:39 AM
> *To:* [email-masked]; [email-masked]
> *Subject:* [Idr] SNMP bgpPeerTable IPV6
>
> I need to start from now, so i hope that a standard will come up 
> soon... but for now i ask are there enterprise MIBs to do that on 
> Juniper and Cisco routers? anyone knows the root OIDs?
>
> Thank you in advance,
> Best regards,
> Stefano.
>

---

From: Simon Leinen <[email-masked]>
Date: Fri, 30 Jul 2010 14:29:19 +0200

> http://tools.ietf.org/html/draft-ietf-idr-bgp4-mibv2-10

This is an extremely important MIB to get standardized.  As the
original poster had said, how are we operators supposed to monitor
IPv6 BGP peerings without something like this?

The I-D has been active (growing and shrinking) over at least nine
years: draft-ietf-idr-bgp4-mibv2-00 is from July 2001.  Since I cannot
currently follow the IDR WG, I don't know what's holding it up right now.
Maybe just general loss of energy/shifting of priorities, which are
unavoidable over such a long time.  But pushing this towards RFC (at
whatever standards level) would be a very honorable and worthwhile
thing to do.

> Force10 supports it under FORCE10-BGP4-V2-MIB

Thanks, that's great to know.  Force 10 just moved up two notches on
my personal vendor sympathy scale.  Of course your feedback (and that
of users on the operator side, if any) would be very useful for
advancing this in IDR.
-- 
Simon.

---

From: [email-masked]
Date: Sat, 31 Jul 2010 01:29:46 -0400

On (07/30/10 14:29), Simon Leinen wrote:
> To: Kalpesh Zinjuwadia <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
> From: Simon Leinen <[email-masked]>
> Date: Fri, 30 Jul 2010 14:29:19 +0200
> Subject: Re: [Idr] [IETFMIBS]  SNMP bgpPeerTable IPV6
> X-Original-To: [email-masked]
> Delivered-To: [email-masked]
> X-Virus-Scanned: amavisd-new at amsl.com
> X-Spam-Flag: NO
> X-Spam-Level: 
> X-Spam-Status: No, score=-2.6 tagged_above=-999 required=5
> 	tests=[BAYES_00=-2.599, NO_RELAYS=-0.001]
> In-Reply-To:
> 	<[email-masked]>
> X-Mailer: VM 8.1.0-devo-614 under 23.2.1 (x86_64-apple-darwin10.3.0)
> X-SWITCH-SCANNER: bypassed
> X-Mailman-Approved-At: Fri, 30 Jul 2010 09:54:52 -0700
> X-BeenThere: [email-masked]
> X-Mailman-Version: 2.1.9
> Precedence: list
> List-Id: Inter-Domain Routing <idr.ietf.org>
> List-Unsubscribe: <https://www.ietf.org/mailman/listinfo/idr>,
> 	<mailto:[email-masked]?subject=unsubscribe>
> List-Archive: <http://www.ietf.org/mail-archive/web/idr>
> List-Post: <mailto:[email-masked]>
> List-Help: <mailto:[email-masked]?subject=help>
> List-Subscribe: <https://www.ietf.org/mailman/listinfo/idr>,
> 	<mailto:[email-masked]?subject=subscribe>
> Errors-To: [email-masked]
> X-CT-RefId: str=0001.0A090203.4C5303FF.0171:SCFSTAT11644009,ss=1,fgs=0
> X-Source-IP: acsinet11.oracle.com [141.146.126.233]
> X-Auth-Type: Internal IP
> 
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr