Subject: [Idr] draft-uttaro-idr-add-paths-guidelines-02

From: Pierre Francois <[email-masked]>
Date: Mon, 26 Jul 2010 10:43:16 +0200

Hi,

For those who are impatient to read the latest version of the 
add-paths-guidelines draft, and couldn't find it :

http://inl.info.ucl.ac.be/system/files/draft-uttaro-idr-add-paths-guidelines-02.txt

Regards,

Pierre.

---

From: Uli Bornhauser <[email-masked]>
Date: Thu, 29 Jul 2010 16:05:11 +0200

Hi Pierre, all,

as we discussed yesterday, my thoughts and remarks with respect to the draft version:

In section 4.2, the authors mention that receiving multiple paths improves convergence (cf. MED/IGP oscillation section) and Expressiveness (cf. Path optimality section). At this point, you could also mention that path diversity generally improves the consistency. As far as I see, this pro-argument is not covered by the remarks.

With respect to the Path Selection Modes, cf. section 4.3.1: After reading the draft, it seems reasonable to say that the mode described in section 4.3.1.5,

"Advertising Neighbor-AS Group Best Path", is a natural generalization of the common best path advertisement to all neighbor-AS groups.

From my point of view, exchanging best external paths between domains as described in [1] is also a very interesting concept. As this document is a work group draft, I assume that I am not the only one who things so. Similar to the scheme described in section 4.3.1.5., from my point of view, it seems reasonable to generalize the concept of advertising best external paths to all neighbor-AS groups. I.e., I think an interesting path selection mode could be 

"Advertising Neighbor-AS Group Best External Path". Analogously to 4.3.1.5, this could be understood as a generalization of the best external path advertisement scheme [1] to all neighbor-AS groups. According to the draft, the basic idea is simple. Using this scheme, "a speaker"

- advertises its best domain external path for each neighbor-AS group into the own domain, and
- advertises its best domain internal path for each neighbor-AS group to the external domains.

As thoroughly described in [1], a domain can be a Route Reflection cluster (in this case "the speaker" is a RR) or the AS (in that case "the speaker" is an ASBR). This concept would combine the advantages of advertising best external paths and the availability of group best paths. Comments to this idea are of course welcome. I something did not become clear, feel free to ask.

All in all, I think that besides the one scheme I mentioned, the draft covers all important and interesting modes that can be to applied upon add-path. So far, a very good and substantial work.

Best Regards

Uli

[1] http://tools.ietf.org/id/draft-ietf-idr-best-external-01.txt

Am 26.07.2010 um 10:43 schrieb Pierre Francois:

> 
> 
> Hi,
> 
> For those who are impatient to read the latest version of the add-paths-guidelines draft, and couldn't find it :
> 
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr

-- 
_______________________________________________________
ULI BORNHAUSER
University of Bonn - Institute of Computer Science IV
c/o Bonn-Aachen International Center for Information Technology B-IT 
Dahlmannstr. 2 - D-53113 Bonn - Germany

Web: www.cs.bonn.edu/IV/ub
Email: [email-masked]			
Phone: +49 (228) 2699-154
Fax: +49 (228) 73 - 4571