Subject: Re: [Idr] Fwd: I-D Action:draft-keyur-bgp-enhanced-route-refresh-00.txt

From: Paul Jakma <[email-masked]>
Date: Thu, 25 Nov 2010 12:51:34 +0000 (GMT)

Hi,

On Wed, 6 Oct 2010, Enke Chen wrote:

> FYI.  Will appreciate comments.

Re the intended working of this mechanism, might it be an idea to 
cover the question of overlapping Start/Ends?

E.g. either explicitly ban overlaps (easiest probably) and state that 
first End means all previously signalled starts are finished; or else 
add a generation number to the start and end markers to allow 
overlaps to be detected?

Otherwise, imagine:

A			B
Start
.
.
Start
.
.
.
End			<start purge process>
.
.
.
End

Could result in routes being purged that shouldn't be.

regards,
-- 
Paul Jakma	[email-masked]	@pjakma	Key ID: 64A2FF6A
Fortune:
If the thunder don't get you, then the lightning will.

---

From: Jakob Heitz <[email-masked]>
Date: Thu, 25 Nov 2010 11:59:02 -0500

A second start will immediately abort the first one. That means do all your stale marking again. I thought this was discussed.

--
Jakob Heitz.

On Nov 25, 2010, at 4:52 AM, "Paul Jakma" <[email-masked]> wrote:

> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr

---

From: Enke Chen <[email-masked]>
Date: Thu, 25 Nov 2010 09:53:36 -0800

Yes, that is correct.  Renwei brought up the question at the meeting.   
Will clarify in the next revision.

Thanks.     -- Enke

On 11/25/10 8:59 AM, Jakob Heitz wrote:
> On Nov 25, 2010, at 4:52 AM, "Paul Jakma"<[email-masked]>  wrote:
>
>    
>> Hi,
>>
>> End<start purge process>