Subject: [Idr] Path Attribute Type Code 0

From: Claudio Jeker <[email-masked]>
Date: Tue, 30 Nov 2010 15:36:07 +0100

Hi,

It seems that neither RFC4271 nor IANA specifies what a Path Attribute
Type Code of 0 is and therefore it is not clear what the behaviour should
be when receiving an update with such an attribute.
What are other implementations doing when an attribute with type 0 is
encountered? Should it be treated like any other optional attribute?
Should the transitive bit be respected?
Can we update the list at IANA to include 0 so that all possible values
are covered?

regards
-- 
:wq Claudio

---

From: Pradosh Mohapatra <[email-masked]>
Date: Tue, 30 Nov 2010 08:27:46 -0800

> Should the transitive bit be respected?

parse the attribute flags and treat it as any other unknown attribute...

- Pradosh

> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr

---

From: Tony Li <[email-masked]>
Date: Tue, 30 Nov 2010 20:00:29 +0100

Agreed.  Furthermore, type code 0 should be reserved for future use in the registry.

Tony