Subject: [Idr] FW: I-D Action: draft-ge-e164e214-bgp-00.txt

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 10 Aug 2012 12:29:46 +0100

Heads up!

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> On Behalf Of [email-masked]
> Sent: 10 August 2012 08:42
> To: [email-masked]
> Subject: I-D Action: draft-ge-e164e214-bgp-00.txt
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts
directories.
> 
> 
> 	Title           : E.164/214 number BGP routing annoucement
> 	Author(s)       : Shu Ge
> 	Filename        : draft-ge-e164e214-bgp-00.txt
> 	Pages           : 12
> 	Date            : 2012-08-10
> 
> Abstract:
>    Recently, transferring the signaling of mobile network over IP
>    attracts lots of attention from people.  Telephone number based on
>    E.164 or E.214 or SP is the traditional routing address for mobile
>    network, but actually, E.164, E.214 and SP is not supported by MP-BGP
>    protocol.
> 
>    This document presents a new way to support for routing the phone
>    number based on E.164, E.214 or SP though MP-BGP, by extending the
>    MP-BGP for the Phone Number Routing.  It can bring optimizing for the
>    network architecture and improving efficiency.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ge-e164e214-bgp
> 
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-ge-e164e214-bgp-00
> 
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Robert Raszuk <[email-masked]>
Date: Fri, 10 Aug 2012 13:56:36 +0200

Hello Shu,

I have read your draft with interest ! I have three perhaps very basic 
questions ....

--

* What is the use of RD in the NLRI encoding for your application ?

Isn't it the case that both    4) Routing information of different 
traffic based on phone number is
    stored in the routing table of different VPNs. and E.214 already 
provide unique numbering scheme globally ?

Draft says:

    4) Routing information of different traffic based on phone number is
    stored in the routing table of different VPNs.

Could you elaborate more on those different VPNs ? What values in your 
draft are responsible for determining VPN membership of the prefix ? 
Also what "routing information" are you referring to ?

--

* Can you a bit more elaborate on the intersection of this proposal on 
traditional IPv4 and IPv6 Internet routing ?

Your figure 1 illustrates "the routing procedure of mobile network 
combined with IP network".

Which network elements you envision to act as common combined points ?

--

* Is "SP number" an AS number ? If so why do you need to carry it in 
type 3 of the NLRI if it is already carried in the AS_PATH ?

Many thx,
R.

> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr
>
>