Subject: [Idr] draft-ge-e164e214-bgp vs. TRIP

From: <[email-masked]>
Date: Fri, 10 Aug 2012 14:16:02 +0200

Dear Shu,

I read your draft.

Did you considered the use of TRIP (http://tools.ietf.org/html/rfc3219)? Wouldn't TRIP meet your needs?

Thanks.

Cheers,
Med

---

From: <[email-masked]>
Date: Mon, 13 Aug 2012 08:20:37 +0200

Re-,

Which complex method? There is only a code point to assign.

FWIW, below an excerpt from rfc3219:

   Application Protocol:
   The application protocol gives the protocol for which this routing
   table is maintained.  The currently defined application protocols
   are:

            Code              Protocol
            1                 SIP
            2                 H.323-H.225.0-Q.931
            3                 H.323-H.225.0-RAS
            4                 H.323-H.225.0-Annex-G

   This document reserves application protocol code 0.  This document
   reserves application protocol codes 32768-65535 for vendor-specific
   applications (these are the codes with the first bit of the code
   value equal to 1).  Additional application protocols may be defined
   in the future.  Assignment of application protocol codes is
   controlled by IANA.  See Section 13<http://tools.ietf.org/html/rfc3219#section-13> for IANA considerations.

Cheers,
Med

________________________________
De : 葛澍 [mailto:[email-masked]]
Envoyé : dimanche 12 août 2012 08:48
À : BOUCADAIR Mohamed OLNC/NAD/TIP
Cc : [email-masked]
Objet : Re: draft-ge-e164e214-bgp vs. TRIP

[email-masked] ，您好！
       Trip use a complex method to differ the different application,such as MMS,Email.This draft use the MP-BGP's VPN solve the problem,it's very easy.

2012-08-12
________________________________
　　　　　　　　致
礼！

葛澍
副经理
中国移动通信集团公司网络部监控处
地址:北京市西城区复兴门金融街29号  邮编: 10033
移动电话：13911789707
办公电话：010-52686688-1734
公司邮箱：[email-masked]<mailto:[email-masked]>
________________________________
发件人： [email-masked]
发送时间： 2012-08-10  20:16:27
收件人： [email-masked]
抄送： [email-masked]
主题： draft-ge-e164e214-bgp vs. TRIP
Dear Shu,

I read your draft.

Thanks.

Cheers,
Med

---

From: <[email-masked]>
Date: Mon, 13 Aug 2012 08:31:56 +0200

Re-,

There is no change for TRIP at all.

The protocol allows to define new codes for new applications if there is a need. It does also allow to define new AFs than the ones already supported.

Cheers,
Med

________________________________
De : 葛澍 [mailto:[email-masked]]
Envoyé : lundi 13 août 2012 08:27
À : BOUCADAIR Mohamed OLNC/NAD/TIP
Cc : [email-masked]
Objet : Re: RE: draft-ge-e164e214-bgp vs. TRIP

[email-masked] ，您好！
      if add a new application ,The TRIP should change,such as MMS,EMAIl,SMS.It's not very convenient.

2012-08-13

葛澍
副经理
中国移动通信集团公司网络部监控处
地址:北京市西城区复兴门金融街29号  邮编: 10033
移动电话：13911789707
办公电话：010-52686688-1734
公司邮箱：[email-masked]<mailto:[email-masked]>
________________________________
发件人： [email-masked]
发送时间： 2012-08-13  14:21:00
收件人： 葛澍
抄送： [email-masked]
主题： RE: draft-ge-e164e214-bgp vs. TRIP
Re-,

   Application Protocol:

            Code              Protocol
            1                 SIP
            2                 H.323-H.225.0-Q.931
            3                 H.323-H.225.0-RAS
            4                 H.323-H.225.0-Annex-G

Cheers,
Med

2012-08-12

葛澍
副经理
中国移动通信集团公司网络部监控处

I read your draft.

Thanks.

Cheers,
Med

---

From: <[email-masked]>
Date: Mon, 13 Aug 2012 08:42:38 +0200

Re-,

Using BGP to advert e.164 has been considered in the past but there was a decision to define a new protocol instead of using BGP: see http://tools.ietf.org/html/rfc2871#section-5 .

I'm not aware of TRIP deployment but I know the concept of ITAD (IP Telephony Administrative Domain) used in TRIP is widely use: see IANA records http://www.iana.org/assignments/trip-parameters/trip-parameters.xml

Cheers,
Med

________________________________
De : 葛澍 [mailto:[email-masked]]
Envoyé : lundi 13 août 2012 08:36
À : BOUCADAIR Mohamed OLNC/NAD/TIP
Cc : [email-masked]
Objet : Re: RE: RE: draft-ge-e164e214-bgp vs. TRIP

[email-masked] ，您好！
     If something use the MP-BGP can do ,why should we invent a new protocol,such as TRIP to solve? Who use TRIP now？
2012-08-13
________________________________
　　　　　　　　致
礼！

葛澍
副经理
中国移动通信集团公司网络部监控处
地址:北京市西城区复兴门金融街29号  邮编: 10033
移动电话：13911789707
办公电话：010-52686688-1734
公司邮箱：[email-masked]<mailto:[email-masked]>
________________________________
发件人： [email-masked]
发送时间： 2012-08-13  14:32:20
收件人： 葛澍
抄送： [email-masked]
主题： RE: RE: draft-ge-e164e214-bgp vs. TRIP
Re-,

Cheers,
Med

2012-08-13

葛澍
副经理
中国移动通信集团公司网络部监控处

   Application Protocol:

            Code              Protocol
            1                 SIP
            2                 H.323-H.225.0-Q.931
            3                 H.323-H.225.0-RAS
            4                 H.323-H.225.0-Annex-G

Cheers,
Med

2012-08-12

葛澍
副经理
中国移动通信集团公司网络部监控处

I read your draft.

Thanks.

Cheers,
Med

---

From: <[email-masked]>
Date: Mon, 13 Aug 2012 09:35:46 +0200

Re-,

Could you please precise how MP-BGP mitigates the points listed in http://tools.ietf.org/html/rfc2871#section-5?

Cheers,
Med

________________________________
De : 葛澍 [mailto:[email-masked]]
Envoyé : lundi 13 août 2012 09:07
À : BOUCADAIR Mohamed OLNC/NAD/TIP
Cc : [email-masked]
Objet : Re: RE: RE: RE: draft-ge-e164e214-bgp vs. TRIP

[email-masked] ，您好！
     Thank you very much to supply so much knowledge about TRIP for me.I knew a little about TRIP previously.The time when TRIP is proposed in 2002,In that day,Multi protocol BGP is not be considered.Furthermore use BGP advert e.164 is difficult.But I think that today use MP-BGP advert e.164 is very easy and convient,It's only change the MP-BGP very small. So I think that it is valuable to do this draft.

Thanks

2012-08-13

葛澍
副经理
中国移动通信集团公司网络部监控处
地址:北京市西城区复兴门金融街29号  邮编: 10033
移动电话：13911789707
办公电话：010-52686688-1734
公司邮箱：[email-masked]<mailto:[email-masked]>
________________________________
发件人： [email-masked]
发送时间： 2012-08-13  14:43:02
收件人： 葛澍
抄送： [email-masked]
主题： RE: RE: RE: draft-ge-e164e214-bgp vs. TRIP
Re-,

Cheers,
Med

葛澍
副经理
中国移动通信集团公司网络部监控处

Cheers,
Med

2012-08-13

葛澍
副经理
中国移动通信集团公司网络部监控处

   Application Protocol:

            Code              Protocol
            1                 SIP
            2                 H.323-H.225.0-Q.931
            3                 H.323-H.225.0-RAS
            4                 H.323-H.225.0-Annex-G

Cheers,
Med

2012-08-12

葛澍
副经理
中国移动通信集团公司网络部监控处

I read your draft.

Thanks.

Cheers,
Med