Subject: Re: [Idr] draft-ietf-idr-aigp-11.txt

From: <[email-masked]>
Date: Mon, 2 Dec 2013 15:01:10 +0000

Eric,

Thank you for the updated draft.

Version 10 of the draft had:

> 5. Deployment Considerations
> 
>   Using the AIGP attribute to achieve a desired routing policy will be
>   more effective if each BGP speaker can use it to choose from among
>   multiple routes. Thus is it highly recommended that the procedures of
>   [BESTEXT] and [ADDPATH] be used in conjunction with the AIGP
>   Attribute.

In v11, you replaced [ADDPATH] by [CONN-REST]. Could you please elaborate on the reason? (A priori, I find [ADDPATH] more applicable than [CONN-REST]).

Thank you,
Regards,
Bruno

>-----Original Message-----
>From: Idr [mailto:[email-masked]] On Behalf Of Eric Rosen
>Sent: Thursday, November 21, 2013 4:44 PM
>To: [email-masked]
>Subject: [Idr] draft-ietf-idr-aigp-11.txt
>
>I have revised this draft per the WG Last Call comments:
>
>- Error handling for a malformed AIGP attribute is "discard attribute".
>
>- An AIGP attribute with the transitive bit set is regarded to be malformed,
>  and is to be discarded.
>
>- Stated explicitly that the AIGP value used in bestpath computations is the
>  value of the first AIGP TLV in the attribute.
>
>- The requirement to default "AIGP_SESSION" to "enabled" on IBGP sessions
>  has been demoted from "MUST" to "SHOULD".  This reflect the fact that
>  there is some controversy about it, but no real consensus to default it to
>  "disabled".
>
>- Stated that the AIGP value is capped at its maximum (unsigned) value,
>  i.e., it should not wrap around due to addition.
>
>  Also stated that if an AIGP attribute is received and its value is already
>  the maximum, the attribute should be treated as malformed.  (It's not
>  really useful if you can't add to it.)
>
>I would like to thank those of you who commented during the last call, and
>would welcome comments on the changes.
>
>
>
>
>_______________________________________________
>Idr mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/idr

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Eric Rosen <[email-masked]>
Date: Mon, 02 Dec 2013 10:40:53 -0500

> In v11, you replaced [ADDPATH] by [CONN-REST]. Could you please elaborate
> on the reason?

The internet-draft that is being referenced remains the same:
draft-pmohapat-idr-fast-conn-restore-03.txt, but I changed the reference tag
from "addpath" to "conn-rest" because you said that "addpath" is a
misleading "name" for that draft.

---

From: <[email-masked]>
Date: Mon, 2 Dec 2013 16:07:21 +0000

>misleading "name" for that draft.

OK, thank you.
The technical question remains: 
- I understand why ADD PATH would be useful, while it is not cited in the text.
- I'm not sure to understand why conn-rest is useful.

Thank you,
Bruno

---

From: Robert Raszuk <[email-masked]>
Date: Mon, 2 Dec 2013 17:59:47 +0100

Hi Bruno,

I think the idea is that AIGP attribute when present can be used instead of
EDGE DISCRIMINATOR ATTRIBUTE which [CONN-REST] specifies.

Best,
R.

On Mon, Dec 2, 2013 at 5:07 PM, <[email-masked]> wrote:

> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
> recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> This message and its attachments may contain confidential or privileged
> information that may be protected by law;

---

From: Eric Rosen <[email-masked]>
Date: Mon, 02 Dec 2013 13:14:38 -0500

> - I'm not sure to understand why conn-rest is useful.

For context, here's the paragraph in question:

   Using the AIGP attribute to achieve a desired routing policy will be
   more effective if each BGP speaker can use it to choose from among
   multiple routes. Thus is it highly recommended that the procedures of
   [BESTEXT] and [CONN-REST] be used in conjunction with the AIGP
   Attribute.

The two references talk about conditions under which a path or paths other
than (or in addition to) the bestpath should be announced.  The add-path
draft itself really only provides a mechanism for distributing multiple
paths.  So it seemed like a less informative reference.

However, if the reference to conn-rest raises issues or leaves open
questions, it might be best to replace it with a reference to add-path.  I
certainly don't want to deal in this draft with issues like the one Robert
mentioned, of whether AIGP can be used in place of Edge_Discriminator.

---

From: <[email-masked]>
Date: Thu, 5 Dec 2013 16:39:46 +0000

Eric,

Thanks for the updated version of the draft.
More inline.

>paths.  So it seemed like a less informative reference.

Thanks for the clarification. Agreed.
And for clarification, my point was that fast-conn-restore seemed to target more the "fast restoration" application of add path than the "optimal routing" application. (and to some extent, this may also be true for BESTEXT)
As you wish, you may also cite draft-ietf-idr-add-paths-guidelines and possibly the add path mode(s) that you would recommend for AIGP. (e.g. AS-wide best path).

Best regards,
Bruno