Subject: [Idr] 答复: draft-wu-idr-te-pm-bgp-03

From: Xuxiaohu <[email-masked]>
Date: Fri, 3 Jan 2014 03:44:51 +0000

Support.

Xiaohu

发件人: Idr [mailto:[email-masked]] 代表 Susan Hares
发送时间: 2013年12月24日 1:09
收件人: idr wg
抄送: [email-masked]
主题: [Idr] draft-wu-idr-te-pm-bgp-03

idr people

This is to start a WG adoption call for this draft. It will end on 1/6/13.

http://datatracker.ietf.org/doc/draft-wu-idr-te-pm-bgp/

BGP attribute for North-Bound Distribution of Traffic Engineering (TE) performance Metrics

Two implementations in progress so feedback on this draft is also welcomed by the authors.

Sue and John

---

From: Dhruv Dhody <[email-masked]>
Date: Fri, 3 Jan 2014 17:45:18 +0530

Support!

Regards,
Dhruv

On Mon, Dec 23, 2013 at 10:38 PM, Susan Hares <[email-masked]> wrote:

> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr
>
>

---

From: John E Drake <[email-masked]>
Date: Fri, 3 Jan 2014 14:53:20 +0000

Support

Yours Irrespectively,

John

From: Idr [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Monday, December 23, 2013 9:09 AM
To: idr wg
Cc: [email-masked]
Subject: [Idr] draft-wu-idr-te-pm-bgp-03

idr people

Sue and John

---

From: Samita Chakrabarti <[email-masked]>
Date: Fri, 3 Jan 2014 22:32:20 +0000

I am supportive of this document.

Here are my comments on the draft for clarification and improvement:

1.       Clarify how the performance data are originated.  A clarification on the assumption that BGP receives the link-state performance descriptors via another BGP speaker or an IGP-TE implementation or a pointer to the section on BGP-LS (figure-1?) would be helpful.

2.       Is this information (PM data) dynamically collected ? Averaged over a period of time?  Does the TLV format  require additional information than just the PM value in some cases? [ for example, unidirectional delay: should it include  an accuracy factor or  observation period?] Not clear how often this information  is updated?

3.       Section 4 of this document says: "These TLVs

include a bit called the Anomalous (or "A") bit at the left-most bit  after length field of each TLV."  -- Where is this defined in the diagram? A reference will be helpful.

Thanks,

-Samita

From: Idr [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Monday, December 23, 2013 5:39 PM
To: Susan Hares; idr wg
Cc: [email-masked]
Subject: Re: [Idr] draft-wu-idr-te-pm-bgp-03

Support as coauthor.
We plan to implement it after it gets adoption.

Regards!
-Qin
From: Susan Hares [mailto:[email-masked]]
Sent: Tuesday, December 24, 2013 1:09 AM
To: idr wg
Cc: [email-masked]<mailto:[email-masked]>; Qin Wu
Subject: draft-wu-idr-te-pm-bgp-03

idr people

Sue and John

---

From: Wangdanhua <[email-masked]>
Date: Wed, 25 Dec 2013 07:19:43 +0000

Support as coauthor.

发件人: Susan Hares [mailto:[email-masked]]
发送时间: 2013年12月24日 1:09
收件人: idr wg
抄送: [email-masked]; Qin Wu
主题: draft-wu-idr-te-pm-bgp-03

idr people

Sue and John

---

From: Qin Wu <[email-masked]>
Date: Mon, 6 Jan 2014 04:15:58 +0000

Hi, Samita:
Thanks for your comments.
See my reply inline below.

Regards!
-Qin

From: Samita Chakrabarti [mailto:[email-masked]]
Sent: Saturday, January 04, 2014 6:32 AM
To: Qin Wu; Susan Hares; idr wg
Cc: [email-masked]
Subject: RE: draft-wu-idr-te-pm-bgp-03

1.       Clarify how the performance data are originated.  A clarification on the assumption that BGP receives the link-state performance descriptors via another BGP speaker or an IGP-TE implementation or a pointer to the section on BGP-LS (figure-1?) would be helpful.
[Qin]: Good comment, I propose to add one sentence at the end of introduction section as follows:
"
The network performance information can be distributed in the same way as link state information
distribution, i.e., either directly or via a peer BGP speaker (see figure 1 of
[I.D-ietf-idr-ls-distribution]).

"

[Qin]: Yes, the information is dynamic collected. It is obtained by a filter that is reasonably
representative of an average or calculated as rolling averages where the averaging period MUST
be a configurable period of time. The measurement interval or re-advertisement interval are
pre-provisioned and can be defined in the same way as one for ISIS-TE-Metric-extension draft.
So I propose the following change in section 4:
OLD TEXT:
"
   Consistent with existing ISIS TE specifications [ISIS-TE-METRIC], the
   bandwidth advertisements,the delay and delay variation
   advertisements, packetloss defined in this document MUST be encoded
   in the same unit as one defined in IS-IS Extended IS Reachability
   sub-TLVs [ISIS-TE-METRIC].  All values (except residual bandwidth)
   MUST be calculated as rolling averages where the averaging period
   MUST be a configurable period of time.

"
NEW TEXT:
"
   Consistent with existing ISIS TE specifications [ISIS-TE-METRIC], the
   bandwidth advertisements, the delay and delay variation
   advertisements, packet loss defined in this document MUST be encoded
   in the same unit as one defined in IS-IS Extended IS Reachability
   sub-TLVs [ISIS-TE-METRIC].  All values (except residual bandwidth)
   MUST be obtained by a filter that is reasonably representative of
   an average or calculated as rolling averages where the averaging period
   MUST be a configurable period of time.   The measurement interval,
   any filter coefficients, and any advertisement intervals MUST be
   configurable per sub-TLV in the same way as ones defined in
   section 5 of [ISIS-TE-METRIC].

"

[Qin]: Good point. I propose the following change in section 4 as follows:
OLD TEXT:
"
These TLVs include a bit called the Anomalous (or "A") bit at the left-most bit
after length field of each TLV.
"
NEW TEXT:
"
These TLVs include a bit called the Anomalous (or "A") bit at the left-most bit
after length field of each TLV defined in figure 4 of [[I.D-ietf-idr-ls-distribution]].
"

Thanks,

-Samita

Support as coauthor.

Regards!
-Qin

idr people

Sue and John

---

From: Martin Horneffer <[email-masked]>
Date: Tue, 07 Jan 2014 10:28:55 +0100

Support.

Best regards,
Martin Horneffer

> Two implementations in progress so feedback on this draft is also 

##############################################
# Mail Account for technical purposes only
##############################################

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 8 Jan 2014 20:59:12 -0500

This draft has been accepted as a IDR draft.  Please submit it as

draft-ietf-idr-te-pm-bgp 

Sue Hares and John Scudder

From: Idr [mailto:[email-masked]] On Behalf Of Martin Horneffer
Sent: Tuesday, January 07, 2014 4:29 AM
To: [email-masked]
Subject: Re: [Idr] draft-wu-idr-te-pm-bgp-03

idr people 

BGP attribute for North-Bound Distribution of Traffic Engineering (TE)
performance Metrics