Subject: [Idr] Question from session on draft-xli-idr-mpls-path-programming

From: Lou Berger <[email-masked]>
Date: Tue, 22 Jul 2014 11:13:14 -0400

Hi,
    Since we weren't able to close this in the session, I thought I'd
ask my question here.  The question was simply what is supposed to
happen (from a service model perspective) when requested tunnel setup,
or for that matter, any other type of 'path programming' fails?

The  text in the draft that caught my eye is:

      This document defines the following flags:
          0 1 2 3 4 5 6 7
         +-+-+-+-+-+-+-+-+
         |  reserved   |S|
         +-+-+-+-+-+-+-+-+

        + Unicast Tunnel Setup Required (S)

   If the S flag is not set, the client node is just to map the service
   path to the corresponding tunnel.  If the S flag is set, the client
   node MUST set up the tunnel according to the tunnel identifier and
   the tunnel specific attribute firstly.  Then it maps the service path
   to the corresponding tunnel.

Thanks,
Lou

---

From: Lou Berger <[email-masked]>
Date: Tue, 22 Jul 2014 16:02:49 -0400

I think it would be better to have the S bit out of scope of the
document. There are other mechanisms that cover tunnel initiation and
I'm not sure we need another...

Lou

On 7/22/2014 11:26 AM, Lizhenbin wrote:
> Hi Lou,
> You are right. Sorry for my missing the point. The S flag is designed to be able to trigger transport tunnel setup. The tunnel setup maybe fails. If so, there can be two possible process depending on local policy:
> -- The BGP route will not be active since the specified tunel is UP.
> -- The BGP route can be active using alternative best-effort LSP tunnel existing in the ingress PE.
> There exists similiar policy implementation by multiple vendor. I think it is policy which is out of scope of the document.
>
> Thanks & Regards,
> Robin
>
>
>
>
>
> ________________________________________
> 发件人: Lou Berger [[email-masked]]
> 发送时间: 2014年7月22日 23:13
> 收件人: [email-masked]
> 抄送: [email-masked]
> 主题: Question from session on draft-xli-idr-mpls-path-programming
>
> Hi,

---

From: Lizhenbin <[email-masked]>
Date: Tue, 22 Jul 2014 15:26:50 +0000

Hi Lou,

Thanks & Regards,
Robin

Hi,

Thanks,
Lou

---

From: Lizhenbin <[email-masked]>
Date: Wed, 23 Jul 2014 17:12:43 +0000

Hi Lou,
We will re-check the S bit design carefully according to your suggestion.

Thanks,
Robin

________________________________________
发件人: Lou Berger [[email-masked]]
发送时间: 2014年7月23日 4:02
收件人: Lizhenbin; [email-masked]
抄送: [email-masked]
主题: Re: 答复: Question from session on draft-xli-idr-mpls-path-programming

Lou