Subject: Re: [Idr] New version of draft-wang-idr-eag-distribution-00

From: Jeff Tantsura <[email-masked]>
Date: Tue, 28 Oct 2014 18:12:28 +0000

Hi Eric,

Agree, should be treated same way as AG and included in bgp-ls,
Extended Administrative Group with TLV code point 1099

Cheers,
Jeff

From: <Osborne>, Eric <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, October 28, 2014 at 6:48 AM
To: wangzitao <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: Hares Susan <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Idr] New version of draft-wang-idr-eag-distribution-00

I skimmed it and it looks reasonable.  Given that it really just says “use BGP-LS to send EAG just like we already send AG”, why not just fold this content into bgp-ls?  The reason it’s not in bgp-ls already is – I suspect – just a matter of timing between EAG and bgp-ls publication.

eric

From: Idr [mailto:[email-masked]] On Behalf Of wangzitao
Sent: Monday, October 27, 2014 9:04 PM
To: [email-masked]<mailto:[email-masked]>
Cc: Hares Susan
Subject: [Idr] New version of draft-wang-idr-eag-distribution-00

Hi, folks:
We have submitted a new short draft to discuss BGP extension for Extended admin Group
https://tools.ietf.org/html/draft-wang-idr-eag-distribution-00
and requested a timeslot to present it at IETF91.
Please help review and comment on this short draft.
Thanks in advance.

Regards!
-Michael

---

From: Hannes Gredler <[email-masked]>
Date: Thu, 30 Oct 2014 08:30:30 +0100

real question is:

do we want to close BGP-LS base spec and submit it to IESG
or leave it open as an eternal draft ? - IMO EAG is a useful
thing hence vendors will be adding support for this,
but can perfectly live as a standalone document,

/hannes

On Tue, Oct 28, 2014 at 06:12:28PM +0000, Jeff Tantsura wrote:
|    Hi Eric,
|    Agree, should be treated same way as AG and included in bgp-ls,
|    Extended Administrative Group with TLV code point 1099
|    Cheers,
|    Jeff
|    From: <Osborne>, Eric <[1][email-masked]>
|    Date: Tuesday, October 28, 2014 at 6:48 AM
|    To: wangzitao <[2][email-masked]>, "[3][email-masked]"
|    <[4][email-masked]>
|    Cc: Hares Susan <[5][email-masked]>
|    Subject: Re: [Idr] New version of draft-wang-idr-eag-distribution-00
| 
|      I skimmed it and it  looks reasonable.  Given  that it really just  says
|      “use BGP-LS to send EAG just like we already send AG”, why not  just
|      fold this content into bgp-ls?  The reason it’s not in bgp-ls  already
|      is – I  suspect – just  a matter  of timing between  EAG and  bgp-ls
|      publication.
| 
| 
| 
| 
| 
| 
| 
| 
| 
|      eric
| 
| 
| 
|      From: Idr [[6]mailto:[email-masked]] On Behalf Of wangzitao
|      Sent: Monday, October 27, 2014 9:04 PM
|      To: [7][email-masked]
|      Cc: Hares Susan
|      Subject: [Idr] New version of draft-wang-idr-eag-distribution-00
| 
| 
| 
|      Hi, folks:
| 
|      We have  submitted  a new  short  draft  to discuss  BGP  extension  for
|      Extended admin Group
| 
|      [8]https://tools.ietf.org/html/draft-wang-idr-eag-distribution-00
| 
|      and requested a timeslot to present it at IETF91.
| 
|      Please help review and comment on this short draft.
| 
|      Thanks in advance.
| 
| 
| 
|      Regards!
| 
|      -Michael
| 
| References
| 
|    Visible links
|    1. mailto:[email-masked]
|    2. mailto:[email-masked]
|    3. mailto:[email-masked]
|    4. mailto:[email-masked]
|    5. mailto:[email-masked]
|    6. mailto:[email-masked]
|    7. mailto:[email-masked]
|    8. https://tools.ietf.org/html/draft-wang-idr-eag-distribution-00

| _______________________________________________
| Idr mailing list
| [email-masked]
| https://www.ietf.org/mailman/listinfo/idr

---

From: wangzitao <[email-masked]>
Date: Thu, 30 Oct 2014 08:05:20 +0000

Thanks Hannes, Jeff and Eric.
In my opinion, EAG TLV we proposed in draft-wang-idr-eag-distribution is just an optional choice and doesn't need to be mandatory TLV supported by BGP-LS, so taking this draft as standalone document works for us.

Regards!
-Michael
-----邮件原件-----
发件人: Hannes Gredler [mailto:[email-masked]] 
发送时间: 2014年10月30日 15:31
收件人: Jeff Tantsura
抄送: Osborne, Eric; wangzitao; [email-masked]; Hares Susan
主题: Re: [Idr] New version of draft-wang-idr-eag-distribution-00

real question is:

do we want to close BGP-LS base spec and submit it to IESG or leave it open as an eternal draft ? - IMO EAG is a useful thing hence vendors will be adding support for this, but can perfectly live as a standalone document,

/hannes

|    Subject: Re: [Idr] New version of 
| draft-wang-idr-eag-distribution-00

---

From: "Osborne, Eric" <[email-masked]>
Date: Thu, 30 Oct 2014 12:41:01 +0000

I don't see why the draft has to be standalone.  I agree that it would make sense to do that as an add-on to BGP-LS if BGP-LS was already standardized, but it's not (yet).  Keeping sub-TLVs in separate documents seems like it's just doing it for the sake of creating another document.  If that's OK, why not break the bgp-ls draft into 15 separate documents, one for each sub-TLV?

As far as standardizing it, yeah, why not?  It's in several sets of vendor ppt and actual (planned & real) products, and we all know RFCs get made with far less backing.

eric

> -----Original Message-----
> From: wangzitao [mailto:[email-masked]]
> Sent: Thursday, October 30, 2014 4:05 AM
> To: Hannes Gredler; Jeff Tantsura
> Cc: Osborne, Eric; [email-masked]; Hares Susan
> Subject: RE: [Idr] New version of draft-wang-idr-eag-distribution-00
> 
> In my opinion, EAG TLV we proposed in draft-wang-idr-eag-distribution is
> just an optional choice and doesn't need to be mandatory TLV supported by
> BGP-LS, so taking this draft as standalone document works for us.
> 
> Regards!
> -Michael
> -----邮件原件-----
> do we want to close BGP-LS base spec and submit it to IESG or leave it open
> as an eternal draft ? - IMO EAG is a useful thing hence vendors will be adding
> support for this, but can perfectly live as a standalone document,
> 
> /hannes
>

---

From: "Jan Medved (jmedved)" <[email-masked]>
Date: Thu, 30 Oct 2014 18:03:02 +0000

+1 

bgp-ls is in the WG last call, let¹s not restart that clock.

Thanks,
Jan

On 10/30/14, 12:30 AM, "Hannes Gredler" <[email-masked]> wrote:

>|      ³use BGP-LS to send EAG just like we already send AG², why not
>just
>|      fold this content into bgp-ls?  The reason it¹s not in bgp-ls
>already
>|      is  I  suspect  just  a matter  of timing between  EAG and
>bgp-ls
>|      publication.
>| 
>| 
>| 
>| 
>| 
>| 
>| 
>| 
>| 
>|      eric
>| 
>| 
>| 
>_______________________________________________
>Idr mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/idr

---

From: "Bertrand Duvivier (bduvivie)" <[email-masked]>
Date: Thu, 30 Oct 2014 18:18:35 +0000

Agree, 

Best Regards Bertrand Duvivier

-----Original Message-----
From: Idr [mailto:[email-masked]] On Behalf Of Jan Medved (jmedved)
Sent: jeudi 30 octobre 2014 19:03
To: Hannes Gredler; Jeff Tantsura
Cc: [email-masked]; Hares Susan
Subject: Re: [Idr] New version of draft-wang-idr-eag-distribution-00

+1

Thanks,
Jan

On 10/30/14, 12:30 AM, "Hannes Gredler" <[email-masked]> wrote:

>real question is:
>
>do we want to close BGP-LS base spec and submit it to IESG or leave it 
>open as an eternal draft ? - IMO EAG is a useful thing hence vendors 
>will be adding support for this, but can perfectly live as a standalone 
>document,
>
>/hannes
>
>|      I skimmed it and it  looks reasonable.  Given  that it really 
>| just
> says

---

From: Jeff Tantsura <[email-masked]>
Date: Thu, 30 Oct 2014 18:34:27 +0000

Hi Hannes,

Good question!
Since bgp-ls is in the WGLC going thru another iteration would not make
anyone happy.

However instead of spinning yet another draft every time we see a need for
another piece of information in bgp-ls let¹s try to create few,
comprehensive documents, centered around specific technology, as example:

ietf-idr-te-lsp-distribution
ietf-idr-te-pm-bgp 

Cheers,
Jeff

-----Original Message-----
From: "[email-masked]" <[email-masked]>
Date: Thursday, October 30, 2014 at 12:30 AM
To: Jeff Tantsura <[email-masked]>
Cc: "Osborne, Eric" <[email-masked]>, wangzitao
<[email-masked]>, "[email-masked]" <[email-masked]>, Hares Susan
<[email-masked]>
Subject: Re: [Idr] New version of draft-wang-idr-eag-distribution-00

---

From: Qin Wu <[email-masked]>
Date: Fri, 31 Oct 2014 08:25:02 +0000

+1
Let's close the base spec for BGP-LS.

-Qin
-----邮件原件-----
发件人: Idr [mailto:[email-masked]] 代表 Bertrand Duvivier (bduvivie)
发送时间: 2014年10月31日 2:19
收件人: Jan Medved (jmedved); Hannes Gredler; Jeff Tantsura
抄送: [email-masked]; Hares Susan
主题: Re: [Idr] New version of draft-wang-idr-eag-distribution-00

Agree, 

-----Original Message-----
From: Idr [mailto:[email-masked]] On Behalf Of Jan Medved (jmedved)
Sent: jeudi 30 octobre 2014 19:03
To: Hannes Gredler; Jeff Tantsura
Cc: [email-masked]; Hares Susan
Subject: Re: [Idr] New version of draft-wang-idr-eag-distribution-00

+1

Thanks,
Jan