Subject: [Idr] I-D Action: draft-ietf-idr-add-paths-10.txt

From: [email-masked]
Date: Fri, 24 Oct 2014 06:57:42 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Inter-Domain Routing Working Group of the IETF.

        Title           : Advertisement of Multiple Paths in BGP
        Authors         : Daniel Walton
                          Alvaro Retana
                          Enke Chen
                          John Scudder
	Filename        : draft-ietf-idr-add-paths-10.txt
	Pages           : 8
	Date            : 2014-10-24

Abstract:
   In this document we propose a BGP extension that allows the
   advertisement of multiple paths for the same address prefix without
   the new paths implicitly replacing any previous ones.  The essence of
   the extension is that each path is identified by a path identifier in
   addition to the address prefix.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-idr-add-paths/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-idr-add-paths-10

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-idr-add-paths-10

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Jeffrey Haas <[email-masked]>
Date: Fri, 24 Oct 2014 10:18:59 -0400

The update below addressed the major open issue that remained for the
feature, as deployed, to match the spec: The behavior for ebgp has been
moved out of operation and into deployment considerations.

I'm not an author, but I believe this draft is finally read for a hopefully
short Working Group Last Call.

-- Jeff

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 24 Oct 2014 15:01:34 +0000

I just reread it for the first time in a couple years and would agree that
it is ready for WG last call.
Thanks,
Acee

On 10/24/14, 10:18 AM, "Jeffrey Haas" <[email-masked]> wrote:

>_______________________________________________
>Idr mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/idr

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 24 Oct 2014 11:30:47 -0400

Jeff and Acee:

The revision of the add-paths work is good news.  

To WG: 

Will anyone who has knowledge of the implementations of this draft on
add-path please either post the information to the mail-list or send the
information to the John Scudder and myself?  

Sue 

-----Original Message-----
From: Idr [mailto:[email-masked]] On Behalf Of Jeffrey Haas
Sent: Friday, October 24, 2014 10:19 AM
To: [email-masked]
Subject: Re: [Idr] I-D Action: draft-ietf-idr-add-paths-10.txt

-- Jeff

---

From: Jeffrey Haas <[email-masked]>
Date: Fri, 24 Oct 2014 11:35:50 -0400

> information to the John Scudder and myself?  

Juniper has supported add-path for ibgp for years.  The only issue we've
found with it was with regard to packet sniffing of non-BGP applications
such as BMP and MRT file format.  In such cases, knowledge of the session
capabilities or try to parse the NLRI twice is necessary.

Within the context of the protocol, it's stable and IDR should get this
draft off it's work queue and into the RFC editors'. :-)

-- Jeff

---

From: "Bertrand Duvivier (bduvivie)" <[email-masked]>
Date: Fri, 24 Oct 2014 15:48:30 +0000

Agree, has been implemented in many OS's already 

Best Regards Bertrand Duvivier
IP routing Product Manager

-----Original Message-----
From: Idr [mailto:[email-masked]] On Behalf Of Acee Lindem (acee)
Sent: vendredi 24 octobre 2014 17:02
To: Jeffrey Haas; [email-masked]
Subject: Re: [Idr] I-D Action: draft-ietf-idr-add-paths-10.txt

I just reread it for the first time in a couple years and would agree that it is ready for WG last call.
Thanks,
Acee

On 10/24/14, 10:18 AM, "Jeffrey Haas" <[email-masked]> wrote:

>I'm not an author, but I believe this draft is finally read for a 
>hopefully short Working Group Last Call.
>
>-- Jeff
>

---

From: Daniel Walton <[email-masked]>
Date: Fri, 24 Oct 2014 08:49:05 -0700 (PDT)

Juniper, Cisco IOS, IOS-XR and NX-OS all support it.  RX support in quagga is done but isn't in a released version of quagga yet, TX support in quagga is on our roadmap.  Bird added addpath support recently.

Not sure about Arista.

Daniel

----- Original Message -----
From: "Susan Hares" <[email-masked]>
To: "Jeffrey Haas" <[email-masked]>, [email-masked]
Sent: Friday, October 24, 2014 11:30:47 AM
Subject: Re: [Idr] I-D Action: draft-ietf-idr-add-paths-10.txt

Jeff and Acee:

To WG: 

Sue 

-----Original Message-----
From: Idr [mailto:[email-masked]] On Behalf Of Jeffrey Haas
Sent: Friday, October 24, 2014 10:19 AM
To: [email-masked]
Subject: Re: [Idr] I-D Action: draft-ietf-idr-add-paths-10.txt

-- Jeff

---

From: Jeffrey Haas <[email-masked]>
Date: Fri, 24 Oct 2014 11:51:19 -0400

> Juniper, Cisco IOS, IOS-XR and NX-OS all support it.  RX support in quagga is done but isn't in a released version of quagga yet, TX support in quagga is on our roadmap.  Bird added addpath support…

And while I don't speak for competitors, a quick Google search also shows
CLI for ALU. :-)

-- Jeff

---

From: "Bertrand Duvivier (bduvivie)" <[email-masked]>
Date: Fri, 24 Oct 2014 15:56:02 +0000

Acee, Jeff,

To be more precise for Cisco we already support it in our 3 OS's
- IOS XE and IOS classic (CPE and Access routing platform OS)
- IOS XR (hig-end routing platform OS) 
- NXOS (switching platform OS)
And interoperability have been tested between Cisco OS's, with Juniper JUNOS, and few others

---

From: Robert Raszuk <[email-masked]>
Date: Fri, 24 Oct 2014 17:59:36 +0200

Shouldn't we have an implementation report draft documenting those details
before WG last call on the main draft ?

r.

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 24 Oct 2014 12:02:19 -0400

Robert:

100% agree.  This is the reason for the call for implementations.  

Sue 

From: Idr [mailto:[email-masked]] On Behalf Of Robert Raszuk
Sent: Friday, October 24, 2014 12:00 PM
To: Bertrand Duvivier (bduvivie)
Cc: [email-masked]
Subject: Re: [Idr] I-D Action: draft-ietf-idr-add-paths-10.txt

Shouldn't we have an implementation report draft documenting those details before WG last call on the main draft ? 

r.

On Fri, Oct 24, 2014 at 5:56 PM, Bertrand Duvivier (bduvivie) <[email-masked]> wrote:

Acee, Jeff,

---

From: "Bertrand Duvivier (bduvivie)" <[email-masked]>
Date: Fri, 24 Oct 2014 16:14:53 +0000

Robert,

Add-Path has been deployed by many SP’s  with mix vendor environment since years and does works fine...

Thus we may need to ask, what is the added value of such document (outside of following processes).

For Cisco, my BGP team is ready to provide full support if someone start this exercise/ implementation draft but  I’m not ready to take the lead and fund this works, this is not our priority.

BTW:  my personal opinion (Not Cisco): I’m in favor to ask SP’s who deployed Add-Path to speak up and provide feedback and bypass the implementation draft if we believe we got enough return from experience.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Robert Raszuk
Sent: vendredi 24 octobre 2014 18:00
To: Bertrand Duvivier (bduvivie)
Cc: Acee Lindem (acee); Jeffrey Haas; [email-masked]
Subject: Re: [Idr] I-D Action: draft-ietf-idr-add-paths-10.txt

r.

On Fri, Oct 24, 2014 at 5:56 PM, Bertrand Duvivier (bduvivie) <[email-masked]<mailto:[email-masked]>> wrote:
Acee, Jeff,

-----Original Message-----
From: Idr [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Acee Lindem (acee)
Sent: vendredi 24 octobre 2014 17:02
To: Jeffrey Haas; [email-masked]<mailto:[email-masked]>
Subject: Re: [Idr] I-D Action: draft-ietf-idr-add-paths-10.txt

On 10/24/14, 10:18 AM, "Jeffrey Haas" <[email-masked]<mailto:[email-masked]>> wrote:

>On Fri, Oct 24, 2014 at 06:57:42AM -0700, [email-masked]<mailto:[email-masked]> wrote:
>[email-masked]<mailto:[email-masked]>

_______________________________________________
Idr mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/idr

_______________________________________________
Idr mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/idr

_______________________________________________
Idr mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/idr

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Fri, 24 Oct 2014 16:20:36 +0000

Indeed supported for some time now on ALU SROS

On 24/10/14 17:51, "Jeffrey Haas" <[email-masked]> wrote:

>> Juniper, Cisco IOS, IOS-XR and NX-OS all support it.  RX support in
>>quagga is done but isn't in a released version of quagga yet, TX support
>>in quagga is on our roadmap.  Bird added addpath support recently.
>

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 24 Oct 2014 12:22:35 -0400

Betrand:

IMHO+E (in my humble opinion and experience) quick passage of an IDR draft through IESG requires that the IDR chair collects the implementation information.  Implementation drafts are just one way to present the summarized data, and do not become RFCs. 

Would a short online-survey (5 minutes) be quicker for you? 

Sue 

From: Idr [mailto:[email-masked]] On Behalf Of Bertrand Duvivier (bduvivie)
Sent: Friday, October 24, 2014 12:15 PM
To: Robert Raszuk
Cc: [email-masked]
Subject: Re: [Idr] I-D Action: draft-ietf-idr-add-paths-10.txt

Robert,

 

 

r.

Acee, Jeff,

---

From: Robert Raszuk <[email-masked]>
Date: Fri, 24 Oct 2014 18:25:29 +0200

Bertrand,

There are number of optional elements and implementation choices when
developing add-paths functionality.

It would be desirable to see in one place comparison what advertisement
options given implementation supports and which ones are missing.

You may recall a draft from Piere which lists in section 4.3 various
selection options ...

https://tools.ietf.org/html/draft-ietf-idr-add-paths-guidelines-06

Does all cisco implementations support all of those ?

I am not to push processes, but even if IETF becomes a bit more modern and
for each protocol extensions have a wiki where developer can just click
when implementing an optional functionality - it would be very helpful.

Procedurally indeed there is a problem with implementation report drafts as
they seems to be not progressing to RFCs ...

For example this one seems hanging:
https://tools.ietf.org/html/draft-mynam-grow-diverse-path-impl-01

Best,
R.

On Fri, Oct 24, 2014 at 6:14 PM, Bertrand Duvivier (bduvivie) <
[email-masked]> wrote:

> For Cisco, my BGP team is ready to provide full support if someone start
> this exercise/ implementation draft but  I’m not ready to take the lead and
> fund this works, this is not our priority.
>
>
>
> BTW:  my personal opinion (Not Cisco): I’m in favor to ask SP’s who
> deployed Add-Path to speak up and provide feedback and bypass the
> implementation draft if we believe we got enough return from experience.
>
>
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of *Robert
> Raszuk
> *Sent:* vendredi 24 octobre 2014 18:00
> *To:* Bertrand Duvivier (bduvivie)
> *Cc:* Acee Lindem (acee); Jeffrey Haas; [email-masked]
>
> *Subject:* Re: [Idr] I-D Action: draft-ietf-idr-add-paths-10.txt
>
>
>
>
>

---

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Fri, 24 Oct 2014 16:57:57 +0000

On 10/24/14, 12:02 PM, "Susan Hares" <[email-masked]<mailto:[email-masked]>> wrote:

Sue:

I had put an implementation report in my To Do list, but didn’t get to it this time..  If you are ok with it, I can work on it and present it in Hawaii.  I know that would violate the “no draft, no presentation” slot rule, but it would let us move forward.  I can present an update on the latest changes to close the loop as well.

BTW,  we also updated the 'BGP Persistent Route Oscillation Solutions’ draft (draft-walton-bgp-route-oscillation-stop-09): it documents how ADD-PATH can solve the MED churn, which is that started this whole thing.  We would like to ask for WG adoption.

Thanks!

Alvaro.

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 24 Oct 2014 13:01:05 -0400

Alvaro: 

IDR's on Thursday (so you can submit draft on Monday) - smile. 

Seriously - this is great news.  We'll slot that as part of the agenda - but
since we have a short time slot, please be aware we may be tuning this
during IETF. 

Sue 

From: Alvaro Retana (aretana) [mailto:[email-masked]] 
Sent: Friday, October 24, 2014 12:58 PM
To: Susan Hares
Cc: [email-masked]
Subject: Re: [Idr] I-D Action: draft-ietf-idr-add-paths-10.txt

On 10/24/14, 12:02 PM, "Susan Hares" <[email-masked]> wrote:

Sue:

I had put an implementation report in my To Do list, but didn't get to it
this time..  If you are ok with it, I can work on it and present it in
Hawaii.  I know that would violate the "no draft, no presentation" slot
rule, but it would let us move forward.  I can present an update on the
latest changes to close the loop as well.

BTW,  we also updated the 'BGP Persistent Route Oscillation Solutions' draft
(draft-walton-bgp-route-oscillation-stop-09): it documents how ADD-PATH can
solve the MED churn, which is that started this whole thing.  We would like
to ask for WG adoption.

Thanks!

Alvaro.

---

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Fri, 24 Oct 2014 17:03:37 +0000

On 10/24/14, 1:01 PM, "Susan Hares" <[email-masked]<mailto:[email-masked]>> wrote:

IDR’s on Thursday (so you can submit draft on Monday) – smile.

That works!

Thanks!

Alvaro.

---

From: Jeffrey Haas <[email-masked]>
Date: Fri, 24 Oct 2014 13:12:04 -0400

On Fri, Oct 24, 2014 at 04:57:57PM +0000, Alvaro Retana (aretana) wrote:
> I had put an implementation report in my To Do list, but didn?t get to it this time..  If you are ok with it, I can work on it and present it in Hawaii.  I know that would violate the ?no draft, no presentation? slot rule, but it would let us move forward.  I can present an update on the latest changes to close the loop as well.

And if the survey contents were ready in the next week, I promise to have a
report from Juniper to contribute prior to Hawaii.

> BTW,  we also updated the 'BGP Persistent Route Oscillation Solutions? draft (draft-walton-bgp-route-oscillation-stop-09): it documents how ADD-PATH can solve the MED churn, which is that started this whole thing.  We would like to ask for WG adoption.

I'll add this to my review list.  I agree with Alvaro that the scope of the
changes requested in the document make it appropriate for IDR adoption.

To add a dose of operational input on the draft, I've more typically seen
customers asking for add-path with regard to traffic-engineering
applications than for oscillation damping.  There are two ugly challenges
add-path solely for the oscillation case introduces:

- You have to have it turned on to stop the issues.
- The additional state in your network, when you don't need it, consumes
  resources that otherwise may not be needed.

What's unfortunate is the infrastructure to depend this sort of persistent
oscillation is itself expensive making it ugly to only turn on group-best
when necessary.

No answers, only comments.

-- Jeff

---

From: "Bertrand Duvivier (bduvivie)" <[email-masked]>
Date: Fri, 24 Oct 2014 17:20:00 +0000

Ok thanks, sounds great

From: Susan Hares [mailto:[email-masked]]
Sent: vendredi 24 octobre 2014 18:23
To: Bertrand Duvivier (bduvivie); 'Robert Raszuk'
Cc: [email-masked]
Subject: RE: [Idr] I-D Action: draft-ietf-idr-add-paths-10.txt

Betrand:

Sue

From: Idr [mailto:[email-masked]] On Behalf Of Bertrand Duvivier (bduvivie)
Sent: Friday, October 24, 2014 12:15 PM
To: Robert Raszuk
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Idr] I-D Action: draft-ietf-idr-add-paths-10.txt

Robert,

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Robert Raszuk
Sent: vendredi 24 octobre 2014 18:00
To: Bertrand Duvivier (bduvivie)
Cc: Acee Lindem (acee); Jeffrey Haas; [email-masked]<mailto:[email-masked]>
Subject: Re: [Idr] I-D Action: draft-ietf-idr-add-paths-10.txt

r.

---

From: Jeff Tantsura <[email-masked]>
Date: Fri, 24 Oct 2014 17:53:33 +0000

Hi Jeff,

I agree with you, it is a good, coherent document, ready for WGLC.

Cheers,
Jeff

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Mon, 27 Oct 2014 03:42:32 +0000

Hi Sue,

Huawei has supported add-path in VRPv8.

Best regards,
Jie

> From: Idr [mailto:[email-masked]] On Behalf Of Susan Hares
> Sent: Friday, October 24, 2014 11:31 PM
> To: 'Jeffrey Haas'; [email-masked]
> The update below addressed the major open issue that remained for the feature,
> as deployed, to match the spec: The behavior for ebgp has been moved out of
> operation and into deployment considerations.
> 
> I'm not an author, but I believe this draft is finally read for a hopefully short
> Working Group Last Call.
> 
> -- Jeff
> 
> >  This draft is a work item of the Inter-Domain Routing Working Group
> > of
> the IETF.
> >