Subject: [Idr] announcing virtual interim meeting Wed 29 Oct 2014

From: Sandra Murphy <[email-masked]>
Date: Tue, 14 Oct 2014 12:27:20 -0400

At the upcoming IETF, sidr and idr will hold a joint session for the purpose of discussing the bgpsec protocol.

The idr and sidr chairs think that there would be benefit in having a short virtual meeting before hand to get the idr folk who have not been following sidr up to speed on the bgpsec protocol basics, so they can contribute effectively in the joint meeting in Hawaii.

There will be a sidr virtual meeting on Wed 29 Oct 2014 from 10am-12pm EDT and all interested idr folk are invited to participate.  (There won't be much point if you don't!)

The agenda is

1 hr overview and tutorial of bgpsec:
 - underpinings of what BGPSEC/SIDR is
 - why are we here? map of documents
 - origin validation today
 - path validation tomorrow
 - note particular points where bgpsec affects bgp, not so much the
   crypto but where bgp behaviour may change

1 hr of questions and answers.

slides to be made available ahead of time
   
details of the conference technology (webex, google hangout, etc) will be sent to the mailing list.

--Sandy, speaking as one of the co-chairs

---

From: Sandra Murphy <[email-masked]>
Date: Tue, 28 Oct 2014 16:21:00 -0400

This is a reminder that there is a virtual interim meeting scheduled for tomorrow, 10amEDT-12pmEDT.

The slides have been uploaded to the meeting materials site:

http://www.ietf.org/proceedings/interim/2014/10/29/sidr/proceedings.html

The agenda is as below and is also posted to the meeting materials site:

http://www.ietf.org/proceedings/interim/2014/10/29/sidr/agenda/agenda-interim-2014-sidr-1

We can use the sidr jabber room for the usual side commentary.

There will be an audio telecon available:

US Toll Free 1 888 598.1409

Participant passcode:  2085663 then #

For those not in the US, there is an International direct number: +1 720 389.1159

There is also a long list of local access codes per country.  See the attached pdf.

Note that the purpose of this virtual meeting is background tutorial for the IDR folk who have not been following SIDR, so they have a basis to comment productively in the joint SIDR/IDR meeting at IETF91.  This is not a SIDR meeting for the purpose of discussing SIDR issues or suggestions or such.

SIDR folk are welcome to participate if you wish, of course.

--Sandy

---

From: "Sriram, Kotikalapudi" <[email-masked]>
Date: Wed, 29 Oct 2014 23:28:36 +0000

During Sandy's tutorial presentation today, the topics of RIB size and 
CPU workload estimation for BGPSEC came up.
I was asked to post links to past IETF presentations where work on these topics was presented. 

"RIB Size Estimation for BGPSEC"

https://www.ietf.org/proceedings/81/slides/sidr-2.pdf   (SIDR meeting, IETF-81) 

http://www.nist.gov/itl/antd/upload/BGPSEC_RIB_Estimation.pdf    (a few more details here)

(Note: The BGPSEC protocol I-D specifies ECDSA-P256 for signing updates. 
However, RSA-2048 is included and compared in this study because 
RSA-2048 was also considered for signing updates in the early phase of BGPSEC design.)   

"Estimating CPU Cost of BGPSEC on a Router"

http://www.ietf.org/proceedings/83/slides/slides-83-sidr-7.pdf    (SIDR meeting, IETF-83)

http://ripe63.ripe.net/presentations/127-111102.ripe-crypto-cost.pdf    
(slightly different version presented at RIPE-63)

Some other topics also came up for discussion during the tutorial such as consideration 
for route servers (note: current BGPSEC supports transparent route servers by setting pCount=0), 
update packing (i.e. multiple NLRI in an update) - not supported in BGPSEC, etc. 
Design discussions related to these and many other topics (such as consideration 
of peer groups, max PDU size, AS_SETs, etc.) are provided in the following document:       

"BGPSEC Design Choices and Summary of Supporting Discussions"

http://tools.ietf.org/html/draft-sriram-bgpsec-design-choices-06
 
(NOTE: This design choices document pertains only to the 
individual 00-draft [I-D.lepinski-bgpsec-protocol-00] dated March 2011. 
The BGPSEC protocol has obviously gone through many changes since then. 
So please be careful to bear this in mind while looking at I-D.sriram-bgpsec-design-choices.) 

Sriram