Subject: [Idr] I-D Action: draft-ietf-idr-flowspec-redirect-rt-bis-01.txt

From: [email-masked]
Date: Mon, 20 Oct 2014 12:11:03 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Inter-Domain Routing Working Group of the IETF.

        Title           : Clarification of the Flowspec Redirect Extended Community
        Author          : Jeffrey Haas
	Filename        : draft-ietf-idr-flowspec-redirect-rt-bis-01.txt
	Pages           : 5
	Date            : 2014-10-20

Abstract:
   This document clarifies the formatting of the the BGP Flowspec
   Redirect Extended Community, originally documented in RFC 5575
   (Dissemination of Flow Specification Rules).

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-idr-flowspec-redirect-rt-bis/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-idr-flowspec-redirect-rt-bis-01

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-idr-flowspec-redirect-rt-bis-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Mach Chen <[email-masked]>
Date: Wed, 22 Oct 2014 09:16:29 +0000

Hi Jeff,

Thanks for the update.

I just looked through the latest version and reviewed the Border Gateway Protocol (BGP) Extended Communities registry page.

Regarding the registry name, it's better to align with the definitions and conventions at the IANA registry web page (http://www.iana.org/assignments/bgp-extended-communities/bgp-extended-communities.xhtml). For example, the same Upper-lower case, with/without "BGP" at the beginning of a registry name.

Here some editorial change suggestions to the IANA section:

1.
OLD:
"
IANA is requested to update the BGP GENERIC TRANSITIVE EXPERIMENTAL
   USE EXTENDED COMMUNITY SUB-TYPES registry as follows:
"

NEW:
"IANA is requested to update the "Generic Transitive Experimental Use Extended Community Sub-Types" registry as follows:"

OLD:
"IANA is requested to update the BGP TRANSITIVE EXTENDED COMMUNITY
   TYPES registry as follows:"

NEW:
"
IANA is requested to update the "BGP Transitive Extended Community Types" registry as follows:
"

2.
OLD:
"
IANA is requested to create the GENERIC TRANSITIVE EXPERIMENTAL
   EXTENDED COMMUNITY PART 2 SUB-TYPES registry.  It should be seeded
   with the following Sub-Type:
"

NEW:
"
IANA is requested to create the "Generic Transitive Experimental Extended Community Part 2 Sub-Types" registry.  It should be seeded with the following Sub-Type:

3.
OLD:
"
   IANA is requested to create the GENERIC TRANSITIVE EXPERIMENTAL
   EXTENDED COMMUNITY PART 3 SUB-TYPES registry.  It should be seeded
   with the following Sub-Type:
"

NEW:
"
IANA is requested to create the "Generic Transitive Experimental Extended Community Part 3 Sub-Types" registry.  It should be seeded with the following Sub-Type:
"

Best regards,
Mach

> -----Original Message-----
> From: Idr [mailto:[email-masked]] On Behalf Of [email-masked]
> Sent: Tuesday, October 21, 2014 3:11 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Idr] I-D Action: draft-ietf-idr-flowspec-redirect-rt-bis-01.txt
> 
> 
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr

---

From: Jeffrey Haas <[email-masked]>
Date: Fri, 24 Oct 2014 12:11:57 -0400

Mach,

> Here some editorial change suggestions to the IANA section:

I've incorporated the edits.  I believe that I chose the style that was on
this page at a prior time.  Further edits will be left to the RFC Editor
coordinating with IANA. :-)

Thanks for your review.

Sue & John, I believe all open editorial comments on this draft are
complete.

-- Jeff

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 24 Oct 2014 12:13:38 -0400

Jeff:

Thank you for addressing the editorial issues.  

Sue 

-----Original Message-----
From: Idr [mailto:[email-masked]] On Behalf Of Jeffrey Haas
Sent: Friday, October 24, 2014 12:12 PM
To: Mach Chen; John G. Scudder; Susan Hares
Cc: [email-masked]
Subject: Re: [Idr] I-D Action:
draft-ietf-idr-flowspec-redirect-rt-bis-01.txt

Mach,

On Wed, Oct 22, 2014 at 09:16:29AM +0000, Mach Chen wrote:
> Hi Jeff,
> 
> Thanks for the update.
> 
> I just looked through the latest version and reviewed the Border Gateway
Protocol (BGP) Extended Communities registry page.
> 
> Regarding the registry name, it's better to align with the definitions and
conventions at the IANA registry web page
(http://www.iana.org/assignments/bgp-extended-communities/bgp-extended-commu
nities.xhtml). For example, the same Upper-lower case, with/without "BGP" at
the beginning of a registry name.

Thanks for your review.

-- Jeff

---

From: Mach Chen <[email-masked]>
Date: Sat, 25 Oct 2014 01:06:27 +0000

Jeff,

Thanks for addressing the comments!

Indeed, and hope there will no significant changes on the IANA page.

Best regards,
Mach

> From: Jeffrey Haas [mailto:[email-masked]]
> Sent: Saturday, October 25, 2014 12:12 AM
> Cc: Jeffrey Haas; [email-masked]
> Subject: Re: [Idr] I-D Action: draft-ietf-idr-flowspec-redirect-rt-bis-01.txt
> 
> Mach,
> 
> (http://www.iana.org/assignments/bgp-extended-communities/bgp-extended-
> communities.xhtml). For example, the same Upper-lower case, with/without
> "BGP" at the beginning of a registry name.
> >
> I've incorporated the edits.  I believe that I chose the style that was on this page
> at a prior time.  Further edits will be left to the RFC Editor coordinating with
> IANA. :-)
> 
> Thanks for your review.
> 
> Sue & John, I believe all open editorial comments on this draft are complete.
> 
> -- Jeff