Subject: Re: [Idr] New version of draft-wang-idr-eag-distribution-00

From: "Osborne, Eric" <[email-masked]>
Date: Mon, 3 Nov 2014 16:33:40 +0000

-1, I guess, is my vote.  Not that we vote around here.  

I'm not sure I understand the practical benefit of closing it when we know there's stuff missing.  It's in WG LC, right?  Isn't the point to find things that need to be addressed *now*, rather than push it out the nest as quickly as possible when we already know we have a change to make?

Adding EAG to bgp-ls isn't a big deal.  And it's not like people have never shipped product based on mature draft standards before.  Why not do it right while we still have the chance?

eric

> -----Original Message-----
> From: Idr [mailto:[email-masked]] On Behalf Of Qin Wu
> Sent: Friday, October 31, 2014 4:25 AM
> To: Bertrand Duvivier (bduvivie); Jan Medved (jmedved); Hannes Gredler;
> Jeff Tantsura
> Cc: [email-masked]; Hares Susan
> Subject: Re: [Idr] New version of draft-wang-idr-eag-distribution-00
> 
> +1
> Let's close the base spec for BGP-LS.
> 
> -Qin
> -----邮件原件-----
> 发件人: Idr [mailto:[email-masked]] 代表 Bertrand Duvivier (bduvivie)
> 发送时间: 2014年10月31日 2:19
> 收件人: Jan Medved (jmedved); Hannes Gredler; Jeff Tantsura
> 抄送: [email-masked]; Hares Susan
> 主题: Re: [Idr] New version of draft-wang-idr-eag-distribution-00
> 
> Agree,
> 
> Best Regards Bertrand Duvivier
> 
> 
> -----Original Message-----
> From: Idr [mailto:[email-masked]] On Behalf Of Jan Medved (jmedved)
> Sent: jeudi 30 octobre 2014 19:03
> To: Hannes Gredler; Jeff Tantsura
> Cc: [email-masked]; Hares Susan
> Subject: Re: [Idr] New version of draft-wang-idr-eag-distribution-00
> 
> +1
> 
> bgp-ls is in the WG last call, let¹s not restart that clock.
> 
> 
> Thanks,
> Jan
> 
> 
> On 10/30/14, 12:30 AM, "Hannes Gredler" <[email-masked]> wrote:
> 
> >real question is:
> >
> >do we want to close BGP-LS base spec and submit it to IESG or leave it
> >open as an eternal draft ? - IMO EAG is a useful thing hence vendors
> >will be adding support for this, but can perfectly live as a standalone
> >document,
> >
> >/hannes
> >
> >On Tue, Oct 28, 2014 at 06:12:28PM +0000, Jeff Tantsura wrote:
> >|    Hi Eric,
> >|    Agree, should be treated same way as AG and included in bgp-ls,
> >|    Extended Administrative Group with TLV code point 1099
> >|    Cheers,
> >|    Jeff
> >|    From: <Osborne>, Eric <[1][email-masked]>
> >|    Date: Tuesday, October 28, 2014 at 6:48 AM
> >|    To: wangzitao <[2][email-masked]>, "[3][email-masked]"
> >|    <[4][email-masked]>
> >|    Cc: Hares Susan <[5][email-masked]>
> >|    Subject: Re: [Idr] New version of
> >| draft-wang-idr-eag-distribution-00
> >|
> >|      I skimmed it and it  looks reasonable.  Given  that it really
> >| just
> > says
> >|      ³use BGP-LS to send EAG just like we already send AG², why not
> >just
> >|      fold this content into bgp-ls?  The reason it¹s not in bgp-ls
> >already
> >|      is  I  suspect  just  a matter  of timing between  EAG and
> >bgp-ls
> >|      publication.
> >|
> >|
> >|
> >|
> >|
> >|
> >|
> >|
> >|
> >|      eric
> >|
> >|
> >|
> >|      From: Idr [[6]mailto:[email-masked]] On Behalf Of wangzitao
> >|      Sent: Monday, October 27, 2014 9:04 PM
> >|      To: [7][email-masked]
> >|      Cc: Hares Susan
> >|      Subject: [Idr] New version of draft-wang-idr-eag-distribution-00
> >|
> >|
> >|
> >|      Hi, folks:
> >|
> >|      We have  submitted  a new  short  draft  to discuss  BGP
> >extension  for
> >|      Extended admin Group
> >|
> >|
> >| [8]https://tools.ietf.org/html/draft-wang-idr-eag-distribution-00
> >|
> >|      and requested a timeslot to present it at IETF91.
> >|
> >|      Please help review and comment on this short draft.
> >|
> >|      Thanks in advance.
> >|
> >|
> >|
> >|      Regards!
> >|
> >|      -Michael
> >|
> >| References
> >|
> >|    Visible links
> >|    1. mailto:[email-masked]
> >|    2. mailto:[email-masked]
> >|    3. mailto:[email-masked]
> >|    4. mailto:[email-masked]
> >|    5. mailto:[email-masked]
> >|    6. mailto:[email-masked]
> >|    7. mailto:[email-masked]
> >|    8. https://tools.ietf.org/html/draft-wang-idr-eag-distribution-00
> >
> >| _______________________________________________
> >| Idr mailing list
> >| [email-masked]
> >| https://www.ietf.org/mailman/listinfo/idr
> >
> >_______________________________________________
> >Idr mailing list
> >[email-masked]
> >https://www.ietf.org/mailman/listinfo/idr
> 
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr
> 
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr

---

From: Qin Wu <[email-masked]>
Date: Tue, 4 Nov 2014 01:31:37 +0000

I am okay if WG think adding EAG to bgp-ls is not late.
But I haven't seen any implementation that claims to support EAG TLV.

Regards!
-Qin
-----邮件原件-----
发件人: Osborne, Eric [mailto:[email-masked]] 
发送时间: 2014年11月4日 0:34
收件人: Qin Wu; Bertrand Duvivier (bduvivie); Jan Medved (jmedved); Hannes Gredler; Jeff Tantsura
抄送: [email-masked]; Hares Susan
主题: RE: [Idr] New version of draft-wang-idr-eag-distribution-00

eric

> To: Bertrand Duvivier (bduvivie); Jan Medved (jmedved); Hannes 
> Gredler; Jeff Tantsura
> >do we want to close BGP-LS base spec and submit it to IESG or leave 
> >it open as an eternal draft ? - IMO EAG is a useful thing hence 
> >vendors will be adding support for this, but can perfectly live as a 
> >standalone document,
> >
> >/hannes
> >
> >|      Subject: [Idr] New version of 
> >|    8. 
> >| https://tools.ietf.org/html/draft-wang-idr-eag-distribution-00
> >

---

From: "Jan Medved (jmedved)" <[email-masked]>
Date: Tue, 4 Nov 2014 02:00:48 +0000

Eric,

since BGP-LS has proven to be useful for distributing data other than link
state, we will keep finding new stuff that is “missing". So, as Hannes
pointed out, do we want to keep the document in a perpetual draft state,
or move it forward and define other types of stuff in different drafts?

In other words, is having EAG in the draft/RFC a necessary condition to
make the distribution of link-state function properly? Or is it a
necessary part of the NLRI/Attribute infrastructure proposed in the draft
to support distribution of LS (and other types of) data? If not, IMO it
merits its own draft.

Moreover, by adding EAG into the base BGP-LS draft we will make it a
mandatory requirement for all implementers to deal with it. At this point,
interoperability testing has been finished, and the draft and the
implementations have been aligned. We may have to restart the whole
process. There are plenty of examples of drafts/RFCs of similar scope that
augment some existing draft. I don’t see a reason why this should be a big
deal.

Thanks,
Jan

On 11/3/14, 8:33 AM, "Osborne, Eric" <[email-masked]> wrote:

>I'm not sure I understand the practical benefit of closing it when we
>know there's stuff missing.  It's in WG LC, right?  Isn't the point to
>find things that need to be addressed *now*, rather than push it out the
>nest as quickly as possible when we already know we have a change to make?
>
>Adding EAG to bgp-ls isn't a big deal.  And it's not like people have
>never shipped product based on mature draft standards before.  Why not do
>it right while we still have the chance?
>
>
>
>
>eric
>