Subject: [Idr] FW: New Version Notification for draft-xu-idr-bier-extensions-00.txt

From: Xuxiaohu <[email-masked]>
Date: Tue, 17 Feb 2015 01:30:47 +0000

Hi all,

Any comments are welcome.

Best regards,
Xiaohu

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, February 17, 2015 9:26 AM
> To: Mach Chen; Xuxiaohu; Xuxiaohu; IJsbrand Wijnands; Keyur Patel; Keyur Patel;
> IJsbrand Wijnands; Mach Chen
> Subject: New Version Notification for draft-xu-idr-bier-extensions-00.txt
> 
> 
> A new version of I-D, draft-xu-idr-bier-extensions-00.txt
> has been successfully submitted by Xiaohu Xu and posted to the IETF repository.
> 
> Name:		draft-xu-idr-bier-extensions
> Revision:	00
> Title:		BGP Extensions for BIER
> Document date:	2015-02-16
> Group:		Individual Submission
> Pages:		7
> URL:
> http://www.ietf.org/internet-drafts/draft-xu-idr-bier-extensions-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-xu-idr-bier-extensions/
> Htmlized:       http://tools.ietf.org/html/draft-xu-idr-bier-extensions-00
> 
> 
> Abstract:
>    Bit Index Explicit Replication (BIER) is a new multicast forwarding
>    architecture which doesn't require an explicit tree-building protocol
>    and doesn't require intermediate routers to maintain any multicast
>    state.  BIER is applicable in a multi-tenant data center network
>    envioronment for efficient delivery of Broadcast, Unknown-unicast and
>    Multicast (BUM) traffic while eliminating the need for maitaining a
>    huge amount of multicast state in an underlay.  This document
>    describes BGP extensions for advertising the BIER-specific
>    information.  These extesnions are applicable in those multi-tenant
>    data centers where BGP instead of IGP is deployed as an underlay for
>    network reachability advertisement.  These extensions may also be
>    applicable in other scenarios.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat

---

From: Xuxiaohu <[email-masked]>
Date: Tue, 17 Feb 2015 03:08:44 +0000

Hi Tony,

Thanks a lot for your valuable comments and suggestion. Please see my response inline.

From: Antoni Przygienda [mailto:[email-masked]]
Sent: Tuesday, February 17, 2015 10:07 AM
To: Xuxiaohu; [email-masked]; idr wg
Subject: RE: [Bier] FW: New Version Notification for draft-xu-idr-bier-extensions-00.txt

<hat type="individual cat contributor">

Xuxiaohu, thanks for the work.

multiple things:

  The BFR-ID TLV is encoded as follows:

      Type:TBD2

      Length:5

      Value: contains a two-octet BFR-ID.

I am missing here the indication of subdomain-id since without that, the BFR-ID will easily collide within the BIER domain advertising the BGP info @ the edge.

[Xiaohu] Thanks for point it out. Will fix it in the next version.

The BSL TLV is encoded as follows:

      Type:TBD3

      Length:4

      Value: contains a one-octet BSL which indicates the length of the

      Bitstring in 4-octets.

Is this encoded equivalent to MPLS draft ? Indicate so and indicate WHICH bits are used and which are reserved. If not, indicate how e.g.  33 as bitstring length should be treated if e.g. the ensuing encaps cannot deal with it ?

[Xiaohu] IMHO, it'd better to specify the legal BSL values in the BIER arch draft which should be independent of specific BIER encapsulations.

   The BIER MPLS Encapsualtion TLV is encoded as follows:

      Type:TBD4

      Length:7

      Value: contains a one-octet Label Range Size field indicating the

      size of the label range, and a 3-octect Label Rang Base field

      where the 20 rightmost bits represent the first label in the label

      range.

indicate that the other bits are reserved/must be ignored/send 0

Generally, it is considered de rigeur to make nice pictures of those TLVs to make the documents more readable. I suggest doing so.

[Xiaohu] Thanks for the above suggestions. Will fix them in the next version.

Another question here is what happens when multiple eBPG edges of an AD advertise this attribute. Is the preference driven by MED [or another attribute?] based e.g. on the IGP distance within AD to the BFR ?

[Xiaohu] I think so.

Is the expectation that each BGP router advertising this is BFR itself ? Or has capabilities to unicast tunnel into the BIER domain ?

[Xiaohu]Since the BIER attribute is an optional, transitive BGP path attribute, it should support the scenario where a BGP speaker is allowed to tunnel a BIER packet or the payload of a BIER packet to the BFER directly if the BGP next-hop is a non-BFR. Furthermore, it should support as well the scenario where a BGP speaker is allowed to tunnel a BIER packet to the BGP next-hop if these two BGP peers are not directly connected (e.g., multi-hop EBGP) .

Overall, this seems to imply somewhat that BIER domain is aligned with the whole IGP domain (and not areas) and e.g. two OSPF areas cannot be two BIER domains.  This is an interesting architectural question that wasn't brought up yet ?

[Xiaohu] In this doc, it's assumed that a BIER domain is aligned with the whole network consist of multiple ASes.

Best regards,

Xiaohu

</hat>

thanks

--- tony

> From: BIER [mailto:[email-masked]] On Behalf Of Xuxiaohu

> Sent: Monday, February 16, 2015 5:31 PM

> To: [email-masked]<mailto:[email-masked]>; idr wg

> Subject: [Bier] FW: New Version Notification for draft-xu-idr-bier-extensions-

> 00.txt

> > From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]

> > To: Mach Chen; Xuxiaohu; Xuxiaohu; IJsbrand Wijnands; Keyur Patel;

> > Keyur Patel; IJsbrand Wijnands; Mach Chen

> > Subject: New Version Notification for

> > draft-xu-idr-bier-extensions-00.txt

> > has been successfully submitted by Xiaohu Xu and posted to the IETF

> repository.

> > Please note that it may take a couple of minutes from the time of

> > submission until the htmlized version and diff are available at tools.ietf.org.

> _______________________________________________

> BIER mailing list

> [email-masked]<mailto:[email-masked]>

> https://www.ietf.org/mailman/listinfo/bier

---

From: Antoni Przygienda <[email-masked]>
Date: Tue, 17 Feb 2015 03:24:32 +0000

Length:5

[Tony said] ack

      Type:TBD3

      Length:4

      Bitstring in 4-octets.

[Tony said]  agreed, that's a heads-up for Ice to put it into the architecture draft me thinks. It's hanging in the MPLS draft right now. Given how widely it's referenced, it should be moved up me thinks.

      Type:TBD4

      Length:7

      range.

[Tony said] ack

[Xiaohu] I think so.

[Tony said] ack, I suggest to put it into lead-in section (Special considerations, requireements, assumptions, something ?)

[Tony said] [Tony said] Yes, I suggest a small section stating this and explaining this.

[Tony said] Let's spell it out and have a discussion @ next BOF/WG [whatever we become when we've grown up to have a charter ;-) ]  I think it will be a very relevant architectural decision at this point in time and possibly influence all IGP drafts. What speaks against BIER domain aligned with AD is scalabilty, what speaks for it is simplicity.

--- tony

---

From: Antoni Przygienda <[email-masked]>
Date: Tue, 17 Feb 2015 02:06:41 +0000

multiple things:

      Type:TBD2

      Length:5

      Type:TBD3

      Length:4

      Bitstring in 4-octets.

      Type:TBD4

      Length:7

      range.

</hat>

thanks

--- tony

> To: [email-masked]; idr wg