Subject: Re: [Idr] WG Adoption call for draft-hao-idr-flowspec-evpn (1/19/2015 to 2/2/2015

From: Jeffrey Haas <[email-masked]>
Date: Tue, 24 Feb 2015 14:48:05 -0500

Sue,

On Tue, Jan 20, 2015 at 11:17:48AM -0500, Susan Hares wrote:
> Donald:
> 
> I hope that service providers will comment on the list on the usefulness of
> this draft.   If you have suggestions on improving the security
> considerations, please send these to the list during the WG adoption call. 

I'm long overdue on this draft, but I would support its adoption if the
authors could comment on the perceived scenario for using this functionality
for offramping (redirect) instead of simply rate-limit/drop.  For those
technologies, it seems like a different mechanism for remotely distributing
802.* service mechanisms may be worth considering.

A final comment to the authors and IDR: Please consider requesting a
different extended community code point than the 0x80 registry.  Eric just
got done cleaning up the thing - let's not anchor anything else under
"experimental" unless it's really an experiment. :-)

-- Jeff

---

From: Jeffrey Haas <[email-masked]>
Date: Tue, 24 Feb 2015 14:48:05 -0500

Sue,

-- Jeff

---

From: Haoweiguo <[email-masked]>
Date: Wed, 25 Feb 2015 02:33:11 +0000

Thanks Donald. 
1. Perceived scenario for traffic redirect. After discussing with Stephane, service chain steering is a perceived scenario for traffic redirect. The basic principle is illustrated as follows:
                EVPN
        +-----------------------+        
        |                       |             +------------+
CE ------ PE3               PE1 ----- SFC1 ----   IPVPN#1  |    
        |                       |             +------------+
        |                       |
        |                       |             +------------+
CE ------ PE4               PE2 ----- SFC2 ----   IPVPN#2  |
        |                       |             +------------+
        +-----------------------+
In the diagram above, we consider that each PE connected to a service chain, advertise the service chain as an EVPN ESI.
Let's say that PE1 advertises ESI #10 for SFC1 and PE2 advertises ESI #20 for SFC2.
We want to drive Web traffic to SFC1 and the other traffic to SFC2 from all the CEs that are part of the EVPN.
It might be interresting that a controller will create BGP FS rule to force traffic towards the appropriate ESI.
The controller may create two FS rules : 
  * <dst-port 80>, <action : fwd to ESI#10>
  * <dst-ip 0.0.0.0>, <action : fwd to ESI#20>

2.Different extended community code point.  Yes, a different type other than 0x80 for BGP FS exclusively is good, i want to know IDR chairs and other experts opionion on this. 

Thanks,
weiguo

________________________________________
From: Idr [[email-masked]] on behalf of Jeffrey Haas [[email-masked]]
Sent: Wednesday, February 25, 2015 3:48
To: Susan Hares
Cc: 'John G. Scudder'; 'idr wg'; [email-masked]
Subject: Re: [Idr] WG Adoption call for draft-hao-idr-flowspec-evpn (1/19/2015 to 2/2/2015

Sue,

-- Jeff

_______________________________________________
Idr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/idr

---

From: Haoweiguo <[email-masked]>
Date: Wed, 25 Feb 2015 02:33:11 +0000

Thanks Donald. 

Thanks,
weiguo

Sue,

On Tue, Jan 20, 2015 at 11:17:48AM -0500, Susan Hares wrote:
> considerations, please send these to the list during the WG adoption call