Subject: [Idr] I-D Action: draft-ietf-idr-bgp-gr-notification-06.txt - 1 Week WG LC (11/4 to 11/11/2015)

From: "Susan Hares" <[email-masked]>
Date: Wed, 4 Nov 2015 15:00:57 -0500

Hi all: 

John is correct. This begins a 1 WG Working group last call (11/4 to 11/11/2015) on this draft.  Also, the authors should indicate if they know of any IPR relating to the draft?  

Sue Hares

-----Original Message-----
From: John G. Scudder [mailto:[email-masked]] 
Sent: Wednesday, November 04, 2015 3:44 AM
To: <[email-masked]>
Cc: [email-masked] Hares
Subject: Re: [Idr] I-D Action: draft-ietf-idr-bgp-gr-notification-06.txt

Hi Everybody,

This version incorporates editorial revisions from the working group last call. There is also one small normative change. The old version said "This document defines an extension to the BGP Graceful Restart that permits the Graceful Restart procedures to be performed when the BGP speaker receives a BGP NOTIFICATION Message." The new version adds "... or the Hold Time expires."

This corrects a subtle but serious omission in the previous version – the intent of the draft is that, unless the Hard Reset message is used, graceful restart logic should be applied. Without the change explained above, if the hold time expired, the routing table would be flushed before being repopulated when the new session established, as per normal RFC 4271 procedures. With the change, graceful restart processing is applied instead, of course assuming the other conditions for a successful graceful restart are met.

Since there is a normative change, speaking as an author I would suggest confirmation of it on the list before we consider the working group last call closed.

Thanks,

--John

> On Nov 4, 2015, at 5:33 PM, [email-masked] wrote:
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Inter-Domain Routing Working Group of the IETF.
> 
>        Title           : Notification Message support for BGP Graceful Restart
>        Authors         : Keyur Patel
>                          Rex Fernando
>                          John Scudder
>                          Jeff Haas
> 	Filename        : draft-ietf-idr-bgp-gr-notification-06.txt
> 	Pages           : 7
> 	Date            : 2015-11-04
> 
> Abstract:
>   The current BGP Graceful Restart mechanism limits the usage of BGP
>   Graceful Restart to BGP protocol messages other than a BGP
>   NOTIFICATION message.  This document defines an extension to the BGP
>   Graceful Restart that permits the Graceful Restart procedures to be
>   performed when the BGP speaker receives a BGP NOTIFICATION Message or
>   the Hold Time expires.  This document also defines a new BGP
>   NOTIFICATION Cease Error subcode to prevent BGP speakers supporting
>   the extension defined in this document from performing a Graceful
>   Restart.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-idr-bgp-gr-notification/
> 
> There's also a htmlized version available at:
> https://tools.ietf.org/html/draft-ietf-idr-bgp-gr-notification-06
> 
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-ietf-idr-bgp-gr-notification-0
> 6
> 
> 
> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr

---

From: "John G. Scudder" <[email-masked]>
Date: Fri, 6 Nov 2015 09:12:21 +0900

On Nov 5, 2015, at 5:00 AM, Susan Hares <[email-masked]> wrote:
> the authors should indicate if they know of any IPR relating to the draft?

I am not aware of any IPR relating to the draft.

Thanks,

--John

---

From: "Keyur Patel (keyupate)" <[email-masked]>
Date: Fri, 6 Nov 2015 00:17:06 +0000

+1. Am not aware of any IPR related to the draft.

Regards,
Keyur

---

From: Jeffrey Haas <[email-masked]>
Date: Tue, 17 Nov 2015 17:02:38 -0500

> John is correct. This begins a 1 WG Working group last call (11/4 to 11/11/2015) on this draft.  Also, the authors should indicate if they know of any IPR relating to the draft?  

I believe I unicasted, but for the mailing list: No IPR.

-- Jeff