Subject: [Idr] WG Call for adoption on draft-liang-idr-bgp-flowspec-label-01 (11/24 to 12/8)

From: "Susan Hares" <[email-masked]>
Date: Tue, 24 Nov 2015 06:29:27 -0500

This begins a 2 week adoption call for
draft-liang-idr-bgp-flowspec-label-01.txt  which can be found at: 

http://datatracker.ietf.org/doc/draft-liang-idr-bgp-flowspec-label/

All authors should respond to this email whether the know of any IPR
relating to this draft.   Please note that unless all authors respond to
this email, the draft cannot be adopted as a WG draft.  

This draft is part of the flow specification drafts considered at IETF 94,
and on the mail list.  Out of that discussion, an inter-working draft will
be create between the flow specification drafts.   If you are interested in
this draft, but would like to see the inter-working draft, please indicate
this in your comment. 

Sue Hares

---

From: Liangqiandeng <[email-masked]>
Date: Wed, 25 Nov 2015 05:14:27 +0000

Support as a co-author.   I am not aware of any IPR relating to this draft.

This draft is useful for deploying flowspec in BGP/MPLS network.

发件人: Susan Hares [mailto:[email-masked]]
发送时间: 2015年11月24日 19:29
收件人: [email-masked]
抄送: [email-masked]
主题: WG Call for adoption on draft-liang-idr-bgp-flowspec-label-01 (11/24 to 12/8)

This begins a 2 week adoption call for draft-liang-idr-bgp-flowspec-label-01.txt  which can be found at:

All authors should respond to this email whether the know of any IPR relating to this draft.   Please note that unless all authors respond to this email, the draft cannot be adopted as a WG draft.

This draft is part of the flow specification drafts considered at IETF 94, and on the mail list.  Out of that discussion, an inter-working draft will be create between the flow specification drafts.   If you are interested in this draft, but would like to see the inter-working draft, please indicate this in your comment.

Sue Hares

---

From: Haoweiguo <[email-masked]>
Date: Wed, 25 Nov 2015 06:41:08 +0000

Support the adoption. It's a practical solution for deploying BGP flowspec in MPLS network.

Thanks,

weiguo

________________________________
From: Idr [[email-masked]] on behalf of Liangqiandeng [[email-masked]]
Sent: Wednesday, November 25, 2015 13:14
To: Susan Hares; [email-masked]
Cc: [email-masked]
Subject: [Idr] 答复: WG Call for adoption on draft-liang-idr-bgp-flowspec-label-01 (11/24 to 12/8)

Sue Hares

---

From: "VAN DE VELDE, Gunter (Gunter)" <[email-masked]>
Date: Wed, 25 Nov 2015 07:24:19 +0000

When reading the text I am not clear how this would work and which component is allocating which label to use and how the LFIB on the different devices between network ingress and egress is constructed if Flowspec would be used to allocate labels in some way?

The use case for the proposal is a little vague as it seems to only indicate: “this facilitates monitoring and traffic
   statistics for FlowSpec rules.”.

Before considering for adoption, I think the use-case and operational flow charts should be more clearly documented in the text.

G/

From: Idr <[email-masked]<mailto:[email-masked]>> on behalf of Susan Hares <[email-masked]<mailto:[email-masked]>>
Date: Tuesday 24 November 2015 at 12:29
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Idr] WG Call for adoption on draft-liang-idr-bgp-flowspec-label-01 (11/24 to 12/8)

Sue Hares

---

From: "Bertrand Duvivier (bduvivie)" <[email-masked]>
Date: Wed, 25 Nov 2015 11:18:40 +0000

Agree, labels are in general locally assign by remote nodes and not persistant and thus subject to change (we do have exceptions with global significant labels like prefix-SID), thus re-directicting to a remote label could be a quite random action.
Best Regards Bertrand Duvivier
Principal Engineer . Product Marketing

From: "<VAN DE VELDE>", "Gunter (Gunter)" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday 25 November 2015 08:24
To: Susan Hares <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Idr] WG Call for adoption on draft-liang-idr-bgp-flowspec-label-01 (11/24 to 12/8)

The use case for the proposal is a little vague as it seems to only indicate: "this facilitates monitoring and traffic
   statistics for FlowSpec rules.".

G/

Sue Hares

---

From: Liangqiandeng <[email-masked]>
Date: Wed, 25 Nov 2015 11:41:42 +0000

Hi Bertrand Duvivier and Gunter,

In this draft, the BGP router still allocates a label for a FlowSpec rule locally,  we just use a label to identify a traffic matching the flowspec rule.
so please don’t worry that “re-directicting to a remote label could be a quite random action”, there isn’t this type question.

The draft has described it as the following:
“So this document proposes that the BGP router supports to allocate a
   unique label to a FlowSpec rule, the forwarding path is still decided
   by the best-match unicast route for the embedded destination prefix
   or the best-match route to target IP in the 'redirect to IP' action.
   Figure 1 gives an example that FlowSpec rule bound with a label is
   disseminated in the network.

                  Option-B inter-AS connection
                  |<------AS1----->|    |<------AS2----->|
                  +-----+    +-----+    +-----+    +-----+
       VPN 1,IP1..| PE1 |====|ASBR1|----|ASBR2|====| PE2 |..VPN1,IP2
                  +-----+    +-----+    +-----+    +-----+
                     | LDP LSP1 |          | LDP LSP2 |
                     | -------> |          | -------> |
                     |-------BGP VPN Flowspec LSP---->|
                 (Label1)    (Label2)   (Label3)   (Label4)
                    Figure 1: Usage of FlowSpec with Label

  FlowSpec rule1 (injected in PE2):
       Filters:
          destination ip prefix:IP2/32
          source ip prefix:IP1/32
       Actions:
          traffic-marking: 1

  Labels allocated for FlowSpec1:
       Label4 allocated by PE2
       Label3 allocated by ASBR2
       Label2 allocated by ASBR1
       Label1 allocated by PE1

  PE2 disseminates the FlowSpec1 bound with Label4 to ASBR2.
  ASBR2 disseminates the FlowSpec1 bound with Label3 to ASBR1.
  ASBR1 disseminates the FlowSpec1 bound with Label2 to PE1.
”

“If the BGP router allocates a label for a FlowSpec rule and
   disseminates the labeled FlowSpec rule to the upstream peers, it can
   use the label to match the traffic identified by the FlowSpec rule in
   the forwarding plane.”

Thanks,
Qiandeng

发件人: Bertrand Duvivier (bduvivie) [mailto:[email-masked]]
发送时间: 2015年11月25日 19:19
收件人: VAN DE VELDE, Gunter (Gunter); Susan Hares; [email-masked]
抄送: [email-masked]
主题: Re: [Idr] WG Call for adoption on draft-liang-idr-bgp-flowspec-label-01 (11/24 to 12/8)

G/

Sue Hares

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 25 Nov 2015 10:09:45 -0500

Bertrand,

Think SPRING :) Where labels would be globally allocated and would not
change ...

Many thx
r.

On Wed, Nov 25, 2015 at 6:18 AM, Bertrand Duvivier (bduvivie) <
[email-masked]> wrote:

> Agree, labels are in general locally assign by remote nodes and not
> persistant and thus subject to change (we do have exceptions with global
> significant labels like prefix-SID), thus re-directicting to a remote label
> could be a quite random action.
> From: "<VAN DE VELDE>", "Gunter (Gunter)" <
> [email-masked]>
> To: Susan Hares <[email-masked]>, "[email-masked]" <[email-masked]>
> Cc: "[email-masked]" <
> [email-masked]>
> Subject: Re: [Idr] WG Call for adoption on
> draft-liang-idr-bgp-flowspec-label-01 (11/24 to 12/8)
>
> When reading the text I am not clear how this would work and which
> component is allocating which label to use and how the LFIB on the
> different devices between network ingress and egress is constructed if
> Flowspec would be used to allocate labels in some way?
>
> The use case for the proposal is a little vague as it seems to only
> indicate: “this facilitates monitoring and traffic
> Before considering for adoption, I think the use-case and operational flow
> charts should be more clearly documented in the text.
>
> G/
>
>
>
>
>
> From: Idr <[email-masked]> on behalf of Susan Hares <[email-masked]
> >
> To: "[email-masked]" <[email-masked]>
> Cc: "[email-masked]" <
> [email-masked]>
> Subject: [Idr] WG Call for adoption on
> draft-liang-idr-bgp-flowspec-label-01 (11/24 to 12/8)
>
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr
>
>

---

From: "Bertrand Duvivier (bduvivie)" <[email-masked]>
Date: Wed, 25 Nov 2015 15:11:11 +0000

Agree this is an exception like for static label LSP, thus the draft should specify it no?

Visit Segment Routing:
https://www.linkedin.com/groups/Segment-Routing-8266623 (linkedin)
http://www.segment-routing.net (public - web)
http://cs.co/9006BGoTk (public - TWTV preview)
http://cs.co/9001BGopR (public - TWTV details)
http://wikicentral.cisco.com/display/SLA/Segment+Routing<http://wikicentral.cisco.com/display/SLA/Segment+Routing%20(internal)> (internal)

From: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday 25 November 2015 16:09
To: Bertrand Duvivier <[email-masked]<mailto:[email-masked]>>
Cc: "VAN DE VELDE, Gunter (Gunter)" <[email-masked]<mailto:[email-masked]>>, Susan Hares <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Idr] WG Call for adoption on draft-liang-idr-bgp-flowspec-label-01 (11/24 to 12/8)

Bertrand,

Think SPRING :) Where labels would be globally allocated and would not change ...

Many thx
r.

On Wed, Nov 25, 2015 at 6:18 AM, Bertrand Duvivier (bduvivie) <[email-masked]<mailto:[email-masked]>> wrote:
Agree, labels are in general locally assign by remote nodes and not persistant and thus subject to change (we do have exceptions with global significant labels like prefix-SID), thus re-directicting to a remote label could be a quite random action.
Best Regards Bertrand Duvivier
Principal Engineer . Product Marketing

G/

Sue Hares

_______________________________________________
Idr mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/idr

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 25 Nov 2015 10:14:59 -0500

Well the draft assumes some level of understanding of MPLS in the first
place :) It would be pretty odd to even think about injecting match on
locally significant labels - don't you agree ?

Sure I think one line addition as such may be added to the draft but to me
it states the obvious.

Cheers,
r.

On Wed, Nov 25, 2015 at 10:11 AM, Bertrand Duvivier (bduvivie) <
[email-masked]> wrote:

> http://cs.co/9006BGoTk (public – TWTV preview)
> http://cs.co/9001BGopR (public – TWTV details)
> *http://wikicentral.cisco.com/display/SLA/Segment+Routing
> <http://wikicentral.cisco.com/display/SLA/Segment+Routing%20(internal)>*
>  (internal)
>
> From: "[email-masked]" <[email-masked]>
> To: Bertrand Duvivier <[email-masked]>
> Cc: "VAN DE VELDE, Gunter (Gunter)" <
> [email-masked]>, Susan Hares <[email-masked]>, "
> [email-masked]" <[email-masked]>, "[email-masked]"
> <[email-masked]>
>
>> Before considering for adoption, I think the use-case and operational
>> flow charts should be more clearly documented in the text.
>>
>> G/
>>
>>
>>
>>
>>
>> From: Idr <[email-masked]> on behalf of Susan Hares <
>> [email-masked]>
>> This draft is part of the flow specification drafts considered at IETF
>> 94, and on the mail list.  Out of that discussion, an inter-working draft
>> will be create between the flow specification drafts.   If you are
>> interested in this draft, but would like to see the inter-working draft,
>> please indicate this in your comment.
>>
>>
>>
>> Sue Hares
>>
>>
>>
>>

---

From: "Bertrand Duvivier (bduvivie)" <[email-masked]>
Date: Wed, 25 Nov 2015 15:15:24 +0000

Robert,

BTW with SPRING, prefix-SID are the only one being Global so far.
Adj-SID, Peering-SID, Binding -SID do all have local signification and don't have to be persistant.

Visit Segment Routing:

Bertrand,

Many thx
r.

G/

Sue Hares

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 25 Nov 2015 10:19:33 -0500

That is not the only application.

Notice other ietf drafts describing other (non SPRING) uses cases for
domain wide labels or proposing how one can easily support domain wide
labels today.

References:

https://tools.ietf.org/html/draft-fang-mpls-label-forwarding-no-swap-02

https://tools.ietf.org/html/draft-raszuk-mpls-domain-wide-labels-05

So listing in the draft just prefix-SID would be bad idea as it would not
cover other use cases known today and those to be invented in the future
for global/domain wide labels.

Best,
r.

On Wed, Nov 25, 2015 at 10:15 AM, Bertrand Duvivier (bduvivie) <
[email-masked]> wrote:

> Adj-SID, Peering-SID, Binding –SID do all have local signification and
> don’t have to be persistant.
>

---

From: "Bertrand Duvivier (bduvivie)" <[email-masked]>
Date: Wed, 25 Nov 2015 15:25:15 +0000

Agree, would be better to mention: this draft have applicability in case of “global label signification" usage… Prefix-SID, Static-Label, or other…
Best Regards Bertrand Duvivier
Principal Engineer . Product Marketing

Date: Wednesday 25 November 2015 16:19

Notice other ietf drafts describing other (non SPRING) uses cases for domain wide labels or proposing how one can easily support domain wide labels today.

References:

So listing in the draft just prefix-SID would be bad idea as it would not cover other use cases known today and those to be invented in the future for global/domain wide labels.

Best,
r.

On Wed, Nov 25, 2015 at 10:15 AM, Bertrand Duvivier (bduvivie) <[email-masked]<mailto:[email-masked]>> wrote:
Robert,

BTW with SPRING, prefix-SID are the only one being Global so far.
Adj-SID, Peering-SID, Binding –SID do all have local signification and don’t have to be persistant.

Visit Segment Routing:

Bertrand,

Many thx
r.

G/

Sue Hares

---

From: Wesley Eddy <[email-masked]>
Date: Mon, 30 Nov 2015 22:12:05 -0500

> http://datatracker.ietf.org/doc/draft-liang-idr-bgp-flowspec-label/

I agree with other comments that this is a useful extension.

It would be good in the draft to clarify the assumptions about global 
(or at least mutual) significance of the labels, but this is more about 
clearly describing its use and operation than any impact to the protocol 
spec.

---

From: Youjianjie <[email-masked]>
Date: Tue, 1 Dec 2015 03:43:58 +0000

Support as a co-author.  I am not aware of any IPR related to this draft.

Regards,
Jianjie

Sue Hares

---

From: Gunter Van De Velde <[email-masked]>
Date: Tue, 01 Dec 2015 12:26:55 +0800

All,

To re-iterate what was mentioned earlier and the current status of this 
draft.
The purpose is to provide a telemetry tool for flowspec matches by pushing 
a
label. At current time the draft is too immature for WG addoption due to 
severe
unclarities.

Please address these points to improve maturity and before considering
addoption:

1) assumed is that global labels are used, however it is nowhere mentioned
explicitely in the draft

2) with global labels come applicability area being only SPRING based 
networks,
please add this to the technology usability section

3) Traditional best path selection is used to find best NLRI, however a
different to IGP label is pushed ... The draft does not describe measures 
to
guaranty that the pushed label represents the same destination node.

4) why is this solution better as using traditional flowspec redirect to 
VRF
(with exact one route in VRF)? In this case telemetry for flowspec redirect 
can
be done with existing technology ... Nothing new is required...

Understanding the above considerationd i do not feel the current draft is 
ready
for adoption.

Ciao,,
G/

Sent using CloudMagic Email
[https://cloudmagic.com/k/d/mailapp?ct=pa&cv=8.0.67&pv=6.0&source=email_footer_2] 
On Tue, Dec 01, 2015 at 11:16 AM, Wesley Eddy < [email-masked] 
[[email-masked]] > wrote:
On 11/24/2015 6:29 AM, Susan Hares wrote:
This begins a 2 week adoption call for 
draft-liang-idr-bgp-flowspec-label-01.txt
which can be found at:

http://datatracker.ietf.org/doc/draft-liang-idr-bgp-flowspec-label/
[http://datatracker.ietf.org/doc/draft-liang-idr-bgp-flowspec-label/]

It would be good in the draft to clarify the assumptions about global (or 
at
least mutual) significance of the labels, but this is more about clearly
describing its use and operation than any impact to the protocol spec.