Subject: [Idr] I-D Action: draft-ietf-idr-bgp-gr-notification-06.txt

From: [email-masked]
Date: Wed, 04 Nov 2015 00:33:06 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Inter-Domain Routing Working Group of the IETF.

        Title           : Notification Message support for BGP Graceful Restart
        Authors         : Keyur Patel
                          Rex Fernando
                          John Scudder
                          Jeff Haas
	Filename        : draft-ietf-idr-bgp-gr-notification-06.txt
	Pages           : 7
	Date            : 2015-11-04

Abstract:
   The current BGP Graceful Restart mechanism limits the usage of BGP
   Graceful Restart to BGP protocol messages other than a BGP
   NOTIFICATION message.  This document defines an extension to the BGP
   Graceful Restart that permits the Graceful Restart procedures to be
   performed when the BGP speaker receives a BGP NOTIFICATION Message or
   the Hold Time expires.  This document also defines a new BGP
   NOTIFICATION Cease Error subcode to prevent BGP speakers supporting
   the extension defined in this document from performing a Graceful
   Restart.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-idr-bgp-gr-notification/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-idr-bgp-gr-notification-06

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-idr-bgp-gr-notification-06

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "John G. Scudder" <[email-masked]>
Date: Wed, 4 Nov 2015 17:43:47 +0900

Hi Everybody,

This version incorporates editorial revisions from the working group last call. There is also one small normative change. The old version said "This document defines an extension to the BGP Graceful Restart that permits the Graceful Restart procedures to be performed when the BGP speaker receives a BGP NOTIFICATION Message." The new version adds "... or the Hold Time expires."

This corrects a subtle but serious omission in the previous version – the intent of the draft is that, unless the Hard Reset message is used, graceful restart logic should be applied. Without the change explained above, if the hold time expired, the routing table would be flushed before being repopulated when the new session established, as per normal RFC 4271 procedures. With the change, graceful restart processing is applied instead, of course assuming the other conditions for a successful graceful restart are met.

Since there is a normative change, speaking as an author I would suggest confirmation of it on the list before we consider the working group last call closed.

Thanks,

--John

> On Nov 4, 2015, at 5:33 PM, [email-masked] wrote:
> 
> 
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr