Subject: Re: [Idr] FW: New Version Notification for draft-vandevelde-idr-bgp-ls-segment-routing-rld-01.txt

From: Jeff Tantsura <[email-masked]>
Date: Fri, 03 Mar 2017 12:48:59 -0800

Hi Gunter,

If it is up to a controller to setup EL, this extension needed, same way as described in the IGP drafts.

I’d questions usefulness of RLD outsldie of Entropy Labels use case.
Transit nodes in  general are not interested in the full label stack content outside of entropy use case.

Even if the node in question  can’t read whole stack, it can still properly forward the packet, perhaps with less optimal hasing.
Using RLD as a contsrain in path computation doesn’t seem to be a right thing to do.

Thanks!

Cheers,
Jeff

On 3/3/17, 06:55, "Idr on behalf of Van De Velde, Gunter (Nokia - BE)" <[email-masked] on behalf of [email-masked]> wrote:

    Heads-up… Happy to learn feedback and comments.
    
    This draft is short and defines the attribute to use for BGP-LS to expose a 
    node RLD "Readable Label Depth" to a centralised controller (PCE/SDN).
    
    G/
    
    On 03/03/2017, 14:21, "[email-masked]" <[email-masked]> wrote:

        A new version of I-D, draft-vandevelde-idr-bgp-ls-segment-routing-rld-01.txt
        has been successfully submitted by Gunter Van de Velde and posted to the
        IETF repository.
        
        Name:		draft-vandevelde-idr-bgp-ls-segment-routing-rld
        Revision:	01
        Title:		Signalling RLD using BGP-LS
        Document date:	2017-03-03
        Group:		Individual Submission
        Pages:		5
        URL:            https://www.ietf.org/internet-drafts/draft-vandevelde-idr-bgp-ls-segment-routing-rld-01.txt
        Status:         https://datatracker.ietf.org/doc/draft-vandevelde-idr-bgp-ls-segment-routing-rld/
        Htmlized:       https://tools.ietf.org/html/draft-vandevelde-idr-bgp-ls-segment-routing-rld-01
        Diff:           https://www.ietf.org/rfcdiff?url2=draft-vandevelde-idr-bgp-ls-segment-routing-rld-01
        
        Abstract:
           This document defines the attribute to use for BGP-LS to expose a
           node RLD "Readable Label Depth" to a centralised controller (PCE/
           SDN).

        Please note that it may take a couple of minutes from the time of submission
        until the htmlized version and diff are available at tools.ietf.org.
        
        The IETF Secretariat

    _______________________________________________
    Idr mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/idr

---

From: Gunter Van De Velde <[email-masked]>
Date: Fri, 03 Mar 2017 22:26:58 +0100

There is other use case also to do with Synonimous labels and measurements (Alternate marking for passive measurements) potentially….
Maybe i should add that one also to the use cases.

G/

> On 3 Mar 2017, at 21:48, Jeff Tantsura <[email-masked]> wrote:
> 
> Hi Gunter,
>

---

From: "Van De Velde, Gunter (Nokia - BE)" <[email-masked]>
Date: Fri, 3 Mar 2017 21:58:42 +0000

For completeness, I was referring to the following work as use case of the RLD info in addition to entropy use-case:
https://tools.ietf.org/html/draft-bryant-mpls-sfl-framework-02

G/

On 03/03/2017, 22:26, "Gunter Van De Velde" <[email-masked]> wrote:

    G/

---

From: Jeff Tantsura <[email-masked]>
Date: Fri, 03 Mar 2017 14:25:16 -0800

Aren’t Synonimous labels significant on egress only?

Cheers,
Jeff

On 3/3/17, 13:58, "Van De Velde, Gunter (Nokia - BE)" <[email-masked]> wrote:

    G/

        
        G/

---

From: "Van De Velde, Gunter (Nokia - BE)" <[email-masked]>
Date: Fri, 3 Mar 2017 22:36:20 +0000

Looking at https://tools.ietf.org/html/draft-ietf-ippm-alt-mark-02 and the marking framework discussed by Giuseppe Fioccola it seems that counting of packets with a given marker label (synonymous label) is a key parameter for the passive measurements. In that case one is interested in both counting packets ingress to the router and egress of a router… It allows understanding of the packets lost in the router fabric (or whatever ‘thing’ is doing the switching)

G/

On 03/03/2017, 23:25, "Jeff Tantsura" <[email-masked]> wrote:

    Cheers,
    Jeff

        
        G/

            
            G/