Subject: [Idr] Regd BGP-LS code points early allocation for WG adopted drafts

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Thu, 13 Jul 2017 06:01:16 +0000

Hello,

May I request the authors of the draft-ietf-idr-bgp-ls-segment-routing-ext and draft-ietf-idr-te-pm-bgp and WG chairs to please request for early allocation of their IANA code points?

Also, the link MSD codepoint in draft-tantsura-idr-bgp-ls-segment-routing-msd collides with the suggested codepoints in draft-ietf-idr-te-pm-bgp. Early allocations for WG adopted drafts would help avoid collisions.

Jeff, may I suggest to request the code point 1111 for the Link MSD since the TE PM draft is already a WG item and there may be implementations out there already?

Thanks,
Ketan

From: Idr [mailto:[email-masked]] On Behalf Of Stefano Previdi
Sent: 28 June 2017 21:51
To: Susan Hares <[email-masked]>; 'idr wg' <[email-masked]>
Subject: Re: [Idr] I-D Action: draft-ietf-idr-bgp-ls-segment-routing-ext-02.txt

Hi Sue,

Yes, that definitely would help.

Thanks.

s.
On June 28, 2017 5:36:46 PM GMT+02:00, Susan Hares <[email-masked]<mailto:[email-masked]>> wrote:

Stefano:

Did you want early allocation for the code points while we work through the documentation process?   If so, I will include this in the WG LC.

Sue

-----Original Message-----
From: Idr [mailto:[email-masked]] On Behalf Of stefano previdi
Sent: Monday, June 26, 2017 3:08 AM
To: idr wg
Subject: Re: [Idr] I-D Action: draft-ietf-idr-bgp-ls-segment-routing-ext-02.txt

FYI,

this version has been cleaned up from all unused TLVs according to the changes being done in draft-ietf-[ospf|isis]-segment-routing-extensions.

Due to the number of codepoints this drafts proposes, I’d like to ask the chairs to consider the document for publication.

Thanks.
s.

 On Jun 26, 2017, at 8:56 AM, [email-masked]<mailto:[email-masked]> wrote:

 A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Inter-Domain Routing of the IETF.

        Title           : BGP Link-State extensions for Segment Routing
        Authors         : Stefano Previdi
                          Peter Psenak
                          Clarence Filsfils
                          Hannes Gredler
                          Mach(Guoyi) Chen
  Filename        : draft-ietf-idr-bgp-ls-segment-routing-ext-02.txt
  Pages           : 27
  Date            : 2017-06-25

 Abstract:
   Segment Routing (SR) allows for a flexible definition of end-to-end
   paths within IGP topologies by encoding paths as sequences of
   topological sub-paths, called "segments".  These segments are
   advertised by the link-state routing protocols (IS-IS, OSPF and
   OSPFv3).

   This draft defines extensions to the BGP Link-state address-family in
   order to carry segment information via BGP.

 The IETF datatracker status page for this draft is:
 https://datatracker.ietf.org/doc/draft-ietf-idr-bgp-ls-segment-routing
 -ext/

 There are also htmlized versions available at:
 https://tools.ietf.org/html/draft-ietf-idr-bgp-ls-segment-routing-ext-
 02
 https://datatracker.ietf.org/doc/html/draft-ietf-idr-bgp-ls-segment-ro
 uting-ext-02

 A diff from the previous version is available at:
 https://www.ietf.org/rfcdiff?url2=draft-ietf-idr-bgp-ls-segment-routin
 g-ext-02

 Please note that it may take a couple of minutes from the time of
 submission until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

 Internet-Drafts are also available by anonymous FTP at:
 ftp://ftp.ietf.org/internet-drafts<http://ftp.ietf.org/internet-drafts>/

________________________________

 Idr mailing list
 [email-masked]<mailto:[email-masked]>
 https://www.ietf.org/mailman/listinfo/idr

________________________________

Idr mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/idr

---

From: "John G. Scudder" <[email-masked]>
Date: Sat, 15 Jul 2017 16:09:53 +0300

> May I request the authors of the draft-ietf-idr-bgp-ls-segment-routing-ext and draft-ietf-idr-te-pm-bgp and WG chairs to please request for early allocation of their IANA code points?

Thanks. Will start a discussion on this shortly.
 
> Also, the link MSD codepoint in draft-tantsura-idr-bgp-ls-segment-routing-msd collides with the suggested codepoints in draft-ietf-idr-te-pm-bgp. Early allocations for WG adopted drafts would help…

Thanks for pointing this out (and also to Jie who pointed out similar.) This is also why IDR WG guidelines are to NOT put any "suggested" code points in WG drafts or drafts targeted to become WG drafts. :-(
 
> Jeff, may I suggest to request the code point 1111 for the Link MSD since the TE PM draft is already a WG item and there may be implementations out there already?

Better still, please refrain from putting "suggested" code points in drafts at all, and let IANA do their work. As you say, early allocation is the right way to handle this.

--John

---

From: Jeff Tantsura <[email-masked]>
Date: Sat, 15 Jul 2017 15:35:45 +0200

John,

Would you want the authors of draft-tantsura-idr-bgp-ls-segment-routing-msd  to remove suggested values or wait for early allocation and replace?
Thanks!
 
Cheers,
Jeff

On 7/15/17, 15:10, "John G. Scudder" <[email-masked]> wrote:

     

    
    
    --John

---

From: Job Snijders <[email-masked]>
Date: Sat, 15 Jul 2017 14:15:35 +0000

On Sat, 15 Jul 2017 at 15:35, Jeff Tantsura <[email-masked]> wrote:

> Would  you want the authors of
> draft-tantsura-idr-bgp-ls-segment-routing-msd  to remove suggested values
> or wait for early allocation and replace?

The outcome of the IANA Early Allocation process is not directly connected
to self-assigning (squatting) in the current document. I would suggest the
squatted codepoint should be removed at the earliest opportunity (Monday
morning). Uploading new drafts is cheap and easy after all.

Kind regards,

Job

---

From: Jeff Tantsura <[email-masked]>
Date: Sat, 15 Jul 2017 16:17:36 +0200

That’s the plan!

Cheers,

Jeff

From: Job Snijders <[email-masked]>
Date: Saturday, July 15, 2017 at 16:15
To: Jeff Tantsura <[email-masked]>, "John G. Scudder" <[email-masked]>, "Ketan Talaulikar (ketant)" <[email-masked]>
Cc: Stefano Previdi <[email-masked]>, Susan Hares <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, idr wg <[email-masked]>
Subject: Re: [Idr] Regd BGP-LS code points early allocation for WG adopted drafts

 

The outcome of the IANA Early Allocation process is not directly connected to self-assigning (squatting) in the current document. I would suggest the squatted codepoint should be removed at the earliest opportunity (Monday morning). Uploading new drafts is cheap and easy after all. 

Kind regards,

Job