Subject: [Idr] ORR implementation report

From: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>
Date: Thu, 20 Jul 2017 08:18:24 +0000

Can we update the ORR implementation report on the IDR Wiki?

Attached the updated text

= Implementations of draft-ietf-idr-bgp-optimal-route-reflection =

== Known Implementations ==
* JUNOS (reported by Kevin F. Wang on May 22 2017)
* Cisco IOS XR (reported by )
* Huawei (reported by )
* FRR (reported by )
* BIRD (reported by )
* SROS (reported by Wim Henderickx/Adam Simpson on July 20 2017)

== Implemented Features ==

||                                                                    ||  JUNOS   ||  IOS XR    || Huawei || SROS ||
|| Allows to set IGP location per entire RR instance                  ||   Yes    ||    Yes     ||        || Yes  ||
|| Allows to set IGP location per update/peer group                   ||   Yes    ||   Yes      ||        || Yes  ||
|| Allows to set IGP location per individual peer                     ||   (1)    ||    Yes     ||        || Yes  ||
|| Allows for policy configuration on a per client basis              ||   (1)    ||    Yes     ||        || Yes  ||
|| Allows for IGP based & policy based path selection                 ||   Yes    ||    Yes     ||        || Yes  ||
|| Allows to configure backup IGP location                            ||   Yes    ||  Yes       ||        || Yes  ||
|| Supports co-existence with add-paths                               ||   Yes    ||   Yes      ||        || Yes  ||

(1) - JUNOS supports per peer IGP location or policy when peer is alone in a peer group.

---

From: Robert Raszuk <[email-masked]>
Date: Thu, 20 Jul 2017 10:26:04 +0200

Hi Wim,

Send it to me and I will also gladly update the report I created with your
data.

Btw I also have next version ready (-14) so should post it soon.

Cheers,
R.

On Jul 20, 2017 10:20, "Susan Hares" <[email-masked]> wrote:

> Wim:
>
> If  you have a datatracker account, you can update the wiki.   However, I
> will be glad to update the wiki for you later in the day.
>
> Sue
>
> -----Original Message-----
> From: Idr [mailto:[email-masked]] On Behalf Of Henderickx, Wim
> (Nokia
> - BE/Antwerp)
> Sent: Thursday, July 20, 2017 4:18 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Idr] ORR implementation report
>
> (1) - JUNOS supports per peer IGP location or policy when peer is alone in
> a
> peer group.
>
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr
>
>

---

From: Job Snijders <[email-masked]>
Date: Thu, 20 Jul 2017 10:28:11 +0200

done!

---

From: "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>
Date: Thu, 20 Jul 2017 08:28:37 +0000

Did it in the meanwhile. Thx for support

From: <[email-masked]> on behalf of Robert Raszuk <[email-masked]>
Date: Thursday, 20 July 2017 at 10:26
To: Susan Hares <[email-masked]>
Cc: IDR <[email-masked]>, "Henderickx, Wim (Nokia - BE/Antwerp)" <[email-masked]>
Subject: RE: [Idr] ORR implementation report

Hi Wim,

Send it to me and I will also gladly update the report I created with your data.

Cheers,
R.

On Jul 20, 2017 10:20, "Susan Hares" <[email-masked]<mailto:[email-masked]>> wrote:
Wim:

Sue

-----Original Message-----
From: Idr [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Henderickx, Wim (Nokia
- BE/Antwerp)
Sent: Thursday, July 20, 2017 4:18 AM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [Idr] ORR implementation report

||                                                                    ||
JUNOS   ||  IOS XR    || Huawei || SROS ||
|| Allows to set IGP location per entire RR instance                  ||
Yes    ||    Yes     ||        || Yes  ||
|| Allows to set IGP location per update/peer group                   ||
Yes    ||   Yes      ||        || Yes  ||
|| Allows to set IGP location per individual peer                     ||
(1)    ||    Yes     ||        || Yes  ||
|| Allows for policy configuration on a per client basis              ||
(1)    ||    Yes     ||        || Yes  ||
|| Allows for IGP based & policy based path selection                 ||
Yes    ||    Yes     ||        || Yes  ||
|| Allows to configure backup IGP location                            ||
Yes    ||  Yes       ||        || Yes  ||
|| Supports co-existence with add-paths                               ||
Yes    ||   Yes      ||        || Yes  ||

(1) - JUNOS supports per peer IGP location or policy when peer is alone in a
peer group.

_______________________________________________
Idr mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/idr

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 20 Jul 2017 04:14:26 -0400

Wim: 

Sue 

-----Original Message-----
From: Idr [mailto:[email-masked]] On Behalf Of Henderickx, Wim (Nokia
- BE/Antwerp)
Sent: Thursday, July 20, 2017 4:18 AM
To: [email-masked]
Cc: [email-masked]
Subject: [Idr] ORR implementation report

||                                                                    ||