Subject: [Idr] Early Allocation for draft-ietf-idr-bgp-open-policy-02.txt (1/12/2018 to 1/19/2018)

From: "Susan Hares" <[email-masked]>
Date: Fri, 12 Jan 2018 11:42:39 -0500

This begins a 1 week WG call to approve the early allocation of code points
for draft-ietf-idr-bgp-open-policy-02.txt.   You can obtain a copy of the
specification at: 

https://datatracker.ietf.org/doc/draft-ietf-idr-bgp-open-policy/

There are two groups implementing and testing code.   

In your comments on this call, please indicate if you:

1)      Feel the allocation is in the best interest of Internet (aka -
assign code points early), 

2)      If you feel there any problem with providing an early allocation. 

If we have enough responses after the  1 week, the chairs will forward the
request to the AD.  We are going with a 1 week call because many of you have
indicated you wish to reduce the time and effort to get these early
allocations. 

If there are not enough responses after 1 week, we will extend this call to
a second week. 

Sue Hares

PS - yes this is the second early allocation call for today.

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 12 Jan 2018 17:59:35 +0000

Support. I think we’ve been discussing and refining these techniques for some time in IDR and this draft should be published as soon as there are implementations.
Thanks,
Acee

From: Idr <[email-masked]<mailto:[email-masked]>> on behalf of Susan Hares <[email-masked]<mailto:[email-masked]>>
Date: Friday, January 12, 2018 at 11:42 AM
To: IDR List <[email-masked]<mailto:[email-masked]>>
Subject: [Idr] Early Allocation for draft-ietf-idr-bgp-open-policy-02.txt (1/12/2018 to 1/19/2018)

This begins a 1 week WG call to approve the early allocation of code points for draft-ietf-idr-bgp-open-policy-02.txt.   You can obtain a copy of the specification at:

1)      Feel the allocation is in the best interest of Internet (aka – assign code points early),

If we have enough responses after the  1 week, the chairs will forward the request to the AD.  We are going with a 1 week call because many of you have indicated you wish to reduce the time and effort to get these early allocations.

If there are not enough responses after 1 week, we will extend this call to a second week.

Sue Hares

PS – yes this is the second early allocation call for today.

---

From: Jeff Tantsura <[email-masked]>
Date: Fri, 12 Jan 2018 12:18:50 -0800

Support

Cheers,

Jeff

From: Idr <[email-masked]> on behalf of Susan Hares <[email-masked]>
Date: Friday, January 12, 2018 at 11:42 AM
To: IDR List <[email-masked]>
Subject: [Idr] Early Allocation for draft-ietf-idr-bgp-open-policy-02.txt (1/12/2018 to 1/19/2018)

In your comments on this call, please indicate if you:
Feel the allocation is in the best interest of Internet (aka – assign code points early), 
If you feel there any problem with providing an early allocation. 

Sue Hares

_______________________________________________ Idr mailing list [email-masked] https://www.ietf.org/mailman/listinfo/idr

---

From: Ruediger Volk <[email-masked]>
Date: Fri, 12 Jan 2018 22:00:58 +0100

support 
  > assign code points early), 
yes, definitely so

  > 2)      If you feel there any problem with providing an early allocation. 
no

  > PS - yes this is the second early allocation call for today. 
yay, for supporting creation of running code while avoiding code point squatting

Ruediger Volk

---

From: <[email-masked]>
Date: Mon, 15 Jan 2018 10:19:47 +0000

Support.

And thanks to draft-ietf-idr-bgp-open-policy authors for asking for early allocation (rather than squatting).

Note : as we now allocate code point faster and more easily, we may want to prepare/test for recycling unsuccessful ones.
iOTC attribute seems like an easier candidate, as it's non transitive, typically removed from update from eBGP sessions, and only used as a flag and hence parsing error are limited.
Also, my reading of RFC 6938 is that we have some attributes which have never been used. Plus very unfortunately, my reading of RFC 8093 is that unallocated code points are not necessarily safer.
On the other hand, we still have plenty attributes available, and burning * is always easiest.

--Bruno

From: Idr [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Friday, January 12, 2018 5:43 PM
To: [email-masked]
Subject: [Idr] Early Allocation for draft-ietf-idr-bgp-open-policy-02.txt (1/12/2018 to 1/19/2018)

1)      Feel the allocation is in the best interest of Internet (aka - assign code points early),

Sue Hares

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Randy Bush <[email-masked]>
Date: Mon, 15 Jan 2018 19:43:43 +0900

> for draft-ietf-idr-bgp-open-policy-02.txt.

caveat: i am a co-author

i would appreciate the early allocation so we do not have another round
of stepping on toes.

randy

---

From: Job Snijders <[email-masked]>
Date: Wed, 17 Jan 2018 00:27:56 +0000

On Fri, Jan 12, 2018 at 11:42:39AM -0500, Susan Hares wrote:
> This begins a 1 week WG call to approve the early allocation of code
> points for draft-ietf-idr-bgp-open-policy-02.txt.   You can obtain a
> copy of the specification at: 
> 

I support assigning these code points early.

Kind regards,

Job

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Wed, 17 Jan 2018 01:09:29 +0000

Support the early allocation.

-Jie

From: Idr [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Saturday, January 13, 2018 12:43 AM
To: [email-masked]
Subject: [Idr] Early Allocation for draft-ietf-idr-bgp-open-policy-02.txt (1/12/2018 to 1/19/2018)

Sue Hares