Subject: Re: [Idr] [Lsvr] Kicking off the LSVR (Link State Vector Routing) charter discussion

From: "Rabadan, Jorge (Nokia - US/Mountain View)" <[email-masked]>
Date: Tue, 23 Jan 2018 10:17:26 +0000

After going through the charter text, I believe it is a very good starting point.
Looking forward to seeing fruitful discussions.

Thanks.
Jorge

-----Original Message-----
From: Lsvr <[email-masked]> on behalf of "Van De Velde, Gunter (Nokia - BE/Antwerp)" <[email-masked]>
Date: Wednesday, January 10, 2018 at 11:52 AM
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Victor Kuarsingh <[email-masked]>, Keyur Patel <[email-masked]>, "Van De Velde, Gunter (Nokia - BE/Antwerp)" <[email-masked]>, Shawn Zandi <[email-masked]>, Alvaro Retana <[email-masked]>, "Acee Lindem (acee)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: [Lsvr] Kicking off the LSVR (Link State Vector Routing) charter discussion

    [Note: Target audience, and discussions should happen on [email-masked], however "rtgwg", "idr" and "dcrouting" email lists have been added as the concepts originated in those working groups]
    
    Since dcrouting@ietf100, a few people have been discussing a possible WG charter for LSVR (Link State Vector Routing).
    Here is what we have so far.  Comments and improvements would be most welcome. 
    
    WG page is to be setup soon.
    Subscription to LSVR mailing list: https://www.ietf.org/mailman/listinfo/lsvr
    
    Feedback (comments, edits, corrections, etc)  on the draft LSVR charter is appreciated 

    ***** DRAFT CHARTER UPDATE - JAN 10 2018 *****
     
    Charter: LSVR - Link State Vector Routing 
     
    The Link-State Vector Routing (LSVR) Working Group is chartered to develop and document a hybrid routing protocol utilizing a combination of link-state and path-vector routing mechanisms.  The LSVR WG will utilize existing the IPv4/IPv6 transport, packet formats, and error handling from BGP-4 (RFC4271). Additionally, the BGP-LS NLRI encoding mechanisms defined in RFC7752 are utilized to facilitate Link-State Vector (LSV) routing information distribution. An LSV is intended to be specified as a data structure comprised of a link identification, link attributes, neighbor information, cost toward neighbors, and other attributes that are defined for control plane function and policy-based routing decisions.
     
    The LSVR specification is initially focused on operation within a single datacenter (DC) with preliminary focus on specifying functionality within a single distribution domain.  Routing protocol functionality defined by LSVR would be typically routing within a datacenter's underlay routing plane. 
     
    In order to achieve the noted objective, the working group will focus on standardization of protocol functionality, defining Link-State Vectors (LSVs), and defining standard path-vector route selection utilizing existing Dijkstra SPF based algorithm, BGP-4 protocol mechanics, and BGP-LS NRLI encoding.
     
    For the purposes of the initial work within the LSVR WG, and until further specified by the WG, the following definitions apply to this charter.
     
    - Link-State Vector - An LSV is intended to represent a data structure (data set) comprised of link identification, link attributes, neighbor information, cost towards neighbors, and other potential attributes that can be utilized to make routing decisions.
    - LSVR Distribution Domain - Initially scoped as a set of participating LSVR nodes in a single administrative domain.

    The LSVR WG is chartered to deliver the following documents:
     
    - Publish Applicability Statement for the use of LSVR in the Datacenter - Target Status: Informational
    - Publish specification document describing LSV with standard Dijkstra SPF route/path selection (calculation) utilizing existing BGP protocol baseline functionality and BGP-LS packet encoding formats - Target: Standards Track (Based on draft draft-keyupate-idr-bgp-spf)
    - Publish specification documenting protocol extensions required to efficiently reuse BGP to distribute LSVs within an IPv4/IPv6 DC with scope to include privacy and security considerations - - Target: Standards Track
    - Publish YANG model specification for LSVR - - Target: Standards Track
     
    LSVR Milestones:
     
    - Applicability statement for LSVR in DCs: March 2019
    - LSVR with standard Dijkstra path selection: March 2019
    - LSV distribution using BGP transport: March 2019
    - YANG specification for LSRV: July 2019
    
    _______________________________________________
    Lsvr mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/lsvr

---

From: "徐小虎(义先)" <[email-masked]>
Date: Wed, 24 Jan 2018 09:46:29 +0800

Just a minor question: why call it a hybrid routing protocol utilizing a combination of link-state and path-vector routing mechanisms? more specifically, what part of the BGP-SPF resorts to the path-vector routing mechanism? IMHO, BGP-SPF has transformed the traditional BGP to a complete link-state routing protocol from the perspective of the routing computing algorithm, no?
Best regards,Xiaohu------------------------------------------------------------------发件人：Rabadan, Jorge (Nokia - US/Mountain View) <[email-masked]>发送时间：2018年1月24日(星期三) 03:07收件人："Van De Velde, Gunter (Nokia - BE/Antwerp)" <[email-masked]>; [email-masked] <[email-masked]>抄　送：[email-masked] <[email-masked]>; [email-masked] <[email-masked]>; Victor Kuarsingh <[email-masked]>; Keyur Patel <[email-masked]>; Shawn Zandi <[email-masked]>; [email-masked] <[email-masked]>主　题：Re: [Idr] [Lsvr] Kicking off the LSVR (Link State Vector Routing) charter discussion
After going through the charter text, I believe it is a very good starting point.
Looking forward to seeing fruitful discussions.

Thanks.
Jorge

 -----Original Message-----

    

     

     

     
     
    LSVR Milestones:

_______________________________________________
Idr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/idr

---

From: Keyur Patel <[email-masked]>
Date: Wed, 24 Jan 2018 19:10:42 +0000

Hi Xiaohu,

Your right. Having said that the basic BGP neighbor handling mechanism, update handling, and any implementation specific knobs that can be leveraged aren’t explicitly eliminated as part of BGP-SPF (and hence the reference to the hybrid routing protocol).

Regards,
Keyur

From: Idr <[email-masked]> on behalf of "徐小虎(义先)" <[email-masked]>
Reply-To: "徐小虎(义先)" <[email-masked]>
Date: Tuesday, January 23, 2018 at 5:46 PM
To: "Van De Velde, Gunter (Nokia - BE/Antwerp)" <[email-masked]>, "[email-masked]" <[email-masked]>, Idr <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Victor Kuarsingh <[email-masked]>, Keyur Patel <[email-masked]>, Shawn Zandi <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: [Idr] 回复： [Lsvr] Kicking off the LSVR (Link State Vector Routing) charter discussion

Best regards,
Xiaohu
------------------------------------------------------------------
发件人：Rabadan, Jorge (Nokia - US/Mountain View) <[email-masked]>
发送时间：2018年1月24日(星期三) 03:07
收件人："Van De Velde, Gunter (Nokia - BE/Antwerp)" <[email-masked]>; [email-masked] <[email-masked]>
抄　送：[email-masked] <[email-masked]>; [email-masked] <[email-masked]>; Victor Kuarsingh <[email-masked]>; Keyur Patel <[email-masked]>; Shawn Zandi <[email-masked]>; [email-masked] <[email-masked]>
主　题：Re: [Idr] [Lsvr] Kicking off the LSVR (Link State Vector Routing) charter discussion

Thanks.
Jorge

 -----Original Message-----
From: Lsvr <[email-masked]> on behalf of "Van De Velde, Gunter (Nokia - BE/Antwerp)" <[email-masked]>
Date: Wednesday, January 10, 2018 at 11:52 AM
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Victor Kuarsingh <[email-masked]>, Keyur Patel <[email-masked]>, "Van De Velde, Gunter (Nokia - BE/Antwerp)" <[email-masked]>, Shawn Zandi <[email-masked]>, Alvaro Retana <[email-masked]>, "Acee Lindem (acee)" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: [Lsvr] Kicking off the LSVR (Link State Vector Routing) charter discussion

    LSVR Milestones: