Subject: [Idr] BGP Flowspec(RFC 5575) Numeric Operator for inequality (!=)

From: PVLR Pavana Murthy <[email-masked]>
Date: Wed, 7 Feb 2018 15:02:45 +0530

Hello,
   As per the RFC 5575,

   0   1     2   3   4    5    6   7
+---+---+---+---+---+---+---+---+
| e   | a |   len   | 0  |  lt |gt | eq |
+---+---+---+---+---+---+---+---+

eq - equality between data and value.
The bits lt, gt, and eq can be combined to produce "less or
equal", "greater or equal", and inequality values.

For '<='    lt =1, gt =0, eq =1
For  '>='   lt= 0, gt=1, eq =1

how to achieve inequality? Is it by making lt = 0, gt =0, eq =0 ?

Please clarify.

Thanks,
Pavana.

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 7 Feb 2018 10:35:08 +0100

Yes.

Thx,
R.

On Wed, Feb 7, 2018 at 10:32 AM, PVLR Pavana Murthy <[email-masked]>
wrote:

> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr
>
>

---

From: PVLR Pavana Murthy <[email-masked]>
Date: Wed, 7 Feb 2018 15:21:58 +0530

Hello,
  Thanks for quick response. If  all lt=1, gt=1, eq=1, what should be done
?

Thanks,
Pavana.

---

From: PVLR Pavana Murthy <[email-masked]>
Date: Wed, 7 Feb 2018 15:38:16 +0530

adding idr to To: list.

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 7 Feb 2018 11:17:15 +0100

That's illegal combination as value can not be "less then" and "greater
then" a given value in the same time.

In the spirit of being liberal in what you accept such [op,value] should be
ignored and error (sys)logged.

Legal combinations are clearly listed in the text: lt=1 & eq=1,  gt=1 &
eq=1, all zeros.

Thx,
R.

---

From: Christoph Loibl <[email-masked]>
Date: Wed, 07 Feb 2018 12:08:29 +0100

Hi,

Please refer to the rfc5575bis which is in the queue to be published soon 
and comes with a explicit list of the bitcombinations.

https://datatracker.ietf.org/doc/draft-ietf-idr-rfc5575bis/

Christoph

On 7 February 2018 10:58:33 am Robert Raszuk <[email-masked]> wrote:

> ----------