Subject: Re: [Idr] Genart last call review of draft-ietf-idr-bgp-prefix-sid-10

From: "Peter Yee" <[email-masked]>
Date: Thu, 1 Feb 2018 10:30:37 -0800

Acee,
	Thanks for the quick response. 

>>    Change "extendibility" to "extensibility" throughout the document.

>No - see https://www.merriam-webster.com/dictionary/extendibility

Yeah, I looked over various dictionaries for that word.  Extensibility seemed to be more popular and in some dictionaries closer to what you meant, but either will work.

>>    Page 4, Section 1, 4th paragraph, 1st sentence: delete the comma.

>I'm not sure exactly which comma you are referring to but I believe the punctuation is correct before "reducing".

That should have been Page 3.  Typo on my part.

	I appreciate you addressing my comments (tardy as they were).

		-Peter

-----Original Message-----
From: Acee Lindem (acee) [mailto:[email-masked]] 
Sent: Wednesday, January 31, 2018 3:02 PM
To: Peter Yee; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: Genart last call review of draft-ietf-idr-bgp-prefix-sid-10

Hi Peter, 

Thanks for the review, please see inline.

On 1/31/18, 2:44 PM, "Peter Yee" <[email-masked]> wrote:

    Reviewer: Peter Yee
    Review result: Ready with Nits
    
    I am the assigned Gen-ART reviewer for this draft. The General Area
    Review Team (Gen-ART) reviews all IETF documents being processed
    by the IESG for the IETF Chair.  Please treat these comments just
    like any other last call comments.
    
    For more information, please see the FAQ at
    
    <https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.
    
    Document: draft-ietf-idr-bgp-prefix-sid-10
    Reviewer: Peter Yee
    Review Date: 2018-01-31
    IETF LC End Date: 2018-01-26
    IESG Telechat date: 2018-02-08
    
    Summary: This draft specifies an optional BGP attribute for use with Segment
    Routing.  It's well written and reable, although I make no claims to being an
    expert in this area.  The draft is ready for publication but has some nits that
    should be fixed (really nothing major).
    
    Major issues:
    
    Minor issues:
    
    Nits/editorial comments:
    
    General:
    
    Change "extendibility" to "extensibility" throughout the document.

No - see https://www.merriam-webster.com/dictionary/extendibility
    
    Change "First Come, First Served" (with varying hyphenation) to simply
    "first-come, first-served" in a few places.  Meaning making it lower case and
    hyphenate consistently.

I've made this consistent with IANA terminology.

    Specific.
    
    Page 3, Section 1, 1st paragraph, 2nd sentence: change the colon to a comma.

Fixed.
    
    Page 3, Section 1, 3rd paragraph, 1st sentence: append comma after the close
    parenthesis, "label", and "Dataplane".

Fixed.
    
    Page 4, Section 1, 4th paragraph, 1st sentence: delete the comma.

I'm not sure exactly which comma you are referring to but I believe the punctuation is correct before "reducing". 

    Page 4, Section 1, 4th paragraph, last sentence: consider making "Segment"
    lower case for consistency with previous usage.

Fixed.
    
    Page 4, Section 2.1, 2nd indented paragraph, 2nd sentence: change "to use" to
    "using".

Changed 
    
    Page 7, Section 3.2, 1st paragraph, 2nd sentence: should the uses of "will be"
    throughout the document be changed to "MUST"?

I've consistently used MUST throughout. 
    
    Page 8, 2nd bullet item (Length): insert "a" before "multiple".

I've put it in parenthesis. 
    
    Page 9, Section 4, 1st sentence: delete the comma.
    
Fixed.

    Page 9, Section 4.1, 3rd paragraph, 1st sentence: delete "as".

Reworded.
    
    Page 10, Section 4.2, 1st paragraph, 2nd sentence: delete the first "the".

Fixed.
    
    Page 12, 1st paragraph, 2nd sentence: change "Similarily" to "Similarly".

Fixed.
    
    Page 12, Section 7, 1st paragraph, 2nd sentence: insert "to" before the first
    "the".

Fixed. 

Thanks,
Acee

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Thu, 1 Feb 2018 20:58:05 +0000

Hi Peter, 

On 2/1/18, 1:30 PM, "Peter Yee" <[email-masked]> wrote:

    Acee,

    

    

Thanks - I'll remove that comma in the next revision (which there invariable will be). 

Acee 

    		-Peter
    
    -----Original Message-----
    From: Acee Lindem (acee) [mailto:[email-masked]] 
    Sent: Wednesday, January 31, 2018 3:02 PM
    To: Peter Yee; [email-masked]
    Cc: [email-masked]; [email-masked]; [email-masked]
    Subject: Re: Genart last call review of draft-ietf-idr-bgp-prefix-sid-10
    
    Hi Peter, 

    
        Reviewer: Peter Yee

        

        
        Major issues:
        
        Minor issues:
        
        Nits/editorial comments:
        
        General:

        

        Specific.

    Fixed.

    Fixed.

    
    Fixed.

    Changed 

        

        
    Fixed.

    Reworded.

    Fixed.

    Fixed.

    Fixed. 
    
    Thanks,
    Acee