Subject: Re: [Idr] draft-ietf-idr-route-leak-detection-mitigation

From: "Sriram, Kotikalapudi (Fed)" <[email-masked]>
Date: Mon, 19 Mar 2018 23:06:11 +0000

>Regarding the discussion of this draft in the wg mtg with regard to
>revealing AS business relationships in the RLP,

>1) What ASes actually care about this given that CAIDA and others have
>demonstrated that these relationships can be inferred from DFZ RIBs?  Is
>this argument based on actual complaints within the last decade?

The draft was developed/discussed in GROW for a year before moving to IDR. 
Don’t recall that there were any actual complaints.    

>2) Can the terms just be changed to eliminate this argument?  Don't call it
>customer/peer/transit/complex, call it southbound-AS/east-west-AS/
>northbound-AS/kink-AS.

The draft kind of does that (page 7):

  For the purpose of route-leak detection and mitigation, the RLP field
   value MUST be set to one of two values as follows:

   o  0: This is the default value (i.e., "nothing specified"),

   o  1: This is the 'Do not Propagate Up or Lateral' indication; …

Thanks.

Sriram

---

From: Randy Bush <[email-masked]>
Date: Tue, 20 Mar 2018 10:50:00 +0000

> Don’t recall that there were any actual complaints.

you may want to check the ml archive

---

From: "John G. Scudder" <[email-masked]>
Date: Tue, 20 Mar 2018 11:14:10 +0000

(as an individual contributor)

Hi Sriram,

> On Mar 19, 2018, at 11:06 PM, Sriram, Kotikalapudi (Fed) <[email-masked]> wrote:
> 

During the meeting, when Alex asked that the draft document this concern, I believe you responded in part that it already does, in one of the appendices. I just glanced quickly through the draft and it was not obvious to me where it's documented. Can you provide a pointer?

In any case I think that rather than rehash whether the concern is, or is not, legitimate, it's better to simply document it clearly and move on. Full disclosure, price of doing business, etc. 

Thanks,

--John

---

From: "Sriram, Kotikalapudi (Fed)" <[email-masked]>
Date: Tue, 20 Mar 2018 11:50:44 +0000

John,

>During the meeting, when Alex asked that the draft document this concern, I believe you responded in part that it already does, in one of the appendices. I just glanced quickly through the draft and…

My bad. I got mixed up with another topic that is covered there (in the appendices).

>In any case I think that rather than rehash whether the concern is, or is not, legitimate, it's better to simply document it clearly and move on. Full disclosure, price of doing business, etc.

Yes, I agree. I plan on updating the draft in the next two/three weeks to include this. 
I'll also search the GROW/IDR mailing list archives just to see if we received 
any specific comments from network operators about this in the past 
(since 2014 when the document was first discussed in GROW and later in IDR).
If any, then I would provide pointers to those posts as well.

Thank you.

Sriram