Subject: Re: [Idr] WG LC for draft-ietf-idr-bgp-prefix-sid-17.txt (2/23 to 3/9/2018)

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 9 Mar 2018 13:48:11 +0000

Hi Sue, Alvaro, IDR WG,

The WG last group on the changes to the BGP Prefix-SID draft has completed with unanimous tacit approval from IDR WG. Can we go ahead and advance it? I believe we were going to send it directly the IESG w/o a second IETF last call.
Thanks,
Acee

From: Idr <[email-masked]> on behalf of Susan Hares <[email-masked]>
Date: Friday, February 23, 2018 at 6:09 PM
To: IDR List <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [Idr] WG LC for draft-ietf-idr-bgp-prefix-sid-17.txt (2/23 to 3/9/2018)

This begins a 2 week IDR WG last call on changes to the BGP Prefix SID draft.

The changes are removal of the IPv6 SID TLV/SRv6 data plane and error/conflict handling modifications to section 4. The reasons for removing the IPv6 SID TLV were explained in https://mailarchive.ietf.org/arch/msg/idr/3YE8hDCj0ky0NPFoLrTHV2AAEJ8. The error/conflict handling changes were made based on fruitful  review comments and discussions very late in the process.

Just to refresh your memory, this draft has return from the IESG to the WG.  It is the intent of the WG chairs if IDR WG reaches consensus on this version to immediately send it back the IESG for publication.

Susan Hares

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 13 Mar 2018 18:51:22 +0000

Hi Sue,
Any updates on document progression?
Thanks,
Acee

From: Idr <[email-masked]> on behalf of Acee Lindem <[email-masked]>
Date: Friday, March 9, 2018 at 8:48 AM
To: Susan Hares <[email-masked]>, IDR List <[email-masked]>, Alvaro Retana <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [Idr] WG LC for draft-ietf-idr-bgp-prefix-sid-17.txt (2/23 to 3/9/2018)

Hi Sue, Alvaro, IDR WG,

Susan Hares

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Wed, 14 Mar 2018 02:21:09 +0000

Hi Acee,

Recently Sue has some health issues and may not reply to emails quickly.

Let me check with John and Alvaro about how to move forward with this draft.

Best regards,
Jie

From: Acee Lindem (acee) [mailto:[email-masked]]
Sent: Wednesday, March 14, 2018 2:51 AM
To: Susan Hares <[email-masked]>; 'idr wg' <[email-masked]>; Alvaro Retana <[email-masked]>
Cc: [email-masked]
Subject: Re: [Idr] WG LC for draft-ietf-idr-bgp-prefix-sid-17.txt (2/23 to 3/9/2018)

Hi Sue,

From: Idr <[email-masked]<mailto:[email-masked]>> on behalf of Acee Lindem <[email-masked]<mailto:[email-masked]>>
Date: Friday, March 9, 2018 at 8:48 AM
To: Susan Hares <[email-masked]<mailto:[email-masked]>>, IDR List <[email-masked]<mailto:[email-masked]>>, Alvaro Retana <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Idr] WG LC for draft-ietf-idr-bgp-prefix-sid-17.txt (2/23 to 3/9/2018)

Hi Sue, Alvaro, IDR WG,

From: Idr <[email-masked]<mailto:[email-masked]>> on behalf of Susan Hares <[email-masked]<mailto:[email-masked]>>
Date: Friday, February 23, 2018 at 6:09 PM
To: IDR List <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Idr] WG LC for draft-ietf-idr-bgp-prefix-sid-17.txt (2/23 to 3/9/2018)

Susan Hares

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 14 Mar 2018 14:32:35 +0000

Hi Jie,

From: Jie Dong <[email-masked]>
Date: Tuesday, March 13, 2018 at 10:21 PM
To: Acee Lindem <[email-masked]>, Susan Hares <[email-masked]>, IDR List <[email-masked]>, Alvaro Retana <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: RE: [Idr] WG LC for draft-ietf-idr-bgp-prefix-sid-17.txt (2/23 to 3/9/2018)

Hi Acee,

Sorry to hear.

Let me check with John and Alvaro about how to move forward with this draft.
That would be great – it should be ready for publication.

Thanks,
Acee

Best regards,
Jie

Hi Sue,

Hi Sue, Alvaro, IDR WG,

Susan Hares

---

From: "John G. Scudder" <[email-masked]>
Date: Sun, 18 Mar 2018 17:31:36 +0000

Hi All,

I went back and reviewed the diffs and list traffic around the latest revision, and I have one small concern. In addition to the large normative change of removing the IPv6 SID, which was well reviewed, and some editorial improvements, there's one more normative change I didn't see flagged to the list for review:

-16:
  If multiple different prefixes are received with the same label
  index, either all or all but one of the different prefixes MUST have
  their BGP Prefix-SID attribute considered as "conflicting".  If one
  of the different prefixes is considered "acceptable", it is
  RECOMMENDED that the first prefix using the label index is selected.

-17:
  If multiple different prefixes are received with the same label
  index, all of the different prefixes MUST have their BGP Prefix-SID
  attribute considered as "conflicting".

I see the mailing list discussion, mainly between Robert and Acee, that must have led to this change. I don't see discussion of the change itself. One can argue that everyone had the opportunity to look at the rfcdiff, but nonetheless I'm not fully convinced that in the case of this change, "silence gives [informed] consent" (a.k.a. "unanimous tacit approval") -- it's just a few lines and unless you're looking for it, you might easily breeze by it if reviewing quickly.

I don't want to drag this out interminably but I do want to make sure the group is aware of this change, before returning the document to Alvaro for advancement. I'll also make sure we mention it during the IDR meeting tomorrow. 

Thanks,

--John

> On Mar 9, 2018, at 1:48 PM, Acee Lindem (acee) <[email-masked]> wrote:
> 
> Hi Sue, Alvaro, IDR WG,
>  
>   <>
> The changes are removal of the IPv6 SID TLV/SRv6 data plane and error/conflict handling modifications to section 4. The reasons for removing the IPv6 SID TLV were explained in https://mailarchive.ietf.org/arch/msg/idr/3YE8hDCj0ky0NPFoLrTHV2AAEJ8 <https://urldefense.proofpoint.com/v2/url?u=https-3A__mailarchive.ietf.org_arch_msg_idr_3YE8hDCj0ky0NPFoLrTHV2AAEJ8&d=DwMGaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=hLt5iDJpw7ukqICc0hoT7A&m=WGUfpxYrh9724KMU8rPD4r0IXQC68R_5FBGmzx2OsSw&s=TcIfwaxEmg2iAtMCMAnUWweAfo1uL6t9zvnofDuFurE&e=>. The error/conflict handling changes were made based on fruitful  review comments and discussions very late in the process.
>

---

From: "John G. Scudder" <[email-masked]>
Date: Sun, 18 Mar 2018 17:37:09 +0000

Speaking as an individual contributor, the change looks like an improvement to me. It would be interesting to know if anyone has implemented the "or all but one" clause in the version 16 text, though. If they haven't, then the change seems like a no-brainer.

Thanks,

--John

> On Mar 18, 2018, at 5:31 PM, John G. Scudder <[email-masked]> wrote:
> 
> Hi All,
> 
>> On Mar 9, 2018, at 1:48 PM, Acee Lindem (acee) <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi Sue, Alvaro, IDR WG,
>>  
>> From: Idr <[email-masked] <mailto:[email-masked]>> on behalf of Susan Hares <[email-masked] <mailto:[email-masked]>>
>> To: IDR List <[email-masked] <mailto:[email-masked]>>
>> Cc: "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>

---

From: "John G. Scudder" <[email-masked]>
Date: Tue, 27 Mar 2018 08:48:19 -0500

This last call has concluded. We'll (re) send the draft to the IESG for advancement.

Thanks,

--John

> On Feb 23, 2018, at 5:09 PM, Susan Hares <[email-masked]> wrote:
> 
>  
> The changes are removal of the IPv6 SID TLV/SRv6 data plane and error/conflict handling modifications to section 4. The reasons for removing the IPv6 SID TLV were explained in https://mailarchive.ietf.org/arch/msg/idr/3YE8hDCj0ky0NPFoLrTHV2AAEJ8 <https://urldefense.proofpoint.com/v2/url?u=https-3A__mailarchive.ietf.org_arch_msg_idr_3YE8hDCj0ky0NPFoLrTHV2AAEJ8&d=DwMFAg&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=hLt5iDJpw7ukqICc0hoT7A&m=0MY3l8S5__g0yJoaYq3KeJbmh6jop9RM0-dR_tfjOKE&s=g0G6UhDGw-CfBjU-momMskgovXMUR1rvbIx5womP0sI&e=>. The error/conflict handling changes were made based on fruitful  review comments and discussions very late in the process. 
>