Subject: [Idr] I-D Action: draft-ietf-idr-route-leak-detection-mitigation-08.txt

From: [email-masked]
Date: Mon, 05 Mar 2018 15:34:24 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Inter-Domain Routing WG of the IETF.

        Title           : Methods for Detection and Mitigation of BGP Route Leaks
        Authors         : Kotikalapudi Sriram
                          Doug Montgomery
                          Brian Dickson
                          Keyur Patel
                          Andrei Robachevsky
	Filename        : draft-ietf-idr-route-leak-detection-mitigation-08.txt
	Pages           : 24
	Date            : 2018-03-05

Abstract:
   Problem definition for route leaks and enumeration of types of route
   leaks are provided in RFC 7908.  This document specifies BGP
   enhancements that significantly extend its route-leak detection and
   mitigation capabilities.  The solution involves carrying a per-hop
   route-leak protection (RLP) field in BGP updates.  The RLP fields are
   carried in a new optional transitive attribute, called BGP RLP
   attribute.  The RLP attribute helps with detection and mitigation of
   route leaks at ASes downstream from the leaking AS (in the path of
   BGP update).  This is an inter-AS (multi-hop) solution mechanism.
   This solution complements the intra-AS (local AS) route-leak
   avoidance solution that is described in ietf-idr-bgp-open-policy
   draft.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-idr-route-leak-detection-mitigation/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-idr-route-leak-detection-mitigation-08
https://datatracker.ietf.org/doc/html/draft-ietf-idr-route-leak-detection-mitigation-08

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-idr-route-leak-detection-mitigation-08

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Sriram, Kotikalapudi (Fed)" <[email-masked]>
Date: Tue, 6 Mar 2018 17:53:14 +0000

We (the authors) have updated the draft substantially. 

1. The draft now focuses on the RLP solution which is inter-AS (multi-hop). 
      (Note: The intra-AS (local AS) solution with eOTC Attribute is provided in the bgp-open-policy draft.) 
2. The main body is now concise since several sections have moved into the Appendices.
3. The sections that appear in the Appendices are:
      A. Related prior-work review 
      B. Intra-AS route leak prevention with Community  (includes inputs from NANOG list) 
      C. Stopgap solution
      D. Design Rationale and Discussion (highlights of IDR/GROW discussions captured here).

Thanks for all the suggestions/discussion so far. Further comments are welcome anytime.

Thank you.
Sriram

---------------------------------------------

Abstract