Subject: [Idr] 2 week WG adoption call - draft-scudder-idr-capability-registry-change (9/20/2018 to 10/4/2018)

From: "Susan Hares" <[email-masked]>
Date: Thu, 20 Sep 2018 10:11:23 -0400

Greetings all: 

Based on the messages on the IDR list, there seems to be interest to start a
2 week WG adoption call for
draft-scudder-idr-capabilities-registry-change-02.txt.  The WG adoption call
will go from 9/20/2018 to 10/4/2018. 

You can obtain the document quickly by clicking on the link below: 

https://datatracker.ietf.org/doc/draft-scudder-idr-capabilities-registry-cha
nge/

Please include comments on operational impacts on this proposal. 

Susan Hares 

Co-chair IDR

---

From: <[email-masked]>
Date: Thu, 20 Sep 2018 15:22:16 +0000

1) Support WG adoption.

2)

> Please include comments on operational impacts on this proposal.

The main risk seems collision between future allocation and past usage. IMHO the document adequately covers this by calling for past usages, and given the remaining unallocated space in existing FCFS range (74-127)  (i.e. before we reach the collision range).

Also, that collision risk already exists as of today if we consider that "BGP Capability Codes do not meet the criteria for "Reserved for Private Use" described in [RFC5226<https://tools.ietf.org/html/rfc5226>] S. 4.1.". In this regards, the document improves the situation, so the faster the change, the better.

3) Please find below 2 nits and 1 minor comment

:s/ [RFC5226<https://tools.ietf.org/html/rfc5226>]/ [RFC8126<https://tools.ietf.org/html/rfc8126>]

----

OLD :

   128-238: First Come First Served

NEW :

   128: Reserved

   129-238: First Come First Served

(in order to be consistent with    IANA is requested to allocate value 128 as "Reserved".

---

"   Finally, we invite implementors who have used values in the range

   128-255 to contribute to this draft, so that the values can be

   included in the registry. >

+1
Recalling another thread (from John) some years ago, about whether one could ask for any value or only the next one/the one chosen by IANA...I don't remember its conclusion.
In order to handle post RFC publication contributions, may be we could add a text to ask IANA to allow for request with specific value in the range 129-238.

Thanks,
Regards,
--Bruno

From: Idr [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Thursday, September 20, 2018 4:11 PM
To: 'idr'
Cc: [email-masked]
Subject: [Idr] 2 week WG adoption call - draft-scudder-idr-capability-registry-change (9/20/2018 to 10/4/2018)

Greetings all:

Based on the messages on the IDR list, there seems to be interest to start a 2 week WG adoption call for  draft-scudder-idr-capabilities-registry-change-02.txt.  The WG adoption call will go from 9/20/2018 to 10/4/2018.

https://datatracker.ietf.org/doc/draft-scudder-idr-capabilities-registry-change/

Susan Hares
Co-chair IDR

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.