Subject: [Idr] Requesting WG adoption for draft-scudder-idr-capabilities-registry-change-02.txt

From: John Scudder <[email-masked]>
Date: Thu, 20 Sep 2018 06:10:55 +0000

Hi All,

People with sharp memories may recall that in 2015 I proposed we revise the BGP Capabilities registry to provide a good-sized FCFS space. I think our experience shows this works fine in practice and makes it easier for implementors to get code points in a timely fashion, helping prevent conflicts. I wrote a draft at that time but failed to follow it up. I've revised the draft and would like to propose it as a WG item. Here's the abstract:

   This document updates RFC 5492 by making a change to the registration
   procedures for BGP Capability Codes.  Specifically, the range
   formerly designated "Reserved for Private Use" is divided into three
   new ranges, respectively designated as "First Come First Served",
   "Experimental" and "Reserved".

One thing to draw your attention to in the revised draft:

   Finally, we invite implementors who have used values in the range
   128-255 to contribute to this draft, so that the values can be
   included in the registry.

That is, if you have a shipped implementation that's using one of the Private Use values, please contribute that information to the draft and (assuming the draft progresses) you'll automatically get a registered code point.

https://www.ietf.org/id/draft-scudder-idr-capabilities-registry-change-02.txt

Thanks,

--John (an individual contributor to the WG, and recusing myself as co-chair from the adoption and subsequent process)

---

From: Randy Bush <[email-masked]>
Date: Thu, 20 Sep 2018 10:28:35 +0200

do it

---

From: Sander Steffann <[email-masked]>
Date: Thu, 20 Sep 2018 11:00:18 +0200

Hi,

> People with sharp memories may recall that in 2015 I proposed we revise the BGP Capabilities registry to provide a good-sized FCFS space. I think our experience shows this works fine in practice and makes it easier for implementors to get code points in a timely fashion, helping prevent conflicts. I wrote a draft at that time but failed to follow it up. I've revised the draft and would like to propose it as a WG item.

I think this should be adopted as a WG item.

Cheers,
Sander

---

From: "Van De Velde, Gunter (Nokia - BE/Antwerp)" <[email-masked]>
Date: Thu, 20 Sep 2018 09:42:36 +0000

Yes, support. This work will help future work progress more effective.

G/

-----Original Message-----
From: Idr <[email-masked]> On Behalf Of John Scudder
Sent: Thursday, September 20, 2018 08:11
To: [email-masked]
Cc: [email-masked]
Subject: [Idr] Requesting WG adoption for draft-scudder-idr-capabilities-registry-change-02.txt

Hi All,

Thanks,

_______________________________________________
Idr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/idr

---

From: "Jakob Heitz (jheitz)" <[email-masked]>
Date: Fri, 21 Sep 2018 00:48:11 +0000

I support. Thanks John.

Regards,
Jakob.

-----Original Message-----
From: Idr <[email-masked]> On Behalf Of John Scudder
Sent: Wednesday, September 19, 2018 11:11 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Idr] Requesting WG adoption for draft-scudder-idr-capabilities-registry-change-02.txt

Hi All,

Thanks,

---

From: Gaurav Dawra <[email-masked]>
Date: Thu, 20 Sep 2018 23:03:16 -0700

Makes sense. Support!

Gaurav

Sent from my iPhone

> On Sep 19, 2018, at 11:10 PM, John Scudder <[email-masked]> wrote:
> 
> Hi All,
>

---

From: Joel Jaeggli <[email-masked]>
Date: Fri, 21 Sep 2018 09:08:17 +0200

Sent from my iPhone

> On Sep 20, 2018, at 08:10, John Scudder <[email-masked]> wrote:
> 
> Hi All,
> 

Support working on this.

Making these registries more acessible reduces the incentive to go off and do your own thing.

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Wed, 26 Sep 2018 09:41:31 +0000

Yes, support. This would be helpful to avoid conflicts in future. 

Best regards,
Jie

> From: John Scudder [mailto:[email-masked]]
> Sent: Thursday, September 20, 2018 2:11 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Requesting WG adoption for
> draft-scudder-idr-capabilities-registry-change-02.txt
> 
> Hi All,
> 
> People with sharp memories may recall that in 2015 I proposed we revise the
> BGP Capabilities registry to provide a good-sized FCFS space. I think our
> experience shows this works fine in practice and makes it easier for
> implementors to get code points in a timely fashion, helping prevent conflicts. I
> wrote a draft at that time but failed to follow it up. I've revised the draft and
> would like to propose it as a WG item. Here's the abstract:
> 
> That is, if you have a shipped implementation that's using one of the Private Use
> values, please contribute that information to the draft and (assuming the draft
> progresses) you'll automatically get a registered code point.
>