Subject: [Idr] Some editorial issues related to draft-ietf-idr-segment-routing-te-policy-04

From: Zhuangshunwan <[email-masked]>
Date: Sat, 8 Sep 2018 09:00:59 +0000

Dear authors,

Thank you for providing a good document for us.
There may be some editorial issues in this document.

Page 14 of draft-ietf-idr-segment-routing-te-policy-04  has the following texts:

Type  1: SID only, in the form of MPLS Label
Type  2: SID only, in the form of IPv6 address
Type  3: IPv4 Node Address with optional SID
Type  4: IPv6 Node Address with optional SID for SR MPLS
Type  5: IPv4 Address + index with optional SID
Type  6: IPv4 Local and Remote addresses with optional SID
Type  7: IPv6 Address + index for local and remote pair with optional SID for SR MPLS
Type  8: IPv6 Local and Remote addresses with optional SID for SR MPLS
Type  9: IPv6 Node Address with optional SID for SRv6
Type 10: IPv6 Address + index for local and remote pair with optional SID for SRv6
Type 11: IPv6 Local and Remote addresses for SRv6

Since "Type 9" has been assigned to Weight Sub-TLV per draft-ietf-idr-segment-routing-te-policy-04, so above texts would be as follows:

Type  1: SID only, in the form of MPLS Label
Type  2: SID only, in the form of IPv6 address
Type  3: IPv4 Node Address with optional SID
Type  4: IPv6 Node Address with optional SID for SR MPLS
Type  5: IPv4 Address + index with optional SID
Type  6: IPv4 Local and Remote addresses with optional SID
Type  7: IPv6 Address + index for local and remote pair with optional SID for SR MPLS
Type  8: IPv6 Local and Remote addresses with optional SID for SR MPLS
Type 10: IPv6 Node Address with optional SID for SRv6
Type 11: IPv6 Address + index for local and remote pair with optional SID for SRv6
Type 12: IPv6 Local and Remote addresses for SRv6

If I don't understand it correctly, please give me some help.

Thanks,
Shunwan

---

From: "Dhanendra Jain (dhjain)" <[email-masked]>
Date: Mon, 10 Sep 2018 18:29:13 +0000

Hi Shunwan,

The Types in this section reflect the list of defined Segment Types from SR Policy architecture doc.

The  type code  within sub-TLVs corresponding to the Segment Types (9,10,11) are shifted by 1 to accommodate existing Weight sub-tlv type code (9).
These Segment Types were added later.

This is reflected in IANA code point table in section 8.4.

HTH,
Dhanendra

From: Idr <[email-masked]> on behalf of Zhuangshunwan <[email-masked]>
Date: Saturday, September 8, 2018 at 2:01 AM
To: "[email-masked]" <[email-masked]>
Subject: [Idr] Some editorial issues related to draft-ietf-idr-segment-routing-te-policy-04

Dear authors,

Thanks,
Shunwan