Subject: [Idr] I-D Action: draft-ietf-idr-flowspec-l2vpn-09.txt

From: [email-masked]
Date: Thu, 03 Jan 2019 01:33:05 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Inter-Domain Routing WG of the IETF.

        Title           : BGP Dissemination of L2VPN Flow Specification Rules
        Authors         : Weiguo Hao
                          Donald E. Eastlake, 3rd
                          James Uttaro
                          Stephane Litkowski
                          Shunwan Zhuang
	Filename        : draft-ietf-idr-flowspec-l2vpn-09.txt
	Pages           : 13
	Date            : 2019-01-03

Abstract:
   This document defines a BGP flow-spec extension to disseminate L2 VPN
   Ethernet traffic filtering rules.  SAFI=134 in [RFC5575] is redefined
   for this purpose.  A new subset of component types and extended
   community also are defined.  A new subset of component types and new
   extended community also are defined.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-idr-flowspec-l2vpn/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-idr-flowspec-l2vpn-09
https://datatracker.ietf.org/doc/html/draft-ietf-idr-flowspec-l2vpn-09

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-idr-flowspec-l2vpn-09

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Robert Raszuk <[email-masked]>
Date: Thu, 3 Jan 2019 12:03:16 +0100

Hi,

Two observations:

1.

The current draft extends exisiting SAFI 134 with new NLRI types.

That means that now we have new giant NLRI in SAFI 134.

Have any consideration been made to just define a new flow spec

SAFI instead for L2 filtering ? I am quite skeptical from implementation,

operational and deployment points of view to extend the existing SAFI and it

makes a gradual deployment a nightmare if not mission impossible.

Any change to NLRI format without signalling it with new capability is

far from good practice.

2.

The draft is pretty silent on adjusting validation procedures to make sure only

senders of the original L2 information may inject the L2 flow routes.

I would hope that this is basic omission and will be consider for addition into

next version of he draft.

Thx,

R.

On Thu, Jan 3, 2019 at 10:33 AM <[email-masked]> wrote:

> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>

---

From: "Jakob Heitz (jheitz)" <[email-masked]>
Date: Mon, 7 Jan 2019 05:09:15 +0000

Both are good points.

Regards,
Jakob.

From: Idr <[email-masked]> On Behalf Of Robert Raszuk
Sent: Thursday, January 3, 2019 3:03 AM
To: idr@ietf. org <[email-masked]>
Subject: Re: [Idr] I-D Action: draft-ietf-idr-flowspec-l2vpn-09.txt

Hi,

Two observations:

1.

far from good practice.

2.

senders of the original L2 information may inject the L2 flow routes..

Thx,

R.

On Thu, Jan 3, 2019 at 10:33 AM <[email-masked]<mailto:[email-masked]>> wrote:

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

[email-masked]<mailto:[email-masked]>

---

From: Jeff Tantsura <[email-masked]>
Date: Sun, 6 Jan 2019 21:23:21 -0800

+1

On Thu, Jan 3, 2019 at 03:04 Robert Raszuk <[email-masked]> wrote:

> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr
>