Subject: [Idr] Comments on draft-ietf-idr-flowspec-path-redirect

From: Yu Tianpeng <[email-masked]>
Date: Sat, 16 Mar 2019 13:32:28 -0700

Hi Van de Velde,
When I was reading this draft, I found this draft miss the consideration on
the concept of "color".
Color now has been defined in a couple of drafts and becoming an important
concept.
There can be at least two usages along with flowspec so far I have found:

1. redirect to a color of a SR policy (refer to
draft-ietf-spring-segment-routing-policy).
This draft defines the concept of SR policy which can install a list of
segments allowing per-flow based source routing.
To allow usage of SR-policy along with draft (redirect to a SR-policy), we
can simply use BSID which has been defined in the current draft.
But there is also a scenario defined called "color only steering in section
8.8.1" I would suggest taking into consideration.

2. Flex-Algo
By redirecting to color, we are able to redirect traffic to another alogo
topology/slice.

By the way, I didn't see the resilence consideration in this draft as the
redirected path is always a BSID, and there is no place to pre-install the
backup path.
Did I miss something here?

What is your idea about this?

Comments above apply to your ietf0-srv6 one :)

Thanks in advance.
Regards,
Tim

---

From: [email-masked]
Date: Sat, 16 Mar 2019 23:17:20 +0000 (UTC)

Hi Tim, 

Thanks for reading the draft. Interresting observation.

To my understanding flex algo is orthogonal with flowspec path redirect. The current flowspec draft already support redirect to mpls label or index. Not sure what else is missing. If you plan to redirect to a remote IP address and add a collor then i think we talk about extending https://tools.ietf.org/html/draft-ietf-idr-flowspec-redirect-ip-02. 

The flowspec redirect to path has no capability to match upon bsid or mpls label and is primarily scoped to use rfc5575 type address matching.

If comments refer to the ietf0-srv6 draft, then Huaimo Chen authored that draft and can comment better.

Kind regards,

G/

On Sat, Mar 16, 2019 at 1:32 PM -0700, "Yu Tianpeng" <[email-masked]> wrote:

Hi Van de Velde,When I was reading this draft, I found this draft miss the consideration on the concept of "color".Color now has been defined in a couple of drafts and becoming an important concept.There can be at least two usages along with flowspec so far I have found:
1. redirect to a color of a SR policy (refer to draft-ietf-spring-segment-routing-policy).This draft defines the concept of SR policy which can install a list of segments allowing per-flow based source routing.To allow usage of SR-policy along with draft (redirect to a SR-policy), we can simply use BSID which has been defined in the current draft.But there is also a scenario defined called "color only steering in section 8.8.1" I would suggest taking into consideration.
2. Flex-Algo By redirecting to color, we are able to redirect traffic to another alogo topology/slice.. 
By the way, I didn't see the resilence consideration in this draft as the redirected path is always a BSID, and there is no place to pre-install the backup path.Did I miss something here? 
What is your idea about this? 
Comments above apply to your ietf0-srv6 one :)
Thanks in advance.Regards,Tim