Subject: [Idr] BGP flooding and AS-PATH

From: Robert Raszuk <[email-masked]>
Date: Mon, 11 Mar 2019 10:34:44 +0100

Dear authors of draft-ketant-idr-bgp-ls-bgp-only-fabric,

I would like to ask for a small clarification on how in the quoted RFC7938
design are you going to propagate topology information between peers
configured with the same AS number ? Say between devices belonging to tier
1 stage or to a sets in tier 2 stages ?

Do you assume that those switches just do not need to be aware of each
other's presence say for TE purposes ?

Specifically I am curious how are you going to accomplish it in the cases
where no AS-PATH removing controller is involved as described here:

"An internal software component on any of the BGP routers

(e.g. TE module) can also receive the entire BGP network

topology information from its local BGP process."

Thx a lot,
R.

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Mon, 11 Mar 2019 10:41:21 +0000

Hi Robert,

Please check inline below.

From: Robert Raszuk <[email-masked]>
Sent: 11 March 2019 15:05
To: Ketan Talaulikar (ketant) <[email-masked]>
Cc: idr@ietf. org <[email-masked]>
Subject: BGP flooding and AS-PATH

I would like to ask for a small clarification on how in the quoted RFC7938 design are you going to propagate topology information between peers configured with the same AS number ? Say between devices belonging to tier 1 stage or to a sets in tier 2 stages ?

Do you assume that those switches just do not need to be aware of each other's presence say for TE purposes ?
[KT] This isn’t necessary in the use-cases where controller is doing the TE computations. E.g. a TOR can delegate end to end TE computation (from itself all the way over the DCI/WAN to a remote node) to the controller.

Specifically I am curious how are you going to accomplish it in the cases where no AS-PATH removing controller is involved as described here:

[KT] This is a different variant of the TE use-case where the TOR itself can do TE computation. In this case, you are correct about the topology flooding via the controller when using the ASN scheme in https://tools.ietf.org/html/rfc7938#section-5.2.1 . For this use-case, there are other options and designs though (incl private AS for unique assignment to TORs, allowAS-in, etc.) to make this possible.

Thanks,

Ketan

Thx a lot,
R.

---

From: Robert Raszuk <[email-masked]>
Date: Mon, 11 Mar 2019 12:38:13 +0100

Hi Ketan,

I was not talking about TORs .. they will get all info just fine.

I was talking about same stage peers as they can have same AS number and
with eBGP there may be a bit of challenge to get BGP updates accepted
orignated by same level device.

And I was only waiting for you to mention allowas-in or as-overwrite knobs
;)

Can you reflect those options in the draft? Or at least in any other way
address this scenario ?

Kind regards,
R.

On Mon, Mar 11, 2019, 11:41 Ketan Talaulikar (ketant) <[email-masked]>
wrote:

> *From:* Robert Raszuk <[email-masked]>
> *Sent:* 11 March 2019 15:05
> *To:* Ketan Talaulikar (ketant) <[email-masked]>
> *Cc:* idr@ietf. org <[email-masked]>
> *Subject:* BGP flooding and AS-PATH
>
>
>
> *[KT] This isn’t necessary in the use-cases where controller is doing the
> TE computations. E.g. a TOR can delegate end to end TE computation (from
> itself all the way over the DCI/WAN to a remote node) to the controller.*
>
>
>
> *[KT] This is a different variant of the TE use-case where the TOR itself can do TE computation. In this case, you are correct about the topology flooding via the controller when using the ASN scheme in https://tools.ietf.org/html/rfc7938#section-5.2.1 <https://tools.ietf.org/html/rfc7938#section-5.2.1> . For this use-case, there are other options and designs though (incl private AS for unique assignment to TORs, allowAS-in, etc.) to make this possible.*
>
>
>
> *Thanks,*
>
> *Ketan*
>
>
>
> Thx a lot,
>
> R.
>
>
>

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Mon, 11 Mar 2019 12:23:43 +0000

Agreed, Robert. Will capture this in the next update and thanks for your review and for pointing this out.

Thanks,
Ketan

From: Robert Raszuk <[email-masked]>
Sent: 11 March 2019 17:08
To: Ketan Talaulikar (ketant) <[email-masked]>
Cc: idr@ietf. org <[email-masked]>
Subject: Re: BGP flooding and AS-PATH

Hi Ketan,

I was talking about same stage peers as they can have same AS number and with eBGP there may be a bit of challenge to get BGP updates accepted orignated by same level device.

And I was only waiting for you to mention allowas-in or as-overwrite knobs ;)

Can you reflect those options in the draft? Or at least in any other way address this scenario ?

Kind regards,
R.

On Mon, Mar 11, 2019, 11:41 Ketan Talaulikar (ketant) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Robert,

From: Robert Raszuk <[email-masked]<mailto:[email-masked]>>
Sent: 11 March 2019 15:05
To: Ketan Talaulikar (ketant) <[email-masked]<mailto:[email-masked]>>
Cc: idr@ietf. org <[email-masked]<mailto:[email-masked]>>
Subject: BGP flooding and AS-PATH

Thanks,

Ketan

Thx a lot,
R.