Subject: [Idr] I-D Action: draft-ietf-idr-bgpls-inter-as-topology-ext-01.txt

From: [email-masked]
Date: Wed, 06 Mar 2019 19:53:43 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Inter-Domain Routing WG of the IETF.

        Title           : BGP-LS Extension for Inter-AS Topology Retrieval
        Authors         : Aijun Wang
                          Huaimo Chen
                          Shaowen Ma
	Filename        : draft-ietf-idr-bgpls-inter-as-topology-ext-01.txt
	Pages           : 11
	Date            : 2019-03-06

Abstract:
   This document describes the process to build BGP-LS key parameters in
   multi-domain scenario, defines one new BGP-LS NLRI type(Inter-AS TE
   Link NLRI) and some new inter-AS TE related TLVs for BGP-LS to let
   SDN controller retrieve the network topology automatically under
   various environments.

   Such process and extension can enable the network operator to collect
   the connection information between different domains and then
   calculate the overall network topology automatically based on the
   information provided by BGP-LS protocol.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-idr-bgpls-inter-as-topology-ext/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-idr-bgpls-inter-as-topology-ext-01
https://datatracker.ietf.org/doc/html/draft-ietf-idr-bgpls-inter-as-topology-ext-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-idr-bgpls-inter-as-topology-ext-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Robert Raszuk <[email-masked]>
Date: Thu, 7 Mar 2019 11:40:09 +0100

Dear authors of draft-ietf-idr-bgpls-inter-as-topology-ext-01,

Can you clarify why extensions already defined in
https://tools.ietf.org/html/draft-ietf-idr-bgpls-segment-routing-epe-17 are
not sufficient to cover your use case ?

As a side observation normally peering links are enabled in the IGP as
passive - not "redistributed as static routes".

Thx,
R.

On Thu, Mar 7, 2019 at 4:53 AM <[email-masked]> wrote:

> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr
>

---

From: "Aijun Wang" <[email-masked]>
Date: Fri, 8 Mar 2019 13:05:29 +0800

Hi, Robert:

We have stated our thoughts for your concerned issue in the introduction part(section-1 <https://tools.ietf.org/html/draft-ietf-idr-bgpls-inter-as-topology-ext-01#section-1> ) of this draft. 

The main reason is the consideration of deployment flexibility(Requiring every border router to run BGP-LS).  Can it answer your concern?

For your second question, using passive interface is another solution.  If so, we can put the passive interfaces information within the newly defined inter-AS NLRI.

Thanks for your comments, wish more comments from you.

Best Regards.

Aijun Wang

Network R&D and Operation Support Department

China Telecom Corporation Limited Beijing Research Institute,Beijing, China.

发件人: Robert Raszuk [mailto:[email-masked]] 
发送时间: 2019年3月7日 18:40
收件人: idr@ietf. org
主题: Re: [Idr] I-D Action: draft-ietf-idr-bgpls-inter-as-topology-ext-01.txt

Can you clarify why extensions already defined in https://tools.ietf.org/html/draft-ietf-idr-bgpls-segment-routing-epe-17 are not sufficient to cover your use case ? 

As a side observation normally peering links are enabled in the IGP as passive - not "redistributed as static routes". 

Thx,

R.

Abstract:

The IETF datatracker status page for this draft is:
https://datatracker.ietf..org/doc/draft-ietf-idr-bgpls-inter-as-topology-ext/ <https://datatracker.ietf.org/doc/draft-ietf-idr-bgpls-inter-as-topology-ext/>