Subject: [Idr] draft-li-idr-bgp-ls-sbfd-extensions-03.txt - 2 week WG adoption call

From: "Susan Hares" <[email-masked]>
Date: Thu, 18 Apr 2019 10:24:47 -0400

This begins a 2 week WG adoption call for
draft-li-idr-bgp-ls-sbfd-extensions-03.txt.  You can access the document at:

https://datatracker.ietf.org/doc/draft-li-idr-bgp-ls-sbfd-extensions/

During your comments, please consider the following:

1)      Does adding the announcement of seamless S-BFD descriptors via BGP
LS address family benefit network provisioning?  

2)      Is it important to keep the same BGP-ls information in OSPF, IS-IS,
and BGP regarding S-BFD discriminators? 

3)      Is this document mature enough for WG Adoption? 

4)      Are there any issues that the WG should consider to help quicken the
pace of the adoption? 

5)      Do you know of planned implementations?  If so, should is this
document mature enough to receive early allocation for the BGP-LS code
points. 

Remember that raising issues regarding document during WG adoption will help
us speed this BGP-LS WG document toward WG LC. 

Cheerily, Susan Hares

---

From: Huaimo Chen <[email-masked]>
Date: Thu, 18 Apr 2019 14:33:03 +0000

Support.

Best Regards,
Huaimo
From: Idr [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Thursday, April 18, 2019 10:25 AM
To: [email-masked]
Subject: [Idr] draft-li-idr-bgp-ls-sbfd-extensions-03.txt - 2 week WG adoption call

This begins a 2 week WG adoption call for draft-li-idr-bgp-ls-sbfd-extensions-03.txt.  You can access the document at:

1)      Does adding the announcement of seamless S-BFD descriptors via BGP LS address family benefit network provisioning?

2)      Is it important to keep the same BGP-ls information in OSPF, IS-IS, and BGP regarding S-BFD discriminators?

4)      Are there any issues that the WG should consider to help quicken the pace of the adoption?

5)      Do you know of planned implementations?  If so, should is this document mature enough to receive early allocation for the BGP-LS code points.

Remember that raising issues regarding document during WG adoption will help us speed this BGP-LS WG document toward WG LC.

Cheerily, Susan Hares

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Thu, 18 Apr 2019 15:27:16 +0000

Support as co-author.

  1.  Does adding the announcement of seamless S-BFD descriptors via BGP LS address family benefit network provisioning?
This is not really part of network provisioning as much as distribution of the SBFD discriminators that are flooded within IGP area/level to centralized controllers so that they can be leveraged for SBFD verification of paths across multi-domain/AS (under a single admin domain)

  1.  Is it important to keep the same BGP-ls information in OSPF, IS-IS, and BGP regarding S-BFD discriminators?
I did not quite follow this question.

  1.  Is this document mature enough for WG Adoption?
Yes. It is simple extension - like many others in BGP-LS for defining new TLV corresponding to IGP specs. The concerned IGP specs are now rfc7884 and rfc7883 - so definitely quite mature.

  1.  Are there any issues that the WG should consider to help quicken the pace of the adoption?
SBFD is getting wider use due to it's simplicity and lightweight procedures. This extension in BGP-LS enables controllers to learn SBFD discriminators for running verifications across domains. So faster adoption would help development of those use-cases.

  1.  Do you know of planned implementations?  If so, should is this document mature enough to receive early allocation for the BGP-LS code points.
Yes. Early allocation would be requested.

Thanks,
Ketan

From: Idr <[email-masked]> On Behalf Of Susan Hares
Sent: 18 April 2019 19:55
To: [email-masked]
Subject: [Idr] draft-li-idr-bgp-ls-sbfd-extensions-03.txt - 2 week WG adoption call

  1.  Does adding the announcement of seamless S-BFD descriptors via BGP LS address family benefit network provisioning?
  2.  Is it important to keep the same BGP-ls information in OSPF, IS-IS, and BGP regarding S-BFD discriminators?
  3.  Is this document mature enough for WG Adoption?
  4.  Are there any issues that the WG should consider to help quicken the pace of the adoption?
  5.  Do you know of planned implementations?  If so, should is this document mature enough to receive early allocation for the BGP-LS code points.

Cheerily, Susan Hares

---

From: "Krishna Muddenahally Ananthamurthy (kriswamy)" <[email-masked]>
Date: Thu, 18 Apr 2019 19:07:06 +0000

I support.

Thanks
Krishna

From: Idr <[email-masked]> on behalf of Susan Hares <[email-masked]>
Date: Thursday, April 18, 2019 at 7:25 AM
To: "[email-masked]" <[email-masked]>
Subject: [Idr] draft-li-idr-bgp-ls-sbfd-extensions-03.txt - 2 week WG adoption call

Cheerily, Susan Hares

---

From: Jeff Tantsura <[email-masked]>
Date: Thu, 18 Apr 2019 17:40:04 -0700

support as co-author
+1 Ketan

Cheers,
Jeff
On Apr 18, 2019, 8:27 AM -0700, Ketan Talaulikar (ketant) <[email-masked]>, wrote:
> Yes. It is simple extension – like many others in BGP-LS for defining new TLV corresponding to IGP specs. The concerned IGP specs are now rfc7884 and rfc7883 – so definitely quite mature.
>
>
> SBFD is getting wider use due to it’s simplicity and lightweight procedures. This extension in BGP-LS enables controllers to learn SBFD discriminators for running verifications across domains. So faster adoption would help development of those use-cases.
>
>
> https://datatracker.ietf..org/doc/draft-li-idr-bgp-ls-sbfd-extensions/
>
> _______________________________________________
> Idr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/idr

---

From: Zhuangshunwan <[email-masked]>
Date: Fri, 19 Apr 2019 09:31:24 +0000

Support.

Best Regards,
Shunwan

rom: Idr [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Thursday, April 18, 2019 10:25 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Idr] draft-li-idr-bgp-ls-sbfd-extensions-03.txt - 2 week WG adoption call

Cheerily, Susan Hares

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 19 Apr 2019 10:44:12 +0000

Support. In the future, we’re going to combine BGP-LS for simple extensions like this in the IGP drafts defining the extensions.
Thanks,
Acee

From: Idr <[email-masked]> on behalf of Jeff Tantsura <[email-masked]>
Date: Thursday, April 18, 2019 at 8:40 PM
To: Susan Hares <[email-masked]>, IDR List <[email-masked]>
Subject: Re: [Idr] draft-li-idr-bgp-ls-sbfd-extensions-03.txt - 2 week WG adoption call

support as co-author
+1 Ketan

Cheers,
Jeff

Support as co-author.

Thanks,
Ketan

https://datatracker.ietf..org/doc/draft-li-idr-bgp-ls-sbfd-extensions/<https://datatracker.ietf.org/doc/draft-li-idr-bgp-ls-sbfd-extensions/>

Cheerily, Susan Hares

---

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Fri, 19 Apr 2019 10:48:42 +0000

+1 😊

From: Idr <[email-masked]> On Behalf Of Acee Lindem (acee)
Sent: 19 April 2019 16:14
To: Jeff Tantsura <[email-masked]>; Susan Hares <[email-masked]>; [email-masked]
Subject: Re: [Idr] draft-li-idr-bgp-ls-sbfd-extensions-03.txt - 2 week WG adoption call

From: Idr <[email-masked]<mailto:[email-masked]>> on behalf of Jeff Tantsura <[email-masked]<mailto:[email-masked]>>
Date: Thursday, April 18, 2019 at 8:40 PM
To: Susan Hares <[email-masked]<mailto:[email-masked]>>, IDR List <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Idr] draft-li-idr-bgp-ls-sbfd-extensions-03.txt - 2 week WG adoption call

support as co-author
+1 Ketan

Cheers,
Jeff
On Apr 18, 2019, 8:27 AM -0700, Ketan Talaulikar (ketant) <[email-masked]<mailto:[email-masked]>>, wrote:
Support as co-author.

Thanks,
Ketan

From: Idr <[email-masked]<mailto:[email-masked]>> On Behalf Of Susan Hares
Sent: 18 April 2019 19:55
To: [email-masked]<mailto:[email-masked]>
Subject: [Idr] draft-li-idr-bgp-ls-sbfd-extensions-03.txt - 2 week WG adoption call

Cheerily, Susan Hares
_______________________________________________
Idr mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/idr

---

From: Linda Dunbar <[email-masked]>
Date: Fri, 19 Apr 2019 14:49:55 +0000

Support,

Linda Dunbar

Cheerily, Susan Hares

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Sat, 20 Apr 2019 01:34:37 +0000

Support and agree with Acee about the combination for future extensions.

Best regards,
Jie

From: Idr [mailto:[email-masked]] On Behalf Of Acee Lindem (acee)
Sent: Friday, April 19, 2019 6:44 PM
To: Jeff Tantsura <[email-masked]>; Susan Hares <[email-masked]>; [email-masked]
Subject: Re: [Idr] draft-li-idr-bgp-ls-sbfd-extensions-03.txt - 2 week WG adoption call

support as co-author
+1 Ketan

Cheers,
Jeff

Thanks,
Ketan

Cheerily, Susan Hares