Subject: [Idr] Mail regarding draft-ietf-idr-segment-routing-te-policy

From: Chaitanya Varma <[email-masked]>
Date: Tue, 30 Apr 2019 13:34:26 +0530

Hi,

I have couple of queries from the below draft.

https://tools.ietf.org/html/draft-ietf-idr-segment-routing-te-policy-05

*  “ Typically, a controller defines the set of policies and advertise*

*   them to policy head-end routers (typically ingress routers).” *

How do we communicate SR policies from controller? Is it through BGP-SR
session or PCEP session.

a. If it is through PCEP session what happens if the PCC is non-headend?

b. If it is through BGP-SR what is the role for PCEP between PCE and PCC?

*  “ Moreover, one or more route-target SHOULD be attached to the*

*   advertisement”*How Route-target should be attached to a SR-NLRI update?

Is it done through local configuration or picked up based on some dynamic
parameter?

Appreciate if you can help here.

Regards,

Chaitanya

-- 
.

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 30 Apr 2019 13:00:17 -0400

Stefano, Clarence, Dhanendra, Paul Eric, and Steve: 

I would appreciate if you would take time to answer this query. 

Thank you – Sue 

From: Idr [mailto:[email-masked]] On Behalf Of Chaitanya Varma
Sent: Tuesday, April 30, 2019 4:04 AM
To: [email-masked]
Cc: Gurusiddesh Nidasesi
Subject: [Idr] Mail regarding draft-ietf-idr-segment-routing-te-policy

Hi, 

  “ Typically, a controller defines the set of policies and advertise

   them to policy head-end routers (typically ingress routers).” 

How do we communicate SR policies from controller? Is it through BGP-SR session or PCEP session.

  “ Moreover, one or more route-target SHOULD be attached to the

   advertisement”

How Route-target should be attached to a SR-NLRI update? 

Is it done through local configuration or picked up based on some dynamic parameter?

 

Regards,

Chaitanya

..