Subject: [Idr] Pending IANA early allocation for draft-ietf-idr-segment-routing-te-policy

From: "Ketan Talaulikar (ketant)" <[email-masked]>
Date: Mon, 29 Apr 2019 16:22:56 +0000

Hi Sue/John,

May I request to initiate the IANA early allocation for some codepoints that have not yet been done for https://tools.ietf.org/html/draft-ietf-idr-segment-routing-te-policy-05#section-8.3

We have implementations which are awaiting these allocations. I am also suggesting available code-points for the pending ones below that are in bold.

          Codepoint       Description              Reference
          ------------------------------------------------------
          12              Preference sub-TLV       This document
          13              Binding SID sub-TLV      This document
          128             Segment List sub-TLV     This document
          14              ENLP sub-TLV             This document
          15              Priority sub-TLV         This document
          129             Policy Name sub-TLV      This document

Thanks,
Ketan

From: Ketan Talaulikar (ketant)
Sent: 26 March 2019 14:21
To: 'Przemyslaw Krol' <pkrol=[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; Shyam Sethuram (shsethur) <[email-masked]>
Subject: RE: [spring] IANA assignment for Policy Name, ENLP, Priority Sub-TLVs

+ IDR

Hi PK,

I believe the authors were going to ask the IDR chairs for the code-point allocations for the newer TLVs after this IETF. I will also follow-up on this offline.

Thanks,
Ketan

From: spring <[email-masked]<mailto:[email-masked]>> On Behalf Of Przemyslaw Krol
Sent: 25 March 2019 08:28
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [spring] IANA assignment for Policy Name, ENLP, Priority Sub-TLVs

Greetings,

Not a major issue but wanted to confirm if there is any progress with this one.

thanks,
pk

On Mon, Dec 3, 2018 at 5:42 PM Przemyslaw Krol <[email-masked]<mailto:[email-masked]>> wrote:
Greetings,

Has the process for IANA Type # allocation for Policy Name Sub-TLV<https://tools.ietf.org/html/draft-ietf-idr-segment-routing-te-policy-05#section-2.4.6> been initiated yet?
Same applies to ENLP and Priority Sub-TLVs, fwiw.

Thank you,
pk

--
Przemyslaw "PK" Krol |

 Strategic Network Engineer

ing | [email-masked]<mailto:[email-masked]>

--
Przemyslaw "PK" Krol |

 Strategic Network Engineer

ing | [email-masked]<mailto:[email-masked]>

---

From: Przemyslaw Krol <[email-masked]>
Date: Mon, 29 Apr 2019 09:28:25 -0700

G'day,

Thanks for initiating this Ketan.
This will unblock few efforts on our end.

thanks,
pk

On Mon, Apr 29, 2019 at 9:23 AM Ketan Talaulikar (ketant) <[email-masked]>
wrote:

> Hi Sue/John,
>
>
>
> May I request to initiate the IANA early allocation for some codepoints
> that have not yet been done for
> https://tools.ietf.org/html/draft-ietf-idr-segment-routing-te-policy-05#section-8.3
>
>
>
> We have implementations which are awaiting these allocations. I am also
> suggesting available code-points for the pending ones below that are in
> bold.
>
>
>
> *          14              ENLP sub-TLV             This document*
>
> *          15              Priority sub-TLV         This document*
>
> *          129             Policy Name sub-TLV      This document*
>
>
>
> Thanks,
>
> Ketan
>
>
>
> *From:* Ketan Talaulikar (ketant)
> *Sent:* 26 March 2019 14:21
> *To:* 'Przemyslaw Krol' <pkrol=[email-masked]>;
> [email-masked]
> *Cc:* [email-masked]; [email-masked]; [email-masked]; Shyam Sethuram
> (shsethur) <[email-masked]>
> *Subject:* RE: [spring] IANA assignment for Policy Name, ENLP, Priority
> Sub-TLVs
>
>
>
> + IDR
>
>
>
> Hi PK,
>
>
>
> I believe the authors were going to ask the IDR chairs for the code-point
> allocations for the newer TLVs after this IETF. I will also follow-up on
> this offline.
>
>
>
> Thanks,
>
> Ketan
>
>
>
> *From:* spring <[email-masked]> *On Behalf Of *Przemyslaw Krol
> *Sent:* 25 March 2019 08:28
> *To:* [email-masked]
> *Cc:* [email-masked]
> *Subject:* Re: [spring] IANA assignment for Policy Name, ENLP, Priority
> Sub-TLVs
>
>
>
> Greetings,
>
>
>
> On Mon, Dec 3, 2018 at 5:42 PM Przemyslaw Krol <[email-masked]> wrote:
>
> Greetings,
>
>
>
> Has the process for IANA Type # allocation for Policy Name Sub-TLV
> <https://tools.ietf.org/html/draft-ietf-idr-segment-routing-te-policy-05#section-2.4.6> been
> initiated yet?
>
> ing | [email-masked]
> ing | [email-masked]

-- 
Przemyslaw "PK" Krol |  Strategic Network Engineer ing | [email-masked]

---

From: "Susan Hares" <[email-masked]>
Date: Mon, 29 Apr 2019 14:54:09 -0400

Ketan:

I will start this call today after do some checking on the IANA Registry. 

Sue Hares 

From: Idr [mailto:[email-masked]] On Behalf Of Ketan Talaulikar (ketant)
Sent: Monday, April 29, 2019 12:23 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]; Przemyslaw Krol
Subject: [Idr] Pending IANA early allocation for draft-ietf-idr-segment-routing-te-policy

Hi Sue/John,

Thanks,

Ketan 

+ IDR

Hi PK,

Thanks,

Ketan

From: spring <[email-masked]> On Behalf Of Przemyslaw Krol
Sent: 25 March 2019 08:28
To: [email-masked]
Cc: [email-masked]
Subject: Re: [spring] IANA assignment for Policy Name, ENLP, Priority Sub-TLVs

Greetings,

thanks,

pk

Greetings,

Has the process for IANA Type # allocation for Policy Name Sub-TLV <https://tools.ietf.org/html/draft-ietf-idr-segment-routing-te-policy-05#section-2.4.6>  been initiated yet?

Thank you,

pk

-- 

Przemyslaw "PK" Krol |

ing |  <mailto:[email-masked]> [email-masked] 

-- 

Przemyslaw "PK" Krol |

ing |  <mailto:[email-masked]> [email-masked]