Subject: [Idr] Should BGP communities be restrictive (Issue #38)?

From: Mahesh Jethanandani <[email-masked]>
Date: Fri, 30 Aug 2019 13:32:53 -0700

The following issue (#38) is documented here <https://github.com/mjethanandani/ietf-bgp-yang/issues/38> for the BGP YANG module.

It reads:

The current community type is defined in a restrictive manner. An example of what that restriction looks like can be seen here <https://github.com/mjethanandani/ietf-bgp-yang/blob/master/src/yang/ietf-bgp-types.yang#L296>. At least one of the observations is that, experience has shown that restricting ranges of communities may have negative impact on things such as policy, which may need to refer to out-of-acceptable-range values. The suggestion is to not restrict these beyond limiting the range to uint32, or what in YANG terms is 0..max.

The question therefore for the WG is, should the YANG model define the community-type in a restrictive manner that will then allow for checking of invalid values, or should it loosen restrictions on the types to allow for an unrestricted range of values to be accepted, knowing that it will fail somewhere deep in the bowels of the system.

An alternative is to define two different types for *-community-type. One that is restrictive and the other that is not. The latter will be used in policy definition, while the former will be used for everything else.

If no strong opinion is heard, the model will maintain the current restrictions on the ranges it has.

Cheers.

Mahesh Jethanandani
[email-masked]

---

From: "Jakob Heitz (jheitz)" <[email-masked]>
Date: Sat, 31 Aug 2019 02:43:59 +0000

A bgp speaker interprets a limited number of well known communities. Regardless of that, it must be possible to configure and show a community of any value. For example, 0 is an invalid ASN, but 0:0 is not an invalid community. It may be invalid in the context of a particular interpretation and valid in another interpretation. Either way, the router doesn’t care and should be able to process it in a bgp update message. All tools used on the router must accommodate communities of any value, including “invalid” ones.

Thanks,
Jakob.

On Aug 31, 2019, at 4:34 AM, Mahesh Jethanandani <[email-masked]<mailto:[email-masked]>> wrote:

The following issue (#38) is documented here<https://github.com/mjethanandani/ietf-bgp-yang/issues/38> for the BGP YANG module.

It reads:

The current community type is defined in a restrictive manner. An example of what that restriction looks like can be seen here<https://github.com/mjethanandani/ietf-bgp-yang/blob/master/src/yang/ietf-bgp-types.yang#L296>. At least one of the observations is that, experience has shown that restricting ranges of communities may have negative impact on things such as policy, which may need to refer to out-of-acceptable-range values. The suggestion is to not restrict these beyond limiting the range to uint32, or what in YANG terms is 0..max.

Cheers.

Mahesh Jethanandani
[email-masked]<mailto:[email-masked]>

_______________________________________________
Idr mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/idr