Subject: [Idr] Support for damping (Issue #26)

From: Mahesh Jethanandani <[email-masked]>
Date: Wed, 7 Aug 2019 18:35:21 -0700

Hi Folks,

One of the issues that has been opened against the BGP YANG model is the support for damping. It is documented here <https://github.com/mjethanandani/ietf-bgp-yang/issues/26>.

As it stands, all that the model supports is the notion of disabling/enabling damping. But many more parameters are needed to support damping, and there seems to be no commonality between how different vendors have chosen to support damping. 

The question to the WG therefore is, what form of damping would the WG like to see supported. The version in gated, or the one in Cisco IOS-XR, or Cisco IOS-XE, or Juniper, or Ericsson, etc.

Thanks.

Mahesh Jethanandani
[email-masked]

---

From: Mahesh Jethanandani <[email-masked]>
Date: Fri, 23 Aug 2019 10:01:07 -0700

Since I did not get any feedback on the question of damping, I have gone ahead and added support for damping using the semantics described for GateD.

Cheers.

> On Aug 7, 2019, at 6:35 PM, Mahesh Jethanandani <[email-masked]> wrote:
> 
> Hi Folks,
> 

Mahesh Jethanandani
[email-masked]