Subject: [Idr] FW: New Version Notification for draft-hujun-idr-bgp-ipsec-01.txt

From: "Hu, Jun (Nokia - US/Mountain View)" <[email-masked]>
Date: Thu, 5 Sep 2019 17:31:41 +0000

Hi,
I have posted an update of my draft, following are the updates, should address the comments I have received so far,  review and comment are appreciated!
And regard IPsec transport mode protecting tunnel, like GRE with IPsec transport mode, requires quite different design from IPsec tunnel mode, and since it is not really tunnel stack/nest, so current ietf-idr-tunnel-encaps doesn't have mechanism to cover such case, I plan to submit a separate draft for Ipsec transport mode protecting tunnel;

      *  replaces color sub-TLV with a new IPsec configuration tag sub-
         TLV
      *  add rule on selecting TLV when there multiple feasible TLVs in
         Section 3
      *  change crypto used in example of Section 3
      *  change title from "BGP Signaled IPsec Tunnel Configuration" to
         "BGP Provisioned IPsec Tunnel Configuration"
      *  Add a Section 4.2 on some operation specifics
      *  add more content in Section 6
      *  add specification of number of time each new sub-TLV allowed in
         a given tunnel TLV
      *  add clarification in Section 1 to clarify IPsec tunnel
         means IPsec tunnel mode
      *  traffic selector protocol and port range now come from tag
         mapped configuration

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: Wednesday, September 4, 2019 10:37 PM
To: Hu, Jun (Nokia - US/Mountain View) <[email-masked]>; Hu, Jun (Nokia - US/Mountain View) <[email-masked]>
Subject: New Version Notification for draft-hujun-idr-bgp-ipsec-01.txt

A new version of I-D, draft-hujun-idr-bgp-ipsec-01.txt has been successfully submitted by Hu Jun and posted to the IETF repository.

Name:		draft-hujun-idr-bgp-ipsec
Revision:	01
Title:		BGP Provisioned IPsec Tunnel Configuration
Document date:	2019-09-04
Group:		Individual Submission
Pages:		15
URL:            https://www.ietf.org/internet-drafts/draft-hujun-idr-bgp-ipsec-01.txt
Status:         https://datatracker.ietf.org/doc/draft-hujun-idr-bgp-ipsec/
Htmlized:       https://tools.ietf.org/html/draft-hujun-idr-bgp-ipsec-01
Htmlized:       https://datatracker.ietf.org/doc/html/draft-hujun-idr-bgp-ipsec
Diff:           https://www.ietf.org/rfcdiff?url2=draft-hujun-idr-bgp-ipsec-01

Abstract:
   This document defines a method of using BGP to provide IPsec tunnel
   configuration along with NLRI, it uses and extends tunnel
   encapsulation attribute as specified in [I-D.ietf-idr-tunnel-encaps]
   for IPsec tunnel.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 12 Sep 2019 14:42:29 -0400

Jun:

Thank you for update.  I look forward to seeing your separate draft that
deals with IPsec transport mode protecting tunnel. 

Should I wait for the second draft to make comments on your initial draft? 

Sue 

-----Original Message-----
From: Idr [mailto:[email-masked]] On Behalf Of Hu, Jun (Nokia -
US/Mountain View)
Sent: Thursday, September 5, 2019 1:32 PM
To: [email-masked]
Cc: Paul Wouters; Benjamin Kaduk
Subject: [Idr] FW: New Version Notification for
draft-hujun-idr-bgp-ipsec-01.txt

Hi,
I have posted an update of my draft, following are the updates, should
address the comments I have received so far,  review and comment are
appreciated!
And regard IPsec transport mode protecting tunnel, like GRE with IPsec
transport mode, requires quite different design from IPsec tunnel mode, and
since it is not really tunnel stack/nest, so current ietf-idr-tunnel-encaps
doesn't have mechanism to cover such case, I plan to submit a separate draft
for Ipsec transport mode protecting tunnel;

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: Wednesday, September 4, 2019 10:37 PM
To: Hu, Jun (Nokia - US/Mountain View) <[email-masked]>; Hu, Jun (Nokia -
US/Mountain View) <[email-masked]>
Subject: New Version Notification for draft-hujun-idr-bgp-ipsec-01.txt

A new version of I-D, draft-hujun-idr-bgp-ipsec-01.txt has been successfully
submitted by Hu Jun and posted to the IETF repository.

Name:		draft-hujun-idr-bgp-ipsec
Revision:	01
Title:		BGP Provisioned IPsec Tunnel Configuration
Document date:	2019-09-04
Group:		Individual Submission
Pages:		15
URL:
https://www.ietf.org/internet-drafts/draft-hujun-idr-bgp-ipsec-01.txt
Status:         https://datatracker.ietf.org/doc/draft-hujun-idr-bgp-ipsec/
Htmlized:       https://tools.ietf.org/html/draft-hujun-idr-bgp-ipsec-01
Htmlized:
https://datatracker.ietf.org/doc/html/draft-hujun-idr-bgp-ipsec
Diff:
https://www.ietf.org/rfcdiff?url2=draft-hujun-idr-bgp-ipsec-01

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

_______________________________________________
Idr mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/idr

---

From: "Hu, Jun (Nokia - US/Mountain View)" <[email-masked]>
Date: Thu, 12 Sep 2019 18:53:34 +0000

You don't have to wait for my 2nd draft, it will take some time 

-----Original Message-----
From: Susan Hares <[email-masked]> 
Sent: Thursday, September 12, 2019 11:42 AM
To: Hu, Jun (Nokia - US/Mountain View) <[email-masked]>; [email-masked]
Cc: 'Paul Wouters' <[email-masked]>; 'Benjamin Kaduk' <[email-masked]>
Subject: RE: [Idr] FW: New Version Notification for draft-hujun-idr-bgp-ipsec-01.txt

Jun:

Thank you for update.  I look forward to seeing your separate draft that deals with IPsec transport mode protecting tunnel. 

Sue 

-----Original Message-----
From: Idr [mailto:[email-masked]] On Behalf Of Hu, Jun (Nokia - US/Mountain View)
Sent: Thursday, September 5, 2019 1:32 PM
To: [email-masked]
Cc: Paul Wouters; Benjamin Kaduk
Subject: [Idr] FW: New Version Notification for draft-hujun-idr-bgp-ipsec-01.txt

Hi,

-----Original Message-----
From: [email-masked] <[email-masked]>
Sent: Wednesday, September 4, 2019 10:37 PM
To: Hu, Jun (Nokia - US/Mountain View) <[email-masked]>; Hu, Jun (Nokia - US/Mountain View) <[email-masked]>
Subject: New Version Notification for draft-hujun-idr-bgp-ipsec-01.txt

Abstract:

The IETF Secretariat