Subject: [Idr] RtgDir review: draft-ietf-idr-bgp-ls-segment-routing-msd-05.txt

From: Mach Chen <[email-masked]>
Date: Sun, 15 Sep 2019 12:13:20 +0000

Hello,

I have been selected as the Routing Directorate reviewer for this draft. The Routing Directorate seeks to review all routing or routing-related drafts as they pass through IETF last call and IESG review, and sometimes on special request. The purpose of the review is to provide assistance to the Routing ADs. For more information about the Routing Directorate, please see http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir

Although these comments are primarily for the use of the Routing ADs, it would be helpful if you could consider them along with any other IETF Last Call comments that you receive, and strive to resolve them through discussion or by updating the draft.

Document: draft-ietf-idr-bgp-ls-segment-routing-msd-05.txt
Reviewer: Mach Chen
Review Date: 10 September 2019 
Intended Status: Standards Track

Summary: 
I have some minor concerns about this document that I think should be resolved before publication.

Comments:

Generally, I found the draft quite readable, with a clear explanation of the problem statements and solutions. However, I have one minor comment and a nit.

Major Issues:

No major issues found.

Minor Issues:

This draft is an extension to BGP-LS (RFC 7752) that is under a re-spin, I have a question whether this draft should reference to RFC 7752 or the new bis document.

Nits:
1.1.1.  Terminology

Part of the last bullet should be separated into a dedicated paragraph, it looks like an copy and pastes nit. 

"The number of labels imposed is then the sum of the number of labels that are
      replaced and the number of labels that are pushed.  See [RFC3031]"

Best regards,
Mach

---

From: Jeff Tantsura <[email-masked]>
Date: Sun, 15 Sep 2019 15:12:53 -0700

Hello Mach,

Many thanks for your review.
Please note - the latest version of the document is 07.

Please see inline

Cheers,
Jeff
> This draft is an extension to BGP-LS (RFC 7752) that is under a re-spin, I have a question whether this draft should reference to RFC 7752 or the new bis document.
[jeff] we have added clarifying text in the 07 version. please let me know if this addresses your comments.

---

From: Jeff Tantsura <[email-masked]>
Date: Sun, 15 Sep 2019 15:17:30 -0700

Hi Mach,

Apologies for the second email, hit send too fast.
Wrt Terminology section - I believe a period (full stop) between sentences is missing, not a new paragraph.
If you are OK with my point of view, will update ASAP.

Thanks!

Cheers,
Jeff

---

From: Mach Chen <[email-masked]>
Date: Mon, 16 Sep 2019 01:36:43 +0000

Hi Jeff,

Yes, I am OK with it.

In addition, I had a quick review on the version-07, I am OK with it.

Best regards,
Mach

From: Jeff Tantsura [mailto:[email-masked]]
Sent: Monday, September 16, 2019 6:18 AM
To: Routing ADs <[email-masked]>; Mach Chen <[email-masked]>
Cc: Routing Directorate <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: RtgDir review: draft-ietf-idr-bgp-ls-segment-routing-msd-05.txt

Hi Mach,

Thanks!

Cheers,
Jeff
On Sep 15, 2019, 3:12 PM -0700, Jeff Tantsura <[email-masked]<mailto:[email-masked]>>, wrote:

Hello Mach,

Please see inline

Cheers,
Jeff
On Sep 15, 2019, 5:13 AM -0700, Mach Chen <[email-masked]<mailto:[email-masked]>>, wrote:

Hello,

Summary:

Comments:

Major Issues:

No major issues found.

Minor Issues:

Nits:
1.1.1. Terminology

Best regards,
Mach