Subject: Re: [Idr] draft-ietf-idr-ext-opt-param-06.txt - 2 Week WG LC (7/30 to 8/13/2019) - Extended 1 week - WG Consensus reached

From: "Susan Hares" <[email-masked]>
Date: Thu, 12 Sep 2019 05:56:22 -0400

The WG consensus appears to have been reached by August 30th. 

The shepherd will review the draft and write-up the shepherd report. 

This draft has been placed in waiting for implementations because 

the authors have not placed an implementation report on the IDR wiki page. 

A page has been created at: 

https://trac.ietf.org/trac/idr/wiki/draft-ietf-idr-ext-opt-param%20implement
ations

I believe there are multiple implementations but the authors need 

to provide this information. 

Sue (Shepherd) 

From: Idr [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Thursday, August 15, 2019 11:17 AM
To: [email-masked]
Subject: Re: [Idr] draft-ietf-idr-ext-opt-param-06.txt - 2 Week WG LC (7/30
to 8/13/2019) - Extended 1 week

Greetings: 

This WG LC is extended 1 Week due to the confusion on the draft.   

The authors need to update the wiki page on implementations and summarize
any changes needed to the draft. 

We need additional support for this draft to have it forwarded to the IESG. 

Cheerily, Susan Hares 

From: Idr [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Tuesday, July 30, 2019 12:06 PM
To: [email-masked]
Subject: [Idr] draft-ietf-idr-ext-opt-param-06.txt - 2 Week WG LC (7/30 to
8/13/2019)

This begins a 2 week working group last call on
draft-ietf-idr-ext-opt-param-06.txt from 7/30 to 8/13/2019.  

You can access the draft at: 

https://datatracker.ietf.org/doc/draft-ietf-idr-ext-opt-param/

John and Enke - I am counting on you gather information on the 2
implementations and post this on the IDR Wiki during these 2 weeks. 

For the WG, consider if:

1)      The technology is ready for publication or if there are flaws that
prevent its publication, 

2)      Is this technology useful to BGP deployments? 

3)      Are there any minor editorial errors the authors should address
before publication. 

Cheerily, Sue Hares

---

From: Ondrej Zajicek <[email-masked]>
Date: Thu, 12 Sep 2019 14:50:50 +0200

> to provide this information. 

Note that we just implemented the draft in BIRD.

-- 
Elen sila lumenn' omentielvo

Ondrej 'Santiago' Zajicek (email: [email-masked])
OpenPGP encrypted e-mails preferred (KeyID 0x11DEADC3, wwwkeys.pgp.net)
"To err is human -- to blame it on a computer is even more so."

---

From: Jeffrey Haas <[email-masked]>
Date: Thu, 12 Sep 2019 09:49:13 -0400

Sue,

I've filled in details for Junos and our interop with Nokia (their version still needed).

Ondrej, Adam, would you similarly fill in your entries?

-- Jeff

> On Sep 12, 2019, at 5:56 AM, Susan Hares <[email-masked]> wrote:
> 
> https://trac.ietf.org/trac/idr/wiki/draft-ietf-idr-ext-opt-param%20implementations <https://trac.ietf.org/trac/idr/wiki/draft-ietf-idr-ext-opt-param%20implementations>
>  
> From: Idr [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Susan Hares
> To: [email-masked] <mailto:[email-masked]>
> Subject: Re: [Idr] draft-ietf-idr-ext-opt-param-06.txt - 2 Week WG LC (7/30 to 8/13/2019) - Extended 1 week
>  
> Greetings: 
>  
> The authors need to update the wiki page on implementations and summarize any changes needed to the draft. 
>  
> From: Idr [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Susan Hares
> To: [email-masked] <mailto:[email-masked]>
> Subject: [Idr] draft-ietf-idr-ext-opt-param-06.txt - 2 Week WG LC (7/30 to 8/13/2019)
>  
> This begins a 2 week working group last call on draft-ietf-idr-ext-opt-param-06.txt from 7/30 to 8/13/2019.  
>  
> https://datatracker.ietf.org/doc/draft-ietf-idr-ext-opt-param/ <https://datatracker.ietf.org/doc/draft-ietf-idr-ext-opt-param/>
>  
> John and Enke – I am counting on you gather information on the 2 implementations and post this on the IDR Wiki during these 2 weeks. 
>  
> For the WG, consider if:
>  
> 1)      The technology is ready for publication or if there are flaws that prevent its publication, 
> 3)      Are there any minor editorial errors the authors should address before publication. 
>  
>  
> Cheerily, Sue Hares 
>  
>  
>  
> _______________________________________________
> Idr mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/idr <https://www.ietf.org/mailman/listinfo/idr>

---

From: Ondrej Zajicek <[email-masked]>
Date: Thu, 12 Sep 2019 18:59:16 +0200

> Ondrej, Adam, would you similarly fill in your entries?

Filled

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 12 Sep 2019 15:27:05 -0400

Greetings Jeff and Ondrej Zajicek: 

Thank you for indicating there are interoperable implementations. 

For approval from the IESG,  please create a chart on this page 

that provides the interoperability results for the 

To the MUST,  MUST  NOT clauses, SHOULD and MAY clauses. 

6 Examples of MUST  Section 2 are: 

1.  length of Optional Parameter in Open message less than 255, 
Implementation MUST use RFC4271 encodings without alteration 

2.  Implementation MUST be prepared to accept an OPEN message that uses

the encoding of this specification for Optional Parameters of any

        length.

3.       length of Optional Parameter in Open message greater than 255, 
  extended encoding defined here MUST be used.  
  non-extended) length field MUST be set to 255.
        The subsequent octet (which would be the first Optional
        Parameter Type in the non-extended format) MUST
        be set to 255 as well.  
 
4.  If bgp peer receving OPEN detects first Optional Parameter Type field is 255.
In this case, the BGP speaker MUST use the Extended Optional
Parameters Length field in lieu of the [RFC4271 <https://tools.ietf.org/html/rfc4271> ] encoding to
determine the length of Optional Parameters contained in the message.
 
5.   The non-extended Optional Parameters Length field MUST
 be set to 255 on transmission, 
 and MUST be ignored on receipt once the use of the
       extended format is determined positively by inspection of 
       the (non-extended) Optional Parameters Type field.
 
6.  On transmission, the subsequent one-octet field, 
that in the non-extended format would be the first 
Optional Parameter Type field, MUST be set to 255 on
      transmission.  

I believe Jeff has seen these tables before so I give you only hints. 

Please let me know if you questions. 

Cheerily, Susan Hares 

From: Jeffrey Haas [mailto:[email-masked]] 
Sent: Thursday, September 12, 2019 9:49 AM
To: Sue Hares
Cc: idr wg; [email-masked]; [email-masked]
Subject: Re: [Idr] draft-ietf-idr-ext-opt-param-06.txt - 2 Week WG LC (7/30 to 8/13/2019) - Extended 1 week - WG Consensus reached

Sue,

 

-- Jeff

 <https://trac.ietf.org/trac/idr/wiki/draft-ietf-idr-ext-opt-param%20implementations> https://trac.ietf.org/trac/idr/wiki/draft-ietf-idr-ext-opt-param%20implementations

Sue (Shepherd) 

From: Idr [ <mailto:[email-masked]> mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Thursday, August 15, 2019 11:17 AM
To:  <mailto:[email-masked]> [email-masked]
Subject: Re: [Idr] draft-ietf-idr-ext-opt-param-06.txt - 2 Week WG LC (7/30 to 8/13/2019) - Extended 1 week

Greetings: 

Cheerily, Susan Hares 

From: Idr [ <mailto:[email-masked]> mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Tuesday, July 30, 2019 12:06 PM
To:  <mailto:[email-masked]> [email-masked]
Subject: [Idr] draft-ietf-idr-ext-opt-param-06.txt - 2 Week WG LC (7/30 to 8/13/2019)

 <https://datatracker.ietf.org/doc/draft-ietf-idr-ext-opt-param/> https://datatracker.ietf.org/doc/draft-ietf-idr-ext-opt-param/

For the WG, consider if:

 

Cheerily, Sue Hares 

_______________________________________________
Idr mailing list
 <mailto:[email-masked]> [email-masked]
 <https://www.ietf.org/mailman/listinfo/idr> https://www.ietf.org/mailman/listinfo/idr

---

From: Robert Varga <[email-masked]>
Date: Sat, 14 Sep 2019 03:29:51 +0200

> Ondrej, Adam, would you similarly fill in your entries?

I have updated the information for OpenDaylight, too.

Regards,
Robert