Subject: [Idr] Adoption: draft-li-idr-bgp-ls-sr-policy-path-segment-03.txt and draft-li-sr-policy-path-segment-01.txt [9/17 to 10/1/2019]

From: "Susan Hares" <[email-masked]>
Date: Tue, 17 Sep 2019 12:35:16 -0400

This begins a 2 week WG Adoption call two related drafts [9/17 to 10/1/2019]

.         draft-li-bgp-ls-sr-policy-path-segment-03.txt and 

.         draft-li-idr-sr-policy-path-segment-01.txt. 

You can access these two drafts at the following location: 

https://datatracker.ietf.org/doc/draft-li-idr-bgp-ls-sr-policy-path-segment/

https://datatracker.ietf.org/doc/draft-li-idr-sr-policy-path-segment/

The authors have pointed out that the adoption of this 

draft since the following  SR-MPLS Path Segment draft has been adopted: 

https://tools.ietf.org/html/draft-ietf-spring-mpls-path-segment-00

Please consider the following questions in your responses? 

1)      Should this SR Policy technology be included in BGP for SR-MPLS 

Spring has adopted the draft, but IDR can provide feedback 

to spring about putting this technology in BGP.

2)      Is this technology a good way to implement the required 

Features in BGP? 

3)      Is this technology ready for adoption? 

4)      Do you have any concerns about adopting this technology? 

Cheers, Susan Hares

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Wed, 18 Sep 2019 07:20:40 +0000

Support as a co-author. Path Segment is very useful in SR-MPLS and SRv6 passive PM, Bidirectional Path correlation, etc.
BGP SR Policy is a major mechanism to install SR policy, so I think it is correct to use BGP SR policy to assign path segment since this is part of SR policy.
The reasons to BGP-LS are similar.

Yes

Features in BGP?

Yes

Yes, the text of  current version is mature and ready for adoption.

Also, we were required to update the IANA part for helping implementation in the previous revision.

4)      Do you have any concerns about adopting this technology?
Yes, we will update the draft to support multiple bidirectional path in ECMP by copying weight TLV to SR Bidir path sub-TLV in the near future.

Many thanks,
Cheng

From: Idr [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Wednesday, September 18, 2019 12:35 AM
To: 'idr wg' <[email-masked]>
Subject: [Idr] Adoption: draft-li-idr-bgp-ls-sr-policy-path-segment-03.txt and draft-li-sr-policy-path-segment-01.txt [9/17 to 10/1/2019]

*         draft-li-bgp-ls-sr-policy-path-segment-03.txt and

*         draft-li-idr-sr-policy-path-segment-01.txt.

Features in BGP?

Cheers, Susan Hares

---

From: Lizhenbin <[email-masked]>
Date: Thu, 19 Sep 2019 14:06:09 +0000

Support the adoption of the two drafts as the co-author. I think Path Segment is a base work for many applications such as SR OAM, bidirectional SR path and protection.
BGP extensions for the path segment will facilitate the automated solution and reduce the complexity of deployment.

Best Regards,
Zhenbin (Robin)

Features in BGP?

Cheers, Susan Hares

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 19 Sep 2019 19:56:42 +0000

I have read through both documents. I support WG adoption with the following comments:

Path Segment is one of the segments in the Segment List, correct?
But draft-li-idr-sr-policy-path-segment-distribution-01 has a statement saying that Path Segment can be a list of SIDs (Section 3 on Page 3). Does it mean that Path Segment can be mapped to multiple SIDs?
"The Path Segment can be used for identifying an SR path(specified by SID list)".

The following statement of draft-li-idr-sr-policy-path-segment-distribution-01 seems to indicate that Path Segment is one of the Path attributes, just like an attribute for the Path QoS attribute, is it correct?
"For each SR path, it may also have its own path attributes, and Path Segment is one of them."

draft-li-idr-bgp-ls-sr-policy-path-segment-03 has a statement in the Abstract stating that the document is to define ways for collecting configuration and states of SR policies by BGP-LS. So, it really not SR Policies Extensions (as stated in the title), is it?

Linda Dunbar

From: Idr [mailto:[email-masked]] On Behalf Of Susan Hares
Sent: Wednesday, September 18, 2019 12:35 AM
To: 'idr wg' <[email-masked]<mailto:[email-masked]>>
Subject: [Idr] Adoption: draft-li-idr-bgp-ls-sr-policy-path-segment-03.txt and draft-li-sr-policy-path-segment-01.txt [9/17 to 10/1/2019]

https://datatracker.ietf.org/doc/draft-li-idr-bgp-ls-sr-policy-path-segment/<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-li-idr-bgp-ls-sr-policy-path-segment%2F&data=02%7C01%7Clinda.dunbar%40futurewei.com%7C70ced65ae7c34611eb1d08d73d0a9438%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637044987969197226&sdata=odr%2BV4rkoGZILD8wgKAIdloIQ1jghPpqcfVda%2BaLfWY%3D&reserved=0>

https://datatracker.ietf..org/doc/draft-li-idr-sr-policy-path-segment/<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-li-idr-sr-policy-path-segment%2F&data=02%7C01%7Clinda.dunbar%40futurewei.com%7C70ced65ae7c34611eb1d08d73d0a9438%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637044987969197226&sdata=2kKSCwWlStAmZrnxg9v7CWIE6LSPUxAx3vpQyv7hJiE%3D&reserved=0>

https://tools.ietf.org/html/draft-ietf-spring-mpls-path-segment-00<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-spring-mpls-path-segment-00&data=02%7C01%7Clinda.dunbar%40futurewei.com%7C70ced65ae7c34611eb1d08d73d0a9438%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637044987969197226&sdata=94ngznOfyaK3Wl%2BfeWUyGHB2xejsuIqeJgphSPU0vR4%3D&reserved=0>

  1.  Should this SR Policy technology be included in BGP for SR-MPLS

  1.  Is this technology a good way to implement the required

Features in BGP?

  1.  Is this technology ready for adoption?

  1.  Do you have any concerns about adopting this technology?

Cheers, Susan Hares

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Fri, 20 Sep 2019 08:15:40 +0000

Hi Linda,

Many thanks, please see my reply inline.

Best,
Cheng

From: Idr [mailto:[email-masked]] On Behalf Of Linda Dunbar
Sent: Friday, September 20, 2019 3:57 AM
To: Susan Hares <[email-masked]>; 'idr wg' <[email-masked]>
Subject: Re: [Idr] Adoption: draft-li-idr-bgp-ls-sr-policy-path-segment-03.txt and draft-li-sr-policy-path-segment-01.txt [9/17 to 10/1/2019]

Path Segment is one of the segments in the Segment List, correct?
[Cheng] For data plane, yes. But for Control plane, it is more like a resource or attributes.

But draft-li-idr-sr-policy-path-segment-distribution-01 has a statement saying that Path Segment can be a list of SIDs (Section 3 on Page 3). Does it mean that Path Segment can be mapped to multiple SIDs?
"The Path Segment can be used for identifying an SR path(specified by SID list)".
[Cheng] Depends on use cases. If we would like to measure the SR policy, then a Path Segment can map to an SR policy, and it will be shared by the SID lists within the SR policy.

[Cheng] Correct.

draft-li-idr-bgp-ls-sr-policy-path-segment-03 has a statement in the Abstract stating that the document is to define ways for collecting configuration and states of SR policies by BGP-LS. So, it really not SR Policies Extensions (as stated in the title), is it?
[Cheng] I am not sure about what kind of extension belongs to SR policies extension. If I make a mistake, we can modify the title.
                 As my understanding , this extension is for collecting states of SR policies, then it is a SR policy extension.

Linda Dunbar

From: Idr [mailto:[email-masked]<mailto:idr-bounces@ietf..org>] On Behalf Of Susan Hares
Sent: Wednesday, September 18, 2019 12:35 AM
To: 'idr wg' <[email-masked]<mailto:[email-masked]>>
Subject: [Idr] Adoption: draft-li-idr-bgp-ls-sr-policy-path-segment-03.txt and draft-li-sr-policy-path-segment-01.txt [9/17 to 10/1/2019]

Features in BGP?

Cheers, Susan Hares

---

From: Linda Dunbar <[email-masked]>
Date: Fri, 20 Sep 2019 18:59:17 +0000

Cheng,

Thanks for the explanation.

if For data plane, Path Segment is one of the segments in the Segment List, But for Control plane, it is more like a resource or attributes.

Why not have a separate name to represent the "resource or attributes" of the path? Will it be more clear for future, for people who are not in today's IETF discussion?

Linda

From: Chengli (Cheng Li) <[email-masked]>
Sent: Friday, September 20, 2019 3:16 AM
To: Linda Dunbar <[email-masked]>; Susan Hares <[email-masked]>; 'idr wg' <[email-masked]>
Subject: RE: [Idr] Adoption: draft-li-idr-bgp-ls-sr-policy-path-segment-03.txt and draft-li-sr-policy-path-segment-01.txt [9/17 to 10/1/2019]

Hi Linda,

Best,
Cheng

From: Idr [mailto:[email-masked]] On Behalf Of Linda Dunbar
Sent: Friday, September 20, 2019 3:57 AM
To: Susan Hares <[email-masked]<mailto:[email-masked]>>; 'idr wg' <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Idr] Adoption: draft-li-idr-bgp-ls-sr-policy-path-segment-03.txt and draft-li-sr-policy-path-segment-01.txt [9/17 to 10/1/2019]

Linda Dunbar

https://datatracker.ietf.org/doc/draft-li-idr-bgp-ls-sr-policy-path-segment/<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-li-idr-bgp-ls-sr-policy-path-segment%2F&data=02%7C01%7Clinda.dunbar%40futurewei.com%7Cfc71199bcad34efa093608d73da2c0d3%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637045641561053885&sdata=3IIFnDFwEMatkK24DfoWTpj1JCQ4k60%2FpOnmqwUAjmo%3D&reserved=0>

https://datatracker.ietf..org/doc/draft-li-idr-sr-policy-path-segment/<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-li-idr-sr-policy-path-segment%2F&data=02%7C01%7Clinda.dunbar%40futurewei.com%7Cfc71199bcad34efa093608d73da2c0d3%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637045641561053885&sdata=GScgio9fqeJIVw0VoqcynIUFVe0pyP3v90QMhXRKF9M%3D&reserved=0>

https://tools.ietf.org/html/draft-ietf-spring-mpls-path-segment-00<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-spring-mpls-path-segment-00&data=02%7C01%7Clinda.dunbar%40futurewei.com%7Cfc71199bcad34efa093608d73da2c0d3%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637045641561063877&sdata=iCZKAyty4%2FNOoN8RJbHBhyg%2BJrKH3cMQWnr%2BQ7N8Yzg%3D&reserved=0>

Features in BGP?

Cheers, Susan Hares

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Sat, 21 Sep 2019 07:31:40 +0000

Hi Linda,

Many thanks for your comments. Will consider it in the future revision.

Best,
Cheng

From: Linda Dunbar [mailto:[email-masked]]
Sent: Saturday, September 21, 2019 2:59 AM
To: Chengli (Cheng Li) <[email-masked]>; Susan Hares <[email-masked]>; 'idr wg' <[email-masked]>
Subject: RE: [Idr] Adoption: draft-li-idr-bgp-ls-sr-policy-path-segment-03.txt and draft-li-sr-policy-path-segment-01.txt [9/17 to 10/1/2019]

Cheng,

Linda

From: Chengli (Cheng Li) <[email-masked]<mailto:[email-masked]>>
Sent: Friday, September 20, 2019 3:16 AM
To: Linda Dunbar <[email-masked]<mailto:[email-masked]>>; Susan Hares <[email-masked]<mailto:[email-masked]>>; 'idr wg' <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Idr] Adoption: draft-li-idr-bgp-ls-sr-policy-path-segment-03.txt and draft-li-sr-policy-path-segment-01.txt [9/17 to 10/1/2019]

Hi Linda,

Best,
Cheng

Linda Dunbar

Features in BGP?

Cheers, Susan Hares

---

From: "Aijun Wang" <[email-masked]>
Date: Wed, 25 Sep 2019 11:34:46 +0800

Hi, All:

Support the adoption.  

One comments: Can these two drafts be merged into one? 

Most of the their contents are overlapped.  Add simply the corresponding
part for “BGP-LS  protocol extension” in
“draft-li-sr-policy-path-segment-01.txt”may be more easily for future
advancing and the user reading.

Best Regards.

Aijun Wang

China Telecom

发件人: [email-masked] [mailto:[email-masked]] 代表 Susan Hares
发送时间: 2019年9月18日 0:35
收件人: 'idr wg'
主题: [Idr] Adoption: draft-li-idr-bgp-ls-sr-policy-path-segment-03.txt and
draft-li-sr-policy-path-segment-01.txt [9/17 to 10/1/2019]

・         draft-li-bgp-ls-sr-policy-path-segment-03.txt and 

・         draft-li-idr-sr-policy-path-segment-01.txt. 

Features in BGP? 

 

Cheers, Susan Hares

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 25 Sep 2019 16:56:02 +0800

Support the WG adoption of the two drafts as the co-author.
Path Segment provides the identification of the SR path. It will be useful for SR deployment.
And then, operator can do the SR performance measurement and SR OAM.
BGP-LS is popular for the router. It's welcome to use BGP extensions for the Path Segment, and then the deployment is easy.
Best regards.
  HUANAN CHEN（陈华南）

Data Communication Research Department
Guangdong Research Institute of China Telecom Co.,Ltd.
Tel：020-3863-9346
PH：133-1609-7163
QQ：17335837
Mail：[email-masked] 
 
From: Susan Hares
Date: 2019-09-18 00:35
To: 'idr wg'
Subject: [Idr] Adoption: draft-li-idr-bgp-ls-sr-policy-path-segment-03.txt and draft-li-sr-policy-path-segment-01.txt [9/17 to 10/1/2019]
This begins a 2 week WG Adoption call two related drafts [9/17 to 10/1/2019] 
·         draft-li-bgp-ls-sr-policy-path-segment-03.txt and 
·         draft-li-idr-sr-policy-path-segment-01.txt. 

 

 

 

Cheers, Susan Hares

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Thu, 26 Sep 2019 14:19:25 +0000

Support the adoption as a coauthor.

Path segment is proved to be useful in several scenarios. And it is important to add the support of path segment in BGP SR policy.

Best regards,
Jie

Features in BGP?

Cheers, Susan Hares

---

From: Zhuangshunwan <[email-masked]>
Date: Sat, 28 Sep 2019 01:51:18 +0000

I have read through both drafts. And I support the WG adoption of them.

Best Regards,
Shunwan

Features in BGP?

Cheers, Susan Hares