Subject: [Idr] Is the SR Policy SAFI described in draft-ietf-idr-segment-routing-te-policy-07 under the MP-NLRI (code =14) or under the Tunnel Path attribute (code = 23)?

From: Linda Dunbar <[email-masked]>
Date: Tue, 22 Oct 2019 23:23:53 +0000

IDR experts and the Authors of draft-ietf-idr-segment-routing-te-policy-07:

The section 2.1 of draft-ietf-idr-segment-routing-te-policy-07 describes a new SR Policy SAFI under NLRI of BGP UPDATE to advertise SR policies.

Does it mean that SR Policy SAFI is under the MP-NLRI Path Attribute (Code = 14)?

The Section 2.2 indicates that SR Policy is encoded in the Tunnel Encapsulation Path Attribute defined in the draft-ietf-idr-tunnel-encaps-12.

Does it mean the SR policy is also under the Tunnel Path Attribute with Code =23?

Can you please explain is it MP-NLRI Path Attribute or Tunnel Encap Path Attribute that SR policy are encoded?

Thank you very much.

Linda Dunbar

---

From: stefano previdi <[email-masked]>
Date: Wed, 23 Oct 2019 11:05:17 +0200

> On Oct 23, 2019, at 1:23 AM, Linda Dunbar <[email-masked]> wrote:
> 

yes, the nlri with the new safi identifies the policy:
   +------------------+
   |  NLRI Length     | 1 octet
   +------------------+
   |  Distinguisher   | 4 octets
   +------------------+
   |  Policy Color    | 4 octets
   +------------------+
   |  Endpoint        | 4 or 16 octets 
   +------------------+

> Does it mean the SR policy is also under the Tunnel Path Attribute with Code =23?

the content (i.e., the details) of the sr policy is encoded in the tunnel path attribute.

> Can you please explain is it MP-NLRI Path Attribute or Tunnel Encap Path Attribute that SR policy are encoded?

there are separate items: policy identifier and policy content.

the policy identifier (distinguisher, color, endpoint) goes into the nlri and the policy content (e.g., the segment list) go into the tunnel path attribute.

s.

---

From: Linda Dunbar <[email-masked]>
Date: Wed, 23 Oct 2019 14:40:17 +0000

Stefano, 

Since the MP-NLRI Path Attribute (code=14) and the Tunnel Path Attribute (code =23) are at the same level, does it mean that one BGP UPDATE can only carry one policy? 

I am just curious why not encoding the Policy Content as subTLVs nested within the Policy Identifier encoded in the MP-NLRI? So that one BGP UPDATE can carry multiple SR policies.

Thanks, Linda

-----Original Message-----
From: stefano previdi <[email-masked]> 
Sent: Wednesday, October 23, 2019 4:05 AM
To: Linda Dunbar <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: Is the SR Policy SAFI described in draft-ietf-idr-segment-routing-te-policy-07 under the MP-NLRI (code =14) or under the Tunnel Path attribute (code = 23)?

s.